Что нового появилосьв Visual FoxPro 7.0

Visual FoxPro является постоянно развивающейся системой. По сравнению с предыдущей версией, в Visual FoxPro 7.0 сделан еще один шаг в расширении функциональных возможностей системы, улучшены имеющиеся средства, касающиеся интерфейса среды разработки.

Visual FoxPro 7.0 поддерживает технологию IntelliSense, облегчающую создание программного кода. Суть данной технологии состоит в том, что при вводе операторов, свойств и функций FoxPro предлагает на выбор возможные варианты написания. Это уменьшает количество вводимого вручную кода и избавляет разработчика от необходимости лишний раз обращаться к документации. Технология IntelliSense Visual FoxPro содержит следующие функции:

  • показывает список допустимых дочерних объектов (свойств, событий, методов) для указанного объекта. Для СОМ-объектов информация считывается из библиотеки типов;
  • показывает окно подсказки, содержащее список допустимых параметров или аргументов для команд, функций, свойств, методов и событий.

В редактор Visual FoxPro были добавлены следующие возможности:

  • использование для выделения текста на выбор пробела или табулятора с настраиваемыми параметрами;
  • настройка строк комментария;
  • поддержка в редакторе гиперссылок на Web-страницы или документацию;
  • поддержка Dirty File Indicator для отображения времени внесения изменений в код;
  • удобная установка точек прерывания в программном коде;
  • использование закладок для быстрого возврата на нужный фрагмент кода.

Для настройки параметров редактора используются новые вкладки Editor (Редактор) и IDE (Интерактивная среда разработки) диалогового окна Options (Параметры), которое открывается при выполнении команды Options (Параметры) из меню Tools (Сервис).

Для облегчения работы пользователя с несколькими окнами, такими как Command (Команда), Properties (Свойства) и окном редактора, VisualFoxPro 7.0 позволяет перемещать и закреплять окна, т. е. манипулировать ими по своему усмотрению. Например, вы можете установить командное окно и окно свойств в одно окно-контейнер и привязать его к правому краю экрана, а окно редактора — в другое окно-контейнер, привязав его к левому краю экрана.

СОМ-компоненты Visual FoxPro могут использовать свойства, события и методы СОМ-интерфейса, определенного в другом СОМ-компоненте. В Visual FoxPro появилось средство Task List (Список заданий), позволяющее пользователю формировать список задач в проекте и управлять их выполнением.

Приложение Object Browser (Браузер объекта), входящее в состав Visual FoxPro и запускаемое из меню Tools (Сервис), позволяет просматривать свойства, методы и события СОМ-объектов, что очень удобно при работе с объектами, на которые нет документации.

В Visual FoxPro появились новые средства управления XML-файлами:

  • XMLTOCURSOR — преобразовывает XML-текст в курсор или таблицу Visual FoxPro;
  • CURSORTOXML — преобразовывает курсор Visual FoxPro в XML-текст.Поддержка Active Accessibility в Visual FoxPro позволяет создавать приложения, которые могут использовать люди с проблемами зрения, слуха или моторики.

В базе данных, созданной в Visual FoxPro, вы можете использовать события, связанные с базой данных, такие как открытие таблицы, добавление или удаление таблицы для проверки прав доступа при открытии таблицы, трассировки выполняемых действий и т. п.


Объекты Visual FoxPro

Visual FoxPro состоит из отдельных компонентов, которые используются для хранения информации, ее отображения и редактирования. В Visual FoxPro вся информация хранится в базе данных, которая состоит из таблиц, отношений между таблицами, индексов, триггеров и хранимых процедур. Каждая таблица имеет уникальное имя и хранится в отдельном файле, наименование которого совпадает с именем таблицы. Созданный файл имеет расширение DBF.

Каждая создаваемая таблица может иметь связанные с ней индексы, используемые для упорядочения данных и быстрого поиска необходимых записей, причем каждая таблица может иметь несколько индексов. Для хранения значений полей типа Memo и General применяются отдельные файлы. Memo-поля таблиц содержат текстовую информацию, а поля типа General используются, как правило, для хранения двоичной информации и данных других приложений, работающих в среде Windows.В Visual FoxPro реализованы триггеры, которые позволяют централизованно обрабатывать события, возникающие при любых изменениях в базе данных.Вы также можете создавать хранимые процедуры, которые являются частью базы данных и могут использоваться при описании таблиц, для проверки введенных данных, определения значения по умолчанию и т. п.

Чрезвычайно удобным и полезным средством доступа к базе данных являются представления данных. Представления данных позволяют объединять данные таблиц и отображать их в более удобном виде. Вы можете выбрать только интересующие вас поля таблиц, объединить несколько полей в одно поле, вычислить итоговые значения и задать новые имена полей таблицы. Как правило, количество представлений в базе данных намного превосходит количество таблиц. По мере эксплуатации базы данных их количество непрерывно растет. Во многих информационных системах доступ к данным, включая просмотр, добавление и редактирование, осуществляется только с помощью представлений данных. Данный подход позволяет осуществить гибкое управление доступом к информации. При использовании представлений для выборки данных в формах, отчетах, при создании запросов и в программах применяются те же правила, что и для таблиц. Редактирование данных, включенных в представление, возможно только при определенных условиях. Например, в том случае, если оно создано на основе только одной таблицы.

Для отображения и редактирования данных используются формы, отчеты, запросы и программы. При создании форм, отчетов и запросов применяются конструкторы. Поэтому эти компоненты часто называют конструкторскими объектами. Формы и отчеты являются составными объектами, т. к. они состоят из более мелких объектов (таких как поля, кнопки, диаграммы, рамки, OLE - компоненты и т. п.), которые называются объектами интерфейса.

Формы используются для просмотра или ввода данных в таблицы. Данные можно вводить непосредственно в таблицы, но использование формы является более быстрым и более эффективным способом ввода. Форма содержит некоторые или все поля таблиц, в которые вы вводите информацию. Для создания форм вы можете использовать мастер создания форм или конструктор форм. Мастер форм содержит целый ряд шаблонов, которые определяют соотношение между помещаемыми в форму таблицами, вид отображения данных и порядок размещения полей. Для создания сложных форм применяется конструктор форм.

Отчеты используются для просмотра и вывода на печать содержащейся в базе данных информации. Примерами отчетов являются прайс-лист товаров, список покупателей, оборотная складская ведомость. Как правило, отчеты создаются в том случае, если информацию необходимо передавать кому-либо в печатном виде. Для создания отчетов в Visual FoxPro, как и для форм, используются мастер и конструктор отчетов. С помощью мастера отчетов вы можете быстро создать собственный отчет на основе имеющихся шаблонов. Применение конструктора отчетов позволяет создавать отчеты произвольной сложности, включая многоуровневую группировку данных и размещение вычисляемых полей.

Запросы являются средством выборки данных из одной или нескольких таблиц. В Visual FoxPro для создания запроса вы можете использовать как конструктор запросов, так и специализированный язык Structured Query Language (SQL). Результаты выполнения запроса могут отображаться в форме, выводиться в виде отчетов и диаграмм или сохраняться в указанной вами таблице.

Программы, написанные на языке Visual FoxPro, являются объектно-ориентированными. С помощью них вы обрабатываете события в форме, создаете объекты, осуществляете различные вычисления, управляете базой данных. Для удобства работы вы можете объединить программы в библиотеки.

Для создания форм в Visual FoxPro можно использовать не только базовые классы, но и создавать собственные. Например, вы можете определить класс форм, в котором задан определенный цвет фона и стандартный набор кнопок для управления данными. Чтобы стандартизировать разработку, полезно иметь один или несколько пользовательских классов для каждого базового класса. Классы, созданные в Visual FoxPro, хранятся в библиотеках классов.

Для объединения компонентов создаваемого приложения используется проект, в который включаются все перечисленные выше компоненты. Использование проекта упрощает разработку приложения и его сопровождение.

В Visual FoxPro имеется возможность сохранять параметры основного окна Visual FoxPro, настройки таблиц, параметры диалоговых окон и панели инструментов с помощью файла параметров настройки.

Каждый компонент хранится в отдельном файле, причем имена файлов, содержащих основные компоненты, вы задаете самостоятельно, а наименования файлов, содержащих объекты, связанные с таблицей, совпадают с именем таблицы. В зависимости от типа содержащегося в нем объекта Visual FoxPro автоматически присваивает каждому файлу расширение, которое помогает в идентификации объекта. Список расширений файлов приведен в табл. 1.1.

Таблица 1.1. Расширения имен файлов объектов Visual FoxPro

Наименование объекта
 | Расширения
Проект | PRJ, FPC, CAT, PJX, PJT
База данных | DBC
Таблица Visual FoxPro | DBF
Составной индексный файл | CDX
Memo-поле и поле типа General | FRT
Форма | sex
Запрос | QPR
Отчет | FRX, FRM
Почтовая наклейка | LBX, LBL
Меню | MNX
Библиотека класса | VCX
Программа, библиотека программ,текст меню, текст запроса | PRG, FXP, MPR, QPR
Рисунок | BMP, JPG, GIF, ICO, DIB, CUR, ANI
Звукозапись | WAV


Современные реляционные СУБД

Для создания базы данных, изменения ее структуры, редактирования и выборки данных используются системы управления базами данных. Современные реляционные системы управления базами данных содержат:

  • набор инструментов для создания таблиц и отношений между связанными таблицами;
  • средства администрирования базы данных;
  • развитый пользовательский интерфейс, который позволяет получить доступ к информации, хранящейся в базе данных;
  • средства разработки приложений, использующих базы данных.

На рис. 1.2 показан пример учета междугородних телефонных разговоров с помощью двух таблиц реляционной базы данных в Visual FoxPro.

С помощью средств СУБД вы можете:

  • выбрать информацию, представляющую для вас интерес. Например, вы можете получить сведения обо всех междугородних разговорах определенного клиента за любой интервал времени;

Рис. 1.2. Учет заказов с помощью реляционных таблиц

Рис. 1.3. Отчет в табличном виде, содержащий информацию о клиентах телефонной компании

  • вывести на печать всю таблицу или только выбранные записи и поля в различных форматах. Например, на рис. 1.3 показан табличный отчет, содержащий адреса клиентов телефонной компании. На рис. 1.4 приведен один из вариантов информационного письма, содержащего имена и фамилии клиентов из той же самой таблицы;
  • отображать информацию базы данных в графическом виде. Например, нарис. 1.5 выведены, в виде диаграммы, данные о количестве клиентов торговой фирмы по городам;
  • осуществлять необходимые вычисления при формировании отчетов и выборке данных из таблиц.

Рис. 1.4. Информационное письмо, использующее сведения из базы данных

В настоящее время имеется более десяти популярных СУБД для персональных компьютеров. Традиционно одной из наиболее распространенных в России и странах СНГ является СУБД Visual FoxPro, новая версия которой, Visual FoxPro 7.0, содержит дополнения и улучшения, расширяющие возможности системы.

Рис. 1.5. Графическое представление информации о количестве клиентов торговой фирмы


Реляционные базы данных

Первые системы управления базами данных появились в середине шестидесятых годов XX века и поддерживали иерархическую модель данных в которой между записями существовали отношения предок/потомок. Спустя короткое время, были разработаны сетевые базы данных, в основу которых была заложена значительно более сложная сетевая модель. У каждой из этих моделей имелись свои достоинства и недостатки, которые сыграли ключевую роль в развитии реляционной модели.

В 1970 году статья научного сотрудника компании IBM доктора Е. Ф. Коддао реляционной модели данных произвела революцию в подходе к хранению и обработке информации. На основе этой модели в семидесятые годы были разработаны первые реляционные базы данных, а в настоящее время они рассматриваются как стандарт для современных коммерческих СУБД.

В реляционных базах данных вся информация сведена в таблицы, строки и столбцы которых называются записями и полями соответственно. Эти таблицы получили название реляций [Отношение — математический термин из теории множеств, которая легла в основу реляционной модели данных. В английском языке слову "отношение" соответствует слово relation, отсюда название "реляция". — Ред. ], поэтому модель стала называться реляционной. Записи в таблицах не повторяются. Их уникальность обеспечивается первичным ключом, содержащим набор полей, однозначно определяющих запись. Для быстрого поиска информации в базе данных создаются индексы по одному или нескольким полям таблицы. Значения индексов хранятся в упорядоченном виде и содержат ссылки на записи таблицы. Для автоматической поддержки целостности связанных данных, находящихся в разных таблицах, используются первичные и внешние ключи. Для выборки данных из нескольких связанных таблиц используются значения одного или нескольких совпадающих полей. Например, таблица регистрации междугородних телефонных разговоров может содержать следующие сведения:

  • Номер заказа
  • Код услуги
  • Номер телефона
  • Дата разговора
  • Код города
  • Продолжительность разговора
  • Стоимость
  • Примечание

Записи о междугородних разговорах заносятся в книгу регистрации в табличном виде в хронологическом порядке (рис. 1.1). Каждая строка имеет одинаковую структуру и состоит из восьми полей. В рассматриваемом примере это поля : Номер заказа, Код услуги, Номер телефона, Дата разговора, Код города, Продолжительность, Стоимость.

Рис. 1.1. Книга регистрации междугородних разговоров

Замечание

В реляционных базах данных поля могут иметь разные типы данных (числовой, строковый, типа даты и т. п.), но для каждой записи тип данных поля остается неизменным.

Одним из важных требований к базам данных является быстрая выборка хранимой в ней информации. Используя телефонно-адресную книгу, в которой данные упорядочены по фамилиям, вы можете найти номер телефона по фамилии его владельца. Однако, если записи в книге регистрации междугородних разговоров упорядочены в хронологическом порядке, вам придется потратить значительное время на получение списка клиентов, заказывавших разговор с определенным городом, или на выяснение того, в каком районе проживают абоненты, приносящие наибольшую прибыль телефонной компании своими продолжительными разговорами.

На помощь приходят компьютерные базы данных. Они, несмотря на огромный объем хранящейся в них информации, обеспечивают высокую скорость поиска необходимой информации. В таких базах данных пользователь может выполнить поиск по любому интересующему его параметру. Кроме того, компьютерные базы данных очень компактны. База данных, содержащая несколько тысяч записей, может поместиться на одной дискете.


ГЛАВА 1
Знакомство с Visual FoxPro

Перемены, произошедшие в нашей стране в последнее время, не могли не затронуть областей информатики и вычислительной техники. Еще десять лет назад работа с базами данных была уделом профессиональных программистов. Сами системы не были предназначены для простого пользователя. Основным потребителем таких систем был военно-промышленный комплекс. С появлением банков, акционерных обществ, частных компаний базы данных нашли более широкое применение. Люди понимают, что информация — это деньги. Ее потеря или несвоевременное получение могут дорого стоить. Именно этим можно объяснить столь бурный рост информационных технологий и стремительное развитие систем управления базами данных (СУБД).


  • Знакомство с Visual FoxPro
  • Реляционные базы данных
  • Современные реляционные СУБД
  • Объекты Visual FoxPro
  • Что нового появилось в Visual FoxPro 7.0


Создание трехмерных диаграмм

Таблица CNTCUST содержит всего одно числовое поле, поэтому диаграмма,показанная на рис. 10.17, представляет собой простейшую диаграмму. Дляпостроения более сложной диаграммы обратимся к перекрестной таблице SALEREG.

Рис. 10.18. Трехмерная диаграмма,построенная для таблицы SALEREG

Для создания диаграммы выполните следующие действия:

  1. Запустите мастера создания диаграммы Graph Wizard (Мастер диаграмм).
  2. На первом шаге выберите таблицу SALEREG и поля, содержащие код товараи объемы продаж по городам. Чтобы диаграмма была более наглядной, ограничьтесь выбором нескольких городов. Нажмите кнопку Next (Далее).
  3. Перенесите поле, содержащее наименование города, в область Axis (Ось),а объемы продаж по городам — в Data Series (Ряд данных).
  4. Укажите тип создаваемой диаграммы и нажмите кнопку Next (Далее) дляперехода к завершающей стадии создания диаграммы с помощью мастера.
  5. Введите заголовок диаграммы: Продажи по городам.

Созданная диаграмма будет иметь вид, представленный на рис. 10.18.


Создание диаграммы с помощьюмастера Graph Wizard

Для построения диаграммы воспользуемся одномерной перекрестной таблицей CNTCUST, отображающей распределение клиентов по городам. О нейупоминалось в начале данной главы.

На первом шаге создания диаграммы с помощью мастера указывается таблица, для которой строится диаграмма. Это может быть таблица из базыданных или выборка из нескольких таблиц. После выбора полей, используемых при создании диаграммы, вызывается приложение WZGRAPH.APP.Это приложение передает выбранные данные в Microsoft Graph и на их основе создается диаграмма указанного вами типа.

Рассмотрим создание диаграммы с помощью мастера более подробно.

  1. В меню File (Файл) выберите команду New (Новый).
  2. В диалоговом окне New (Новый) укажите тип создаваемого объекта Query(Запрос) и нажмите кнопку Wizard (Мастер).
  3. Из диалогового окна Wizard Selection (Выбор мастера) запустите мастерасоздания диаграммы, выбрав значение Graph Wizard (Мастер диаграмм).
  4. На первом шаге работы мастера выберите исходную таблицу CNTCUST иполя, которые будут использоваться при создании диаграммы(рис. 10.12). Рассматриваемая исходная таблица содержит всего два поля.Выберите их.

Совет

Если исходная таблица содержит много полей, вы можете ограничить количество выбираемых полей, т. к. при большом количестве полей диаграмма получается недостаточно наглядной и ее трудно анализировать.

Рис. 10.12. Выбор исходной таблицы и полей

Завершив выбор полей, нажмите кнопку Next (Далее).5. В следующем диалоговом окне мастера (рис. 10.13) выполните действия:

  • укажите поле, содержащее названия городов, значения которого будутиспользоваться в категориях диаграммы;
  • укажите поле, содержащее количество клиентов, значения которогобудут использоваться в рядах данных.

Для этого перенесите поле город исходной таблицы в область Axis (Ось),а поле количество — в область Data Series (Ряд данных) диалогового окна. Затем нажмите кнопку Next (Далее).

Рис. 10.13. Определение категории и рядов данных

  6. На следующем шаге вы должны указать тип создаваемой диаграммы(рис. 10.14), выбрав значение из предложенных вариантов. В данномпримере выберите гистограмму. Для перехода к следующему шагу нажмите кнопку Next (Далее).

Рис. 10.14. Определение типа диаграммы

  7. В последнем диалоговом окне мастера (рис. 10.15) введите заголовокдиаграммы и установите флажок добавления в диаграмму легенд (то естьусловных обозначений рядов данных). Используя кнопку Preview(Просмотр), просмотрите результат своей работы. Еще не поздно вернуться к предыдущим шагам в работе мастера и изменить установленныетам параметры. После этого, используя расположенные в окне переключатели (табл. 10.5), укажите дальнейшие ваши действия.

Таблица 10.5. Назначение переключателей диалогового окна Graph Wizard Step 4

Переключатель | Назначение
Save graph to a form (Сохранитьдиаграмму в форме) | Сохраняет созданную диаграмму в форме
Save graph to a table (Сохранитьдиаграмму в таблице) | Сохраняет созданную диаграмму в таблице,содержащей поле типа General
Create a query that produces thegraph (Сохранить и создать длядиаграммы запрос) | Сохраняет созданный запрос и открывает егов окне конструктора запросов

Выберите третий вариант и нажмите Finish (Готово). Мастер сохранит запрос с заданным именем и откроет окно конструктора с созданным запросом. Тело запроса содержит конструкцию SELECT и команду вызоваприложения создания диаграммы.

Рис. 10.15. Завершающая стадия создания диаграммы

  8. Запустите запрос на выполнение.
  9. Снова вызывается мастер построения диаграмм, предлагая повторитьшаги с третьего по пятый. На завершающей стадии построения диаграммы задайте ее заголовок, нажмите кнопку Finish (Готово) и введите имяформы, в которой будет храниться созданная диаграмма. После этогомастер вызывает программу Microsoft Graph, в которую передает результаты выборки и параметры диаграммы. На рис. 10.16 показана созданнаядиаграмма.

Диаграмма сохранена в форме. Вы можете открыть форму, изменить типдиаграммы или отформатировать ее элементы. Для подробного ознакомления с этими возможностями обратитесь к справочной системе MicrosoftGraph или руководству пользователя.

Чтобы перейти в режим редактирования диаграммы, выделите диаграмму ивыберите из контекстного меню команду Chart Object (Объект "диаграмма"),а затем команду Edit (Правка). Теперь вы можете приступить к изменениюее параметров.

Рис. 10.16. Диаграмма распределения клиентов по городам

Рис. 10.17. Круговая диаграмма распределения клиентов по городам

Замечание

В режиме редактирования можно настраивать самые разнообразные параметры диаграммы: формат отображения данных, заголовок диаграммы, надписиосей, параметры сетки, шрифт, формат выводимых значений и т. п.

Созданная нами диаграмма является одномерной. Для исходной таблицы выможете также построить круговую диаграмму, которая позволяет увидетьотносительный вклад каждой из величин в итоговое значение (рис. 10.17).Каждому элементу данных на диаграмме соответствует сектор круга, а суммарному значению — весь круг.


Построение диаграмм

Для визуального анализа данных, хранящихся в таблицах Visual FoxPro, выможете использовать диаграммы.

В распоряжение разработчика Visual FoxPro предоставляет двенадцать типовдиаграмм. Вам необходимо правильно определиться с ее типом, т. к. одну иту же информацию можно представить с помощью диаграмм разных типов.

Для построения диаграмм в Visual FoxPro используется программа MicrosoftGraph, данные в которую передаются с помощью мастера построения диаграмм или с использованием приложения WZGRAPH.APP.


Экспорт данных

Созданную в Visual FoxPro перекрестную таблицу вы можете использовать впрограммах управления электронными таблицами, таких как Microsoft Excel,Lotus 1-2-3 и т. д. Для этого вы должны ее экспортировать в формат той электронной таблицы, в которой будет осуществляться дальнейшая обработка.

Для экспорта данных предназначена команда Export (Экспорт) из меню File(Файл). В результате выполнения этой команды открывается диалоговое окно Export (Экспорт) (рис. 10.11), в котором вы должны указать исходнуютаблицу, задать формат данных, имя выходного файла, а затем нажать кнопку ОК.

Рис. 10.11. Диалоговое окно Export


Программа создания перекрестной таблицы

Мастер перекрестных таблиц использует в своей работе программуVFPXTAB.PRG. Эту программу вы можете вызывать из ваших программ,предварительно подготовив и открыв в текущей области требуемую таблицу.

Для работы программы, создающей перекрестную таблицу, необходимо определить используемые в ней параметры (табл. 10.4).

Таблица 10.4. Параметры программы, создающей перекрестные таблицы

Порядковыйномерпараметра | Назначение | Значениепо умолчанию
1 | Имя выходного файла или курсора | xtab.dbf
2 | Признак создания только курсора | True
3 | Признак закрытия исходной таблицы при выходе изпрограммы | True
4 | Признак отображения индикатора работы программы | True
5 | Номер поля, являющегося строкой перекрестнойтаблицы | 1
6 | Номер поля, являющегося столбцом перекрестнойтаблицы | 2
7 | Номер поля, являющегося полем данных перекрестной таблицы | 3
8 | Признак формирования итогового поля | False
9 | Тип вычисления итогового поля (0 — сумма, 1 — количество, 2 — доля от итогового значения в процентах) |

Воспользуемся программой VFPXTAB.PRG для представления итоговогообъема продаж товара по месяцам в виде перекрестной таблицы.

  1. В окне конструктора запросов создайте запрос, используя таблицыOrdsaiem и Ordsaied. Разместите в итоговых полях код товара, месяц продажи и стоимость проданного товара. Установите группировку данных покоду товара, месяцу продажи и упорядочение данных по коду товара.
  2. Просмотрите созданный запрос и убедитесь, что он правильно осуществляет выборку данных из таблиц.
  3. Откройте диалоговое окно, в котором отображается SQL-оператор, соответствующий созданному вами запросу. Для этого в меню Query (Запрос)выберите команду View SQL (Показать SQL).
  4. Скопируйте SQL-оператор в буфер обмена Windows.
  5. Откройте новое окно редактора программ. Для этого перейдите на вкладку Code (Код) конструктора проекта, установите курсор в группу Programs (Программы) и нажмите кнопку New (Новый).
  6. В открывшемся окне новой программы разместите из буфера обменаконструкцию SELECT, определяющую итоговые ежемесячные продажи.
  7. Добавьте в вашу программу вызов программы генерации перекрестнойтаблицы:

SELECT SaleMon

DO (_GENXTAB) WITH 'SMon',.F.,.T.,.T.,,,, .T.,2

После размещения в программе всех необходимых команд она будетиметь вид, представленный на рис. 10.9.

Рис. 10.9. Завершающая стадия создания перекрестной таблицы

  8. Сохраните программу с именем Salemon.prg и запустите ее на выполнение. Будет создана таблица smon с ежемесячными итоговыми объемамипродаж товаров (рис. 10.10).

Рис. 10.10. Итоговые ежемесячные объемы продаж товаров

Совет

При создании выборки вы можете для определения имени месяца вместо егономера использовать подготовленную заранее функцию. Однако в этом случаепри упорядочении выборки по месяцам в перекрестной таблице названия месяцев будут расположены в алфавитном, а не в хронологическом порядке.


Создание перекрестной таблицыс помощью мастера

В Visual FoxPro для создания перекрестной таблицы можно использоватьмастер Cross-Tab Wizard (Мастер построения перекрестных таблиц). В появляющемся после запуска мастера диалоговом окне необходимо указать исходную таблицу, которая может быть таблицей из базы данных или являтьсярезультатом выборки данных из нескольких таблиц. Мастер на основе исходной таблицы создает итоговую выборку, в которой группирует и сортирует данные по полям, используемым в качестве строки и столбца перекрестной таблицы, а также вычисляет суммарное значение по заданному полюданных. Затем Visual FoxPro вызывает программу vfpxtab.prg, наименование которой хранится в системной переменной _GENXTAB.

Чтобы продемонстрировать возможности мастера по созданию перекрестнойтаблицы, воспользуемся таблицей Salegoods.

Для создания перекрестной таблицы с помощью мастера выполните следующие действия:

  1. В меню File (Файл) выберите команду New (Новый).
  2. В диалоговом окне New (Новый) выберите тип создаваемого объектаQuery (Запрос) и нажмите кнопку Wizard (Мастер).
  3. Из диалогового окна Wizard Selection (Выбор мастера) запустите мастерсоздания перекрестной таблицы, выбрав Cross-Tab Wizard (Мастер построения перекрестных таблиц).

Замечание

Для запуска мастера по созданию перекрестной таблицы можно также в менюTools (Сервис) выбрать команду Wizard (Мастер), а затем — значение Query(Запрос). При этом открывается диалоговое окно Wizard Selection (Выбор мастера).

  4. В первом окне мастера (рис. 10.4) выберите исходную таблицу Salegoodsи все три поля, которые будут использоваться в качестве строки, столбцаи поля данных перекрестной таблицы. Для перехода к следующему шагунажмите кнопку Next (Далее).

Рис. 10.4. Выбор исходной таблицы и полей

  5. На втором шаге в работе мастера (рис. 10.5) необходимо указать расположение полей в создаваемой перекрестной таблице. Вам предлагаетсяразместить поля таблицы в трех полях диалогового окна. Для перемещения полей используйте метод "перенести-и-оставить".

Рис. 10.5. Определение строк, столбцов и поля данных

Перенесите поле город в область Column (Колонка), поле код_товара —в область Row (Ряд) и поле сумма — в область Data (Данные). Послеэтого диалоговое окно будет выглядеть так, как показано на рис. 10.6.Нажмите кнопку Next (Далее) для перехода к следующему шагу.

Рис. 10.6. Диалоговое окно после определения строк,столбцов и поля данных

  6. В следующем диалоговом окне Cross-Tab Wizard (Мастер построения перекрестных таблиц) (рис. 10.7) содержится группа переключателей Summary(Итог), позволяющая вычислять групповые значения по полю (табл. 10.1).

Таблица 10.1. Назначение группы переключателей Summaryдиалогового окна Cross-Tab Wizard Step 3

Переключатель | Назначение
Sum (Сумма) | Итоговые значения равны сумме значений для каждой парыстрока/столбец
Count (Количество) | Итоговые значения равны количеству значений для каждойпары строка/столбец
Average (Среднее) | Итоговые значения равны среднему значению для каждойпары строка/столбец
Мах (Наибольшее) | Итоговые значения равны наибольшему из всех значений длякаждой пары строка/столбец
Min (Наименьшее) | Итоговые значения равны наименьшему из всех значенийдля каждой пары строка/столбец

Установите опцию Sum.

  7. На третьем шаге в работе мастера вы можете добавить столбец в создаваемую перекрестную таблицу, который будет содержать итоговое значение по каждой строке результирующей таблицы (см. рис. 10.7). Мастерпозволяет выбрать один из переключателей группы Subtotals (табл. 10.2).

Рис. 10.7. Определение типа группировки и итогового столбца

Таблица 10.2. Назначение группы переключателей Subtotalsдиалогового окна Cross-Tab Wizard Step 3

Переключатель | Назначение
Sum of data (Сумма данных) | Итоговые значения равны сумме значений длятекущей строки
Number of cells containingdata (Число ячеек, содержащих данные) | Итоговые значения равны количеству ячеек, содержащих значения
Percentage of the table total (Процент от итоговой суммы) | Итоговые значения равны сумме значений длятекущей строки, выраженной в процентах по отношению к итоговой сумме
None (Нет) | Итоговый столбец не создается

Установите опцию Percentage of the table total (Процент от итоговой суммы). Для перехода к завершающей стадии создания перекрестной таблицы нажмите кнопку Next (Далее).

  8. На последнем шаге работы мастера (рис. 10.8) вы можете просмотретьрезультаты, нажав кнопку Preview (Просмотр). Воспользуйтесь этой возможностью и убедитесь, что правильно установили все параметры.
  9. Установите в завершающем окне мастера одну из опций, описанных втабл. 10.3.

Выберите третий вариант и нажмите кнопку Finish (Готово). Мастер завершит работу и откроет созданный запрос в окне конструктора. Просмотрите SQL-оператор. Для этого в меню Query (Запрос) выберите команду ViewSQL (Показать SQL).

Рис. 10.8. Завершающая стадия создания перекрестной таблицы

Таблица 10.3. Назначение переключателей диалогового окна Cross-Tab Wizard Step 4

Переключатель | Назначение
Save cross-tab query (Сохранить перекрестную таблицу в запросе) | Мастер сохраняет созданный запрос
Save and run cross-tab query (Сохранитьперекрестную таблицу в запросе и запустить) | Мастер сохраняет созданный запроси запускает его на выполнение
Save cross-tab query and modify in theQuery Designer (Сохранить перекрестнуютаблицу и открыть для модификации в конструкторе запросов) | Мастер сохраняет созданный запроси открывает его в окне конструкторазапросов

Запрос, созданный с помощью мастера, содержит конструкцию для выборкиданных, вызов программы, формирующей перекрестную таблицу, и командупросмотра таблицы в режиме Browse (Просмотр):

SELECT SaleGoods.Код_товара, SaleGoods .Город, SUM(SaleGoods.Сумма);

FROM 'SaleGoods.DBF' SaleGoods;

GROUP BY SaleGoods.Код_товара, SaleGoods.Город;

ORDER BY SaleGoods.Код_товара, SaleGoods.Город;

INTO CURSOR SYS(2015)

DO (_GENXTAB) WITH 'Query',.t.,.t.,.t.,;, ,.t.,0,.t.

BROWSE NOMODIFY

Результат запроса аналогичен приведенному на рис. 10.3.


Двумерные перекрестные таблицы

Информация в двумерных перекрестных таблицах группируется по двумфакторам. Примером такой таблицы является Saiegoods, представленная нарис. 10.2. Она содержит сведения о стоимости проданных товаров по городам. Данная таблица была получена из таблиц customer, ordsaiem иordsaied с помощью многотабличного запроса. Для наглядности результирующим полям запроса присвоены русскоязычные названия.

SELECT Customer.cCity AS Город, Ordsaied.icdGoods AS Код_товара,;

SUM{Ordsaied.nQuant*Ordsaled.nUnitprice) AS Сумма;

FROM Sales!Customer INNER JOIN Sales!Ordsaiem;

INNER JOIN Sales!Ordsaied ;

ON Ordsaiem.icdOrder = Ordsaied.icdOrder ;

ON Customer.icdCustomer = Ordsaiem.icdCustomer;

GROUP BY Customer.cCity, Ordsaied.icdGoods;

INTO TABLE saleGoods.dbf

В таблице, представленной на рис. 10.2, отображается вся необходимая информация о продажах товаров, однако более удобным для анализа являетсяпредставление этой информации в виде перекрестной таблицы. На рис. 10.3представлена двумерная перекрестная таблица, созданная на основе таблицы Saiegoods.

Рис. 10.2. Таблица Salegoods

Рис. 10.3. Двумерная перекрестная таблица

Числа в ячейках таблицы соответствуют стоимости проданного товара длякаждой пары уникальных значений "код товара/город". Значения поля, содержащего наименование города, расположены в верхней строке таблицы, азначения поля, обозначающего код проданного товара, — в левом столбцетаблицы. Сохраните таблицу с именем salereg. Ее можно будет использовать при создании трехмерных диаграмм.


Одномерные перекрестные таблицы

Простейшим типом перекрестной таблицы является одномерная перекрестная таблица, используемая для анализа распределения данных одного типапо одному фактору.

Рис. 10.1. Одномерная перекрестная таблица

Рассмотрим создание перекрестной таблицы, отображающей распределениеклиентов по городам (рис. 10.1). Исходная информация содержится в таблице Customer.

  1. В окне проекта на вкладке Data (Данные) выберите группу Queries(Запросы) и нажмите кнопку New (Новый).
  2. Добавьте в окно конструктора запросов таблицу Customer со спискомклиентов.
  3. На вкладке Fields (Поля) окна конструктора запросов разместите в списке Selected fields (Выбранные поля) поле ccity и итоговое полеCOUNT (icdcustomer), подсчитывающее количество клиентов.
  4. На вкладках Group By (Группировка) и Order By (Упорядочение) установите группировку и упорядочение по полю ccity.
  5. Выполните команду Run Query (Выполнить запрос) меню Query (Запрос).
  6. Сохраните результат выборки в таблице cntcust, воспользовавшись дляэтого кнопкой Query Destination (Результаты запроса) панели инструментов Query Designer (Конструктор запроса). Данная таблица будет содержать распределение клиентов по городам (см. рис. 10.1). Вы можете использовать эту таблицу для формирования отчета или представленияданных в виде диаграммы.


ГЛАВА 10
Перекрестные таблицы и диаграммы

В Visual FoxPro имеются мощные средства анализа большого объема информации, хранящегося в базе данных в одной или нескольких таблицах —диаграммы и перекрестные таблицы.

Отображение данных в виде диаграмм и графиков позволяет решать самыеразные задачи. Основное достоинство такого представления — наглядность.На диаграммах хорошо просматриваются тенденции к изменению, различные соотношения, прирост, взаимосвязь различных процессов и т. д.

Но, как правило, таблицы не подготовлены для создания диаграмм. Данныев них представлены в виде нескольких составляющих, расположенных вбольшом количестве записей. Диаграмма, построенная для такой таблицы,будет иметь вид, который трудно использовать для анализа. Поэтому, прежде чем строить диаграмму, информацию необходимо преобразовать к виду,наиболее приемлемому для построения диаграмм. Для этого в Visual FoxProиспользуются перекрестные таблицы и итоговые запросы.

Перекрестная таблица - это таблица, в которой информация группируется всоответствии со значениями одного или нескольких полей и фактическиприводится к виду, аналогичному электронной таблице.

В Visual FoxPro для построения диаграмм используется Microsoft Graph.Помимо этого, для построения диаграмм из подготовленных в Visual FoxProданных вы можете использовать Microsoft Excel и другие электронные таблицы, имеющиеся в среде Windows.

Перекрестные таблицы

Перекрестная таблица в Visual FoxPro имеет вид, похожий на электроннуютаблицу. Но, в отличие от последней, вам не нужно вручную заполнять каждую ячейку таблицы, предварительно определив ее значение. Visual FoxProавтоматически разбивает данные на группы в соответствии с одним или несколькими факторами и выполняет итоговые вычисления над данными,включенными в группу. После чего информация, полученная в результатегрупповых вычислений, сортируется и заносится в перекрестную таблицу.Например, используя перекрестную таблицу, вы можете определить, сколько клиентов фирмы проживает в том или ином районе города или как распределяются между ними проданные товары. Очевидно, что каждый клиентможет покупать один и тот же товар несколько раз. Получить такие сведения без создания перекрестной таблицы достаточно трудно.

При работе с Visual FoxPro вы можете использовать одномерные и многомерные перекрестные таблицы. Для создания простейших одномерных перекрестных таблиц применяйте обычный итоговый запрос. Для построениядвумерных и более сложных перекрестных таблиц в Visual FoxPro используется мастер создания перекрестных таблиц Cross-Tab Wizard (Мастер построения перекрестных таблиц).

Прежде чем приступить непосредственно к созданию перекрестной таблицы, вы должны определить, какой тип перекрестных таблиц в наибольшейстепени подходит к выполнению текущей задачи.


  • Перекрестные таблицы
  • Одномерные перекрестные таблицы
  • Двумерные перекрестные таблицы
  • Создание перекрестной таблицы с помощью мастера
  • Программа создания перекрестной таблицы
  • Экспорт данных
  • Построение диаграмм
  • Создание диаграммы с помощью мастера Graph Wizard
  • Создание трехмерных диаграмм


Определение параметров меню

Для строки меню вы можете определить процедуры, которые будут выполняться перед запуском меню, а также после выхода из него. Кроме того, вы можете указать месторасположение строки меню. Для этого используется диалоговое окно General Options (Основные параметры) (рис. 11.14), открываемое при выборе команды General Options (Основные параметры) из меню View (Вид).

В группе Location (Размещение) этого диалогового окна можно выбрать один из вариантов размещения строки созданного меню (табл. 11.5). В поле Procedure (Процедура) вы можете ввести фрагмент программы, которая будет выполняться при активизации строки меню.

Рис. 11.14. Диалоговое окно General Options

Таблица 11.5. Группа переключателей Location диалогового окна General Options

Переключатель | Вид размещения
Replace (Замещать) | Меню замещает основное меню Visual FoxPro
Append (Добавить) | Меню добавляется в основное меню Visual FoxPro
Before (Перед) | Меню вставляется перед указанным пунктом основного меню Visual FoxPro
After (После) | Меню размещается за указанным пунктом основного меню Visual FoxPro

Флажки Setup (Задать) и Cleanup (Очистить) используются для открытия окна редактирования процедуры, вызываемой при запуске сгенерированной программы с описанием меню, и процедуры, вызываемой перед завершением этой программы.

При установленном флажке Top-Level Form (Форма высокого уровня) меню будет отображаться в отдельном окне. В противном случае меню можно использовать только в окне Visual FoxPro.


Разделители элементов меню

Для улучшения внешнего вида, а также для объединения в группы схожие по смыслу команды в меню можно использовать разделительные линии. Разделительные линии представляют собой пункт меню, в котором в поле ввода Prompt (Приглашение) вместо наименования пункта вводятся символы \-. Рассмотрим создание разделительных линий в подменю Покупатели. Для этого выполните следующие действия:

  1. Откройте файл меню в окне конструктора проекта.
  2. Перейдите в режим редактирования пункта меню Покупатели, нажав кнопку Create (Создать).
  3. Вставьте новый элемент меню после пункта меню Ввод данных. Для этого установите курсор на пункт Отчеты и нажмите кнопку Insert (Вставить).
  4. В поле Prompt (Приглашение) образованного подпункта меню New Item (Новый пункт) введите \-. ,
  5. Аналогично вставьте разделительную линию после пункта меню Отчеты.
  6. Нажмите кнопку Preview (Просмотр). Выберите пункт меню Покупатели. На экране появится подменю с разделительными линиями (рис. 11.13).

Рис. 11.13. Создание разделителей в подменю Покупатели


Действия для пунктов меню

Основное назначение пункта меню — выполнять определенное для него действие. Результат выбора пункта меню задается его типом (табл. 11.4).

Таблица 11.4. Типы пункта меню

Тип пункта меню | Действие
Submenu (Подменю) | Раскрывается связанное с данным пунктом меню ниспадающее подменю
Procedure (Процедура) | Выполняется процедура, определенная в конструкторе меню
Command (Команда) | Выполняется команда, расположенная в поле рядом с типом пункта меню

Команда

Чтобы определить команду, которая будет выполняться при выборе пункта меню, необходимо выполнить следующие действия:

  1. В столбце Result (Результат) конструктора меню выбрать из списка значение Command (Команда).
  2. Ввести в поле, расположенное с правой стороны списка, команду Visual FoxPro, которая будет выполняться при выборе данного пункта меню.

Обычно команды используются для вызова форм, отчетов, пользовательских процедур. Например, для запуска формы ввода списка клиентов достаточно ввести следующую команду:

DO FORM Client

Процедура

В том случае, если при выборе пункта меню должна выполняться некоторая последовательность команд, вам необходимо в столбце Result (Результат) окна конструктора выбрать для пункта меню тип Procedure (Процедура) и определить требуемые команды.

Рис. 11.11. Окно редактирования процедуры для пункта меню Справка

Для этого нажмите кнопку Create (Создать) и в открывшемся окне редактирования процедуры определите фрагмент кода, связанный с элементом строки меню. Например, для пункта меню Справка вы можете указать тип Procedure (Процедура) и в окне создания процедуры задать имя файла справки и команду вызова справочной системы (рис. 11.11).

При вводе процедуры не используйте команду PROCEDURE, т. к. Visual FoxPro генерирует эту команду автоматически.

Во время генерации для каждой процедуры, включенной в меню, Visual FoxPro создает уникальное имя и включает его вместе с указанием местонахождения процедуры в код, связанный с соответствующим элементом строки меню.

Замечание

После определения текста процедуры наименование кнопки Create (Создать) изменяется на Edit (Правка).

Определение подменю

Большинство команд меню создаваемого приложения открывает подменю. Например, пункт меню Покупатели должен содержать команды Ввод данных, Отчеты и Запросы. Для создания данного подменю выполните следующие действия:

  1. Нажмите кнопку Create (Создать) пункта меню Покупатели. На экране появляется пустое окно конструктора меню. Список Menu Level (Уровень меню) нового окна содержит метку текущего пункта меню.
  2. Введите в поле Prompt (Приглашение) первой строки команду Ввод данных. Используя список Result (Результат), задайте тип созданного пункта меню.
  3. Во второй строке введите команду Отчеты и также задайте тип.
  4. Аналогичным образом введите третью команду (рис. 11.12).

Замечание

Параметры пунктов подменю определяются аналогично определению пунктов строки меню. Для перехода в меню верхнего уровня используйте список Menu Level.

Рис. 11.12. Окно создания подменю


Задание параметров пункта меню в диалоговом окне Prompt Options

Для задания параметров пункта меню используется диалоговое окно Prompt Options (Опции элемента меню) (рис. 11.6). Для открытия этого окна установите в конструкторе курсор на пункт меню и нажмите появившуюся в строке кнопку Options (Опции).

Рис. 11.6. Диалоговое окно Prompt Options

В диалоговом окне Prompt Options (Опции элемента меню) содержится область Shortcut (Всплывающее меню) для задания клавиш быстрого вызова, а также поля ввода (табл. 11.3).

Таблица 11.3. Назначение полей ввода диалогового окна Prompt Options

Поле ввода | Назначение
Skip For {Пропустить для) | Позволяет заблокировать пункт меню
Message (Сообщение) | Позволяет задать сообщение, которое будет отображаться в строке состояния при выборе пункта меню
Pad Name (Имя пункта меню) | Задает имя пункта меню
Comment (Комментарий) | Задает комментарий к пункту меню

Область Negotiate (Соглашение) содержит два раскрывающихся списка, имеющих следующее назначение:

  • Container (Контейнер) — определяет расположение меню при редактировании по месту OLE-объектов;
  • Object (Объект) — задает расположение меню при выполнении приложения типа Active Document в Web-браузере.

Определение клавиш быстрого вызова пунктов меню

Помимо "горячих" клавиш, в создании которых используются только символы текста меню, в Visual FoxPro можно определить для каждого пункта меню клавиши быстрого вызова пунктов меню. В качестве такой клавиши могут использоваться символы, функциональные клавиши, комбинации клавиш. Примером клавиши ускоренного действия в программе Visual FoxPro является функциональная клавиша <F1>, используемая для вызова справочной системы. При нажатии на клавишу, определенную в качестве клавиши ускоренного действия, активизируется связанный с ней пункт меню без предварительного отображения самого меню.

Рассмотрим последовательность действий по определению клавиши быстрого вызова пункта меню справочной системы приложения.

  1. В конструкторе меню установите курсор на пункт меню Справка.

Рис. 11.7. Определение клавиши быстрого вызова для пункта меню Справка

  2. Нажмите кнопку Options (Опции).
  3. В открывшемся диалоговом окне Prompt Options (Опции элемента меню) в области Shortcut (Всплывающее меню) поле Key Label (Метка) содержит подсказку press the key (нажмите клавишу). Установите курсор в поле Key Label (Метка) и нажмите клавишу или комбинацию клавиш, используемую в качестве клавиши быстрого вызова, и в поле появится метка, соответствующая нажатию клавиши. В поле ввода Key Text (Пояснение) вы можете ввести краткое пояснение к определяемой клавише. Для пункта меню Справка нажмите клавишу <F1> клавиатуры. В поле Key Text (Пояснение) по умолчанию будет введено F1 (рис. 11.7). Оставьте это значение.
  4. Нажмите кнопку ОК для закрытия диалогового окна.

Формирование сообщения для пункта меню

Используя поле ввода Message (Сообщение) диалогового окна Prompt Options (Опции элемента меню), вы можете определить для пункта меню сообщение, которое будет отображаться в строке состояния при установке на него курсора. В качестве сообщения можно использовать не только строку текста, но и произвольное символьное выражение. В этом случае нажмите кнопку вызова конструктора выражения, расположенную с правой стороны поля, и в открывшемся диалоговом окне Expression Builder (Построитель выражения) создайте необходимое выражение.

Определим сообщение для пункта меню Справка. Для этого выполните следующие действия:

  1. Нажмите кнопку Options (Опции) для пункта меню Справка.
  2. В открывшемся диалоговом окне Prompt Options (Опции элемента меню) нажмите кнопку вызова построителя выражения для поля Message (Сообщение).
  3. В поле Message (Сообщение) построителя выражений введите строку текста "Вызов справочной системы приложения ".

Замечание

Введенную строку текста не забудьте поместить в кавычки.

  4. Нажмите кнопку ОК для закрытия диалогового окна Expression Builder (Построитель выражения). Вы оказываетесь в окне Prompt Options (Опции элемента меню). Введенное вами выражение размещено в поле Message (Сообщение) (рис. 11.8).
  5. Нажмите кнопку ОК.

Рис. 11.8. Определение сообщения для пункта меню Справка

Аналогичным образом вы можете определить сообщения для остальных пунктов меню. На рис. 11.9 показан результат вывода сообщения в строке состояния.

Рис. 11.9. Отображение в строке состояния сообщения для пункта меню

Блокирование команд меню

Иногда возникает необходимость сделать какой-либо пункт меню недоступным для пользователя. Например, вы можете использовать условие блокировки для ограничения доступа определенных пользователей к отдельным пунктам меню. Или рассмотрим еще такую ситуацию. Ваша система уже эксплуатируется пользователями, но не все пункты меню завершены. При их выборе на экране появляются сообщения об ошибках. Пользователь начинает нервничать. В этом случае вы можете задать для незавершенных пунктов меню условие блокировки. Чтобы определить условия блокировки, выполните следующие действия:

  1. Нажмите кнопку Options (Опции) для пункта меню, который хотите заблокировать.
  2. В открывшемся диалоговом окне Prompt Options (Опции элемента меню) нажмите кнопку вызова построителя выражения для поля Skip For (Пропустить для).
  3. Введите .71 в поле Skip For (Пропустить для) построителя выражений.
  4. Нажмите кнопку ОК для закрытия диалогового окна Expression Builder (Построитель выражения). Вы оказываетесь в окне Prompt Options (Опции элемента меню).

Замечание

Задавая условия блокировки, вы можете ввести любое допустимое логическое выражение. При вводе простого выражения, не требующего использования функций конструктора выражений, введите формируемое выражение в поле Skip For (Пропустить для) диалогового окна Prompt Options (Опции элемента меню).

  5. Нажмите кнопку ОК для его закрытия.

Когда значение выражения, заданное в условии блокировки, является истинным, пункт меню становится недоступным.

В режиме просмотра вы не увидите, что пункт меню заблокирован. Чтобы убедиться в правильно созданной блокировке, вам необходимо созданное в конструкторе меню сгенерировать и полученную в результате программу запустить на выполнение.

Присвоение имени пункту меню

По умолчанию при генерации программы Visual FoxPro в качестве имен пунктов меню создает уникальные имена. Для повышения читабельности программы можно определить эти имена явным образом, используя поле ввода Pad Name (Имя пункта меню) диалогового окна Prompt Options (Опции элемента меню).

На рис. 11.10 приведено диалоговое окно Prompt Options (Опции элемента меню) для пункта меню Справка с определенным для него именем пункта меню, сообщением в строке состояния и условием блокировки.

Рис. 11.10. Диалоговое окно Prompt Options для пункта меню Справка


"Горячие" клавиши

Для выбора пункта меню используются клавиши-стрелки или мышь. Помимо этого, вы можете определить для пункта меню "горячую" клавишу, нажатие которой вместе с клавишей <Alt> активизирует этот пункт.

Для создания "горячей" клавиши, предоставляющей пользователю возможность ускоренного выбора пункта меню, необходимо включить в его имя перед активизирующим символом следующие символы \<. В качестве "горячей" клавиши можно использовать первый символ имени пункта, что, конечно, более предпочтительно, а также и любой другой символ из его имени. Символы, используемые в качестве "горячей" клавиши, выделяются в строке меню подчеркиванием.

"Горячие" клавиши для пунктов меню назначаются Visual FoxPro по умолчанию. Для их создания используются первые буквы элементов строки меню. Если два элемента вашего меню начинаются с одинаковой буквы, то обоим элементам строки меню в качестве "горячей" клавиши назначается одинаковый символ. В этом случае вам нужно переопределить "горячую" клавишу для одного из элементов строки меню.

Для облегчения назначения "горячих" клавиш можно использовать искусственный прием: перед именами пунктов меню разместить цифры и их использовать в качестве "горячих" клавиш (рис. 11.5).

Рис, 11.5. Создание строки меню с назначенными "горячими" клавишами


Создание меню

После того как вы открыли конструктор, можно приступать к созданию меню. Для этого выполните следующие действия:

  1. В поле Prompt (Приглашение) введите наименования первого пункта меню и нажмите клавишу <Enter> или <ТаЬ> для перехода на следующее поле. Курсор оказывается в списке Result (Результат).
  2. Для определения типа пункта меню (табл. 11.2) нажмите кнопку раскрытия списка и выберите необходимое значение из тех, которые предлагает система.

Таблица 11.2. Типы пунктов меню

Тип меню | Назначение
Command (Команда) | При выборе пункта меню данного типа будет выполняться связанная с ним команда
Pad Name (Наименование строки меню) | При выборе пункта меню никаких действий выполняться не будет. Как правило, используется в качестве дополнительного пояснения к меню
Submenu (Подменю) | При выборе пункта меню раскрывается связанное с данным пунктом ниспадающее меню
Procedure (Процедура) | При выборе пункта меню вызывается процедура, определенная для данного пункта меню

Замечание

При использовании значения типа Command (Команда) с правой стороны появляется поле для ввода команды, выполняемой при выборе данного пункта меню. Это может быть, например, команда вызова формы или формирования отчета. Если из списка Result (Результат) вы выбрали значение Procedure (Процедура) или Submenu (Подменю), в окне конструктора правее описания типа пункта меню появляется кнопка Create (Создать). При нажатии на эту кнопку вы переходите, соответственно, в окно создания процедуры или в окно создания ниспадающего меню для выбранного пункта меню.

Рис. 11.3. Основное меню приложения

  3. Указав тип пункта меню, перейдите в следующую строку и введите информацию о втором пункте меню.
  4. Введите наименования остальных пунктов меню и их типы (рис. 11.3).
  5. Для просмотра созданных пунктов меню нажмите кнопку Preview (Просмотр). Основное меню Visual FoxPro будет заменено созданным меню. Пункты меню отображаются на экране в порядке их описания. На экране также появляется диалоговое окно Preview (Просмотр), в котором отображается текст текущего пункта меню, его тип и выполняемое действие (рис. 11.4).

Рис. 11.4. Просмотр созданного меню приложения


Запуск конструктора меню

Для открытия окна конструктора меню воспользуйтесь одним из следующих способов:

  • В меню File (Файл) выберите команду New (Новый). В открывшемся диалоговом окне New установите опцию Menu (Меню) и нажмите кнопку New File (Новый файл).
  • В окне проекта перейдите на вкладку Other (Остальные) и выберите группу Menus (Меню). Затем нажмите кнопку New (Новый) окна проекта.
  • Находясь в группе Menus (Меню) окна проекта, нажмите кнопку New (Новый) на стандартной панели инструментов Visual FoxPro. В открывшемся диалоговом окне New (Новый) установите опцию Menu (Меню) и нажмите кнопку New File (Новый файл).

На экране открывается диалоговое окно New Menu (Новое меню), в котором предлагается два варианта меню (рис. 11.1).

  • Menu — меню в виде строки.
  • Shortcut — всплывающее меню, в котором основные пункты расположены по вертикали.

Рис. 11.1. Диалоговое окно New Menu

Выберите тип создаваемого меню, нажав соответствующую кнопку. В результате запускается конструктор меню, а в основное меню Visual FoxPro добавляется новый пункт Menu (Меню) (рис. 11.2). Сначала рассмотрим создание меню в виде строки. Для этого выберите опцию Menu (Меню).

Рис. 11.2. Конструктор меню

Область конструктора меню, над которой размещены надписи Prompt (Приглашение), Result (Результат) и Options (Опции), предназначена для формирования меню.

В поле Prompt (Приглашение) можно ввести наименования пунктов меню. Раскрывающийся список Result (Результат) используется для указания типа пункта меню. Кнопка Options (Опции) открывает диалоговое окно Prompt Options (Опции элемента меню), в котором можно определить дополнительные параметры данного элемента меню ("горячие" клавиши, сообщение, отображаемое в строке состояния при выборе пункта меню, и т. д.). В списке Menu level (Уровень меню) указывается уровень текущего меню.

Слева в конструкторе меню размещены кнопки (табл. 11.1).

Таблица 11.1. Назначение кнопок конструктора меню

Кнопка | Назначение
Insert (Вставить) | Добавляет в меню новый пункт
Insert Bar (Вставить команды системного меню) | Открывает диалоговое окно Insert System Menu Bar, содержащее команды системного меню Visual FoxPro, позволяя разместить их в создаваемом пользовательском меню
Delete (Удалить) | Удаляет текущий пункт меню
Preview (Просмотр) | Размещает создаваемое меню на экране, позволяя просмотреть его внешний вид


Действия, необходимые для создания меню

Строкой меню называется горизонтальное меню, располагаемое в верхней части экрана. Примером строки меню является основное меню Visual FoxPro, а также меню программ, работающих в среде Windows. Созданное вами в конструкторе меню может замещать основное меню Visual FoxPro или добавляться к нему.

Для создания меню необходимо выполнить следующие действия:

  1. Открыть окно конструктора меню.
  2. Описать вид меню, текст, пункты меню и его атрибуты.
  3. Определить действия, которые будут выполняться при выборе пунктов меню.
  4. Сгенерировать меню, используя команду Generate (Генерация) из меню Menu (Меню). При этом создается программа, которую вы в результате и запускаете на выполнение.

Замечание

На каждом шаге создания меню приложения вы можете просматривать его с помощью кнопки Preview (Просмотр) конструктора.

Рассмотрим эти этапы более подробно.


Создание всплывающего меню

В Visual FoxPro 7.0 имеется возможность создания всплывающего меню средствами конструктора меню.

Способ создания меню данного типа аналогичен созданию горизонтального меню в виде строки. Для этого меню, как и для обычного, можно определить оперативные клавиши и опции, устанавливаемые в диалоговом окне Prompt Options (Опции элемента меню).

Чтобы создать всплывающее меню, выполните следующую последовательность действий:

  1. Откройте проект.
  2. Для открытия окна конструктора меню в окне проекта перейдите на вкладку Other (Остальные) и выберите группу Menus (Меню).
  3. Нажмите кнопку New (Новый) окна проекта.
  4. В открывшемся диалоговом окне New Menu (Новое меню) нажмите кнопку Shortcut (Всплывающее меню). Откроется окно конструктора меню.
  5. В поле Prompt (Приглашение) последовательно введите тексты пунктов меню и определите для них выполняемые действия (рис. 10.16).

Рис. 11.16. Создание меню типа Shortcut

  6. Для генерации выберите команду Generate (Генерация) в меню Menu (Меню).
  7. Запустите меню на выполнение. Вид данного меню при запуске представлен на рис. 11.17.

Рис. 11.17. Меню типа Shortcut


Сохранение, генерация и запуск меню

Для сохранения созданного меню выберите команду Save as (Сохранить как) в меню File (Файл). В открывшемся диалоговом окне Save as (Сохранить как) из списка Папка выберите папку, в которой вы предполагаете сохранить файл, откройте ее, в поле Save Menu (Сохранить меню) введите имя сохраняемого меню. В заключение нажмите кнопку Сохранить.

С помощью кнопки Preview (Просмотр) окна конструктора меню можно просмотреть внешний вид создаваемого меню, но нельзя его активизировать. Чтобы можно было использовать меню в приложениях, его необходимо предварительно сгенерировать. Для этого выполните следующие действия:

  1. В меню Menu (Меню) выберите команду Generate (Генерация). Откроется диалоговое окно Generate Menu (Генерация меню) (рис. 11.15).
  2. В поле Output File (Внешний файл) введите имя файла, который будет создан в результате генерации.
  3. Для запуска генерации описания меню нажмите кнопку Generate (Генерация).

Рис. 11.15. Диалоговое окно Generate Menu

После завершения генерации можно запустить программу меню на выполнение. Для этого выполните одно из следующих действий.

  • В окне проекта установите курсор на наименование созданного меню и нажмите кнопку Run (Запустить).
  • В меню Program (Программа) выберите команду Do (Выполнить). В открывшемся диалоговом окне Do (Выполнить) откройте папку, в которой вы сохранили файл меню, выберите файл с расширением MPR и нажмите кнопку Do (Выполнить).

На экране появится созданное вами меню, которое заменит основное меню Visual FoxPro, если в диалоговом окне General Options (Основные параметры) перед генерацией была установлена опция Replace (Замещать).

Совет

Если вам не удается восстановить на экране системное меню Visual FoxPro, введите в командном окне команду SET SYSMENU то DEFAULT.


ГЛАВА 11
Меню приложения

В соответствии со стандартами Windows в любом приложении рекомендуется иметь строку меню, которая в Visual FoxPro содержит команды, предназначенные для вызова форм, формирования отчетов, запросов и т. д.

При разработке приложения вы можете создать все требуемые объекты (базу данных, входящие в нее таблицы, формы, отчеты, запросы). Затем объединить отдельные объекты с помощью меню. Можно поступить иначе. Сначала разработать и создать меню, а затем по мере создания форм и отчетов включать их запуск в меню. Второй способ более нагляден. Вы в любой момент можете запустить меню и продемонстрировать заказчику, как создаваемая система выглядит, как осуществляется вызов тех или иных программ, запустить уже созданные формы, напечатать подготовленные отчеты.

Подготовка к созданию меню

На начальном этапе разработки необходимо определить требования, предъявляемые к создаваемому приложению, состав информации, которая будет содержаться в проектируемой базе данных.

После этого определяется структура таблиц и совпадающие поля для их связывания. Затем создаются сами таблицы, входящие в базу данных, определяются отношения между ними.

Одновременно с составом информации вы должны определить те средства, которые получит в свое распоряжение пользователь при работе с вашим приложением.

Приложение должно содержать эффективную справочную систему, содержащую информацию о приложении, описание его основных функций и инструкцию по работе. В среде Windows предпочтительнее всего создавать справочную систему в принятом в Windows стандарте, чтобы облегчить пользователю поиск информации в знакомой ему среде.

После того как определена структура данных, спроектированы таблицы, входящие в базу данных, вы можете приступить к разработке структуры меню. Прежде чем описывать структуру меню в конструкторе, нарисуйте эскиз меню на бумаге, посоветуйтесь с пользователями приложения.


  • Подготовка к созданию меню
  • Действия, необходимые для создания меню
  • Запуск конструктора меню
  • Создание меню
  • "Горячие" клавиши
  • Задание параметров пункта меню в диалоговом окне Prompt Options
  • Действия для пунктов меню
  • Разделители элементов меню
  • Определение параметров меню
  • Сохранение, генерация и запуск меню
  • Создание всплывающего меню


Содержание справочной системы

Обычно окно справочной системы содержит три вкладки: Содержание, Указатель и Поиск. Для того чтобы в диалоговом окне присутствовала вкладка Содержание, необходимо создать файл с содержанием справки. Например, для файла справки, приведенного на рис. 12.8, не был создан файл с содержанием справочной системы. Конечно, можно в области текста темы, открываемой при вызове справочной системы, указать ссылки на все остальные темы файла справки. Но при создании файла справки в среде

Windows более предпочтительным является отображение содержания в иерархическом виде. Для создания такого содержания в Help Workshop выполните следующие действия:

  1. В меню File (Файл) выберите команду New (Создать).
  2. В диалоговом окне New (Новый) выберите опцию Help Contents (Содержание).
  3. На экране открывается диалоговое окно, в котором можно выбрать режим создания содержания справочной системы. Выберите опцию Help Contents (Содержание). Открывается окно редактора содержания справочной системы.
  4. В поле Default filename (and window) (Стандартный титул файла и окна) введите имя файла справки, содержащего темы, на которые ссылаются элементы содержания.
  5. В поле Default title (Стандартный титул) введите заголовок окна содержания.
  6. В центре диалогового окна расположена область отображения содержания справочной системы. В нее вы можете добавить заголовки нескольких уровней вложенности и ссылки на темы справочной системы. Для добавления заголовка самого верхнего уровня нажмите на кнопку Add Below (Добавить ниже). На экране открывается диалоговое окно Edit Contents Tab Entry.
  7. Установите опцию Heading (Заголовок).
  8. В поле Title (Титул) введите наименование заголовка.
  9. Нажмите кнопку ОК для закрытия диалогового окна.
  10. Для ввода заголовка следующего уровня опять нажмите кнопку Add Below (Добавить ниже) и создайте следующий заголовок.
  11. Созданный заголовок является на самом деле подзаголовком предыдущего заголовка. Нажатием кнопки Move Right (Переместить вправо) переместите его правее на следующий уровень вложенности.
  12. Для добавления ссылки \на тему справочной системы нажмите кнопку Add Below (Добавить ниже) или Add Above (Добавить выше).
  13. В открывшемся диалоговом окне Edit Contents Tab Entry установите опцию Topic (Тема).
  14. В поле Title (Титул) введите наименование заголовка, а в поле Topic ID — идентификатор темы справки.
  15. Если тема находится в файле справки, отличном от файла, указанного в поле Default filename (and window) (Стандартный титул файла и окна), укажите в поле ввода Help file (Файл справки) имя файла справки.
  16. После ввода содержания справочной системы сохраните его.

Чтобы подключить содержание к файлу справки откройте окно файла проекта и в разделе [OPTIONS] укажите имя файла с содержанием справочной системы.


Компиляция справочной системы

После того как описание тем справочной системы и файл проекта подготовлены, можно приступать к компиляции справочной системы. В результате будет создан файл справки, имеющий расширение HLP.

Для компиляции справочной системы в Visual FoxPro вы можете воспользоваться программой Help Workshop, выполнив следующие действия:

  1. Запустите программу Help Workshop.
  2. Появляется пустое окно программы. Откройте в этом окне созданный вами файл справочной системы проекта sales командой Open (Открыть) из меню File (Файл).
  3. Окно проекта содержит область просмотра файла проекта и кнопки, предназначенные для редактирования его разделов. Например, для редактирования раздела [OPTIONS] нажмите кнопку Options (Параметры). В результате на экране откроется диалоговое окно Options (Параметры), содержащее несколько вкладок. Для того чтобы скорректировать текст файла проекта, вам необходимо установить на вкладках требуемые параметры. Открывая соответствующие диалоговые окна, скорректируйте текст файла проекта.
  4. Уточнив параметры файла проекта, запустите его на компиляцию, нажав кнопку Save and Compile (Сохранить и компилировать), расположенную в нижнем правом углу окна проекта. Результаты компиляции отображаются в диалоговом окне Compilation (Компиляция).

Если не было ошибок компиляции, создается файл справки, вы можете запустить его для проверки непосредственно из программы Help Workshop. Для этого выполните следующие действия:

  1. В меню File (Файл) выберите команду Run Winhelp (Запустить WinHelp).
  2. В поле File (Файл) открывшегося диалогового окна введите имя файла справки или выберите нужный файл из раскрывающегося списка ранее созданных файлов справок. Для поиска файла справки вы можете воспользоваться кнопкой Browse (Обзор), расположенной с правой стороны этого поля.
  3. Используя раскрывающийся список Mapped Topic IDs (Идентификаторы тем), выберите тему, которую хотите отобразить на экране.


Формирование файла проекта справочной системы

Файл проекта справочной системы содержит параметры ее компиляции и может включать до шести разделов, выполняющих функции, описанные в табл. 12.5.

Таблица 12.5. Разделы файла проекта справочной системы

Раздел | Функция
[Files] | Определяет список файлов с описанием тем
[Options ] | Определяет заголовок справочной системы, а также некоторые другие параметры компиляции
[BuildTags] | Определяет список тем, включаемых в справочную систему
[Alias] | Определяет псевдонимы тем
[Map] | Назначает числовой индекс идентификатору темы
[Bitmaps] | Определяет список графических файлов, включаемых в справочную систему

Раздел [Files]

В разделе [Files] перечисляются файлы в формате RTF, которые включаются в состав справочной системы. Например:

[Files]

SALES.RTF; инструкция пользователя

EDIT.RTF; инструкция по общим правилам ввода данных

Определение параметров компиляции

Раздел [Options] файла проекта справочной системы содержит описание параметров компиляции. Основные из них следующие:

  • TITLE — определяет заголовок окна справочной системы, который должен содержать не более 32 символов;
  • COMPRESS — используется для сжатия справочного файла, создаваемого компилятором. Параметр может принимать значение True или False;
  • WARNING — определяет количество сообщений об ошибках и предупреждениях, выводимых при компиляции;
  • FORCEFONT — данный параметр используется в том случае, если в описании справочной системы использовались шрифты, отсутствующие на компьютере, где будет выполняться приложение. Параметр указывает компилятору на необходимость преобразования всех используемых в описании шрифтов к типу, введенному с параметром FORCEFONT.

Замечание

Наименование шрифта, заданного параметром FORCEFONT, должно совпадать с его именем, которое отображается в папке Панель управления Windows. Пробелы в наименовании типа шрифта не допускаются.

Синтаксис параметра TITLE следующий:

TITLE = имяЗагчэловка

Параметр WARNING имеет следующий синтаксис:

WARNING = уровень

Где параметр уровень имеет одно из трех значений, приведенных в табл. 12.6.

Таблица 12.6. Уровни параметра WARNING

Уровень | Выводимая информация
1 | Только наиболее серьезные ошибки
2 | Все ошибки
3 | Все ошибки и предупреждения

Раздел [Map]

Раздел [Map] является обязательным в том случае, если при организации файла справочной системы использовались контекстные ссылки или использовалось свойство HeipContextiD для вызова темы справочной системы.

Данный раздел содержит описание связи между идентификаторами тем и соответствующими им целыми значениями индекса тем. При использовании в приложении контекстного вызова справочной системы в разделе необходимо описать все идентификаторы, по которым будет осуществляться контекстный вызов.


Пояснения к терминам

В справочной системе помимо перекрестных ссылок можно создать пояснения к отдельным терминам. Пояснение создается аналогично отдельной теме. Для него определяется идентификатор темы, после чего термин, требующий кратких пояснений, выделяется одинарным подчеркиванием. Затем за термином в скрытом формате вводится идентификатор поясняющей темы.

В справочной системе термины, для которых созданы пояснения, выделяются цветом и пунктирным подчеркиванием. При щелчке мыши на данном термине открывается окно с поясняющим текстом. Для закрытия окна с пояснениями необходимо щелкнуть мышью вне окна с текстом пояснения. После этого вы возвращаетесь в то же окно, откуда вызвали окно пояснения.


Ключи для поиска тем

При определении ключей необходимо иметь в виду следующее.

  • В качестве маркера сноски используется латинский символ К.
  • В тексте сноски можно определить сразу несколько ключей поиска, разделив их знаком (;).
  • Длина строки с ключами поиска должна быть не более 255 символов.

Рис, 12.6. Определение ключей для поиска тем справочной системы

  • Ключи могут содержать любые символы, а также знаки пунктуации (за исключением точки с запятой) и пробелы.
  • При поиске тем по ключам регистр введенных букв не учитывается.

На рис. 12.6 представлен фрагмент текстового описания справочной системы, а на рис. 12.7 — вкладка Предметный указатель основного окна справочной системы.

Рис. 12.7. Поиск темы по ключам справочной системы

Перекрестные ссылки

Используя перекрестные ссылки справочной системы, вы можете из текущей темы перейти в связанные с ней или близкие ей темы.

В предыдущем разделе мы рассматривали создание тем, для которых были определены идентификаторы. Теперь создадим тему, в которой будет приведена ссылка на связанные с ней темы.

В теме создадим в качестве примера ссылку между фразой печать данных этой темы и темой с идентификатором Print__text. Для этого установите для фразы печать данных формат Двойное подчеркивание. Далее установите курсор на следующую позицию за выделенной фразой, определите формат Скрытый и введите идентификатор темы, с которой устанавливается связь (в данном случае: Print_text).

Замечание

Идентификатор расположите сразу же за выделенной фразой, не оставляя между ними пробела (рис. 12.8).

Рис. 12.8. Создание перекрестной ссылки

Замечание

По умолчанию скрытый текст не отображается на экране, что довольно неудобно при создании описания справочной системы. Чтобы скрытый текст отображался на экране, установите для категории Просмотр режим отображения скрытого текста в диалоговом окне Параметры, открывающемся при выборе команды Параметры из меню Сервис.

Аналогичным образом вы можете установить связь с другими темами справочной системы. Несмотря на то, что в тексте фраза была установлена в формате с двойным подчеркиванием, в справочной системе она появляется с обычным подчеркиванием. При позиционировании курсора на выделенной фразе меняется вид курсора, а при щелчке осуществляется переход к теме, связанной с этой фразой.


Темы справочной системы

Создание тем справочной системы начинается с создания файла описания в формате RTF. Проще всего для этого использовать редактор Microsoft Word. Создайте с помощью него новый файл. После этого введите тексты тем справочной системы, расположив каждую тему на отдельной странице. Поэтому для разделения тем вставьте между ними признак начала новой страницы путем нажатия комбинации клавиш <Ctrl>+<Enter>. В тексте вы можете форматировать отдельные части темы, а также вставлять в текст рисунки (рис. 12.4).

Рис. 12.4. Тексты тем с рисунками

Можно определить заголовки, идентификаторы и ключи поиска для каждой темы. В Microsoft Word для этих целей необходимо воспользоваться сносками. Указатели сноски должны располагаться в начале темы, а сам текст заголовка, идентификатора и ключа поиска — в области сноски.

Для определения заголовка темы выполните следующие действия:

  1. Установите курсор в начало темы.
  2. В меню Вставка выберите команду Сноска.
  3. В открывшемся диалоговом окне для определения сноски выберите опцию Нестандартный маркер, а в качестве маркера сноски используйте символ $.
  4. После этого введите текст сноски, который будет являться текстом заголовка темы (рис. 12.5).

Предупреждение

Будьте внимательны. Между маркером сноски и текстом заголовка должен быть только один пробел. Заголовок должен содержать не более 128 символов. Кроме того, он не может быть форматированным.

Рис. 12.5. Определение заголовка темы

Идентификатор темы определяется аналогично заголовку темы, только в качестве маркера сноски используется символ #. При создании идентификатора необходимо придерживаться следующих правил.

  • Идентификатор может содержать латинские буквы, цифры и символы: точка (.) и подчеркивание (_).
  • Длина идентификатора не должна быть более 255 символов.
  • Имя идентификатора должно быть уникальным, т. к. оно используется для организации перекрестных ссылок.


Создание справочной системы в формате WinHelp

Основой справочной системы являются темы, содержащие пояснительный текст. Содержание справочной системы включает список тем, доступных в системе. Каждая тема имеет заголовок и уникальный символьный идентификатор. Дополнительно каждой теме можно поставить в соответствие уникальный индекс темы, который должен быть целым числом.

В справочной системе для поиска темы используются ключи, содержащие название темы и ссылку на нее. Каждая тема может иметь более одного ключа поиска. Кроме того, один ключ может содержать ссылку на несколько тем.

Для организации контекстного вызова темы из справочной системы вы можете использовать числовые значения индексов или значения ключа. Использование идентификаторов тем для контекстного вывода справочной информации не допускается.

Чтобы связать между собой отдельные темы, используются перекрестные ссылки. При этом текст, используемый для организации перекрестной ссылки, выделяется зеленым цветом и подчеркиванием.

В описании любой системы используются термины, специфичные для конкретной системы. Например, в системах складского учета такими терминами будут накладная, счет, отпуск товара. В качестве термина может рассматриваться не только отдельное слово, но и любая фраза из текста темы. Справочная система Windows позволяет дать каждому термину приложения краткое определение. Такие термины на экране выделены зеленым цветом и пунктирным подчеркиванием. Если щелкнуть мышью на термине, для которого определено краткое описание, это описание появится на экране в рамке поверх текста темы.

Создание справочной системы в формате WinHelp включает следующие этапы:

  1. Создание описания справочной системы. Для этого можно использовать любой текстовый редактор, поддерживающий формат RTF. Описание содержит темы, индексы и ключи справочной системы. Структура документа должна соответствовать требованиям, предъявляемым компилятором справочной системы (Help Compiler).
  2. Формирование файла с расширением CNT, содержащего иерархическое содержание создаваемой справочной системы.
  3. Формирование текстового файла с расширением HPJ, содержащего параметры для компиляции справочной системы: имя файла с описанием справочной системы, заголовок справочной системы.
  4. Компиляция созданного текстового описания с использованием Help Compiler.
  5. Определение свойства HeipContextio для требуемых объектов формы, а также создание в приложении кнопок и пунктов меню для вызова справочной системы.

Мы рассмотрим только наиболее часто используемые средства при создании справочной системы. Подробную информацию вы найдете в руководстве по применению Help Compiler. В качестве примера создадим простую справочную систему, состоящую из нескольких тем. Для каждой темы определим заголовки, идентификаторы и ключи, используемые для поиска информации.

Замечание

При разработке справочной системы крупных приложений, как правило, используются специальные средства, например ForeHelp, которые содержат интегрированную среду.


Справка типа "What's This?"

Для краткого описания отдельных объектов формы можно использовать справку типа "What's This?" (Что это?), которая аналогична контекстнозависимой справке, выводимой для объекта, на котором установлен фокус. Но, в отличие от нее справка типа "What's This?" (Что это?) отображается в виде небольшого окна с текстом справочной информации и удаляется с экрана, как только вы щелкнете мышью где-либо на экране.

Для создания справка данного типа используются свойства, описанные в табл. 12.8.

Таблица 12.8. Свойства справки типа What's This?

Свойство | Описание
WhatsThisHeip | Установка этого свойства для формы позволяет использовать справку типа What's This? (Что это?) как для формы, так и для входящих в нее объектов
WhatsThisButton | При установке этого свойства в правой части области заголовка формы появляется кнопка What's This? (Что это?) LZJ
WhatsThisHelpID | Задает идентификатор темы справочной системы для данного объекта

Кроме того, для изменения вида курсора на знак вопроса и вызова справки типа What's This? при щелчке мышью на объекте можно использовать метод WhatsThisMode.

Замечание

Темы для справки типа "What's This?" выводятся в окне небольшого размера, поэтому должны содержать только краткую, на несколько строк, информацию.

Для определения справки типа "What's This?" выполните следующие действия:

  1. Откройте в окне конструктора форму, для которой хотите создать справку данного типа.
  2. Установите для формы свойство whatsThisHeip равным True.
  3. Для отображения кнопки What's This? (Что это?) в заголовке формы установите СВОЙСТВО WhatsThisButton равным True.
  4. Для задания темы справочной системы используйте свойство WhatsThisHelpID.


Определение темы справочной системы для элементов управления

При создании справочной системы для каждой формы приложения, а иногда и для отдельных объектов формы можно создать отдельную тему файла справки. Затем необходимо определить для формы файл справки и связанную с формой тему. Для этого используется команда SET HELP то имяфайла, которая должна выполняться при открытии формы или при запуске приложения, если справочная информация для всех форм находится в одном файле справки.

Затем необходимо задать для объектов формы или для самой формы свойство HELPContextiD (рис. 12.19), которое использует индекс темы, заданный в разделе [MAP] файла проекта справочной системы.

Если вы установили это свойство, то во время просмотра формы нажатие клавиши <F1> приведет к открытию указанной темы справочной системы. Вы видите использование справки в формате WinHelp, а на рис. 12.20 — в формате HTML.

Рис. 12.19. Определение свойства HELPContextiD

Рис. 12.20. Вид темы справочной системы в формате HTML


Использование диалоговых окон

В процессе выполнения приложения осуществляются разнообразные проверки, например, проверка соответствия введенного в поле значения заданным условиям. Если в результате проверки окажется, что введенное значение не удовлетворяет требуемым условиям, необходимо об этом сообщить пользователю. Из текста сообщения должна быть ясна причина ошибки. Кроме того, текст должен содержать рекомендации по ее исправлению. Для вывода информационного сообщения вы можете воспользоваться функцией MESSAGEBOX или создать собственную функцию. Рассмотрим описание функции MESSAGEBOX и приведем пример ее использования.

Рис. 12.1. Определение пояснений для элемента управления Функция имеет следующий синтаксис:

MESSAGEBOX (текст-Сообщения [, типДиалоговогоОкна [, заголовок] ] }

Аргумент текстсообщения содержит текст выводимого сообщения. Длинное сообщение автоматически располагается на нескольких строках. Если сообщение состоит из нескольких предложений и вы хотите разбить его на абзацы, то используйте функцию снк(13) для формирования новой строки.

Аргумент типДиалоговогоОкна задает перечень кнопок и значков, которые будут отображаться в диалоговом окне. Данный аргумент является числовым и его значение определяется как сумма трех параметров: типа кнопок, типа значков и номера кнопки, выбранной по умолчанию. Возможные значения этих параметров приведены в табл. 12.1—12.3.

Таблица 12.1. Кнопки, отображаемые в диалоговом окне

Значение | Кнопки
0 | ОК
1 | ОК и Cancel
2 | Abort, Retry, Ignore
3 | Yes, No, Cancel
4 | Yes, No
5 | Retry, Cancel

Таблица 12.2. Значки, отображаемые в диалоговом окне

Значение | Значок
16 | Знак Stop
32 | Вопросительный знак
48 | Восклицательный знак
64 | Информационный знак ( i )

Таблица 12.3. Кнопка, выбираемая по умолчанию

Значение | Кнопка по умолчанию
0 | Первая кнопка
256 | Вторая кнопка
512 | Третья кнопка

Функция MESSAGEBOX возвращает числовое значение, определяющее нажатую пользователем кнопку. Возможные значения приведены в табл. 12.4.

Таблица 12.4. Значения, возвращаемые функцией

Значение | Кнопка
1 | ОК
2 | Cancel
3 | Abort
4 | Retry
5 | Ignore
6 | Yes
7 | No

Рассмотрим использование диалогового окна для вывода сообщения об ошибке ввода значения кредита клиента. Для этого выполните следующие действия:

  1. Откройте форму для ввода информации о клиентах.
  2. Выберите поле ввода значения кредита и для события valid определите процедуру (рис. 12.2), которая проверяет введенное значение и при необходимости открывает диалоговое окно с сообщением об ошибке:

if THIS.Value > 5000

= MESSAGEBOX("Максимальный кредит для клиента составляет ;

5000 рублей." + ;

CHR(13) + ;

"В особых случаях согласуйте величину кредита ;

с Генеральным директором.",;

0+48+ 0, "Предупреждение")

endif

Рис. 12.2. Определение процедуры для события Valid

  3. Запустите форму на выполнение, введите значение кредита более 5000, перейдите на следующее поле. Откроется диалоговое окно с сообщением об ошибке (рис. 12.3).

Рис. 12.3. Диалоговое окно с сообщением об ошибке


Команды Visual FoxPro для управления справочной системой

Для определения файла, содержащего справочную систему, а также для вывода на экран содержания или указанной темы из справочной системы используются команды Visual FoxPro. Список этих команд и их назначение приведены в табл. 12.7.

Таблица 12.7. Назначение команд для управления справочной системой

Команда | Назначение
SET HELP | Запрещает или разрешает вывод справочной системы или определяет имя используемой справочной системы
HELP | Выводит на экран содержание или указанную тему справочной системы
SET TOPIC TO | Определяет содержание справочной системы

SET HELP

Команда SET HELP управляет выводом справочной системы и определяет ее имя. Она имеет два варианта синтаксиса:

SET HELP ON | OFF | Предназначена для разрешения или запрета активизации стандартной справочной системы программы Visual FoxPro. Если использована команда SET HELP ON, при нажатии клавиши <F1> или при выполнении команды HELP основного меню отображается стандартная справочная система Visual FoxPro. При использовании команды SET HELP OFF средства просмотра справочной системы будут недоступны
SET HELP TO имяФайла | Определяет дополнительный файл справочной системы. Этот вариант команды позволяет использовать созданную вами справочную систему

Например:

SET HELP TO sales.hip

HELP

Для вывода на экран содержания справочной системы или указанной темы в окне справочной системы предназначена команда HELP, имеющая следующий синтаксис:

HELP [идентификаторТемы | ID индексТемы]

[IN [WINDOW] имяОкна I IN [WINDOW] SCREEN] /" I IN [WINDOW] MACDESKTOP] [NOWAIT]

Для вывода содержания справочной системы необходимо использовать команду HELP без указания имени темы. Если вы хотите отобразить контекстную справку, необходимо указать идентификатор темы или ее индекс.

Опция IN [WINDOW] позволяет открыть окно справочной системы внутри окна, описанного с помощью команды DEFINE WINDOW.

По умолчанию при вызове справочной системы приостанавливается выполнение программы, позволяя пользователю найти требуемую информацию. При использовании опции NOWAIT после вывода справочной информации программа продолжает свое выполнение.

SET TOPIC

По умолчанию содержанием справочной системы является первая по порядку тема. Для изменения содержания используется команда SET TOPIC, позволяющая определить тему, которая в дальнейшем будет являться содержанием справочной системы.

Команда имеет два варианта синтаксиса:

  1. SET TOPIC ТО [имяТемы | логическоеВыражение]
  2. SET TOPIC ID TO [индексТемы]

Используя команду SET TOPIC то имяТемы, вы можете задать имя темы, отображаемой в справочной системе.

Команда SET TOPIC то логическоеВыражение отображает заданную тему в справочной системе в зависимости от значения логического выражения.

Команда SET TOPIC ID то [индексТемы] используется для указания отображаемой темы по его идентификатору.


Использование справочной системы в приложениях

Мы рассмотрели создание справочных систем двух типов. Однако обращение к ним из приложения, созданного в Visual FoxPro, осуществляется одинаково. Рассмотрим в данном разделе команды Visual FoxPro, управляющие выводом справочной информации, и свойства элементов управления, с помощью которых организуется связь с темами справочной системы.


Компиляция и тестирование справочной системы

После того как вы подготовили проект справочной системы, его необходимо сохранить и скомпилировать. Используя кнопку Save project, contents and index files (Сохранить проект, содержание и индексированные файлы) на панели инструментов вкладки Project (Проект), можно сохранять файлы проекта, содержания и указателя. Для компиляции созданного проекта нажмите кнопку Compile HTML file (Компилировать HTML файл) панели инструментов HTML Help Workshop.

Нажмите кнопку View compiled file (Просмотр скомпилированного файла), чтобы просмотреть созданный файл справочной системы. Откроется окно, представленное на рис. 12.18.

Рис. 12.18. Просмотр справочной системы


Создание ключей для поиска тем

Для создания ключей поиска перейдите на вкладку Index (Указатель). Используя кнопки панели инструментов вкладки, вы можете создать новый ключ, редактировать ранее созданный или удалить ключ (рис. 12.16).

Рис. 12.16. Определение ключей для поиска тем

Для добавления нового ключа нажмите кнопку Insert a keyword (Вставить ключ). Откроется диалоговое окно Index Entry (Ввод указателя) (рис. 12.17), в котором в поле Keyword (Ключ) введите значение ключа, а затем в список Files/URLs and their information types (Файлы/Интернет ссылки и их типы) с помощью кнопки Add (Добавить) добавьте созданные ранее темы справочной системы. Для изменения тем используйте кнопку Edit (Редактировать), а для удаления — кнопку Remove (Удалить).

Рис. 12.17. Определение тем для ключа


Создание содержания справочной системы

Для создания содержания справочной системы в иерархическом виде перейдите на вкладку Contents (Содержание). В области содержания справочной системы (рис. 12.14) вы можете добавить заголовки нескольких уровней вложенности и непосредственно ссылки на темы справочной системы.

Рис. 12.14. Вкладка Contents

Рис. 12.15. Определение элемента содержания справочной системы

Чтобы добавить заголовок или строку ссылки на тему справочной системы, нажмите соответственно на кнопки Insert a heading (Вставить заголовок) или Insert a page (Вставить страницу). Откроется диалоговое окно Table of Contents Entry (Ввод содержания) (рис. 12.15), в котором задайте наименование строки содержания и ссылку на тему справочной системы.

Вы можете создать многоуровневое содержание справочной системы. Для изменения уровня заголовка используйте кнопки Move selection right (Сдвинуть вправо) и Move selection left (Сдвинуть влево).


Определение связи между псевдонимами и индексами тем

Для открытия определенной темы справочной системы используются индексы тем. Связь между псевдонимами тем и соответствующими им целочисленными значениями индекса тем задается в отдельном текстовом файле. В этом файле вы должны описать все идентификаторы, по которым будет осуществляться контекстный вызов. Данный файл состоит из строк, содержащих ключевое слово #Define, за которым следуют разделенные пробелом идентификатор и индекс темы. Пример текста приведен ниже:

#Define IDH_CUSTOMER 3

#Define IDH_GOODS 4

После создания файла связи вы должны связать его с файлом проекта. Для этого в диалоговом окне HtmlHelp API information перейдите на вкладку Map (Карта) и добавьте его в список подключаемых файлов.


Определение псевдонимов тем

Чтобы в приложениях можно было использовать справочную систему, вы должны определить псевдоним каждой темы.

Рис. 12.12. Список псевдонимов тем

Для этого откройте диалоговое окно HtmlHelp API information нажатием одноименной кнопки на панели инструментов вкладки Project (Проект) и перейдите на вкладку Alias (Псевдоним) (рис. 12.12). После нажатия кнопки Add (Добавить) и задания в диалоговом окне Alias (Псевдоним) псевдонима и имени связанного с ним файла темы (рис. 12.13) будет добавлен новый псевдоним.

Рис. 12.13. Определение псевдонимов тем


Определение параметров проекта справочной системы

Параметры проекта отображаются в разделе [options] вкладки Project (Проект). Для их редактирования нажмите кнопку Change Project Options (Изменить параметры проекта) на панели инструментов вкладки. Откроется диалоговое окно Options (Параметры) (рис. 12.11), которое содержит четыре вкладки: General (Общие), Files (Файлы), Compiler (Компилятор) и Merge Files (Объединяемые файлы).

На вкладке General (Общие) вы определяете:

  • заголовок окна справочной системы;
  • файл темы и окно, которые выбираются при открытии справочной системы;
  • язык справочной системы.

Вкладка Files (Файлы) используется для указания расположения файлов справочной системы, файлов с указателями и содержанием. На вкладке Compiler (Компилятор) задаются параметры компиляции справочной системы.

Рис. 12.11. Определение параметров проекта


Окно HTML Help Workshop

Окно программы HTML Help Workshop (рис. 12.9) состоит из двух частей. В левой части находятся вкладки Project (Проект), Contents (Содержание), Index (Указатель) и Help (Справка). Слева от каждой вкладки размешена соответствующая панель инструментов.

В правой части окна отображается содержимое выбранной темы справочной системы в виде файла HTML. Вы можете не только просмотреть этот файл, но и редактировать его с помощью команд из меню Tags (Теги) и кнопок панели инструментов.

Рис. 12.9. Окно программы HTML Help Workshop

HTML Help Workshop предоставляет возможность просмотра файлов с темами в Web-браузере (рис. 12.10). Для этого выберите имя требуемого файла в разделе [FILES] и нажмите кнопку Display in Browser (Отобразить в браузере).

Рис. 12.10. Просмотр темы справочной системы в Web-браузере


Создание справочной системы в формате HTML

Для создания справочной системы в формате HTML можно использовать HTML Help Workshop.

  1. Создайте темы справочной системы, сохраняя при этом каждую тему в отдельном HTML-файле. Для создания этих файлов вы можете использовать любой редактор файлов HTML, например, Microsoft Word.
  2. Запустите программу HTML Help Workshop и постройте новый проект справочной системы. С помощью мастера проекта включите в проект ранее созданные файлы с темами. Определите свойства проекта.

Замечание

Если у вас имеется ранее созданный проект справочной системы в формате WinHelp, с помощью мастера вы можете преобразовать его в проект срормата HTML.

  3. Укажите псевдоним для каждой темы.
  4. Создайте файл, содержащий описание связи между псевдонимами тем и соответствующими им целочисленными значениями индексов тем. Включите этот файл в проект.
  5. Создайте ключи для поиска тем справочной системы.
  6. Сохраните все файлы проекта и скомпилируйте его.
  7. В создаваемом в Visual FoxPro приложении укажите файл справочной системы (с расширением СНМ) с помощью команды SET HELP то.
  8. Для каждого объекта приложения, с которым связана тема справочной системы, задайте свойство HELPCONTEXTID.


ГЛАВА 12
Создание справочной системы приложения

Разработанное вами приложение должно быть интуитивно понятным и дружественным к пользователю. Если у пользователя возникнут затруднения, он должен быстро получить справку о возможных действиях. Требуемую информацию пользователь может найти в руководстве пользователя или обратиться за консультацией к разработчику. Но проще всего воспользоваться справочной системой, содержащей информацию о приложении, описание его основных функций и инструкцию по работе.

Для отображения справочной информации в Visual FoxPro вы можете использовать строку состояния, диалоговое окно и справочную систему в формате WinHelp или HTML.

Строка состояния

В Visual FoxPro строка состояния используется для пояснения назначения элементов управления формы и пунктов меню. Пояснения к элементам управления, отображаемые в строке состояния, задаются в свойстве statusBarText (Текст строки состояния). Кроме текста строки состояния вы можете задать текст подсказки, который будет отображаться под курсором мыши, если его установить на элемент управления и удерживать некоторое время. Текст подсказки задается в свойстве TooiTipText (Текст подсказки). На рис. 12.1 для поля редактирования, содержащего адрес клиента, в окне Properties (Свойства) установлены значения свойств statusBarText (Текст строки состояния) и TooiTipText (Текст подсказки).


  • Строка состояния
  • Использование диалоговых окон
  • Создание справочной системы в формате WinHelp
  • Темы справочной системы
  • Ключи для поиска тем
  • Пояснения к терминам
  • Формирование файла проекта справочной системы
  • Компиляция справочной системы
  • Содержание справочной системы
  • Создание справочной системы в формате HTML
  • Окно HTML Help Workshop
  • Определение параметров проекта справочной системы
  • Определение псевдонимов тем
  • Определение связи между псевдонимами и индексами тем
  • Создание содержания справочной системы
  • Создание ключей для поиска тем
  • Компиляция и тестирование справочной системы
  • Использование справочной системы в приложениях
  • Команды Visual FoxPro для управления справочной системой
  • Определение темы справочной системы для элементов управления
  • Справка типа "What's This?"


Настройка параметров окнаГалереи компонентов

На панели инструментов окна Галереи компонентов расположена кнопкаOptions (Параметры), при нажатии которой открывается диалоговое окноComponent Gallery Options (Параметры галереи компонентов) (рис. 13.10).Оно содержит три вкладки, назначение которых описано в табл. 13.3.

Таблица 13.3. Назначение вкладок диалогового окна Component Gallery Options

Вкладка | Назначение
Standard (Стандартные) | На данной вкладке можно определить общие параметры настройки Галереи компонентов
Catalogs (Каталоги) | Позволяет добавить в Галерею компонентов новыекаталоги
Dynamic Views (Динамические представления) | Позволяет добавлять, изменять и удалять типыпредставлений данных

Рис. 13.10. Вкладка Standard диалогового окнаComponent Gallery Options

Вкладка Standard (Стандартные) диалогового окна Component Gallery Options (Параметры галереи компонентов) предназначена для настройки параметровокна Галереи компонентов. В области Global defaults (Общие установки)данной вкладки расположены флажки. Действия, выполняемые при установке этих флажков, описаны в табл. 13.4.

Таблица 13.4. Назначение флажков диалогового окна

Component Gallery Options

Флажок | Назначение
Enable item renaming (Возможностьпереименования объекта) | Разрешается изменять имена каталогов иобъектов в окне Галереи компонентов
FFC Builder Lock (Закреплениепостроителя) | Для объекта, помещаемого в форму, будетавтоматически запускаться построитель
Drag and drop to desktop (Перенестии оставить на рабочем столе) | Объекты из Галереи компонентов можно переносить на Рабочий стол Visual FoxPro
Advanced editing enabled (Возможность дополнительногоредактирования) | В диалоговое окно свойств Properties объектов Галереи компонентов добавляются дополнительные вкладки Type, Scripts, Views иComments

Переключатель Item default behavior (Действие объекта по умолчанию)вкладки Standard (Стандартные) позволяет определить, какое действие будетосуществляться при двойном щелчке на объекте Галереи компонентов. Еслиустановлена опция Modify item file (Модифицировать файл), при двойномщелчке на объекте автоматически запускается построитель для данного объекта. При установленной опции Run item file (Запускать файл) двойнойщелчок на объекте приводит к запуску объекта на выполнение.


Запуск Галереи компонентов

Для запуска Галереи компонентов выполните одно из следующих действий:

  • Выберите в меню Tools (Сервис) команду Component Gallery (Галереякомпонентов).

Рис. 13.9. Галерея компонентов

  • В командном окне введите следующую команду:

DO (_GALLERY)

При этом на экране открывается окно Галереи компонентов (рис. 13.9).Оно разделено на две области. В левой области размещен иерархическийсписок каталогов, в правой — содержимое каталога, выбранного в левойобласти.

В верхней части окна Галереи компонентов находится панель инструментов,кнопки которой позволяют настроить параметры окна Галереи компонентов,найти нужный объект, а также управляют отображением объектов в окне.


Галерея компонентов Visual FoxPro

Галерея компонентов является средством организации разработки в VisualFoxPro, позволяющим разработчику группировать и упорядочивать компоненты, такие как используемые в работе проекты, библиотеки, классы,формы, отчеты, кнопки и т. п. Созданное вами упорядочение можно динамически изменять, что позволит использовать разные подходы к классификации компонентов разработки.

В Галерее компонентов для работы можно разместить различные элементыVisual FoxPro, локальные и удаленные документы, файлы или папки, Automation-серверы, например, Microsoft Excel, Microsoft Word и HTML-файлы.В ней содержатся также новые базовые классы Visual FoxPro.

Галерея компонентов призвана создать рабочую среду и являться хранилищем данных, используемым для быстрой разработки приложений. В нейможно разместить не только компоненты, из которых создается приложение, но и созданные вами или сторонними организациями проекты, статьии другие документы, содержащие информацию, полезную для разработки. Вокне Галереи компонентов можно также хранить ссылки на используемыепри разработке Web-страницы.

Галерея компонентов располагает средствами для создания новых проектов,форм, а также для изменения свойств объектов и классов. Объекты, размещенные в Галерее компонентов, можно переносить в проекты и формы (инаоборот) с помощью метода "перенести-и-оставить".


Построение проекта

При построении проекта Visual FoxPro просматривает все компоненты, перечисленные в нем, и формирует проект. Например, в проект должнывключаться все программы, формы и отчеты, которые вызываются при выборе пунктов меню. Если какие-либо компоненты вызывают в свою очередьдругие компоненты, то они также включаются в проект.Для создания проекта нажмите кнопку Build (Построить) в окне проектаили выберите команду Build (Построить) из меню Project (Проект). На экране открывается диалоговое окно Build Options (Опции построения)(рис. 13.7), содержащее пять опций следующего назначения:

  • Rebuild project (Перестроить проект) — собирает проект, проверяя наличие в нем всех необходимых файлов;
  • Application (app) (Приложение) — создает исполняемое приложение срасширением АРР. Данный файл может запускаться на выполнение вVisual FoxPro командой Do (Выполнить) из меню Program (Программа);
  • Win32 executable/COM server (exe) (Исполняемый файл) — создает исполняемое приложение с расширением ЕХЕ. Данный файл может запускаться на выполнение как в главном окне Visual FoxPro, так и вне егопри наличии соответствующих библиотек;
  • Single-threaded COM serve (dll) (Однопоточный СОМ-сервер) — создаетоднопоточную динамическую библиотеку (Dynamic Link Library) с расширением DLL;
  • Multi-threaded COM server (dll) (Многопоточный СОМ-сервер) — создаетмногопоточную динамическую библиотеку (Dynamic Link Library) с расширением DLL.

Рис. 13.7. Диалоговое окно Build Options

В диалоговом окне Build Options (Опции построения) расположены флажки,позволяющие задать параметры создаваемого проекта:

  • Recompile All Files (Обновлять все файлы) — устанавливается для обновления всех компонентов проекта. По умолчанию обновляются только текомпоненты проекта, которые были изменены после предыдущего построения;
  • Display Errors (Показывать ошибки) — при установке флажка после завершения построения проекта на экране появляется диалоговое окно(рис. 13.8), сообщающее об ошибках, встретившихся в процессе построения. Если флажок не установлен, ошибки построения можно просмотреть, выполнив команду Errors (Ошибки) из меню Project (Проект);
  • Run After Build (Запустить после построения) — флажок устанавливается втом случае, если необходимо запустить приложение сразу после создания;
  • Regenerate Component IDs (Перестроить идентификаторы Automation-серверов) — флажок устанавливается в том случае, если необходимо установить и регистрировать Automation-серверы, содержащиеся в проекте.

Кнопка Version (Версия) открывает одноименное диалоговое окно, в котором можно указать информацию о номере и типе версии приложения.

Замечание

Флажок Regenerate Component IDs (Перестроить идентификаторы Automation-серверов) доступен только при установленной опции Win32 executable/COMserver (Исполняемый файл), Single-threaded COM server (ОднопоточныйСОМ-сервер) Multi-threaded COM server (Многопоточный СОМ-сервер).

Рис. 13.8. Диалоговое окно, сообщающее об ошибках,возникших при построении приложения

Для построения проекта выберите опцию Rebuild Project (Перестроить проект) и нажмите кнопку ОК. В появившемся запросе о необходимости сохранения проекта выберите значение Yes (Да).

Если в процессе построения проекта диспетчер проектов обнаружит компонент, не описанный в проекте, на экране появится диалоговое окно LocateFile (Определение файла), содержащее имя ненайденного файла.Для поиска компонента нажмите кнопку Locate (Определить) и найдите надиске необходимый файл. Вы можете проигнорировать данную ошибку.В этом случае нажмите кнопку Ignore (Игнорировать).

Список всех обнаруженных ошибок сохраняется в файле, имя которого совпадает с именем файла проекта и имеет расширение ERR.

Когда все требуемые компоненты включены в проект, вы можете создать исполняемый файл, установив в диалоговом окне Build Options (Опции построения) опции Application (Приложение) или Win32 executable/COM server (exe)(Исполняемый файл). Для создания файла с расширением АРР, который может запускаться на выполнение из программы Visual FoxPro, необходимо использовать опцию Application (Приложение). В том случае, если вы хотитесоздать файл с расширением ЕХЕ, который может запускаться автономно, воспользуйтесь опцией Win32 executable/COM server (exe) (Исполняемый файл).

После создания приложения с установленной опцией Build Options опцииApplication (Приложение) или Win32 executable/COM server (exe) (Исполняемый файл) вы можете запустить его, используя команду DO, введенную вокне Command Visual FoxPro или командой Do (Выполнить) из менюProgram (Программа). При выполнении этой команды открывается диалоговое окно Do (Выполнить). Откройте в нем нужную папку, в списке файловвыберите созданный вами файл проекта, имеющий расширение АРР, и нажмите кнопку Do (Выполнить).

Для выполнения приложения, созданного с опцией Win32 executable/COM server (exe) (Исполняемый файл), вы должны иметь доступ к динамическимбиблиотекам Vfp7.dll и Vfp7enu.dll.


Очистка проекта от удаленных файлов

Вся информация о проекте хранится в системной таблице Visual FoxPro.При разработке приложения после удаления компонента из проекта в этойтаблице ставится лишь метка об его удалении. Чтобы окончательно удалитьиз проекта информацию обо всех помеченных на удаление компонентов,необходимо таблицу проекта упаковать, воспользовавшись командой CleanUp Project (Упаковать проект) из меню Project (Проект).


Использование опции Exclude

Выполняемые компоненты проекта (программы, формы, меню) при создании приложения с помощью проекта объединяются для создания кода приложения. Невыполняемые компоненты, такие как таблицы, индексы включаются в приложение доступными только для чтения. Вы можете разрешить конечному пользователю модифицировать компоненты, исключив их изпроекта.

Чтобы исключить компонент из проекта можно воспользоваться следующими средствами:

  • Командой контекстного меню Exclude (Исключить).
  • Командой Exclude (Исключить) из меню Project (Проект).

Рядом с исключенным компонентом в окне проекта появляется кружок, перечеркнутый линией.

Исключенные из проекта компоненты остаются в списке проекта, но невключаются в состав приложения при его построении. Поэтому вам необходимо самостоятельно отслеживать их наличие и доступ к ним из приложения.Для включения в проект исключенного компонента необходимо воспользоваться командой контекстного меню Include (Включить) или командойInclude (Включить) из меню Project (Проект).


Установка основнойпрограммы проекта

Проект обязательно должен содержать программу, которая запускает приложение и управляет его работой. Такой файл называется основной программой иим чаще всего является меню приложения. Вы можете также определить вкачестве основной программы созданную вами программу управления приложением, содержащую установку основных параметров, используемых глобальных переменных и т. д.

Чтобы сделать компонент проекта основным, выполните следующие действия:

  1. Выберите в окне проекта файл, который хотите сделать основным.
  2. В меню Project (Проект) выберите команду Set Main (Основная программа) или выберите команду контекстного меню файла Set Main(Основная программа).

В окне проекта имя файла выделяется жирным шрифтом, указывая, чтоданный компонент является основной программой (рис. 13.6).

Замечание

Для установки основной программы проекта вы можете также воспользоватьсядиалоговым окном Project Information (Параметры проекта). На вкладке Files(Файлы) выделите необходимый файл, нажмите правую кнопку мыши и из контекстного меню выберите команду Set Main (Основная программа).

Рис. 13.6. Установка основной программы в окне проекта


Задание параметров проекта

Можно задать параметры, которые будут использоваться в процессе построения каждого проекта. Это информация о разработчике, месте расположения проекта, параметры генерации приложения и значок для выполняемого файла приложения. Чтобы задать параметры проекта, выполнитеследующие действия:

  1. В меню Project (Проект) выберите команду Project Info (Параметры проекта). Открывается диалоговое окно Project Information (Параметры проекта),содержащее вкладки Project (Проект), Files (Файлы) и Servers (Серверы).
  2. На вкладке Project (Проект) (рис. 13.2) в полях Author (Автор), Company(Фирма), Address (Адрес), City (Город), Country (Страна), State (Область)и Postal Code (Почтовый индекс) укажите информацию о разработчикахпроекта.
  3. Поле ввода Ноте (Домашний каталог) вкладки Project (Проект) используется для задания места расположения проекта. Для изменения папки, указанной в поле, используется диалоговое окно Select Directory (Выбор каталога) (рис. 13.3), которое вызывается при нажатии кнопки, расположеннойсправа от поля ввода. Выберите из открывшегося диалогового окна папку,в которой размещен проект, и нажмите кнопку Select (Выбор).
  4. Если вы хотите создать значок, при щелчке на котором будет запускатьсявыполняемый файл проекта, то установите флажок Attach icon (Определить значок).

Рис. 13.2. Диалоговое окно Project Information

Рис. 13.3. Диалоговое окно Select Directory

  5. В открывшемся диалоговом окне Open (Открыть) найдите на диске файлы с расширением ICO, которые можно использовать в качестве значкадля создаваемого приложения. Например, просмотрите предлагаемыеVisual FoxPro значки из папки Graphics (Графика) (рис. 13.4). Установивфлажок Preview (Просмотр) диалогового окна Open (Открыть), вы можетепросмотреть вид значка в области Picture (Изображение). Выбрав значок,нажмите кнопку ОК для закрытия окна.

Рис. 13.4. Выбор значка для проекта

  6. Просмотрите информацию в поле Last built (Последнее построение). Этополе содержит дату последнего построения проекта.
  7. Для включения отладочной информации в исполняемый код установитефлажок Debug info (Информация об отладке). Эта информация поможетпри отладке программы и исправлении ошибок, возникших на компьютере конечного пользователя.

Предупреждение

Используйте флажок Debug info (Информация об отладке) только в случае необходимости, т. к. его установка может привести к декомпиляции программы.

  8. Чтобы сохранить права на интеллектуальную собственность разработанного проекта, используйте флажок Encrypted (Шифровать). Установитеэтот флажок, если хотите, чтобы Visual FoxPro зашифровал исполняемыйкод проекта, повышая тем самым степень защиты вашей программы отдекомпиляции.
  9. Нажмите кнопку ОК для закрытия диалогового окна.

Вкладка Files (Файлы) диалогового окна Project Information (Параметрыпроекта) содержит в табличном виде список файлов, входящих в проект(рис. 13.5). Просмотрите этот список. Для удобства просмотра информации,содержащейся в таблице, данные можно упорядочить по параметрам, представленным в табл. 13.2.

Таблица 13.2. Параметры упорядочения

Наименование столбца | Тип упорядочения
Туре (Тип) | По типам файлов
Name (Имя) | По именам файлов
Last Modified (Последняя модификация) | По дате последней модификации файлов

Для упорядочения данных необходимо щелкнуть на заголовке соответствующего столбца. Столбец Included (Включен) указывает, включен ли текущийфайл в исполняемый файл. Просмотрите список файлов. Отметку в этомстолбце не имеют только свободные таблицы, не входящие в базу данных.

Рис. 13.5. Вкладка Files диалогового окна Project Information


Создание новой формыиз Галереи компонентов

Из окна Галереи компонентов можно создавать новые и редактировать существующие формы.

Для создания новой формы можно воспользоваться одним из следующихспособов.

  • Щелкнуть на шаблоне или выбрать пункт меню New Form (Новая форма)(рис. 13.14) из контекстного меню любого шаблона в папке Forms(Формы) Галереи компонентов.
  • Вызвать мастера форм с помощью щелчка мышью на значке Form Wizard(Мастер формы) (рис. 13.14) в папке Forms (Формы) Галереи компонентов.

Рис. 13.14. Каталог Галереи компонентов,из которого можно создавать новые формы


Использование метода"перенести-и-оставить"для перемещения объектов

Объекты, расположенные в окне Галереи компонентов, можно переноситьна Рабочий стол Visual FoxPro, в открытый проект или форму. При этомперемещаемые в окно проекта объекты помещаются в соответствующие разделы окна конструктора проекта.

Чтобы переместить объект из Галереи компонентов с помощью метода"перенести-и-оставить", выполните следующие действия:

  1. Выделите объект, который хотите перенести. Значок Move (Переместить), расположенный в верхнем левом углу окна Галереи компонентов, изменит свой рисунок в соответствии со значком выбранного вамиобъекта.
  2. Установите курсор на значок Move (Переместить).
  3. Нажмите кнопку мыши и, удерживая ее нажатой, перенесите объект наРабочий стол, в проект или в форму.
  4. Завершив перемещение, отпустите кнопку мыши.

В табл. 13.6 отображены все возможные результаты выполнения операции"перенести-и-оставить", а назначение цифр — в табл. 13.7.

Таблица 13.6. Возможные результаты операции перемещения объектов

Тип объекта | Проект | Форма | Рабочий стол | Объект
Class ( Classltem) | — | — | 6 | —
File (_FileItem) | — | — | — | —
URL (_UrlItem) | — | 1 | — | —
Form (_FormItem) | — | 9 | 11 | —
Report (__ReportItem) | — | 9 | 11 | —
Program ( Programltem) | — | — | 11 | —
Menu ( Menultem) | — | 10 | 11 | —
Image ( Imageltem) | — | 2 | 7 | 2
Sound ( Soundltera) | — | 3 | — | —
Video ( Videoltem) | — | 3 | — | —
ActiveX ( ActiveXItem) | — | — | — | —
Data ( Dataltem) | — | 4 | — | —
Template ( Templateltem) | 5 | — | — | —
Catalog ( Catalogltem) | — | — | 8 | —
Sample ( Sampleltem) | — | — | — | —
Project ( Projectltem) | — | — | 11 | —

Таблица 13.7. Назначение цифр

Цифра | Обозначение
1 | Добавляет класс Hyperlink
2 | Добавляет класс Image или устанавливает свойства изображения
3 | Добавляет класс мультимедиа
4 | Добавляет класс таблицы Grid
5 | Создает новый файл и добавляет его в проект
6 | Создает объект на экране
7 | Устанавливает на Рабочем столе Visual FoxPro узор
8 | Открывает новое окно Галереи компонентов с каталогом
9 | Добавляет класс кнопки для вызова формы или отчета
10 | Добавляет всплывающее меню в форму
11 | Открывает конструктор для модификации


Работа с проектом из окнаГалереи компонентов

В окне Галереи компонентов можно создавать новые проекты с помощьюшаблонов, построителей и мастеров. Для этого предназначен значок NewApplication (Новое приложение) каталога Catalogs (Каталоги).

При щелчке на значке New Application (Новое приложение) на экране появляется диалоговое окно Enter Project Name (Введите имя проекта), являющееся первым шагом в создании проекта (рис. 13.13).

Рис. 13.13. Диалоговое окно Enter Project Name

Введите в поле Project name (Имя проекта) имя создаваемого проекта, а вполе Project file (Файл проекта) — его расположение. Используя флажок Create project directory structure (Создать структуру каталогов проекта), можно указать, создавать ли для проекта структуру каталогов. При установкефлажка Add to Favorites catalog (Добавить в избранное) значок созданногопроекта будет добавлен в каталог Favorites (Избранное).

Установив в диалоговом окне Enter Project Name (Задать имя проекта) параметры, нажмите кнопку ОК для запуска мастера создания нового проекта.Кнопка Cancel (Отмена) позволяет отменить работу мастера.


Представления данных

На панели инструментов Галереи компонентов расположен раскрывающийся список View Type (Тип представления), содержащий по умолчанию несколько значений, управляющих видом отображения данных в окне. Используя вкладку Dynamic Views (Динамические представления) (рис. 13.12)диалогового окна Component Gallery Options (Параметры галереи компонентов), можно добавить в данный список дополнительные значения, изменитьили удалить значения, добавленные пользователями.

Чтобы добавить в список View Type (Тип представления) новое значение,выполните следующие действия:

  1. Нажмите кнопку Options (Параметры) на панели инструментов Галереикомпонентов.
  2. Выберите вкладку Dynamic Views (Динамические представления).
  3. Нажмите кнопку New (Новый).
  4. В открывшемся диалоговом окне Edit View (Редактирование представления) введите параметры нового типа представления данных.
  5. Нажмите кнопку Save (Сохранить).

Расположенные на вкладке Dynamic Views (Динамические представления)кнопки Edit (Редактировать) и Remove (Удалить) предназначены для изме нения параметров типа представления данных и удаления представленияданных из списка соответственно.

Рис. 13.12. Вкладка Dynamic Views диалогового окнаComponent Gallery Options


Каталоги Галереи компонентов

При первом открытии Галереи компонентов в левой части окна отображаются стандартные каталоги, содержащие объекты, которые будут полезныпри разработке приложений. Список стандартных каталогов Visual FoxProприведен в табл. 13.5.

Таблица 13.5. Назначение каталогов Галереи компонентов

Каталог | Назначение
Visual FoxPro Catalog {Каталог Visual FoxPro) | Содержит базовые классы Visual FoxPro, шаблоны приложений, форм, отчетов, а также другие полезные дляразработки приложений средства
Favorites (Избранное) | Предназначен для хранения наиболее важных объектов
My Base Classes (Мои базовые классы) | Содержит подклассы базовых классов Visual FoxPro
ActiveX Catalog (КаталогActiveX-компонентов) | Динамический каталог, содержащий зарегистрированные объекты ActiveX
World Wide Web (Всемирная паутина) | Содержит список адресов Web-страниц, >икоторых вы найдете информацию о программных продуктах Microsoft
Multimedia Catalog (Каталог мультимедиа) | Содержит список рисунков, звуков и видеоизображенийкоторые можно использовать в приложениях
Visual FoxPro Samples (Примеры Visual FoxPro) | Содержит примеры приложений, входящих в поставкуVisual FoxPro

На вкладке Catalogs (Каталоги) (рис. 13.11) диалогового окна ComponentGallery Options (Параметры галереи компонентов) расположен список каталогово, входящих в Галерею компонентов. Используя кнопку New (Новый), в этот список можно добавить новый каталог. Флажки, расположенные подкнопкой, определяют свойства выбранного в списке каталога.

Рис. 13.11. Вкладка Catalogs диалогового окнаComponent Gallery Options


ГЛАВА 13
Управление проектом и создание приложения

Мы рассмотрели создание форм, отчетов, запросов, перекрестных таблиц,диаграмм и меню. Каждый из этих компонентов проекта можно запуститьна выполнение. Что же еще необходимо сделать, чтобы все объекты, включенные в создаваемый нами проект, функционировали как единое целое?Это мы сейчас и рассмотрим.

Определение свойств окна проекта

При работе с файлами, размещенными в проекте, для их открытия и запуска на выполнение мы использовали кнопки Modify (Модифицировать),Browse (Обзор) и Run (Запустить) окна проекта. Visual FoxPro позволяет дляэтих целей использовать также мышь. При этом выполняемое действие определяется параметрами, установленными на вкладке Project (Проект) диалогового окна Options (Параметры) (рис. 13.1), вызываемого командойOptions (Параметры) из меню Tools (Сервис).

Используя опции области Project double-click action (Действия, выполняемыепри двойном щелчке в проекте) этого диалогового окна, вы можете указатьдействие, выполняемое при двойном щелчке на имени компонента. Поумолчанию установлен признак модификации выбранного компонента проекта, поэтому после двойного щелчка на нем вызывается конструктор, используемый при модификации файла данного типа.

Вы можете установить опцию Run selected file (Запустить выбранный файл).В этом случае при двойном щелчке на имени файла он будет запускаться.Таблица при двойном щелчке будет открываться в режиме Browse (Обзор)для просмотра содержащихся в ней записей.

Если в диалоговом окне Options (Параметры) установлен флажок Prompt forWizard (Запрос мастеров), при создании нового компонента проекта открывается диалоговое окно с запросом об использовании мастера для его создания. Если этот флажок не установлен, то сразу будет вызываться конструктор, соответствующий создаваемому объекту.

Чтобы настроить основные параметры управления проектом, вы можете использовать флажки области Source control options (Параметры хранилища данных), предназначенные для управления крупным проектом, выполняемым группой разработчиков. Назначение установки флажков описано втабл. 13.1.

Рис. 13.1. Определение параметров окна проекта

Таблица 13.1. Назначение флажков вкладки Project

Флажок | Назначение
Automatically add new projects tosource control (Автоматическидобавлять новые проекты в хранилище данных) | Создаваемый проект автоматически помещается в хранилище данных. В противном случае выдолжны будете добавлять проект вручную
Check out files upon modify (Выбор файла для эксклюзивногоредактирования) | Редактируемый файл автоматически выбирается для эксклюзивного редактирования пользователем. Если файл уже выбран для эксклюзивного редактирования другим пользователем,Visual FoxPro выдает соответствующее предупреждение
Add files to source control upon add (Добавлять данные в хранилище) | Файлы автоматически добавляются в хранилище данных проекта. Если флажок не установлен, то файлы будут добавляться только в проект (в файл с расширением PJX), но не будутдобавляться в хранилище. Следовательно, вамбудет необходимо размещать файл в хранилище вручную
Remove files from source controlupon removal from project (Удалять файлы из хранилища приудалении из проекта) | Удаляемый из проекта файл автоматическиудаляется из хранилища данных. Если флажокснят, то при удалении файла из проекта информация о файле сохраняется в хранилищеданных. При этом, если файл не был удален сжесткого диска, к нему можно получить доступ,используя систему совместной разработки внеVisual FoxPro
Display dialog box for shortcutmenu commands (Открывать диалоговое окно из всплывающегоменю команд) | При выборе элемента проекта с помощьюкоманды всплывающего меню проекта VisualFoxPro открывает диалоговое окно, позволяющее для работы с данной командой выбратьболее одного файла


  • Определение свойств окна проекта
  • Задание параметров проекта
  • Установка основной программы проекта
  • Использование опции Exclude
  • Очистка проекта от удаленных файлов
  • Построение проекта
  • Галерея компонентов Visual FoxPro
  • Запуск Галереи компонентов
  • Настройка параметров окна Галереи компонентов
  • Каталоги Галереи компонентов
  • Представления данных
  • Работа с проектом из окна Галереи компонентов
  • Использование метода "перенести-и-оставить" для перемещения объектов
  • Создание новой формы из Галереи компонентов


Просмотр представления данных

После задания в окне конструктора представлений условий для выбора записей и указания результирующих полей, вы можете просмотреть результаты выполнения представления данных.

Для этого выполните одно из следующих действий.

  • Нажмите кнопку Run (Запустить) на стандартной панели инструментов.
  • Выберите команду контекстного меню Run Query (Выполнить запрос).
  • Выберите в меню Query (Запрос) команду Run Query (Выполнить запрос).
  • Нажмите комбинацию клавиш <Ctrl>+<Q>.

На экране появится сформированное представление данных.

Для просмотра созданного представления данных вы можете также использовать окно проекта или окно Data Session (Окно данных). Чтобы просмотреть представления данных в окне проекта, достаточно установить на него курсор и нажать кнопку Browse (Обзор). Если вы просматриваете представление в окне Data Session (Окно данных), откройте его как обычную таблицу и нажмите кнопку Browse (Обзор).


Сохранение созданного представления данных

Сформированное в окне конструктора представление данных можно сохранить, выполнив следующие действия:

  1. В меню File (Файл) выберите команду Save As (Сохранить как).
  2. В поле View Name (Имя представления) открывшегося диалогового окна Save (Сохранить) (рис. 14.8) укажите имя созданного представления данных.
  3. Нажмите кнопку ОК.

Замечание

Обратите внимание, что в отличие от сохранения запроса, вам не требуется указывать место расположения представления, т. к. описание представления хранится в самой базе данных.

Рис. 14.8. Задание имени представления данных

Для открытия сохраненного представления данных из окна проекта необходимо установить на него курсор и нажать кнопку Modify (Модифицировать).


Создание представления данных

Для создания представления используется конструктор представлений данных. Существует несколько альтернативных способов его вызова.

  • Выберите в меню File (Файл) команду New (Новый). В открывшемся диалоговом окне установите опцию View (Представление данных) и нажмите кнопку New file (Новый файл).
  • В окне конструктора проекта на вкладке Data (Данные) перейдите в раздел Local Views (Локальные представления данных) выбранной базы данных и нажмите кнопку New (Новый).
  • Введите в командном окне Command команду CREATE VIEW.

Замечание

При любом из вариантов вызова для создания представления данных вы можете воспользоваться услугами мастера, который аналогичен мастеру создания запросов.

При вызове конструктора представлений открывается диалоговое окно Add Table and View (Добавить таблицу или представление данных), позволяющее разместить в конструкторе таблицы и созданные ранее представления данных. Для отображения представлений в этом диалоговом окне необходимо в области Select (Выбор) установить опцию Views (Представления данных). Выбрав необходимую таблицу или представление данных, перенесите их в конструктор, нажав кнопку Add (Добавить). Сформировав список таблиц, нажмите кнопку Close (Закрыть) для закрытия диалогового окна Add Table and View (Добавить таблицу или представление). Выбранные таблицы размещаются в открывшемся на экране окне конструктора представлений данных (рис. 14.7).

Окно конструктора представлений данных похоже на окно конструктора запросов и отличается от последнего некоторыми дополнительно предоставляемыми функциями.

  • Можно указать поля для модификации данных.
  • Можно задать параметры, значения которых будут запрашиваться при открытии представления данных.
  • Можно определить количество выбираемых записей.

Для формирования представления данных вы можете использовать команды меню Query (Запрос) и кнопки на панели инструментов View Designer (Конструктор представления данных). Функции кнопок панели инструментов View Designer описаны в табл. 14.2.

Рис. 14.7. Окно конструктора представлений данных

Таблица 14.2. Назначение кнопок панели инструментов View Designer

Название | Назначение
Add Table (Добавить таблицу) | Добавляет в представление новую таблицу или представление данных
Remove Table (Удалить таблицу) | Удаляет выбранную таблицу из запроса
Add Join (Добавить объединение) | Открывает диалоговое окно Join Condition (Условие объединения) для задания условия объединения таблиц
Show the SQL windows (Показать SQL-оператор) | Открывает диалоговое окно, в котором отображается SQL-оператор, соответствующий созданному представлению данных
Maximize the table view (Раскрыть панель представления таблиц) | Раскрывает на весь экран панель отображения используемых в представлении таблиц. Повторное нажатие на эту кнопку возвращает панели первоначальный размер


Использование представлений данных

Таблицы базы данных предназначены для хранения данных, а для просмотра данных предпочтительнее использовать представления данных, которые позволяют объединять связанные таблицы, выбирать интересующие вас поля таблиц или объединить несколько полей в одно поле, вычислять итоговые значения, определять новые имена для выбираемых полей таблицы и задавать условие выборки данных. После создания представления данных вы можете использовать его как обычную таблицу в формах, отчетах и при создании запросов.

Представления являются незаменимым средством для ограничения доступа пользователей к отдельным записям таблиц. В этом случае вся работа с базой данных осуществляется через представления данных.

Замечание

Описание представления данных хранится в словаре базы данных, поэтому для их просмотра вы должны предварительно открыть базу данных.


Условия достоверности ввода данных на уровне поля таблицы

Для определения условия достоверности ввода данных на уровне поля таблицы используется область Field validation (Проверка правильности ввода) вкладки Fields (Поля) окна конструктора таблиц. В поле Rule (Условие) задается логическое выражение, а в поле Message (Сообщение) — сообщение, отображаемое на экране, если логическое выражение возвращает значение False (Ложь).

Определим условие достоверности данных для поля nquant, содержащего количество купленного товара, таблицы ordsaied. При вводе количества товара необходимо автоматически проверять его фактическое количество на складе.

Для определения данного условия достоверности данных выполните следующие действия:

  1. Откройте проект sales.
  2. Перейдите на вкладку Data (Данные).
  3. В разделе Tables (Таблицы) выберите таблицу ordsaied и нажмите кнопку Modify (Модифицировать).
  4. В окне конструктора таблицы выберите поле nquant.
  5. В поле ввода Rule (Условие) области Field validation (Проверка правильности ввода) введите вызов функции checkQuant ().
  6. В поле ввода Message (Сообщение) введите текст сообщения: "Заказанное количество товара превышает его фактическое количество"Чрис. 14.6).
  7. Откройте окно редактирования хранимых процедур и добавьте в него новую процедуру CheckQuant:

    procedure CheckQuant nCdGoods = Ordsaied.iCdGoods

* определяем фактическое количество товара SELECT nFactQuant;

FROM Goods;

WHERE iCdGoods = nCdGoods;

INTO ARRAY nQuant

* сравниваем заказанное количество с имеющимся на складе

RETURN Ordsaied.nQuant(1) <= nQuant(1)

Рис. 14.6. Определение условия достоверности для поля nquant


Использование триггеров и хранимых процедур

Рассмотрим несколько примеров использования триггеров и хранимых процедур для определения условия достоверности ввода данных и начальных значений полей таблицы.

Определение значения поля при добавлении новой записи

Рассмотрим следующий пример. Чтобы создать для таблицы customer первичный ключ, в таблицу было добавлено поле, содержащее код клиента. Информация в данное поле должна заноситься программно, чтобы не нарушалась уникальность ключа. Для формирования и записи в таблицу кода клиента при добавлении новой записи создадим хранимую процедуру GetAutoNewNum.

  1. Откройте окно проекта sales.
  2. Создайте в базе данных sales таблицу Records, которая будет использоваться для хранения последних введенных значений кода. Данная таблица содержит два поля. Первое поле предназначено для ввода наименования таблицы, второе — для указания последнего введенного числового кода в данную таблицу. При вызове хранимой процедуры значение второго поля указанной таблицы увеличивается на единицу, и процедура возвращает новое значение кода. Введите в созданную таблицу название таблицы Customer и число, указывающее количество записей, содержащихся в ней.
  3. Выберите в окне проекта таблицу customer и нажмите кнопку Modify (Модифицировать).
  4. Для определения свойств поля, содержащего код клиента, перейдите на вкладку Fields (Поля).
  5. В поле ввода Default value (Значение по умолчанию) области Field validation (Проверка правильности ввода) задайте вызов функции GetAutoNewNum о , введя Getautonewnum("'Customer ") (рис. 14.4).
  6. Нажмите кнопку ОК для закрытия конструктора таблицы.
  7. Теперь необходимо определить функцию GetAutoNewNum. Откройте окно редактирования хранимой процедуры и введите следующие команды:

FUNCTION GetAutoNewNum

LPARAMETERS cNameAliasGANN

LOCAL nDefaultValueGANN

IF TYPE("cNameAliasGANN")="L"

= GetMessage ("Нужно ввести имя таблицы для определения начального

значения в таблице"+ALIAS()+"!",48,"Функция GetAutoNewNum")

RETURN 1

ENDIF

cNameAliasGANN=ALLTRIM (UPPER (cNameAliasGANN) )

DO OpenTable WITH "SALES!RECORDS", 1

IF !SEEK{cNameAliasGANN)

APPEND BLANK

REPLACE NameOfTable WITH cNameAliasGANN

REPLACE ColRecordsInTable WITH 1

ELSE

REPLACE ColRecordsInTable WITH ColRecordsInTable+1

ENDIF

nDefaultValueGANN=ColRecords!nTable

SELECT (cNameAliasGANN)

RETURN nDefaultValueGANN

Рис. 14.4. Задание вызова хранимой процедуры

Проверка удовлетворения введенных значений заданному условию

В данном примере определим условие проверки достоверности ввода данных для таблицы ordsaied, содержащей информацию о заказе. Например, при формировании накладной отпуска товара в кредит необходимо сравнивать итоговую сумму заказываемых товаров с максимально допустимым кредитом для данного клиента, содержащимся в таблице customer. Проверку будем осуществлять при вводе каждой позиции заказа.

  1. Откройте окно проекта sales.
  2. Выберите в окне проекта таблицу ordsaied и нажмите кнопку Modify (Модифицировать).
  3. Для определения свойств таблицы перейдите на вкладку Table (Таблица).
  4. В поле ввода Rule (Условие) области Record validation (Проверка правильности ввода записи) задайте вызов функции checkMaxCredit о, которая сравнивает итоговую сумму заказа с максимально допустимым кредитом клиента.
  5. В поле Message (Сообщение) области Record validation введите текст сообщения (рис. 14.5) "Вы превысили допустимую сумму кредита клиента".

Рис. 14.5. Определение условия достоверности данных

  6. Определим функцию CheckMaxCredit как свойство базы данных, поэтому создадим ее в виде хранимой процедуры.

Для создания хранимой процедуры CheckMaxCredit в окне редактирования хранимых процедур, которое содержит ранее созданные программы, введите следующий текст:

procedure CheckMaxCredit

nCdOrder=Ordsaled.icdOrder && номер текущего заказа

* вычисляем сумму всех введенных позиций заказа

SELECT SUM(Ordsaied.nQuant*Ordsaled.nUnitPrice);

FROM Ordsalem, Ordsaied;

WHERE Ordsalem.icdOrder = Ordsaied.icdOrder;

AND Ordsaied.icdOrder=nCdOrder;

INTO ARRAY nSum

* определяем максимальный кредит клиента из таблицы Customer

SELECT Customer

SEEK Ordsalem.icdCustomer

* если запись о данном покупателе в таблице Customer есть, возвращаем

* результат сравнения суммы заказа с максимальным кредитом

IF FOUND( )

RETURN nSum(l) < CUSTOMER.yCreditLimit

ELSE

RETURN .F.

ENDIF

RETURN

Действия, выполняемые при добавлении новых записей

Триггеры позволяют не только проверять условие достоверности ввода данных на уровне записей, но и выполнять требуемые действия при добавлении, удалении и изменении записей. Рассмотрим один из примеров использования триггера insert.

В некоторых случаях полезно иметь таблицу, в которой содержится список новых покупателей, которые обратились в вашу фирму за последний месяц. Данная таблица очищается в начале каждого месяца и может использоваться для рассылки рекламной информации новым покупателям. Для хранения списка новых покупателей используется таблица Newcustomer.

В данном примере определим триггер insert для таблицы customer:

  1. Откройте окно проекта sales.
  2. Выберите таблицу customer, содержащую список товаров, и нажмите кнопку Modify (Модифицировать).
  3. Для определения свойств таблицы перейдите на вкладку Table (Таблица) конструктора таблиц.
  4. В поле ввода Insert trigger (Триггер добавления) задайте вызов функции AddNewCustomer о, которая добавляет новую запись в таблицу Newcustomer.
  5. Для добавления новой хранимой процедуры AddNewCustomer откройте окно редактирования хранимых процедур и добавьте в него следующий текст:

procedure AddNewCustomer

nCurCdCustomer= icdCustomer

SELECT NewCustomer

APPEND BLANK

REPLACE icdCustomer WITH nCurCdCustomer

SELECT NewCustomer

RETURN .T.


Хранимые процедуры

Для создания хранимой процедуры выполните следующие действия:

  1. В окне проекта выберите базу данных.
  2. Перейдите в группу Stored Procedures (Хранимые процедуры).
  3. Нажмите кнопку New (Новый) (рис. 14.2).

Рис. 14.2. Для создания хранимой процедуры предназначена группа Stored Procedures окна проекта

  4. Открывается окно редактирования хранимых процедур (рис. 14.3), которое содержит все ранее созданные хранимые процедуры, включая процедуры, создаваемые автоматически при определении условий целостности базы данных.

Рис. 14.3. Окно редактирования хранимых процедур

Предупреждение

Редактирование или удаление хранимых процедур, которые Visual FoxPro создал автоматически при определении условия целостности данных, могут привести к непредсказуемым последствиям.

Для редактирования хранимых процедур в Visual FoxPro вы можете использовать команду MODIFY PROCEDURE, которая открывает окно редактирования хранимых процедур текущей базы данных.

Для удаления хранимой процедуры необходимо в окне редактирования выделить текст удаляемой процедуры и нажать клавишу <Delete> или в окне конструктора проекта установить курсор на ее наименование и выполнить команду Remove (Удалить) окна проекта.


Триггеры

В Visual FoxPro для таблиц, входящих в состав базы данных, вы можете определить триггеры, приведенные в табл. 14.1.

Таблица 14.1. Триггеры

Триггер | Описание
Insert (Вставить) | Определяет действия, которые будут выполняться после добавления новой записи в таблицу
Update (Обновить) | Определяет действия, которые будут выполняться после изменения записи таблицы
Delete (Удалить) | Определяет действия, которые будут выполняться после удаления записи из таблицы

Для определения триггеров введите в поля ввода Insert trigger (Вставить триггер), Update trigger (Обновить триггер) или Delete trigger (Удалить триггер) вкладки Table (Таблица) окна конструктора выбранной таблицы операторы сравнения, вызов хранимой процедуры или любое логическое выражение. Если результат вычисления выражения равен True (Истина), то считается, что введены допустимые значения. В противном случае сохранения введенных данных не происходит и формируется сообщение об ошибке. При использовании хранимых процедур вы сможете не только проверить условие достоверности ввода данных, но и задать действия, выполняемые при добавлении, удалении и изменении данных.

Вызов триггера Delete (Удалить) осуществляется:

  • при выполнении команды DELETE;
  • когда вы помечаете запись на удаление в режиме Browse (Обзор) или Edit (Правка).

Вызов триггера insert (Вставить) осуществляется в следующих случаях:

  • при выполнении команд APPEND FROM, APPEND FROM ARRAY,-APPEND BLANK;
  • при добавлении в таблицу новой записи в режиме Browse (Обзор) или Edit (Правка);
  • при выполнении команд IMPORT, INSERT SQL, RECALL;
  • при снятии метки об удалении записи в режиме Browse (Обзор) или Edit (Правка).

Триггер update (Обновить) вызывается, когда:

  • наступает любое событие, которое приводит к модификации записи (например, при изменении значения поля);
  • выполняются команды GATHER, REPLACE, REPLACE FROM ARRAY, UPDATE SQL.

При использовании триггеров необходимо учитывать ограничения, имеющиеся в Visual FoxPro.

  • При модификации записей, помеченных для удаления, и выполнении команды PACK триггеры не вызываются.
  • Выполнение команды ZAP не вызывает триггер Delete (Удалить).
  • При использовании буферизации ввода триггер update (Обновить) вызывается только при вызове функции TABLEUPDATE (),

Для удаления триггера в окне конструктора перейдите на вкладку Table (Таблица) и очистите поле ввода выражения для триггера или используйте Команду DELETE TRIGGER.


Редактирование данных

В Visual FoxPro представления данных могут использоваться не только для просмотра результатов выборки данных, но и для редактирования таблиц, которые использовались при его создании. Создавая представления данных, вы можете указать признак редактирования выбираемых полей базовых таблиц. Таким образом, вы можете задать список полей для просмотра и редактирования. Например, при изменении фамилии, имени и отчества клиента вы должны видеть на экране наименование фирмы, фамилию, имя и отчество клиента, но можете редактировать только поля, содержащие фамилию, имя и отчество.

Для определения таблиц и полей, которые будут изменяться при модификации данных с помощью представления, используется вкладка Update Criteria (Критерий обновления).

Перечень всех таблиц, поля которых используются для создания представления, приведен в раскрывающемся списке Table (Таблица). При выборе таблицы из этого списка в области Field name (Имя таблицы) отображается список выбранных полей. Для каждого поля вы можете определить признаки ключевого поля и разрешения модификации, которые устанавливаются с помощью флажка в столбцах, заголовки которых содержат изображение ключа и карандаша соответственно.

Кнопка Reset Key (Сброс ключа) устанавливает исходное состояние флажков разрешения модификации и ключевых полей. При этом сбрасываются все флажки в столбце разрешения модификации, а флажки в столбце признака ключевых полей устанавливаются только для тех полей, которые являются первичными ключами.

Кнопка Update All (Обновить все) устанавливает флажки в столбце разрешения модификации для всех полей, кроме ключевых.

Замечание

Все выбранные на вкладке Update Criteria (Критерий обновления) параметры действительны только в том случае, если установлен флажок Send SQL updates (Отправить SQL-обновление).

Установка редактируемых полей

Рассмотрим последовательность действий при создании представления данных, позволяющего редактировать информацию в полях, содержащих фамилию, имя и отчество клиента.

  1. Откройте окно конструктора представлений и добавьте в него таблицу customer.
  2. В список Selected fields (Выбранные поля) перенесите наименование фирмы ccompany, а также clastname, cf irstname и csecondname.
  3. Для определения редактируемых полей перейдите на вкладку Update Criteria (Критерий обновления).
  4. Установите флажки разрешения редактирования для полей clastname, cfirstname и csecondname.
  5. Установите флажок Send SQL updates (Отправить SQL-обновление).
  6. Сохраните представление данных и откройте его для редактирования данных в режиме Browse (Обзор).


Параметры представления данных

В Visual FoxPro при создании представления данных вы можете задать параметры представления. Значения этих параметров будут запрашиваться при открытии представления. Например, в предыдущем примере мы создали представление данных, которое содержит итоговые объемы продаж товаров. Использование параметров позволит вам выбирать не все продажи, а объем продаж за определенный интервал времени, продажи конкретного товара или покупки определенного клиента.

При открытии представления, для которого заданы параметры, запрашиваются значения заданных параметров, и выборка данных осуществляется с учетом введенных значений. Для определения параметров используется команда View Parameters (Параметры представления данных) из меню Query (Запрос).

Добавим в созданное в предыдущем примере представление данных параметр, указывающий дату, для которой будет осуществляться выборка.

  1. Выберите в окне проекта представление данных sumCust и нажмите кнопку Modify (Модифицировать).
  2. В окне конструктора представления данных в меню Query (Запрос) выберите команду View Parameters (Параметры представления данных). На экране открывается соответствующее диалоговое окно. Это диалоговое окно содержит список всех параметров представления, для каждого из которых заданы имя параметра и его тип.
  3. Введите параметр Date_View и определите для него тип данных Date.
  4. Определите условие выборки данных для заданной даты. Для этого перейдите на вкладку Filter (Фильтр) и добавьте условие для поля ordsaiem.dDoc. Для выбора значения за конкретную дату используйте оператор ==, а в поле ввода Example (Образец) введите ?Date_View.

Замечание

Вопросительный знак перед именем параметра является признаком использования параметра.

  5. Сохраните представление данных.
  6. Для просмотра итоговых продаж товаров за конкретный день откройте представление данных SumCust. Поскольку для представления определен параметр, на экране появляется диалоговое окно View Parameter (Параметр представления данных), предлагающее ввести значение параметра.

Замечание

Если при создании представления данных вы задали несколько параметров, то для ввода значения каждого параметра будет открываться отдельное окно.

  7. Введите значение параметра и нажмите кнопку ОК. На экране появится выборка записей, соответствующих дате, введенной в окне View Parameter (Параметр представления данных).

Замечание

Диалоговое окно View Parameter (Параметры представления данных) для ввода значения параметра рекомендуется использовать только при отладке представления. Вы можете определить переменные, наименования которых совпадают с именем параметра, и присвоить им требуемые значения в программе или в форме. В этом случае при открытии представления параметры запрашиваться не будут.


Просмотр объема продаж товаров клиентам

Рассмотрим пример создания представления данных, которое содержит итоговую сумму покупок клиентов. Представление данных будет содержать наименование предприятия, наименование товара и итоговую сумму покупок клиентом каждого товара.

  1. Откройте окно конструктора представлений и добавьте в него таблицы Customer, Ordsalem, Ordsaled И Goods, используемые для с оздания нового представления.
  2. Установите связи между размещенными в окне конструктора таблицами. При создании связей между таблицами необходимо учитывать, что связь между ними осуществляется по следующим полям:
  • Customer и Ordsalem — по коду клиента;
  • Ordsalem и Ordsaled — по код у заказа;
  • Ordsaled и Goods по коду товара.

Если в конструкторе базы данных вы определили постоянные связи между таблицами, то в окне конструктора они установятся автоматически.

  3. В список Selected fields (Выбранные поля) перенесите название фирмы, имя клиента и наименование товара.
  4. Добавьте в список Selected fields (Выбранные поля) вычисляемое поле, содержащее сумму продаж:

    SUM(Ordsaled.nQuant * Ordsaled.nUnitPrice)

  5. Задайте группировку данных по названию предприятия и наименованию товара.
  6. Для сохранения представления данных в меню File (Файл) выберите команду Save As (Сохранить как). В поле View Name (Имя представления) открывшегося диалогового окна Save (Сохранить) укажите имя создаваемого представления данных Sumcust и нажмите кнопку ОК.
  7. Просмотрите созданное представление данных, нажав кнопку Run (Выполнить) на стандартной панели инструментов.
  8. Закройте окно конструктора представлений.

Вы можете просмотреть созданное представление данных в окне Data Session (Окно данных). Для этого выполните следующие действия:

  1. В меню Windows (Окна) выберите команду Data Session (Окно данных).
  2. Нажмите кнопку Browse (Обзор).
  3. В открывшемся диалоговом окне Open (Открыть) в области Select (Выбор) установите опцию Views (Представления данных).
  4. Выберите из списка Views in database (Представления данных в базе данных) (рис. 14.9) требуемое представление данных и нажмите кнопку ОК.

Рис. 14.9. Выбор представления данных

Замечание

При открытии представления данных в окне Data Session (Окно данных) показывается не только выбранное представление, но и все таблицы, используемые при его создании (рис, 14.10).

Рис. 14.10. Окно Data Session после открытия представления данных Sumcust

Совет

Для открытия представления данных вы можете также в командном окне или в программе воспользоваться командой USE.


ГЛАВА 14
Условия достоверности, хранимые процедуры, триггеры, представления данных

В реляционных базах данных, к которым относится и Visual FoxPro, для управления данными могут использоваться не только прикладные програм мы, но и непосредственно сервер базы данных. Такая возможность реал ту ется с помощью условий достоверности ввода данных, триггеров и храни мых процедур, которые являются неотъемлемой частью базы данных.

Удобным средством просмотра хранящейся в базе данных информации я и ляются представления данных, которые содержат результат выборки из о.пнш или нескольких таблиц, удовлетворяющих заданному условию. Предстан кния данных имеют много общего с запросами и таблицами. Так же, как и для запросов, вы можете связывать несколько таблиц, указывать отображаемые поля, задавать условие выборки. Просмотр представления данных orv ществляется аналогично просмотру таблицы Visual FoxPro.

Условия достоверности ввода данных на уровне записей

Условия достоверности позволяют контролировать ввод данных среде там и сервера на уровне записей и полей таблицы. В первом случае условие опрг деляется в окне ввода свойств таблицы, а во втором — в окне свойств и<> ш таблицы. Проверка на уровне записи обычно используется, если необходима проверка при добавлении или удалении записи, а также, если условие про верки изменения записи требует анализа более одного поля.

При определении условий достоверности ввода данных используются трипе ры и хранимые процедуры. Триггеры задают действия, выполняемые прибавлении, удалении или изменении записей таблицы. Хранимые процедуры cо держат наиболее часто используемые процедуры, выполняемые сервером (и нл данных. Если вы определили условия достоверности ввода данных, их при верка осуществляется независимо от способа изменения данных в таблице

Для определения свойств таблицы откройте окно конструктора для выбранной таблицы и перейдите на вкладку Table (Таблица) (рис. 14.1).

Рис. 14.1. Определение свойств таблицы

Для определения достоверности ввода данных могут использоваться триггеры добавления и изменения и поля ввода Rule (Условие) и Message (Сообщение) области Record validation (Проверка правильности ввода записей). В поле Rule (Условие) вводится логическое выражение, которое может содержать вызов хранимой процедуры. Если значение этого выражения равно True (Истина), то считается, что введены допустимые данные и разрешается переход на другую запись или закрытие таблицы. В противном случае выводится сообщение об ошибке, которое было задано в поле Message (Сообщение).


  • Условия достоверности ввода данных на уровне записей
  • Триггеры
  • Хранимые процедуры
  • Использование триггеров и хранимых процедур
  • Условия достоверности ввода данных на уровне поля таблицы
  • Использование представлений данных
  • Создание представления данных
  • Сохранение созданного представления данных
  • Просмотр представления данных
  • Просмотр объема продаж товаров клиентам
  • Параметры представления данных
  • Редактирование данных


Создание формы с использованием таймера

Рассмотрим пример использования таймера в форме, в которой через заданный интервал времени на экран будут выводиться данные о количестве продаж каждого товара на текущий момент времени. Форма будет отображать информацию из представления данных, содержащего наименование товара, суммарное количество проданного товара и сумму продаж по товару:

  1. В Проекте Sales, ИСПОЛЬЗУЯ таблицы Goods, Ordsaled и Ordsalem, создайте представление данных, содержащее наименование товара, суммарное количество проданного товара и суммы продаж по данному товару.
  2. Сгруппируйте данные по коду товара.
  3. Сохраните созданное представление данных.
  4. Откройте новое окно конструктора форм.
  5. Откройте окно среды окружения формы и добавьте в него созданное представление.
  6. Создайте в форме объект Grid (Таблица), разместив в нем все поля представления данных.
  7. Для отображения текущей даты и времени расположите два поля ввода curdate и curtime. Скорректируйте для данных объектов свойство Readonly (Только чтение), установив значение True (Истина).
  8. Для создания объекта-таймера нажмите кнопку Timer (Таймер) на панели инструментов Form Controls (Элементы управления формы) и расположите его в форме.
  9. Откройте окно процедур для метода Timer (Таймер).
  10. Для присвоения значений созданным полям curdate и curtime, а также для обновления данных о продаже товаров через заданный интервал времени введите в окне процедур следующие значения:

    This.Parent.CurDate.Value = DATE()

    This. Parent.CurTime.Value = TIME()

    This.Parent.CurDate.Refresh()

    This.Parent.CurTime.Refresh()

    ThisForm.Gridl.Refresh()

  11. Определите интервал времени, через который необходимо производить обновление данных в таблице. Для этого воспользуйтесь свойством interval (Промежуток времени), значение которого задается в миллисекундах. Для обновления данных каждые 10 мин введите значение 600 000.
  12. Форма готова. Сохраните ее и запустите на выполнение.

Рис. 15.24. Использование таймера в форме

Рис. 15.25. Просмотр итоговых продаж через заданный промежуток времени

При работе в сети каждый час на экране будет обновляться информация об итоговом количестве продаж товаров и их стоимости. На рис. 15.24 показан вид созданной формы, а на рис. 15.25 — просмотр данных с помощью этой формы.


Таймер

В Visual FoxPro существует объект, обрабатывающий данные системных часов, называемый таймером. Его можно использовать для отображения в форме системных часов, а также для выполнения определенных действий через заданный интервал времени. Например, используя объект данного типа, можно обновлять данные в таблицах.

Для размещения в форме таймера используется кнопка Timer (Таймер) на панели инструментов Form Controls (Элементы управления формы). Объект данного типа обладает свойствами, описанными в табл. 15.4.

Таблица 15.4. Назначение свойств объекта Timer

Свойство | Назначение
Interval (Интервал) | Интервал активизации объекта в миллисекундах
Enabled (Доступно) | Устанавливает режим работы таймера. Если значение свойства равно True (Истина), то таймер начинает отсчитывать время сразу же после запуска формы. В противном случае вы должны запустить таймер по какому-либо внешнему событию (например, при нажатии на кнопку)

Помимо вышеперечисленных свойств, для объекта Timer (Таймер) определяется событие Timer (Таймер), наступающее через каждый установленный в свойстве interval (Промежуток времени) промежуток времени. В процедуре обработки данного события необходимо определить действия, выполняемые с заданным интервалом.

Для запуска таймера используется метод Reset (Установить), не связанный с каким-либо событием. Поэтому вы должны выполнить его при наступлении каких-либо других событий, например, при нажатии кнопки запуска таймера.


Набор форм

В Visual FoxPro вы можете объединить несколько форм в набор форм. Для этого служит команда Create Form Set (Создать набор форм) из меню Form (Форма), создающая объект FormSet.

Создадим объект FormSet из двух форм. Первая форма содержит данные о клиентах таблицы customer, а вторая — итоговую сумму покупок клиентов. Для создания набора форм выполните следующие действия:

  1. Откройте проект Sales.
  2. Откройте окно конструктора для создания новой формы.
  3. Выберите в меню Form (Форма) команду Create Form Set (Создать набор форм).
  4. Откройте окно Data Environment (Среда окружения) и добавьте в окружение таблицу customer и представление данных sumcust, содержащее сведения об итоговой стоимости покупок клиентов.
  5. Скорректируйте свойство caption (Надпись) для первой формы, введя заголовок Клиенты.
  6. В форме создайте объект Grid (Таблица), разместив в нем необходимые поля таблицы Customer.
  7. Для добавления второй формы выполните команду Add New Form (Добавить новую форму) из меню Form (Форма). В окне конструктора форм откроется вторая форма.
  8. Скорректируйте свойство caption (Надпись) для второй формы, введя заголовок Итоговые суммы покупок,
  9. Во второй форме создайте объект Grid (Таблица), разместив в нем поля представления данных Sumcust.

Рис. 15.23. Просмотр набора форм

  10. Расположите формы на экране таким образом, чтобы они были удобны для поочередного просмотра.
  11. Сохраните созданную форму, нажав кнопку Save (Сохранить) на стандартной панели инструментов.
  12. Запустите форму на выполнение.
  13. На экране открывается две формы (рис. 15.23). Просмотрев данные в первой форме, перейдите во вторую форму. Для этого активизируйте ее, щелкнув мышью в любом ее месте. Во второй форме вы можете просмотреть итоговые суммы покупок интересующего вас клиента.


Создание формы с вкладками

Visual FoxPro позволяет создавать формы, содержащие несколько вкладок. Объекты данного типа удобно использовать в том случае, когда необходимо разместить большой объем информации или для удобства работы требуется основную, наиболее часто используемую информацию, сгруппировать в одном месте, отделив от менее важной информации.

Чтобы создать вкладки в форме, необходимо воспользоваться кнопкой Page Frame (Вкладка) панели инструментов Form Controls (Элементы управления формы). Созданный объект содержит в контекстном меню команду Edit (Правка), указывающую, что он является сложным объектом, в котором вкладки наделены своими собственными свойствами. Количество вкладок задается свойством Pagecount (Количество вкладок). В процессе создания формы переход с одной вкладки на другую осуществляется в режиме редактирования.

Создание объекта типа page Frame (Вкладка) рассмотрим на примере разработки многостраничной формы для таблицы customer. Форма будет содержать две вкладки. На первой вкладке будет располагаться объект Grid (Таблица), содержащий список всех клиентов, а на второй — дополнительные данные о выбранном на первой вкладке клиенте.

  1. Откройте проект Sales.
  2. Откройте окно конструктора форм для создания новой формы. Скорректируйте свойство caption (Надпись) формы, введя заголовок формы Список клиентов.
  3. Откройте диалоговое окно Data Environment (Среда окружения), выполнив команду Environment (Окружение) из меню View (Вид).
  4. Используя команду Add (Добавить) всплывающего меню, добавьте в форму таблицу Customer. Закройте диалоговое окно.
  5. Нажмите кнопку Page Frame (Вкладка) на панели инструментов Form Controls (Элементы управления формы).
  6. Установите указатель в форму и, удерживая кнопку мыши в нажатом состоянии, переместите курсор по диагонали так, чтобы получилась рамка размером с форму (рис. 15.19).

Рис. 15.19. Размещение в форме объекта Page Frame

  7. Откройте окно свойств созданного объекта. Убедитесь, что для свойства Pagecount, определяющего количество вкладок формы, по умолчанию установлено значение 2.
  8. Скорректируйте свойство caption (Надпись) для объектов Pagei и Раде2, определяющих заголовок каждой вкладки. Для объекта Pagei введите заголовок Основная информация, а для объекта Раде2 — Дополнительная информация.
  9. Для перехода в режим редактирования объекта Page Frame (Вкладка) выберите команду Edit (Правка) контекстного меню. Вокруг объекта появилась штриховая контурная рамка.
  10. Убедитесь, что вы находитесь на первой вкладке объекта Page Frame (Вкладка). Для этого щелкните мышкой на вкладке Основная информация в верхней части формы.
  11. Используя кнопку Grid (Таблица) на панели инструментов Form Controls (Элементы управления формы), создайте объект Grid (Таблица) для отображения ПОЛеЙ icdcustomer, ccompany таблицы Customer.
  12. В третьем столбце таблицы для отображения фамилии, имени и отчества представителя в свойстве Control Sour се (Источник данных) введите выражение следующего вида:

a lit rim (customer .cLastname) + " " + allt rim (customer .cFirstname) + " " + alltrim(customer.cSecondname)

  13. Определите заголовки столбцов и другие параметры созданного объекта Grid (Таблица).
  14. В нижней части страницы расположите кнопки перемещения по записям таблицы и выхода из формы.

На рис. 15.20 представлена первая вкладка созданной формы.

Рис. 15.20. Первая страница многостраничной формы

  15. Перейдите на вторую вкладку объекта Page Frame (Вкладка). Для этого щелкните на названии вкладки Дополнительная информация в верхней части формы.

Совет

Если ваша попытка перейти на вторую вкладку оказалось безуспешной, убедитесь, что объект Page Frame (Вкладка) находится в режиме редактирования.

  16. На второй странице объекта расположите все поля таблицы Customer и надписи к ним.
  17. При переходе на другую вкладку формы необходимо обновлять значения данных, отображаемых в ней. Для этого вы можете использовать событие Activate (Активизация) каждой вкладки объекта Page Frame (Вкладка). Откройте окно редактирования процедуры обработки данного события и введите следующую команду, использующую метод Refresh (Обновить):

screen.ActiveForm.Refresh()

Окно процедур для метода Refresh представлено на рис. 15.21.

  18. Сохраните созданную форму и запустите ее на выполнение.

Замечание

Обратите внимание, что после ввода информации в окно процедуры в свойстве данного метода появляется значение [User Procedure].

Рис. 15.21. Окно процедуры для метода Refresh

Используя первую вкладку формы, вы можете, перемещаясь по записям таблицы, просмотреть весь список клиентов. Для просмотра дополнительной информации по любому из клиентов установите на него курсор и нажмите ярлык Дополнительная информация. В результате откроется вторая вкладка формы (рис. 15.22), на которой располагается дополнительная информация о выбранном клиенте.

Рис. 15.22. Вторая вкладка формы


Создание объекта Grid с помощью конструктора форм

Форма для таблиц, имеющих отношение "один-ко-многим", с помощью мастера создается достаточно быстро. Но она требует определенной доработки в конструкторе форм. Поэтому вам необходимо уметь создавать многотабличные формы с помощью конструктора, чтобы при необходимости уметь их модифицировать. Для создания формы в конструкторе форм следует выполнить следующие действия:

  1. В окне Data Environment (Среда окружения) разместите таблицы, используемые в форме.
  2. Установите связи между таблицами.
  3. Разместите в форме поля главной таблицы.
  4. Создайте в форме объект Grid (Таблица) для отображения данных подчиненной таблицы.

Создание формы, содержащей объект Grid

Рассмотрим создание формы, с помощью которой можно просмотреть информацию о клиентах, их телефонах и сделанных ими покупках. В отчете будем использовать следующие таблицы: Customer, Phoncust, Ordsalem, ordsaied и Goods. В таблицах содержится следующая информация:

  • Сustomer — список клиентов;
  • Phoncust — средства связи, по которым можно связаться с клиентом;
  • Ordsalem — информация о продажах: номер заказа, дата заказа, код клиента, итоговая сумма заказа;
  • O rdsaied — код, количество и стоимость проданного товара по данному заказу;
  • Goods — информация о товарах.

Отношение между таблицами customer и Phoncust определяется как "одинко-многим", т. к. клиент может иметь несколько номеров телефона или факс для связи.

Отношение между таблицами Customer и Ordsalem также "один-ко-многим", поскольку каждый клиент может сделать несколько покупок.

Приступим к созданию формы.

  1. Откройте проект Sales.
  2. Откройте окно конструктора форм для создания новой формы.
  3. Откройте окно Data Environment (Среда окружения), выполнив команду Environment (Окружение) из меню View (Вид).
  4. Используя команду Add (Добавить) из меню Data Environment (Среда окружения), добавьте В форму таблицы Customer, Phoncust, Ordsalem, Ordsaied и Goods. Между ними существуют следующие отношения:
  • customer — родительская по отношению к таблицам Phoncust и Ordsalem;
  • Ordsalem — родительская по отношению к таблице ordsaied;
  • ordsaied — родительская по отношению к таблице Goods. Связь между таблицами осуществляется:
  • customer и Phoncust — по коду клиента;
  • Customer и Ordsalem — по коду клиента;
  • Ordsalem и Ordsaied — по коду заказа;
  • Ordsaied и Goods — по коду товара.

Данные в таблицах customer, Ordsalem и Phoncust должны быть упорядочены по коду клиента, в ordsaied — по коду заказа, а в Goods — по коду товара.

  5. Установив все необходимые связи между таблицами и указав упорядочение данных (рис. 15.14), закройте окно Data Environment (Среда окружения).

Рис. 15.14. Окно Data Environment создаваемой формы

  6. Используя кнопки панели инструментов Form Controls (Элементы управления формы), расположите в форме заголовок, надписи и необходимые поля таблицы Customer.
  7. Выберите кнопку Grid (Таблица) на панели инструментов Form Controls (Элементы управления формы).
  8. Установите указатель в место предполагаемого расположения объекта и, удерживая кнопку мыши нажатой, переместите курсор по диагонали, нарисовав рамку требуемого размера.
  9. Для определения параметров созданного объекта выделите его и откройте окно свойств, выполнив команду Properties (Свойства) из меню View (Вид).
  10. Скорректируйте свойство coiumnCount (Количество столбцов) объекта Grid (Таблица), задав количество столбцов в создаваемом объекте равным 3.
  11. Если вы хотите изменить цвет сетки таблицы, определите свойство GridLineCoior (Цвет сетки таблицы) объекта Grid (Таблица).
  12. Используя свойство controisource (Источник данных) каждого из трех объектов column (Столбец), входящих в объект Grid (Таблица), свяжите столбцы с полями таблицы Phoncust.
  13. Используя свойство caption (Надпись) каждого из трех объектов Header (Заголовок), входящих в объект Grid (Таблица), введите заголовки столбцов Вид связи, Номер кода и Номер. Чтобы заголовки располагались по центру столбцов, скорректируйте для каждого из них свойство Alignment (Выравнивание), установив значение Middle (По середине) Center (По центру).

    Определение первого объекта Grid (Таблица) завершено. Разместим в форме второй объект Grid (Таблица).

  14. Нажмите кнопку Grid (Таблица) на панели инструментов Form Controls (Элементы управления формы).
  15. Установите указатель в нижней части формы и, удерживая кнопку мыши в нажатом состоянии, переместите курсор по диагонали так, чтобы получилась рамка необходимого размера.
  16. Для определения параметров созданного объекта выделите его и откройте окно свойств.
  17. Скорректируйте свойство CoiumnCount (Количество столбцов) объекта Grid (Таблица), задав количество столбцов (6) в создаваемом объекте.
  18. Если необходимо выбрать цвет сетки таблицы, определите свойство GridLineCoior (Цвет сетки таблицы) объекта Grid (Таблица).
  19. Используя свойство controisource (Источник данных) каждого из пяти объектов column (Столбец), входящих в объект Grid (Таблица), выполните следующие действия:
  • свяжите первые два столбца с полями cndoc и ddoc таблицы Ordsaiem;
  • свяжите третий столбец с полем cnmgoods таблицы Goods;
  • четвертый и пятый столбцы свяжите с полями nquant и nunitprice таблицы Ordsaled.
  20. Шестой столбец таблицы будет содержать вычисляемое поле, определяющее стоимость проданного товара. Используя свойство Controisource (источник данных) для шестого объекта Column (Столбец), задайте выражение для вычисляемого поля: Ordsaled.nQuant*Ordsaled.nUnitPrice
  21. Используя свойство caption (Надпись) каждого из шести объектов Header (Заголовок), входящих в объект Grid (Таблица), введите заголовки столбцов: Номер документа, Дата, Наименование товара, Количество, Цена и Стоимость. Чтобы заголовки столбцов располагались по центру, скорректируйте для каждого из них свойство Alignment (Выравнивание), установив значение Middle (По середине) center (По центру).
  22. Используя свойство ForeCoior каждого из пяти объектов Text (Текст), входящих в объект Grid (Таблица), установите цвет (например, красный) для выделения информации при установке курсора на данное поле.
  23. Добавьте в создаваемую форму кнопки перемещения по записям. Полученная форма показана на рис. 15.15.

Рис. 15.15. Многотабличная форма

  24. Сохраните созданную форму и запустите ее на выполнение. Отметьте, что при перемещении по записям таблицы customer в первом объекте Grid (Таблица) отображается список телефонных номеров, по которым можно связаться с клиентом, а во втором объекте Grid (Таблица) показывается полный список товаров, купленных данным клиентом (рис. 15.16).

Рис. 15.16. Просмотр многотабличной формы

Создание формы, содержащей три объекта Grid

В рассмотренном примере мы использовали поля формы для отображения информации главной таблицы. Модифицируем созданную форму и разместим поля таблицы customer в объекте Grid (Таблица).

  1. Откройте в окне конструктора форм созданную в предыдущем примере форму и сохраните ее под новым именем.
  2. Удалите из формы все поля и надписи, оставив только объекты Grid (Таблица) (рис. 15.17).
  3. Нажмите кнопку Grid (Таблица) на панели инструментов Form Controls (Элементы управления формы), установите указатель в левой верхней части формы и создайте новый объект Grid (Таблица).
  4. В окне свойств созданного объекта скорректируйте для объекта Grid (Таблица) свойство coiumncount (Количество столбцов), задав количество столбцов (4) в создаваемом объекте.
  5. Свяжите столбцы объекта с полями ccompany, clastname, cfirstname и caddress таблицы Customer.

Рис. 15.17. Удаление из формы полей ввода и надписей к ним

Рис. 15.18. Форма с тремя объектами Grid

  6. Скорректируйте для вновь созданных объектов свойства, определяющие цвет сетки таблицы, расположение заголовков, цвета отображения заголовков и выводимых данных.
  7. Сохраните форму и запустите ее на выполнение. Вид созданной формы показан на рис. 15.18.


Создание многотабличных форм для таблиц, имеющих отношение "один-ко-многим"

Во всех рассмотренных нами ранее примерах по созданию форм использовались связанные таблицы с отношением между ними "один-к-одному" или "многие-к-одному". При создании приложений очень часто возникает необходимость просмотра и редактирования данных, имеющих отношение "один-ко-многим". В этом случае при создании формы для отображения записей основной таблицы можно использовать поля формы или объект Grid (Таблица), а для отображения данных подчиненной таблицы — объект Grid (Таблица). Рассмотрим создание многотабличных форм с помощью мастера и конструктора форм.

Создание многотабличной формы с помощью мастера

Рассмотрим создание формы для связанных таблиц customer и Phoncust, имеющих отношение "один-ко-многим" с помощью мастера. Таблица customer содержит информацию о клиентах, таблица Phoncust — номера телефонов, по которым можно с ними связываться.

  1. Откройте проект sales.
  2. Перейдите на вкладку Documents (Документы), выберите группу Forms (Формы) и нажмите кнопку New (Новый).
  3. В открывшемся диалоговом окне New Form (Новая форма) выберите опцию Form Wizard (Мастер формы).

Рис. 15,6. Диалоговое окно для выбора мастера многотабличной формы

  4. На экране открывается диалоговое окно, предназначенное для выбора мастера создания формы (рис. 15.6). Поскольку мы создаем форму для связанных таблиц, выберите опцию One-to-Many Form Wizard (Мастер формы с отношением "один-ко-многим") и нажмите кнопку ОК для вызова мастера многотабличной формы.
  5. В области Databases and tables (Базы данных и таблицы) выберите главную таблицу формы Customer. После выбора таблицы в списке Available fields (Имеющиеся поля) появится перечень всех полей данной таблицы. Перенесите из этого списка в список Selected fields (Выбранные поля) поля, которые вы хотите поместить в создаваемую форму из данной таблицы (рис. 15.7). Затем нажмите кнопку Next (Далее) для перехода к следующему шагу.
  6. На втором шаге работы мастера выберите подчиненную таблицу и ее поля, которые будут размещены в форме в виде объекта Grid (Таблица) (рис. 15.8). Для перехода к следующему шагу нажмите кнопку Next (Далее).

Рис. 15.7. Выбор полей главной таблицы

  7. На третьем шаге мастера необходимо установить связь между таблицами, используемыми в форме (рис. 15.9). В диалоговом окне размещены два раскрывающихся списка, содержащие индексы и поля исходных таблиц. В нашем примере для установления связи воспользуемся ключевым полем icdcustomer Таблицы Customer и индексом icdcustomer таблицы Phoncust. Установив связь между таблицами, нажмите кнопку Next (Далее).
  8. На четвертом шаге (рис. 15.10) необходимо установить стиль отображения объектов формы, воспользовавшись значениями из списка Style (Стиль), и тип кнопок управления, выбрав одну из опций в группе Button type (Тип кнопки). Выберите стиль, просмотрите результат выбора в верхней части диалогового окна. Затем выберите тип отображения кнопок управления (с текстовыми надписями или с изображениями). Если вы не хотите размещать кнопки в форме, установите опцию No buttons (Без кнопок). После того как вы установили требуемые параметры, нажмите кнопку Next (Далее).

Рис. 15.8. Выбор полей подчиненной таблицы, помещаемых в объект Grid

Рис. 15.9. Установка связи между таблицами

Рис. 15.10. Выбор стиля отображения полей и управляющих кнопок

  9. На следующем шаге формируется список полей, по которым будет осуществляться сортировка отображаемых в форме данных. Для переноса поля из списка Available fields or index tag (Имеющиеся поля и индексы) в список Selected fields (Выбранные поля) установите курсор на поле или индекс, по значению которого требуется упорядочивать данные, и нажмите кнопку Add (Добавить). Если вы ошибочно перенесли не то поле или индекс, удалить его из списка Selected fields (Выбранные поля) можно с помощью кнопки Remove (Удалить). Установите опцию Ascending (По возрастанию) или Descending (По убыванию), определяющую, по возрастанию или по убыванию значения выбранного поля будут упорядочиваться данные (рис. 15.11). Для перехода к следующему шагу создания формы нажмите кнопку Next (Далее).
  10. На последнем, шестом шаге, в поле ввода Т^ре a title for your form (Тип заголовка формы) задайте заголовок, размещаемый в форме, и выберите один из трех вариантов продолжения работы с формой (рис. 15.12) (табл. 15.3).

Таблица 15.3. Варианты продолжения работы с формой

Опция | Действие
Save form for later use (Сохранить форму) | Созданная форма сохраняется на диске
Save and run form (Сохранить и запустить форму на выполнение) | Созданная форма сохраняется и запускается на выполнение
Save form and modify it in the Form Designer (Сохранить и открыть для модификации в конструкторе форм) | Созданная форма сохраняется и открывается в конструкторе форм для модификации

Рис. 15.11. Установка критерия сортировки данных

После установки требуемой опции нажмите кнопку Finish (Готово) для завершения создания объекта с помощью мастера. В открывшемся диалоговом окне Save as (Сохранить как) выберите папку, в которой хотите разместить форму, и введите имя созданной формы.

Рис. 15.12. Заключительное диалоговое окно мастера

Посмотрите на форму, созданную с помощью мастера (рис. 15.13). Надписи к полям основной таблицы созданы с использованием информации, введенной в поле Caption (Надпись) свойства таблицы. Однако при формировании названий столбцов объекта Grid (Таблица) мастер не использовал это свойство таблицы. Для изменения наименований столбцов вам потребуется конструктор форм.

Рис. 15.13. Многотабличная форма, созданная с помощью мастера форм


Свойства объекта Grid

Построитель — очень удобное средство для быстрого создания объекта Grid (Таблица). Однако созданный с его помощью объект требует некоторой модификации внешнего вида. С этой целью рассмотрим основные свойства, характеризующие объект Grid (Таблица).

Щелкните правой кнопкой мыши на объекте Grid (Таблица). В контекстном меню содержится команда Edit (Правка), указывающая, что объект является сложным, т. е. состоящим из нескольких входящих в него объектов.

Такими объектами являются column (Столбец), Header (Заголовок) и Text (Текст). Выделите объект Grid (Таблица) и откройте окно свойств (рис. 15.5). Созданный объект характеризуется свойствами, относящимися ко всему объекту в целом. Помимо этого, объекты column (Столбец), Header (Заголовок) и Text (Текст) обладают своими собственными свойствами.

Объекты, характеризующие столбцы таблицы, представлены в табл. 15.2.

Таблица 15.2. Назначение объектов, характеризующих столбцы таблицы

Объект | Назначение
Column (Столбец) | Определяет свойства, относящиеся к помещаемой в столбец информации
Header (Заголовок) | Определяет свойства, характеризующие заголовок столбца
Text (Текст) | Определяет свойства поля таблицы, когда на нем установлен фокус

Рис. 15.5. Окно свойств объекта Grid

Свойства, определяющие объект Grid

Сначала обратимся к основным свойствам, определяющим объект Grid (Таблица) в целом. К числу таких свойств относятся:

  • ComumnCount — количество столбцов в создаваемом объекте Grid (Таблица);
  • GridLineWidth — толщина сетки таблицы;
  • GridLineCoior — цвет сетки таблицы;
  • GridLines — стиль оформления таблицы; может принимать одно из следующих значений:
    • None (Нет) — в таблице отсутствуют горизонтальные и вертикальные линии;
    • Horizontal (Горизонтальные) — в таблице присутствуют горизонтальные линии;
    • vertical (Вертикальные) — в таблице присутствуют только вертикальные линии;
    • Both (Default) (Горизонтальные и вертикальные) — в таблице присутствуют горизонтальные и вертикальные линии;
  • Recordsource — задает источник данных помещаемой в объект информации;
  • RecordSourceType — задает тип источника данных и может принимать одно из следующих значений:
    • Table (Таблица) — автоматически открывает таблицу, заданную свойством RecordSource;
    • Alias (Псевдоним) — использует заданный псевдоним таблицы;
    • Prompt (Запрашиваемое значение) — если для формы в среде окружения не определены таблицы, запрашивается исходная таблица для отображения в объекте Grid (Таблица);
    • Query (QPR) (Запрос) — в качестве источника данных используются результаты запроса;
    • SQL statement (SQL-предложение) — в качестве источника данных используется SQL-предложение;
  • C hi l d O rder — задает имя индекса, используемого для установления связи между таблицами;
  • RecordMark — определяет наличие с левой стороны объекта Grid (Таблица) столбца, содержащего указатель текущей записи.

Свойства объекта Column

Объект column (Столбец) является составной частью объекта Grid (Таблица) и определяет информацию, выводимую в столбцах объекта Grid (Таблица).

Используя свойства объекта column (Столбец), можно задать цвет фона столбца, а также цвет выводимой информации, тип шрифта, размер, выделив тем самым наиболее важную информацию в размещенном в форме табличном объекте.

Объект column (Столбец) характеризуется следующими основными свойствами:

  • CoiumnOrder — задает порядок следования столбцов;
  • Alignment — выравнивает информацию в столбце;
  • Controisource — связывает столбец с источником данных.

Свойства объекта Header

Объект Grid (Таблица) состоит из столбцов, каждый из которых имеет собственный заголовок, являющийся объектом Header (Заголовок). В Visual FoxPro заголовок каждого столбца является самостоятельным объектом. Его можно корректировать, изменяя свойства.

Свойство caption (Надпись) объекта определяет наименование заголовка столбца, а свойство Alignment (Выравнивание) задает его расположение в столбце.

Помимо этого, объект Header (Заголовок), как и объект column (Столбец), характеризуется свойствами, определяющими цвет фона, тип и размер шрифта заголовка.

Свойства объекта Text

Объект Text (Текст) определяет вид информации, выводимой в столбцах объекта Grid (Таблица), при установленном курсоре на текущую запись в столбце.

Используя свойства данного объекта, можно задать цвет фона, тип и размер шрифта выводимой информации.


Использование построителя

Использование построителя ускоряет размещение объекта в форме и определение его свойств. Особенно заметным это преимущество становится при создании сложных объектов, к числу которых относится объект Grid (Таблица). Рассмотрим пример размещения объекта Grid (Таблица) с помощью построителя для таблицы Customer и изучим свойства, которыми наделен данный объект.

Для создания формы, в которой данные будут представлены в табличном виде, выполните следующие действия:

  1. Откройте Проект Sales.
  2. Выберите вкладку Documents (Документы), перейдите в группу Forms (Формы), а затем нажмите кнопку New (Новый).
  3. В открывшемся диалоговом окне New Form (Новая форма) выберите опцию New Form (Новая форма). На экране открывается окно конструктора форм.
  4. Откройте окно среды окружения формы Data Environment (Среда окружения), выполнив команду Environment (Окружение) из меню View (Вид).
  5. Для добавления таблицы в окружение выполните команду контекстного меню Add (Добавить).
  6. В открывшемся диалоговом окне Add Table or View (Добавить таблицу или представление данных) выберите таблицу customer и нажмите кнопку ОК. В окне Data Environment (Среда окружения) появилась выбранная таблица. Закройте окно окружения.
  7. Нажмите кнопку Builder Lock (Закрепитель построителя) LE__i на панели инструментов Form Controls (Элементы управления формы).
  8. Выберите кнопку Grid (Таблица) И' на панели инструментов Form Controls (Элементы управления формы).
  9. Установите указатель в место предполагаемого расположения таблицы, нажмите кнопку мыши и, удерживая ее нажатой, переместите курсор по диагонали, чтобы получилась рамка требуемого размера.
  10. Запускается построитель и на экране открывается диалоговое окно Grid Builder (Построитель таблицы) (рис. 15.1), позволяющее задать основные параметры объекта Grid (Таблица).

Диалоговое окно построителя объекта Grid (Таблица) содержит четыре вкладки, используя которые вы можете настроить его параметры (табл. 15.1).

Таблица 15.1. Назначение вкладок окна Grid Builder

Вкладка | Назначение
Grid Items (Элементы объекта Grid) | Позволяет сформировать список полей, размещаемых в создаваемом объекте
Style (Стиль) | Позволяет задать стиль отображения таблицы, выбрав один из предложенных вариантов: Professional (Профессиональный), Standard (Стандартный), Embossed (Изысканный), Ledger (Бизнес)
Layout (Расположение) | Позволяет переопределить заголовки столбцов объекта Grid (Таблица) и определить тип объекта, отображаемого в столбце таблицы
Relationship (Отношения) | При создании многотабличных форм позволяет определить отношения между таблицами
  11. Используя кнопки со стрелками, перенесите из списка Available fields (Имеющиеся поля) в список Selected fields (Выбранные поля) поля, которые вы хотите разместить, используя объект Grid (Таблица).

Рис. 15.1. Диалоговое окно Grid Builder

  12. Для задания стиля отображения данных в таблице перейдите на вкладку Style (Стиль). Используя одноименный список, выберите один из вариантов оформления таблицы (рис. 15.2).
  13. По умолчанию заголовки столбцов совпадают с именами полей таблицы, заданными в свойстве Caption (Надпись) конструктора таблиц. Чтобы переопределить заголовки столбцов объекта Grid (Таблица), перейдите на вкладку Layout (Расположение) (рис. 15.3). Она содержит создаваемый объект с реальными данными. При перемещении по столбцам таблицы в поле ввода Caption (Надпись) вкладки отображается наименование данного столбца. Для изменения наименования столбца скорректируйте имя, отображаемое в этом поле.

Рис. 15.2. Определение стиля объекта Grid

Рис. 15.3. Переопределение заголовков столбцов объекта Grid

  14. На вкладке Layout (Расположение) вы можете задать тип объекта, отображаемого в столбце. Для этого воспользуйтесь раскрывающимся списком Control type (Стиль элементов управления), содержащим перечень всех типов объектов, которые могут отображаться в столбце: Textbox, Editbox, Spinner, Checkbox и OLEBoundControl. Выберите из списка необходимое значение типа данных столбца.

Замечание

При использовании объекта Grid (Таблица) для создания многотабличных форм вы можете выбрать вкладку Relationship (Отношение) (рис. 15.4) и на ней задать ключевое поле главной таблицы и индекс подчиненной таблицы. Если вторая таблица не добавлена в окружение формы, нажмите кнопку, расположенную рядом со списком Key field in parent table (Ключевое поле в родительской таблице), и в открывшемся диалоговом окне Open (Открыть) выберите необходимую таблицу. Она будет добавлена построителем в окружение формы.

  15. После завершения определения всех параметров нажмите кнопку ОК для закрытия окна построителя.

Рис. 15.4. Вкладка Relationship для установки связи между таблицами

  16. Используя кнопку Label (Текстовый объект) на панели инструментов Form Controls (Элементы управления формы), разместите заголовок в форме.


Добавление данных в список

В главе 6 мы рассматривали использование объектов типа ListBox (Список), которые значительно облегчают ввод данных в поля, одновременно избавляя от дополнительных ошибок, которые могут возникнуть при вводе. Список может формироваться из значений, содержащихся в поле таблицы, массива, запроса и т. п. В этой главе рассмотрим создание списка, значения которого вводятся в интерактивном режиме пользователем с использованием дополнительного поля ввода.

Создание списка рассмотрим на примере редактирования поля, содержащего город, для таблицы Customer. Для создания формы:

  1. Откройте форму для ввода списка клиентов в окне конструктора форм.
  2. Нажмите кнопку List Box (Список) на панели инструментов Form Controls (Элементы управления формы).
  3. Установите указатель мыши на место предполагаемого расположения поля и, удерживая кнопку мыши в нажатом состоянии, переместите курсор по диагонали так, чтобы получилась рамка требуемого размера для поля списка.
  4. Откройте окно свойств для размещенного в форме списка.
  5. Скорректируйте свойство Name (Имя) созданного объекта, присвоив ему имя IstCity.
  6. Чтобы связать созданное поле с полем таблицы customer, выберите свойство controisource (Источник данных). В поле ввода значения свойства воспользуйтесь кнопкой раскрытия списка и из списка всех полей открытой таблицы Customer выберите поле ccity.
  7. Скорректируйте свойство RowSourceType (Тип источника данных), которое указывает тип источника данных. Выберите из списка значение Value (Значение), поскольку список городов будет формироваться с помощью вводимых значений.
  8. Используя кнопку Text Box (Поле ввода) на панели инструментов Form Controls (Элементы управления формы), создайте под списком поле редактирования.
  9. Скорректируйте свойство Name (Имя) поля редактирования, присвоив ему имя txtAddText.
  10. Используя окно процедур свойства Keypress (Нажатие клавиши), введите в нем следующие команды:

LPARAMETERS nKeyCode, nShiftCtrlAlt

IF nKeyCode = 13 && 13 код клавиши <Enter>

IF 1EMPTY(THIS,Value)

* добавляем значение в список

THISFORM.lstCity.Addltem (THIS.Value}

ENDIF

* очищаем поле ввода

THIS.Value = ""

ENDIF

Эта процедура позволит пользователю ввести текст в поле ввода и нажатием клавиши <Enter> добавить значение в список, освободив окно для ввода следующей информации (рис. 15.26).

Рис. 15.26. Определение свойства KeyPress

Теперь при запуске формы на выполнение значения, введенные в поле ввода Поле формирования списка, при нажатии клавиши <Enter> переносятся в список городов (рис. 15.27).

Рис. 15.27. Формирование списка с помощью поля ввода в диалоговом режиме


ГЛАВА 15
Расширенные средства ввода данных

В главе 6 мы рассмотрели создание в конструкторе форм формы, предназначенной для ввода и просмотра данных. Но средства, предлагаемые системой Visual FoxPro, настолько разнообразны, что мы продолжим изучение возможностей ввода данных и в этой главе.

Отображение данных в форме в табличном виде

В Visual FoxPro для отображения в форме данных в табличном виде используется объект Grid (Таблица), который может помещаться в форму, как и любой другой объект интерфейса.

При использовании табличного режима информация лучше воспринимается, и, кроме того, проще вводить данные, т. к. пользователь видит сразу несколько записей и может вводить информацию по аналогии. Без табличного режима трудно обойтись, когда необходимо вводить и просматривать информацию из нескольких связанных таблиц, имеющих отношение "один-комногим".


  • Отображение данных в форме в табличном виде
  • Использование построителя
  • Свойства объекта Grid
  • Создание многотабличных форм для таблиц, имеющих отношение "один-ко-многим"
  • Создание объекта Gride помощью конструктора форм
  • Создание формы с вкладками
  • Набор форм
  • Таймер
  • Создание формы с использованием таймера
  • Добавление данных в список


Использование календаря в форме

Календарь также является одним из ActiveX-компонентов. Вы можете использовать его для ввода информации в поля дат.

Сначала разместим календарь в форме, чтобы посмотреть свойства, которыми обладает данный объект, и возможности их настройки. Затем рассмотрим пример программного использования календаря для ввода даты.

Настройка свойств календаря

Чтобы разместить в форме календарь, который на панели инструментов Form Controls (Элементы управления формы), содержащей ActiveX - компоненты, отображается в виде кнопки Calendar Control (Элемент управления календарь), нажмите данную кнопку, установите указатель мыши в форму и нарисуйте курсором рамку требуемого размера. Календарь размещен в форме.

С целью настройки свойств календаря выделите размещенный объект и нажмите правую кнопку мыши. В контекстном меню выберите команду Календарь Свойства. На экране откроется диалоговое окно Свойства: Календарь созданного объекта, содержащее набор параметров, позволяющих настроить календарь.

Диалоговое окно Свойства: Календарь содержит три вкладки: Общие (General), Шрифт (Font), Цвет (Color).

Вкладка Общие содержит поля, позволяющие настроить параметры, описанные в табл. 16.2.

Таблица 16.2. Назначение полей окна Свойства: Календарь

Поле | Назначение
Значение (Value) | Текущая дата
Первый день недели (First Day) | День, принимаемый за первый день недели
Формат дня {Day Length) | Формат отображения наименования дня недели; может принимать одно из трех значений: короткий, средний, длинный
Формат месяца (Month Length) | Формат отображения наименования месяца; может принимать одно из двух значений: короткий и длинный
Оформление (Grid Cell Effect) | Стиль отображения ячеек таблицы

Область Отображение (Show) вкладки Общие (General) содержит флажки, описанные в табл. 16.3.

Таблица 16.3. Назначение флажков области Отображение вкладки Общие

Флажок | Назначение
Заголовок месяца и года (Month/Year Title) | Указывает на необходимость отображения заголовка месяца и года
Выбор месяца и года (Month/Year Selectors) | Указывает на необходимость размещения в заголовке полей для выбора месяца и года
Дни недели (Days of Week) | Указывает на необходимость отображения в заголовке таблицы дней недели
Сетка по горизонтали (Horizontal Grid) | Указывает на необходимость отображения в таблице горизонтальных линий сетки
Сетка по вертикали (Vertical Grid) | Указывает на необходимость отображения в таблице вертикальных линий сетки

При изменении любого из параметров вкладки становится доступной кнопка Применить, при нажатии на которую сохраняются введенные изменения.

Вкладка Шрифт (Font) окна свойств календаря позволяет настроить шрифты объекта. Список Свойства (Properties) вкладки содержит объекты оформления календаря, для которых можно настроить шрифты:

  • DayFont — дни недели, расположенные в заголовке таблицы;
  • GridFont — числа, размещенные в таблице календаря;
  • Title Font — месяц и год в заголовке календаря.

Списки Шрифт (Font) и Размер (Size) позволяют задать наименование и размер шрифта, выбранного из списка Свойства (Properties) объекта, а флажки области Атрибуты (Effects) — стиль оформления.

Вкладка Цвет (Color) окна свойств календаря позволяет изменить цветовое оформление календаря. Список Свойства (Properties) содержит элементы календаря, для которых можно настроить цвета:

  • Backcoior — фон календаря;
  • DayFontcoior — дни недели, расположенные в заголовке таблицы;
  • GridFontCoior — числа, размещенные в таблице календаря;
  • GridLinesCoior — линии сетки таблицы календаря;
  • TitieFontCoior — месяц и год в заголовке календаря.

С помощью списка Набор цветов (Color Set) можно установить используемую цветовую схему, а списка Цветовая палитра (Color Palette) — цвет выбранного из списка Свойства (Properties) элемента.

При нажатии на кнопку Справка (Help) открывается окно справочной системы, содержащее список всех методов, свойств и событий ActiveXкомпонента.

Использование календаря для ввода информации в поля дат

Мы описали свойства календаря. Теперь посмотрим, как можно использовать данный ActiveX-компонент для ввода информации в поля таблицы, содержащие даты. В качестве примера создадим форму для ввода информации о сотрудниках фирмы. Исходная таблица Manager содержит поле ddatebirth с информацией о дате рождения сотрудника. Информацию в это поле будем вводить с помощью программно формируемого ActiveX-компонента календарь.

Чтобы создать форму, выполните следующие действия:

  1. В проекте sales откройте окно конструктора.
  2. В окружение формы добавьте таблицу, содержащую список сотрудников.
  3. Разместите в форме необходимые для ввода информации поля таблицы.
  4. Откройте окно свойств Properties (Свойства) поля, предназначенного для ввода даты рождения сотрудника.
  5. Используя свойство Name (Имя), присвойте объекту наименование txtbirthday.
  6. Используя свойство control sour се (Источник данных), задайте в качестве источника данных поля для ввода даты рождения поле ddatebirth таблицы.
  7. Рядом с полем, предназначенным для ввода даты рождения, расположите кнопку.
  8. Используя свойство caption (Надпись), присвойте кнопке название Календарь
  9. Откройте окно свойств Properties (Свойства) кнопки Календарь.
  10. В окне процедур свойства click (Нажатие) введите команды, которые программно формируют и задают свойства ActiveX-компонента календарь:

#DEFINE C_CALCAPTION_LOC "Календарь"

oCalForm = Create('form' )

oCalForm.NewObject("oleCalendar","_olecalendar", "_datetime")

WITH oCalForm.oleCalendar

.date_cclumn = "manager.ddatebirth"

.RefreshDisplay{)

.BackColor = THISFORM.BackColor

.Visible = .T.

ENDWITH

WITH OCalForm

.BorderStyle = 2

.MaxButton = .F.

.MinButton = .F.

.Height = oCalForm.oleCalendar.Height

.Width = oCalForm. oleCalendar.Width

.Caption = C_CALCAPTION_LOC

ENDWITH

oCalForm.Show(l)

THISFORM.Refresh

  11. Закройте окно процедур.

Создание формы завершено. Запустите ее на выполнение. Для ввода информации в поле дата рождения нажмите кнопку Календарь. На экране откроется календарь. Выберите необходимое число, месяц и год и закройте календарь. Указанная вами дата будет перенесена в поле день рождения.


Связь ActiveX-компонентов с базой данных

В предыдущем разделе мы рассмотрели размещение в форме ActiveX - компонентов. Но форма предназначена, в основном, для работы с базой данных. Возникает вопрос, а как же использовать ActiveX-компоненты для работы с таблицами базы данных? Связь ActiveX-компонентов с базой данных рассмотрим на примере RTF-объекта, который используется для ввода в Memo-поля таблицы форматированного текста. Чтобы создать форму с размещенным в ней RTF-объектом, будем использовать таблицу customer, содержащую Memo-поле mnotes с дополнительной информацией о клиенте:

  1. Добавьте на панель инструментов Form Controls (Элементы управления формы) кнопку Microsoft Rich TextBox Control (Элемент управления для редактирования текста в формате RTF). Для этого на вкладке Controls (Элементы управления) диалогового окна Options (Параметры) в списке Selected (Выбранные) установите флажок рядом со значением Microsoft Rich TextBox Control (Элемент управления для редактирования текста в формате RTF) и нажмите кнопку ОК.
  2. Для управления RTF-объектом нам понадобятся элементы управления, которые содержатся в библиотеке классов Samples (Образцы), содержащейся в поставке Visual FoxPro. Присоедините данную библиотеку. После этого при нажатии кнопки View Classes (Просмотр классов) появляется меню, содержащее команды для размещения на панели инструментов Form Controls (Элементы управления формы) ActiveX-компонентов и объектов из библиотеки Samples (Образцы).

Замечание

Присоединение внешних библиотек мы рассмотрели в начале этой главы.

  3. Откройте проект Sales.
  4. Откройте в конструкторе форму, позволяющую вводить информацию в таблицу Customer.
  5. Удалите из формы поле, которое использовалось вами ранее для ввода информации в поле таблицы mnotes.
  6. Чтобы отобразить на панели инструментов Form Controls (Элементы управления формы) кнопки для размещения в форме ActiveXкомпонентов, нажмите кнопку View Classes (Просмотр классов) и в появившемся меню выберите команду ActiveX Controls (Элементы управления ActiveX).
  7. Выберите на панели инструментов Form Controls (Элементы управления формы) кнопку Microsoft Rich TextBox Control (Элемент управления для редактирования текста в формате RTF) и разместите в форме поле, предназначенное для ввода примечания.
  8. Чтобы можно было управлять созданным полем, необходимо поместить в форму элементы управления RTF-объектом. Для этого на панели инструментов Form Controls (Элементы управления формы) нажмите кнопку View Classes (Просмотр классов) и в появившемся меню кнопки выберите команду Samples (Образцы).
  9. Нажмите на панели инструментов Form Controls (Элементы управления формы) кнопку rtfcontrols (Элементы управления RTF) из библиотеки samples (Образцы) и разместите в форме элементы управления. В результате форма примет вид.
  10. Чтобы связать размещенное в форме поле с полем таблицы Customer, откройте окно Properties (Свойства) и для свойства controisource (Источник данных) задайте поле mnotes.
  11. Для элементов управления RTF-объектом задайте методы, устанавливающие значения свойств объекта.


Размещение ActiveX-компонентов в форме

Рассмотрим пример создания формы, содержащей две вкладки, на которых разместим такие ActiveX-компоненты, как электронная таблица и документ Microsoft Word. Для создания формы выполните следующие действия:

  1. Откройте проект Sales.
  2. Выберите вкладку Documents (Документы), перейдите в группу Forms (Формы), а затем нажмите кнопку New (Новый).
  3. В открывшемся диалоговом окне New Form (Новая форма) выберите опцию New Form (Новая форма). Откроется окно конструктора форм.
  4. Нажмите кнопку View Classes (Просмотр классов) на панели инструментов Form Controls (Элементы управления формы), в результате чего на экране появится меню данной кнопки, содержащее команды выбора библиотеки из ранее размещенных на панели инструментов ActiveXкомпонентов и добавления новой библиотеки.
  5. Выберите значение Standard (Стандартная). Это необходимо, чтобы на панели инструментов Form Controls (Элементы управления формы) были размещены стандартные элементы управления.

Рис. 16.11. Форма с размещенным в ней объектом Page Frame

  6. Разместите в форме объект Page Frame (Вкладка), используя кнопку Page Frame (Вкладка) на панели инструментов Form Controls (Элементы управления формы).
  7. Введите название формы, воспользовавшись свойством caption (Надпись).
  8. Задайте для объекта Page Frame (Вкладка) две вкладки, используя свойство Pagecount (Количество вкладок).
  9. Используя свойство caption (Надпись) каждой вкладки, присвойте им названия (рис. 16.11).
  10. Форма готова. Теперь можно разместить в ней ActiveX-компоненты. Для этого необходимо отобразить на панели инструментов элементов управления формы ActiveX-компоненты: нажмите кнопку View Classes (Просмотр классов) на панели инструментов Form Controls (Элементы управления формы).
  11. Выберите из появившегося меню пункт ActiveX Controls (Элементы управления ActiveX).

Электронная таблица

На первую вкладку формы поместим электронную таблицу Excel (рис. 16.12), используя кнопку Лист Microsoft Excel на панели инструментов Form Controls (Элементы управления формы).

Рис. 16.12. Электронная таблица, размещенная на первой вкладке формы

Для редактирования электронной таблицы используется конструктор. Чтобы его запустить, необходимо выполнить следующие действия:

  1. Выделите в форме электронную таблицу.
  2. Нажмите правую кнопку мыши.
  3. В контекстном меню выберите команду Лист Object, а затем опцию Изменить или Открыть.

После выбора пункта меню Изменить интерфейс Visual FoxPro изменяется. Вы переходите в режим редактирования по месту электронной таблицы (рис. 16.13), при котором в окно Visual FoxPro добавляются панели инструментов Microsoft Excel. Можете приступить к редактированию таблицы с помощью средств электронной таблицы.

Рис. 16.13. Редактирование электронной таблицы в Visual FoxPro

В том случае, если вы выбираете пункт меню Открыть, запускается приложение Microsoft Excel и в нем открывается созданный вами лист электронной таблицы (рис. 16.14).

Рис. 16.14. Редактирование электронной таблицы в отдельном приложении

Документ Microsoft Word

На вторую вкладку формы поместим объект для работы с документом Microsoft Word (рис. 16.15), используя кнопку Документ Microsoft Word на панели инструментов Form Controls (Элементы управления формы).

Для редактирования объекта типа Документ Microsoft Word вы также можете использовать команды Изменить и Открыть контекстного меню. На рис. 16.16 приведен режим редактирования по месту.

Работа с ActiveX-компонентами после запуска формы на выполнение

При запуске формы, содержащей ActiveX-компоненты, они активизируются. Поведение ActiveX-компонентов определяется заданными для них алгоритмами управления. Например, для редактирования информации в электронной таблице достаточно дважды щелкнуть на объекте (рис. 16.17).

Рис. 16.15. Объект для работы с документом Microsoft Word

Рис. 16.16. Редактирование документа Microsoft Word

Рис. 16.17. Редактирование электронной таблицы


Отображение ActiveX-компонентов на панели инструментов Form Controls

Для отображения ActiveX-компонентов на панели инструментов Form Controls (Элементы управления формы) при создании форм выполните следующие действия:

  1. Нажмите кнопку View Classes (Просмотр классов) на панели инструментов Form Controls (Элементы управления формы), в результате чего на экране появится меню кнопки.
  2. Выберите команду ActiveX Controls (Элементы управления ActiveX) данного меню. На панели инструментов Form Controls (Элементы управления формы) будут размещены кнопки, содержащие значки выбранных вами ActiveX-компонентов в диалоговом окне Options (Параметры) (рис. 16.10). Теперь вы можете размещать данные объекты в форме обычным образом.

Рис. 16.10. Панель инструментов, содержащая ActiveX-компоненты


Использование ActiveX-компонентов в форме

Компоненты ActiveX представляют собой 32-разрядные объекты, содержащие код и данные. В отличие от библиотек классов Visual FoxPro, ActiveX-компоненты могут создаваться с помощью различных средств разработки, например, Visual C++ или Visual Basic. Вы можете использовать ActiveX-компоненты аналогично базовым компонентам Visual FoxPro. Основным

Преимуществом данных компонентов является их огромное количество, т. к. их разработкой занимаются многие фирмы, а также отдельные программисты. Часть этих компонентов является коммерческой продукцией, часть распространяется бесплатно. Множество компонентов включено в поставку Visual Studio и в приложение Microsoft Office. Для поиска необходимых вам компонентов вы можете использовать Интернет.

Для формирования списка используемых при разработке ActiveX-компонентов необходимо воспользоваться диалоговым окном Options (Параметры), выполнив следующие действия:

  1. Выберите в меню Tools (Сервис) команду Options (Параметры).
  2. В диалоговом окне Options (Параметры) выберите вкладку Controls (Элементы управления) (рис. 16.9).
  3. Установите опцию ActiveX controls (Элементы управления ActiveX). При этом в списке Selected (Выбранные) будет отображен список всех доступных на вашем компьютере ActiveX-компонентов.
  4. Установите флажки рядом с теми объектами списка Selected (Выбранные), которые хотите разместить на панели инструментов Form Controls (Элементы управления формы) и использовать для размещения в форме.
  5. Нажмите кнопку ОК для закрытия диалогового окна Options (Параметры).

Рис. 16.9. Вкладка Controls диалогового окна Options

Замечание

Кнопка Add (Добавить) вкладки Controls (Элементы управления) диалогового окна Options (Параметры) предназначена для добавления новых объектов в список Selected (Выбранные). При нажатии на данную кнопку открывается диалоговое окно Open (Открыть), используя которое можно выбрать файл с ActiveX-компонентами.


Class Browser

Еще одним способом размещения в форме объектов внешней библиотеки классов является применение окна Class Browser (Обзор классов) (рис. 16.7). Для его открытия выполните команду Class Browser (Обзор классов) из меню Tools (Сервис).

Рис. 16.7. Окно Class Browser

Для размещения в окне Class Browser (Обзор классов) библиотеки предназначены кнопки Open (Открыть) и View Additional File (Показать дополнительный файл) панели инструментов окна. При их нажатии открывается диалоговое окно Open (Открыть) (см. рис. 16.1), позволяющее открыть и разместить в Class Browser (Обзор классов) существующую библиотеку классов.

Чтобы добавить в форму элемент управления из окна Class Browser (Обзор классов), выполните следующие действия:

  1. Откройте в конструкторе форму, в которую хотите добавить объекты из библиотеки классов.
  2. В окне Class Browser (Обзор классов) откройте библиотеку, содержащую классы объектов, которые вы собираетесь разместить в форме.
  3. Выберите из списка требуемый класс. Значок Move (Переместить), расположенный в верхнем левом углу окна Class Browser (Обзор классов), изменит свой рисунок в соответствии со значком выбранного вами класса.
  4. Установите курсор на значок Move (Переместить).
  5. Нажмите кнопку мыши и, удерживая ее нажатой, перенесите объект в форму.
  6. Завершив перемещение, отпустите кнопку мыши. Результат перемещения класса кнопки в форму показан на рис. 16.8.

Рис. 16.8. Размещение в форме объектов из окна Class Browser


Галерея компонентов

Галерея компонентов Visual FoxPro содержит библиотеки классов Foundation Classes (рис. 16.5), которые размещены в одноименном каталоге. Для размещения объекта выбранного класса в форме вы можете выполнить любое из следующих действий.

  • Выделить класс в окне Галереи компонентов и перенести в требуемое место формы, используя механизм "перенести-и-оставить".
  • Щелкнуть правой кнопкой мыши на классе и из контекстного меню выбрать команду Add to Form (Добавить в форму) (рис. 16.6).
  • Выделить класс в окне Галереи компонентов, щелкнуть на значке Move (Перенести), расположенном в левом верхнем углу окна, и перенести выбранный класс в требуемое место формы.

Рис. 16.5. Каталог Foundation Classes

Рис. 16.6. Использование контекстного меню для размещения объекта выбранного класса в форме

Замечание

Для некоторых классов определены построители, автоматически запускаемые при размещении их в форме.


Панель инструментов Form Controls

Чтобы использовать панель инструментов Form Controls (Элементы управления формы), вы должны разместить на ней объекты внешней библиотеки. Для этого выполните следующие действия:

  1. Нажмите кнопку View Classes (Просмотр классов) на панели инструментов Form Controls (Элементы управления формы).
  2. Появившееся меню содержит команду Add (Добавить) и список библиотек классов. Для добавления внешней библиотеки нажмите кнопку Add (Добавить).
  3. На экране открывается диалоговое окно Open (Открыть) (рис. 16.1), позволяющее выбрать необходимую библиотеку классов.
  4. Используя раскрывающийся список Папка, найдите папку Classes (Классы), содержащую библиотеки классов Visual FoxPro.
  5. Выберите, например, библиотеку классов buttons (Кнопки), входящую в поставку Visual FoxPro, и нажмите кнопку Open (Открыть) диалогового окна.

Замечание

Файлы библиотек классов имеют расширение VCX.

Рис. 16.1. Диалоговое окно Open для присоединения внешней библиотеки

Замечание

После выбора библиотеки классов нажмите кнопку View Classes (Просмотр классов) на панели инструментов Form Controls (Элементы управления формы). Обратите внимание на то, что в ее меню добавился пункт с выбранной вами библиотекой классов (в данном примере Buttons (Кнопки)).

  6. Выберите пункт меню с наименованием добавленной вами библиотеки. На панели инструментов Form Controls (Элементы управления формы) будут размещены кнопки элементов управления выбранной библиотеки (рис. 16.2). Используя панель инструментов, вы теперь можете размещать эти объекты в форме так же, как и стандартные элементы управления.

Рис. 16.2. Меню кнопки View Classes и панель инструментов, содержащая элементы управления внешней библиотеки

Библиотека Buttons (Кнопки) содержит набор кнопок, назначение которых описано в табл. 16.1.

Таблица 16.1. Кнопки библиотеки Buttons

Наименование | Назначение
mailbtn | Размещает в форме кнопку, позволяющую передать данные таблицы по электронной почте
vcr | Размещает набор кнопок перемещения по записям таблицы
cmdok | Размещает в форме кнопку ОК
cmdHelp | Размещает в форме кнопку Help
cmdCancel | Размещает в форме кнопку Cancel

Рассмотрим размещение этих кнопок в форме:

  1. В проекте sales выберите любую из созданных ранее форм и откройте ее в конструкторе.
  2. Удалите в нижней части формы кнопки перемещения по записям, созданные вами ранее.
  3. Выберите объект vcr на панели инструментов Form Controls (Элементы управления формы) и поместите его на месте удаленных кнопок (рис. 16.3).

Рис. 16.3. Размещение объекта vcr в форме

  4. Запустите форму на выполнение. Убедитесь в том, что, используя размещенные для управления таблицей кнопки, можно перемещаться по записям таблицы (рис. 16.4).

Рис. 16.4. Форма с размещенным объектом vcr для перемещения по записям


Использование браузера объектов

В Visual FoxPro 7 появилось новое средство для просмотра списка классов, свойств, методов, событий и констант библиотек СОМ-объектов или ActiveX-компонентов — Object Browser (Браузер объектов). В окне браузера можно выполнять поиск заданного значения в пределах всей библиотеки.

Дня запуска браузера можно воспользоваться одним из следующих способов.

  • Выполнить команду Object Browser (Браузер объектов) из меню Tools (Сервис).
  • Нажать кнопку Object Browser на стандартной панели инструментов.

Для открытия библиотеки и просмотра ее структуры в окне браузера объектов предназначена кнопка Open Type Library (Открыть библиотеку) При нажатии этой кнопки открывается диалоговое окно Open (Открыть), которое содержит три вкладки следующего назначения:

  • Recent History (Хронология) — содержит список открытых ранее библиотек;
  • COM Libraries (СОМ-библиотеки) — содержит список СОМ-библиотек, имеющихся на компьютере;
  • Current Selection (Выбранные) — содержит список открытых в окне Object Browser (Браузер объектов) библиотек.

При нажатии кнопки Find (Найти) в верхней части окна Object Browser (Браузер объектов) появляется поле Look for (Значение для поиска) и кнопка Go (Начать поиск), предназначенные для текстового поиска.


ГЛАВА 16
Библиотеки классов и ActiveX-компоненты

В предыдущих главах мы рассмотрели использование стандартных элементов управления, которые представляют лишь небольшую часть доступных элементов управления. Множество разнообразных элементов управления находится в библиотеках классов, объединенных общим названием Visual FoxPro Foundation Classes, которые входят в комплект поставки Visual FoxPro. Кроме библиотеки Foundation Classes, вы можете также использовать библиотеки классов, которые разрабатывают сторонние фирмы.

В последнее время широкое распространение получают ActiveX-компоненты, которые представляют собой полнофункциональные элементы управления. Вы можете размещать их так же, как и обычные элементы управления, задавать свойства и обрабатывать события.

В процессе разработки приложения вы можете создавать свои библиотеки классов и размещать в форме собственные элементы управления.

Использование библиотек классов

Применение внешних библиотек классов не только облегчает разработку приложения, но и ускоряет процесс. Для размещения в форме объектов библиотек вы можете использовать панель инструментов Form Controls (Элементы управления формы), Галерею компонентов и Class Browser (Обзор классов).


  • Использование библиотек классов
  • Панель инструментов Form Controls
  • Галерея компонентов
  • Class Browser
  • Использование ActiveX-компонентов в форме
  • Отображение ActiveX-компонентов на панели инструментов Form Controls
  • Размещение ActiveX-компонентов в форме
  • Связь ActiveX-компонентов с базой данных
  • Использование календаря в форме
  • Использование браузера объектов


Использование в отчетах отношения "один-ко-многим"

Visual FoxPro поддерживает в отчетах отношение "один-ко-многим". Эта возможность упрощает отображение в отчете иерархических данных. Добавим в форму просмотра телефонов клиентов и их заказов, созданную в главе 75, средства для печати телефонов клиента, информация о котором отображена в форме. Для этого в форме расположим кнопку для печати телефонов и создадим соответствующий отчет.

  1. Откройте Проект Sales.
  2. Откройте для модификации форму Клиенты и продажи.
  3. Добавьте в форму кнопку с надписью Печать.
  4. Откройте окно свойств кнопки. Выберите метод click (Нажатие) и введите в окне процедуры следующий текст программы вызова отчета:

curiCdCustomer=icdCustomer

REPORT FORM RepCust TO PRINTER;

FOR PhonCust.icdCustomer=curiCdCustomer

SELECT PhonCust

SET SKIP TO

select Customer

ThisForm.Refresh()

  5. Откройте новое окно конструктора отчетов и добавьте в окно Data Environment (Среда окружения) таблицы customer и PhonCust.
  6. Главной таблицей отчета является Customer, а подчиненной по отношению к ней — таблица PhonCust. Установите связи между этими таблицами и определите свойство опетомапу (Один-ко-многим), выбрав значение True (Истина).
  7. В заголовке отчета расположите его название.
  8. Добавьте в отчет группировку по коду клиента.
  9. В полосе Group Header (Группа сверху) разместите поля из таблицы customer и надписи к ним, а также надписи к полям из таблицы phoncust.
  10. В полосе Detail (Детали) разместите поля из таблицы Phoncust.
  11. Сохраните отчет под именем RepCust.
  12. Запустите на выполнение форму Клиенты и продажи. Для печати телефонов клиента, на котором установлен курсор, нажмите кнопку Печать телефонов.


Создание этикетки с помощью конструктора

При создании сложных этикеток вы можете использовать конструктор этикеток. Для его открытия выполните одно из следующих действий.

  • В меню File (Файл) выберите команду New (Новый). В открывшемся диалоговом окне New (Новый) установите опцию Label (Этикетка) и нажмите кнопку New file (Новый файл).
  • Нажмите кнопку New (Новый), предварительно выбрав на вкладке Documents (Документы) в окне проекта группу Labels (Этикетки) и в открывшемся диалоговом окне New Label (Новая этикетка) выберите опцию New Label (Новая этикетка).

Открывается диалоговое окно New Label (Новая этикетка) (рис. 17.7), где в табличном виде находится список наиболее часто используемых этикеток. Столбцы таблицы имеют следующее назначение:

  • Avery No — наименование (номер) этикетки;
  • Height — высота этикетки;
  • Width — ширина этикетки;
  • Columns — число колонок.

Выберите из предложенных вариантов требуемый тип этикетки и нажмите кнопку ОК. На экране откроется окно конструктора этикеток.

Рис. 17.7. Диалоговое окно New Label

Окно конструктора этикеток выглядит примерно так же, как окно конструктора отчетов. Отличие заключается в том, что для этикетки заданы размеры отчета и количество колонок в отчете. В остальном создание этикетки аналогично созданию отчета.

Рассмотрим создание этикетки на примере подготовки адресов для рассылки корреспонденции клиентам, используя информацию из таблицы customer. Этот пример аналогичен примеру создания многоколоночного отчета, описание которого дано в главе 8.

Основное преимущество этикеток, по сравнению с отчетами, состоит в автоматическом выборе размеров этикетки и расстояния между ними. Нет необходимости самостоятельно рассчитывать размер получаемого отчета и заботиться о том, чтобы он поместился на бумаге. При печати на обычной бумаге это преимущество не вполне очевидно, но как только вы начнете использовать для этих целей специальные листы с наклейками, вы ощутите удобство выбора типа наклейки.

Для создания этикетки выполните следующие действия:

  1. В меню File (Файл) выберите команду New (Новый). В открывшемся диалоговом окне New (Новый) установите опцию Label (Этикетка) и нажмите кнопку New file (Новый файл).
  2. В открывшемся диалоговом окне New Label (Новая этикетка), содержащем список типов наиболее часто используемых этикеток, выберите этикетку такого типа, которая удовлетворяет вашим требованиям.
  3. Откройте окно Data Environment (Среда окружения) и добавьте в него таблицу Customer.
  4. Воспользовавшись командой Quick Report (Стандартный отчет) из меню Report (Отчет), перенесите в этикетку поля, содержащие почтовый индекс, страну проживания клиента, его адрес, фамилию, имя и отчество. При этом выберите размещение полей по строкам.
  5. В окне конструктора разместите поля так, как это принято для почтовых этикеток в конкретной стране. В рассматриваемом примере будем считать, что почтовые этикетки изготавливаются для рассылки в пределах СНГ, поэтому расположим их так.
  6. Просмотрите созданные этикетки в окне просмотра. В результате вы увидите отчет.

Замечание

В том случае, если вы хотите изменить количество этикеток, печатаемых на одной странице, или порядок их расположения, выберите в меню File (Файл) команду Page Setup (Разметка страницы). Затем в открывшемся диалоговом окне Page Setup (Разметка страницы) установите новые значения параметров, как при работе с обычным отчетом.

  7. Сохраните созданную этикетку. Для этого в меню File (Файл) выберите команду Save as (Сохранить как).
  8. Если работа над этикетками закончена, напечатайте их, воспользовавшись командой Print (Печать) из меню File (Файл).


Использование мастера при создании этикеток

Сначала рассмотрим создание этикетки с помощью мастера. Выполните следующие действия:

  1. Откройте созданный проект.
  2. Выберите вкладку Documents (Документы).
  3. Установите курсор в группу Labels (Этикетки) и нажмите кнопку New (Новый) окна конструктора проекта.
  4. Открывается диалоговое окно New Label (Новая этикетка). Выберите в нем опцию Label Wizard (Мастер этикетки).

Совет

Для запуска мастера создания этикеток вы можете также в меню Tools (Сервис) выбрать команду Wizards (Мастера), а затем в открывшемся меню — опцию Label (Этикетка).

  5. Запускается мастер по созданию почтовой этикетки. В его первом диалоговом окне выберите источник данных (рис. 17.1), т. е. укажите таблицу, из которой будут выбираться данные, и нажмите кнопку Next (Далее).
  6. На втором шаге из предложенного списка наиболее часто используемых размеров этикеток выберите подходящий (рис. 17.2). Столбец Avery содержит наименования этикеток. В столбце Dimensions (Размеры) отображается размер этикетки, а в столбце Columns (Колонки) — количество колонок этикеток, помещаемых на странице. По умолчанию размер этикеток указывается в дюймах, а при установке опции Metric (Размерность) — в миллиметрах.

В этот список можно добавить новые размеры этикеток. Для этого нажмите кнопку New Label (Новая этикетка). Открывается диалоговое окно Custom Labels (Пользовательские этикетки) (рис. 17.3) со списком пользовательских этикеток. В этом окне можно ввести новые размеры этикеток или изменить существующие.

Рис. 17.1. Выбор источника данных для создания этикеток

Рис. 17.2. Выбор типа этикетки

Для создания новой или редактирования существующей этикетки необходимо нажать кнопку New (Новый) или Edit (Редактировать) соответственно. При этом открывается диалоговое окно New Label Definition (Определение размеров новой этикетки) (рис. 17.4), позволяющее ввести размеры этикетки или отредактировать установленные. Введите на схеме размеры этикетки, введите в поле Label Name (Наименование этикетки) наименование этикетки и нажмите кнопку Add (Добавить) или Update (Обновить) для добавления или изменения этикетки соответственно.

Рис. 17.3. Диалоговое окно Custom Labels со списком пользовательских размеров

Рис. 17.4. Диалоговое окно New Label Definition для определения нового размера этикетки

  7. На третьем шаге создания этикетки необходимо расположить поля, знаки пунктуации (точка, запятая, дефис, пробел, двоеточие), сформировав текст этикетки. Этикетка заполняется последовательно, поэтому перед переносом в нее объектов тщательно спланируйте их размещение в этикетке. Для формирования адреса выполните следующие действия:
  • перенесите из списка Available fields (Имеющиеся поля) в список Selected fields (Выбранные поля) поле, содержащее почтовый индекс. Для этого дважды щелкните на поле или нажмите кнопку со стрелкой;
  • чтобы разместить запятую, нажмите кнопку с изображением запятой;
  • для размещения пробела перед названием страны нажмите кнопку Space (Пробел);
  • перенесите поле, содержащее название страны;
  • если необходимо расположить данные с новой строки, нажмите кнопку с изображением изогнутой стрелки;
  • аналогично расположите остальные поля этикетки.

Разместив все необходимые поля (рис. 17.5), нажмите кнопку Next (Далее) для перехода к следующему шагу.

Рис. 17.5. Расположение объектов в этикетке

  8. Теперь следует задать порядок сортировки данных (рис. 17.6). Перенесите из списка Available fields or index tag (Имеющиеся поля и индексы) в список Selected fields (Выбранные поля) поля или индексы, по которым хотите упорядочить этикетки. Нажмите кнопку Next (Далее).
  9. В последнем окне мастера укажите вариант завершающих действий (сохранение этикетки, сохранение и открытие ее в конструкторе этикеток или сохранение и печать), выбрав соответствующую опцию.

При выборе второй опции созданная этикетка сохраняется на диске и открывается в окне конструктора этикеток .

Совет

В том случае, если при создании этикеток вы хотите использовать вычисляемые поля для объединения полей исходной таблицы, отображения инициалов вместо полного имени и отчества и т. п., предварительно создайте представление данных, содержащее всю необходимую информацию в том виде, в каком нужно, и используйте его при создании этикеток с помощью мастера.

Рис. 17.6. Определение порядка сортировки


Этикетки

На практике часто возникает необходимость в создании отчетов, предназначенных для рассылки информации рекламного характера потенциальным клиентам или рассылки сведений о результатах деятельности предприятия за отчетный период. В Visual FoxPro для этих целей имеется специальный тип отчетов и соответствующий мастер для создания почтовых этикеток. В данном разделе мы рассмотрим создание этикеток, как с помощью мастера, так и в окне конструктора этикеток.


ГЛАВА 17
Расширенные средства создания отчетов

Вопросы создания отчетов нами уже обсуждались. В этой главе рассмотрим использование при создании отчетов представлений данных, создание отчетов для таблиц, имеющих отношение "один-ко-многим", а также конструирование этикеток.

Использование в отчетах представлений данных

В главе 14 мы познакомились с представлениями данных, содержащими результат выборки из базовых таблиц базы данных. Их удобно использовать при создании отчетов, т. к. задавая параметры для представлений данных, можно печатать отчеты, содержащие информацию за определенный интервал времени, о конкретном клиенте и т. п.

Рассмотрим создание отчета, данные для которого находятся в представлении данных, содержащем итоговые суммы продаж по клиентам.

  1. Откройте проект Sales.
  2. Для создания нового отчета откройте окно конструктора отчетов.
  3. Откройте окно Data Environment (Среда окружения), выполнив команду Environment (Окружение) из меню View (Вид) или выбрав команду Data Environment (Среда окружения) всплывающего меню.
  4. Для добавления представления данных в среду окружения выполните команду Add (Добавить) из меню Data Environment (Среда окружения).
  5. В открывшемся диалоговом окне Add Table or View (Добавить таблицу или представление данных) установите опцию View (Представление данных) и выберите из списка представление данных sumcust.
  6. Закройте окно Data Environment (Среда окружения).
  7. Создайте стандартный отчет, используя команду Quick Report (Стандартный отчет) из меню Report (Отчет). При создании отчета воспользуйтесь размещением по строкам и выберите все поля представления данных.
  8. Скорректируйте заголовки полей в полосе Page Header (Верхний колонтитул) отчета.
  9. Добавьте в отчет группировку по коду клиента, воспользовавшись командой Data Grouping (Группировка данных) из меню Report (Отчет).
  10. В полосе Group Footer (Группа снизу) создайте итоговое поле, которое будет суммировать продажи по каждому клиенту.
  11. Добавьте в отчет полосы для размещения заголовка и итоговой части отчета, выполнив команду Title/Summary (Титул/Итоги) из меню Report (Отчет).
  12. В заголовке отчета введите текст Стоимость продаж по клиентам.


  • Использование в отчетах представлений данных
  • Этикетки
  • Использование мастера при создании этикеток
  • Создание этикетки с помощью конструктора
  • Использование в отчетах отношения "один-ко-многим"


Сохранение результатов запроса в формате HTML

Visual FoxPro позволяет сохранять результат выполнения запроса, как и любую другую таблицу, в формате HTML. Для этого предназначена команда Save As HTML (Сохранить как HTML файл) из меню File (Файл), открывающая соответствующее диалоговое окно (рис. 18.5), содержащее три переключателя, приведенных в табл. 18.2.

Рис. 18.5. Диалоговое окно Save As HTML

Таблица 18.2. Переключатели диалогового окна Save As HTML

Переключатели | Назначение
Save file for later use (Сохранить файл) | Сохраняет результат запроса на диске в формате файла HTML
Save and edit file (Сохранить файл и открыть для редактирования) | Сохраняет результат запроса на диске в формате файла HTML и открывает его для редактирования (рис. 18.5)
Save file and view in web browser (Сохранить файл и открыть для просмотра в Web-браузере) | Сохраняет результат запроса на диске в формате файла HTML и открывает его для просмотра в окне Web-браузера (рис. 18. 6)

Поле, расположенное в нижней части диалогового окна Save As HTML (Сохранить как HTML файл), позволяет указать расположение сохраняемого файла. Если хотите изменить указанный по умолчанию адрес, воспользуйтесь кнопкой открытия диалогового окна Save As (Сохранить как), расположенной справа от поля, укажите имя создаваемого файла с расширением НТМ, а также папку, в которой файл будет сохранен.

Рис. 18.6. Просмотр HTML-файла в окне Web-браузера


Создание этикеток с использованием результатов запроса

Опция Label (Этикетки) диалогового окна Query Destination (Результаты запроса) позволяет использовать результаты запроса для создания этикеток. При установке этой опции окно имеет вид, представленный на рис. 18.4. Параметры окна аналогичны опциям вывода запроса в отчет.

Рис. 18.4. Диалоговое окно Query Destination с выбранной опцией Label


Использование результатов запроса в отчете

Для использования результатов запроса в отчете в диалоговом окне Query Destination (Результаты запроса) выберите опцию Report (Отчет).

Рис. 18.3. Диалоговое окно Query Destination с выбранной опцией Report

Окно примет вид, представленный на рис. 18.3. Оно содержит две кнопки следующего назначения:

  • Open Report (Открыть отчет) — открывает диалоговое окно, позволяющее выбрать отчет, в который необходимо включить результаты запроса;
  • Builder Lock (Закрепитель построителя) — запускает мастер отчетов, с помощью которого вы сможете достаточно быстро создать новый отчет.

Замечание

Поле, расположенное справа от кнопки Open Report (Открыть отчет), предназначено для ввода имени нового отчета.

Кроме того, в диалоговом окне Query Destination (Результаты запроса) расположены три флажка. При установке флажка Page preview (Просмотр страницы) отчет выводится в окно просмотра. Флажок Console on (Включить консоль) дублирует вывод отчета в текущем окне, а флажок Eject page before report (Пропускать страницу перед отчетом) указывает на необходимость печати отчета с начала страницы.

При установке флажка Page preview (Просмотр страницы) вывод отчета на принтер или в текстовый файл запрещен. Для печати отчета или записи его в файл необходимо снова запустить запрос на выполнение.

Переключатели области Secondary output (Вторичный вывод) указывают, куда направлять дополнительный вывод результатов запроса:

  • None — не осуществлят;
  • То printer — на принтер;
  • То text file — в текстовый файл.

При установке флажка Suppress column headings (He отображать заголовки столбцов) области Options (Параметры) при формировании отчета не указываются заголовки столбцов. Флажок Summary information only (Только итоговая информация) предоставляет возможность не выводить промежуточные строки, а печатать только заголовки, группы, страницы и итоговую часть отчета.


Представление результатов запроса на экране

На рис. 18.2 показано диалоговое окно Query Destination (Результаты запроса), в котором выбрана опция Screen (Экран).

Рис. 18.2. Диалоговое окно Query Destination с выбранной опцией Screen

Область Secondary output (Вторичный вывод) содержит переключатели, указывающие, куда дополнительно направляются результаты запроса.

  • None (Нет) — вывода результатов запроса не происходит.
  • То printer (На принтер) — результаты запроса выводятся на принтер.
  • То text file (В текстовый файл) — вывод результатов осуществляется в текстовый файл.

В области Options (Параметры) диалогового окна расположены два флажка. При установке флажка Suppress column headings (He отображать заголовка столбцов) в отображаемом запросе не указываются заголовки столбцов. Установленный флажок Pause between screens (Пауза между экранами) указывает на необходимость делать паузу при заполнении экрана.

Замечание

Если при выдаче информации на экран делаются паузы, то при повторном выводе заголовки столбцов будут повторяться каждый раз при заполнении нового экрана.


Использование результатов запроса для создания диаграммы

При выборе в диалоговом окне Query Destination (Результаты запроса) кнопки Graph (Диаграмма) строится диаграмма по результатам запроса. Рассмотрим использование данной опции для запроса из таблиц orcisaiem и ordsaied, созданного в главе 9 и содержащего итоговую сумму по заказам.

  1. Откройте созданный ранее запрос.
  2. В меню Query (Запрос) выберите команду Query Destination (Результаты запроса).
  3. В диалоговом окне Query Destination (Результаты запроса) выберите опцию Graph (Диаграмма) и нажмите кнопку ОК. Диалоговое окно закроется.
  4. Запустите на выполнение запрос, нажав кнопку Run (Запустить) на основной панели инструментов.
  5. Запускается мастер построения диаграмм. В открывшемся диалоговом окне Graph Wizard (Мастер диаграммы) укажите заказ в качестве поля, значения которого будут использоваться в категориях диаграммы. Для заполнения рядов данных выберите поле стоимость.

Для переноса данных используйте мышь. Завершив установку, нажмите кнопку Next (Далее) для перехода к следующему шагу.

  6. На следующем шаге укажите стиль создаваемой диаграммы, нажав на одну из двенадцати кнопок, предлагаемых Visual FoxPro. Затем нажмите кнопку Next (Далее) для перехода к следующему шагу.
  7. На последнем шаге работы мастера задайте заголовок, который будет располагаться над диаграммой. В этом диалоговом окне можно нажать кнопку Preview (Просмотр) и просмотреть созданную диаграмму.
  8. Нажмите кнопку Finish (Готово). В открывшемся диалоговом окне введите имя таблицы, в которой собираетесь сохранить данные для построения диаграммы. На экране открывается созданная диаграмма


Сохранение результатов запроса в таблице

Для сохранения результатов запроса в таблице предназначена кнопка Table (Таблица) диалогового окна Query Destination (Результаты запроса). При ее нажатии становится доступным поле Table name (Имя таблицы), используемое для ввода имени таблицы, в которой будут сохранены результаты. Для указания папки, в которой требуется сохранить таблицу, воспользуйтесь расположенной справа от поля кнопкой, открывающей диалоговое окно Open (Открыть).

Таблицу с результатами запроса можно в любой момент открыть, просмотреть, ввести в нее изменения.


Сохранение результатов запроса в курсоре

В том случае, если вы хотите ссылаться на результаты запроса из программы, вам необходимо сохранить их в курсоре. Курсор является временной таблицей, доступной только для чтения и удаляемой из памяти при закрытии курсора.

Для направления результатов запроса в курсор в диалоговом окне Query Destination (Результаты запроса) установите опцию Cursor (Курсор), в поле Cursor name (Имя курсора) введите имя курсора и нажмите кнопку ОК. Введенное имя будет служить псевдонимом для ссылки на результаты запроса.

Совет

Для повышения быстродействия и избежания проблем, связанных с именами файлов при работе в сети, небольшие курсоры желательно держать в памяти или на локальном диске. При увеличении размера курсоров и отсутствии достаточного количества места Visual FoxPro записывает их на физический носитель.


Просмотр результатов запроса в режиме Browse

По умолчанию Visual FoxPro помещает результаты запроса во временную таблицу и выводит ее на экран в режиме Browse (Обзор). После закрытия окна временная таблица удаляется из памяти. Этот режим удобен в том случае, если вы хотите просто просмотреть результаты запроса.


Оператор UNION

Для объединения результатов запросов используется оператор UNION. Результатом объединения является результирующее множество, состоящее из всех строк, входящих в какое-либо одно или в оба результирующих множества объединяемых запросов.

В качестве примера выберем список покупателей, которые живут в Новгороде или покупают товар с кодом 2103:

SELECT icdCustomer ;

FROM Customer ;

WHERE cCity = 'Новгород ' ;

UNION ;

SELECT icdCustomer;

FROM Ordsalem, Ordsaled ;

WHERE Ordsalem.icdOrder=Ordsaled.icdOrder ;

AND icdGoods = 2103

Из результата выборки, использующей оператор UNION, исключаются повторяющиеся строки. Для отображения их в результирующей выборке используйте опцию ALL.

Предупреждение

Фраза ORDER BY в запросе с использованием оператора UNION может входить только в последний оператор SELECT.


Оператор EXISTS

Оператор EXISTS принимает значение True (Истина), если результат выполнения подзапроса является непустым множеством. Если порожденное подзапросом множество пусто, то EXISTS принимает значение False (Ложь). Оператор NOT EXISTS работает в точности наоборот. Он истинен, если результат подзапроса пуст, и ложен в противном случае.

Замечание

Операторы EXISTS и NOT EXISTS всегда помещаются перед подзапросом.

В качестве примера выберем наименования товаров, которые заказали покупатели из Новгорода:

SELECT cNmGoods ;

FROM Goods ;

WHERE EXISTS ;

(SELECT * ;

FROM Customer, Ordsalem, Ordsaled ;

WHERE Ordsalem.icdOrder=Ordsaled.icdOrder ;

AND Ordsalem.iCdCustomer = Customer.iCdCustomer ;

AND Ordsaled.iCdGoods = Goods.iCdGoods ;

AND Customer.cCity = 'Новгород')


Фраза HAVING

Для применения условий к группам, созданным фразой GROUP BY, используется фраза HAVING, которая играет такую же роль для групп, что и фраза WHERE для записей.

Замечание

Разница между фразами WHERE и HAVING состоит в том, что WHERE применяется к строкам, в то время как HAVING применяется к группам.

Запрос может содержать и фразу WHERE, и фразу HAVING. В этом случае первой выполняется фраза WHERE, поскольку она выполняется до разбиения на группы.

Рассмотрим пример выборки городов, в которых имеется более десяти покупателей:

SELECT cCountry ;

FROM Customer ;

GROUP BY cCountry;

HAVING COUNT(*)>10

Предупреждение

Вы не можете использовать фразу HAVING отдельно от фразы GROUP BY.


Подзапросы

При определении условия выборки можно применять вложенные запросы, которые называются подзапросами. Например, определим список наиболее дорогих товаров, цены которых ниже максимальной цены не более, чем на 10%.

SELECT icdGoods FROM Goods ;

WHERE nUnitPrice >;

(SELECT 0.9 * MAX (nUnitPrice) ;

FROM Goods)


Использование переменных при формировании запросов

При формировании выборки в программах вы можете использовать переменные для определения условий выборки и задания имени таблицы, в которую записываются результаты выборки.

Рассмотрим пример создания запроса, в котором определяется итоговая сумма по каждому заказу. За основу возьмем аналогичный запрос, созданный ранее в интерактивном режиме. В него добавим возможность задания интервала, за который будет осуществляться выборка, а также имени результирующей таблицы.

  1. Откройте новое окно редактирования программы. Для этого в меню File (Файл) выберите команду New (Новый).
  2. В открывшемся диалоговом окне выберите опцию Program (Программа) и нажмите кнопку New file (Новый файл).
  3. Откройте окно созданного ранее запроса, содержащего выборку из таблиц Ordsalem и Ordsaled с итоговой суммой по каждому заказу.
  4. Нажмите кнопку Show the SQL Window (Показать SQL) на панели инструментов Query Designer (Конструктор запроса) или в меню Query (Запрос) выберите команду View SQL (Показать SQL).
  5. В окне просмотра выделите команду SELECT и сохраните ее во временном буфере Windows.
  6. Скопируйте содержимое буфера Windows в окно редактирования программы.
  7. Укажите перед командой SELECT начальную и конечную даты, определяющие промежуток времени, а также значение переменной, которая задает имя результирующей таблицы:

dBeg=CTOD("01.11.01") && начальная дата

dEnd=CTOD("30.11.01") && конечная дата

c0utput="0rds" && имя результирующей таблицы

  8. Добавьте в конструкцию SELECT условие задания периода времени, используя переменные dBeg и dEnd:

SELECT Ordsalem.cnDoc AS заказ,;

SUM(Ordsaled.nQuant*Ordsaled.nUnitPrice) AS стоимость;

FROM sales!ordsalem INNER JOIN saleslordsaled ;

ON Ordsalem.icdorder = Ordsaled.icdorder;

WHERE Ordsalem.dDoc BETWEEN dBeg AND dEnd;

GROUP BY Ordsalem.icdorder;

INTO TABLE ScOutput

  9. Сохраните программу под именем Ords.prg и проверьте синтаксис.
  10. Выполните программу, в результате чего в таблицу ords будет записана итоговая сумма по заказам. В дальнейшем вы можете использовать эту таблицу для просмотра, печати отчета или построения графика.


Применение в программах команды Select

При создании приложений для выборки данных широко применяется команда SELECT. В отличие от интерактивного режима, при программировании вы можете использовать переменные и пользовательские функции. Кроме того, в программах вы можете использовать более сложные выборки, включая вложенные запросы, кванторы существования и объединение запросов.


ГЛАВА 18
Расширенные средства выборки данных

В главе 9 нами были рассмотрены основные вопросы создания запросов. Результаты запроса отображались в табличном виде на экране. В этой главе рассмотрим, как использовать результаты выполнения запроса для построения диаграмм, создания отчетов, этикеток, а также в программах.

Вывод результатов запроса

По умолчанию Visual FoxPro направляет результат выборки в стандартную результирующую таблицу, которая отображается на экране в режиме Browse (Обзор). Однако вы можете направить результат выборки во вновь создаваемую таблицу, в отчет или в программу Microsoft Graph.

Для изменения направления вывода используется диалоговое окно Query Destination (Результат запроса) (рис. 18.1). Чтобы его открыть, выполните одно из следующих действий.

  • Нажмите кнопку Query Destination (Результат запроса) на панели инструментов Query Designer (Конструктор запроса).
  • В меню Query (Запрос) выберите команду Query Destination (Результаты запроса).

Диалоговое окно Query Destination (Результаты запроса) содержит кнопки, описанные в табл. 18.1.

Таблица 18.1. Назначение кнопок диалогового окна Query Destination

Кнопка | Назначение
Browse (Обзор) | Сохраняет результат выборки в стандартной результирующей таблице и отображает результаты запроса в режиме Browse (Обзор) на экране
Cursor (Курсор) | Обеспечивает временное хранение результатов запроса в виде, доступном только для чтения
Graph (Диаграмма) | Запускает Microsoft Graph (приложение OLE) для создания графиков и диаграмм
Screen (Экран) | Отображает результаты выборки в активном окне
Table (Таблица) | Сохраняет результаты запроса в таблице
Report (Отчет) | Отображает результат выборки в виде отчета
Label (Этикетка) | Отображает результат выборки в виде этикетки

Рис. 18.1. Диалоговое окно Query Destination

При нажатии любой из кнопок открывается диалоговое окно, в котором определяются дополнительные параметры вывода данных запроса.


  • Вывод результатов запроса
  • Просмотр результатов запроса в режиме Browse
  • Сохранение результатов запроса в курсоре
  • Сохранение результатов запроса в таблице
  • Использование результатов запроса для создания диаграммы
  • Представление результатов запроса на экране
  • Использование результатов запроса в отчете
  • Создание этикеток с использованием результатов запроса
  • Сохранение результатов запроса в формате HTML
  • Применение в программах команды Select
  • Использование переменных при формировании запросов
  • Подзапросы
  • Фраза HAVING
  • Оператор EXISTS
  • Оператор UNION


Создание подклассов

При разработке приложений широко применяются подклассы, которые позволяют использовать уже имеющиеся пользовательские классы в качестве базы для создания следующих классов. Поскольку подкласс создается на базе ранее созданного класса, наследуются все свойства и методы, то достаточно добавить в подкласс новые свойства и методы или изменить некоторые свойства и методы базового класса.

Рассмотрим использование подклассов на примере создания нескольких классов кнопок. Сначала создадим подкласс пользовательской кнопки, для которой определим ее внешний вид. Далее на базе этого класса создадим текстовую кнопку перемещения на следующую запись. При определении этого класса определим надпись кнопки и выполняемое при нажатии на кнопку действие. Если понадобится кнопка для перемещения на следующую запись, содержащая вместо надписи графическое изображение, нет необходимости определять заново выполняемое при нажатии на нее действие. Достаточно использовать в качестве базового класса кнопку с надписью и определить для нее графическое изображение. Если затем понадобится изменить свойства отображения кнопок, достаточно будет скорректировать данные свойства в первом из созданных подклассов кнопки, и изменения будут отслеживаться во всей иерархии подклассов, созданных на базе этого класса.

Создание текстовой кнопки выхода из формы

Рассмотрим создание класса кнопки выхода из формы. Будем использовать возможности, предоставляемые системой при создании подклассов.

  1. Откройте проект Sales.
  2. В окне проекта выберите вкладку Classes (Классы) и нажмите кнопку New (Новый).
  3. В открывшемся диалоговом окне New Class (Новый класс) в поле ввода Class Name (Имя класса) введите имя создаваемого класса bcCmdButton.

    Из списка Based On (Базовый класс) выберите базовый класс commandButton (Кнопка управления), а затем в поле ввода Store In (Сохранить в) введите имя библиотеки классов Buttons (Кнопки), в которой будет храниться создаваемый класс. Библиотека BASE.vex будет содержать пользовательские классы, созданные на основе базовых классов Visual FoxPro, которые содержат свойства, характерные для данного приложения. На начальной стадии разработки вы можете оставить свойства базового класса без изменения. Такой подход позволяет вам достаточно просто изменить свойства объекта, если в этом возникнет необходимость.

  4. Завершив ввод в поля, нажмите кнопку ОК.
  5. На экране появляется окно конструктора классов, содержащее кнопку. Так как кнопка не является контейнером, вы не можете добавить в нее другие объекты. Ваши возможности ограничены изменением свойств и методов объекта. Для создаваемого класса кнопки измените наименование шрифта, а затем установите свойство Caption (Надпись), введя в поле ввода значения свойства текст Кнопка (рис. 19.12).
  6. Создание класса кнопки на этом завершено. Сохраните созданный класс и закройте окно конструктора классов.

Рис. 19.12. Создание класса кнопки

  7. Теперь приступим к созданию кнопки для выхода из формы. Находясь на вкладке Classes (Классы), нажмите кнопку New (Новый).
  8. В открывшемся диалоговом окне New Class (Новый класс) введите в поле ввода Class Name (Имя класса) имя создаваемого класса bcCmdTxtExit. В поле ввода Store In (Сохранить в) введите имя библиотеки классов

Buttons (Классы), в которой будет храниться создаваемый класс. В данном случае для создания нового класса мы используем не базовый класс Visual FoxPro, а созданный на предыдущем шаге пользовательский класс. Поэтому нам необходимо указать не только имя класса, на основе которого будет создаваться новый класс, но и библиотеку, в которой он хранится. Для выбора библиотеки классов, а также класса из этой библиотеки, нажмите кнопку, расположенную правее списка Based On (Базовый класс). Откроется диалоговое окно Open (Открыть) (рис. 19.13).

Рис. 19.13. Выбор класса из библиотеки классов

  9. Левая часть окна содержит стандартные средства выбора файла. В правой части диалогового окна находится список Class Name (Имя класса), который содержит список классов выбранной библиотеки. Выберите класс bcCmdButton, нажмите кнопку Open (Открыть), и вы вернетесь в диалоговое окно New Class (Новый класс), которое теперь будет содержать заполненные поля Based On (Базовый класс) и From (Откуда) (рис. 19.14). Нажмите кнопку ОК. В результате откроется окно конструктора классов, содержащее кнопку, которая наследует свойства класса (надпись на кнопке и шрифт), на основе которого мы будем создавать новый класс.

Рис. 19.14. Диалоговое окно New Class после выбора пользовательского класса

  10. Для создаваемой кнопки измените надпись, введя в свойстве caption (Надпись) текст Выход.
  11. Используя свойство click (Нажатие), определите действия, выполняемые при нажатии на эту кнопку (рис. 19.15).
  12. Сохраните класс и закройте окно конструктора классов.

Рис. 19.15. Определение свойств и методов для кнопки выхода из формы

Создание кнопки, содержащей изображение, для выхода из формы

На многих кнопках, используемых в Windows, имеется графическое изображение, которое занимает меньше места, чем текст, и является более информативным. В качестве примера использования подклассов создадим кнопку, предназначенную для выхода из формы (она будет содержать изображение вместо текста). Для этого выполните следующие действия:

  1. На вкладке Classes (Классы) нажмите кнопку New (Новый).
  2. В открывшемся диалоговом окне New Class (Новый класс) введите в поле ввода Class Name (Имя класса) имя создаваемого класса bcCmdPicExit.

    В поле ввода Store In (Сохранить в) введите имя библиотеки классов Buttons, в которой будет храниться создаваемый класс. В качестве базового класса для создания нового класса выберите созданный на предыдущем шаге класс bcCmdTxtExit из библиотеки классов Buttons (Кнопки).

  3. Для создаваемого класса наследуется метод, выполняемый при нажатии на кнопку мыши, поэтому нам необходимо только изменить внешний вид кнопки. Удалите надпись кнопки.
  4. В поле ввода свойства Picture (Изображение) укажите имя файла с изображением, которое будет отображаться на кнопке (рис. 19.16).

Рис. 19.16. Определение кнопки с изображением

Совет

Аналогичным образом вы можете создать классы для кнопок перемещения по записям и разместите их в библиотеке Buttons (Кнопки).


Библиотека классов

Библиотеки классов используются для хранения созданных в Visual FoxPro пользовательских классов. Для создания библиотеки предназначено диалоговое окно New Class (Новый класс), рассмотренное нами в предыдущем разделе. При разработке приложения удобно иметь несколько библиотек классов, в которых размещаются отдельные группы классов. Например, в одной библиотеке можно располагать все классы кнопок, используемых в приложении, а в другой — классы форм.

В случае необходимости вы можете копировать класс из одной библиотеки в другую. Для этого перейдите на вкладку Classes (Классы) окна проекта и раскройте обе библиотеки. Затем выберите копируемый класс, нажмите кнопку мыши и, удерживая ее нажатой, перенесите класс в новую библиотеку. В заключение отпустите кнопку мыши.

Для удаления класса из библиотеки выберите класс и нажмите кнопку Remove (Удалить) в окне проекта.

При необходимости вы можете переименовать выбранный класс, используя команду Rename (Переименовать) контекстного меню окна проекта.

Замечание

Для удаления класса из библиотеки классов вы можете воспользоваться командой REMOVE CLASS, а для изменения имени класса — командой RENAME CLASS.


Создание класса типа "форма"

Рассмотрим создание класса для просмотра данных из одиночной таблицы, который содержит кнопки для перемещения по записям и выхода из формы.

  1. Откройте проект sales, в окне проекта выберите вкладку Classes (Классы) и нажмите кнопку New (Новый).
  2. В открывшемся диалоговом окне New Class (Новый класс) в поле ввода Class Name (Имя класса) введите имя создаваемого класса bcSingleTable.
  3. Из списка Based On (Базовый класс) выберите базовый класс Form (Форма).
  4. В поле Store In (Сохранить в) введите имя библиотеки классов Forms (Формы), в которой будет храниться создаваемый класс.
  5. На экране появляется пустая форма. Прежде всего изменим свойство Caption (Надпись) формы, введя в поле ввода значения свойства текст Табличная форма просмотра.
  6. Далее разместим в верхней части формы текст заголовка и определим для него цвет и размер шрифта (рис. 19.10). Форма, созданная на основе данного класса, будет содержать размещенный в классе текст заголовка. Разработчику формы потребуется только изменить текст заголовка, причем будут соблюдены все стандарты на создаваемую форму.

Рис. 19.10. Размещение заголовка формы

  7. Разместите в форме объект Grid (Таблица) и определите его свойства отображения данных, такие как шрифт, цвет, которые будут стандартными для просмотра данных в табличном виде.
  8. Установите для объекта Grid (Таблица) значение свойства Readonly (Только чтение) равным True (Истина), т. к. данную форму предполагается использовать только для просмотра данных.
  9. Для перемещения по записям, а также для выхода из формы используются кнопки, которые мы также разместим в форме и определим для них действия, выполняемые при нажатии на кнопки.
  10. Законченный вид класса приведен на рис. 19.11. Отметьте, что создание класса аналогично созданию формы.

Рис. 19.11. Класс для просмотра данных в табличном виде


Создание пользовательского класса на основе базовых классов Visual FoxPro в конструкторе классов

Для создания нового класса вы можете выполнить одно из следующих действий:

  • в окне проекта выбрать вкладку Classes (Классы) и нажать кнопку New (Новый);
  • в меню File (Файл) выбрать команду New (Новый), а затем в открывшемся диалоговом окне — опцию Class (Класс) и нажать кнопку New File (Новый файл);
  • в командном окне ввести команду CREATE CLASS,

Независимо от выбранного вами способа, на экране откроется диалоговое окно New Class (Новый класс) (рис. 19.8).

Рис. 19.8. Диалоговое окно New Class

В поле ввода Class Name (Имя класса) этого диалогового окна укажите имя создаваемого класса, а в следующем поле ввода Based On (Базовый класс) — имя класса, на основе которого создается новый класс. Поле From (Откуда) доступно только для чтения и содержит имя библиотеки классов, из которой выбран базовый класс. При использовании базовых классов Visual FoxPro данное поле остается пустым.

В поле ввода Store In (Сохранить в) необходимо ввести имя библиотеки, в которой будет храниться создаваемый класс. Библиотека классов представляет собой файл с расширением VCX. Вы можете выбрать созданные ранее библиотеки или указать новую библиотеку в диалоговом окне Save as (Сохранить как), которое вызывается при нажатии на кнопку, расположенную с правой стороны поля ввода.

Замечание

Для создания библиотеки классов вы можете воспользоваться командой CREATE CLASSLIB в командном окне.

После ввода значений в поля нажмите кнопку ОК, в результате чего на экране появится окно конструктора классов. В основное меню Visual FoxPro добавляется пункт Class (Класс) (рис. 19.9), который содержит команды, описанные в табл. 19.8.

Таблица 19.8. Назначение команд пункта меню C l ass

Команда | Назначение
New Property (Новое свойство) | Создает новое свойство
New Method (Новый метод) | Создает новый метод
Edit Property/Method (Правка свойства/метода) | Редактирует наименование созданного ранее метода или свойства
Include File (Включить файл) | Задает имя файла заголовка, содержащего описание предопределенных констант
Class Info (Информация о классе) | Отображает информацию о текущем классе

Окно конструктора классов аналогично окну конструктора форм. Если создаваемый класс является контейнером, вы можете размещать в классе объекты, которые, в свою очередь, могут создаваться на основе пользовательских классов. Для каждого объекта класса вы можете определить свойства и методы, а при необходимости добавить новые. Эти действия аналогичны действиям, выполняемым в окне конструктора форм. Обратимся к примеру создания простого класса, который в дальнейшем может использоваться при создании новых форм.

Рис. 19.9. Окно конструктора классов


Создание пользовательских классов

В предыдущих главах при создании форм мы использовали базовые классы Visual FoxPro. В случае необходимости вы могли добавлять в объекты, созданные на основе базовых классов, новые свойства и методы. Одним из способов повышения производительности разработки является определение стандартных объектов создаваемого приложения и разработка классов для таких объектов. При разработке приложений для больших фирм классы часто используются для стандартизации пользовательского интерфейса. Вы можете определить класс форм, в котором задан определенный цвет фона и стандартный набор кнопок для управления данными. В целях обеспечения стандартизации разработки полезно иметь один или несколько пользовательских классов для каждого базового класса. Например, вы можете определить отдельный класс для поля ввода, которое доступно только для чтения, и класс для редактируемого поля ввода. Если в дальнейшем вам понадобится изменить стандарт, то будет достаточно изменить только пользовательские классы, на основе которых создаются объекты приложения.


Использование вложенных объектов

В Visual FoxPro имеются базовые классы, предназначенные для создания вложенных объектов, например, класс Grid (Таблица). При ссылке на вложенный объект необходимо перечислить все объекты, в которые он входит, разделяя элементы списка точками. Например, ссылка на столбец coicustomerid объекта customer типа Grid (Таблица) определяется следующим образом:

Customer.colCustomerld

Ссылка такого типа называется абсолютной. В Visual FoxPro кроме абсолютной ссылки, которая при большой глубине вложения объекта является слишком громоздкой, вы можете использовать относительные ссылки, т. е. ссылки относительно активных в данный момент объектов (сам объект, форма, в которую входит объект, и группа форм), что значительно сокращает список объектов ссылки и позволяет получить доступ к объекту, даже если вы не знаете его имени.

Ссылка на активную форму осуществляется с помощью свойства ActiveForm (Активная форма) объекта (_SCREEN). Например, следующее выражение позволяет изменить заголовок активной формы:

_SCREEN.ActiveForm.Caption= "Заголовок формы"

Аналогично, свойство ActiveControi (Активный элемент управления) позволяет получить доступ к активному объекту формы, а свойство ActivePage (Активная вкладка) — к активной вкладке формы. Например, следующее выражение позволяет изменить надпись активной кнопки

_SCREEN.ActiveControl.Caption= "Печать отчета"

При ссылке на вложенный объект вы можете использовать свойство Parent (Родительский) и ключевые слова для идентификации объекта, к которому вы хотите получить доступ. Свойство Parent (Родительский) содержит ссылку на непосредственный контейнер объекта. Список ключевых слов и определяемые ими ссылки приведены в табл. 19.7.

Таблица 19.7. Ключевые слова для идентификации объектов

Наименование | Ссылка
THIS | На сам объект
THISFORM | На форму, которая содержит объект
THISFORMSET | На группу форм, которая содержит объект

Для примера определим цвет текущего объекта и объекта, являющегося его непосредственным контейнером, а также заголовки формы и группы форм, которые содержат данный объект:

THIS.BackColor=RGB(255,255,255)

THIS.Parent.BackColor=RGB(192,0,0)

THISFORM.Caption="Форма, содержащая объект"

THISFORMSET.Caption="Группа форм, содержащая объект"

Каждый объект обрабатывает связанные с ним события независимо. Поэтому контейнер не может реагировать на события вложенного в него объекта даже в том случае, если данный объект не содержит метода для обработки события, а контейнер может реагировать на данное событие.

Ранее мы рассмотрели команды создания формы и присвоения ей заголовка. Теперь дополним эти команды командами размещения в форме кнопки, являющейся по отношению к ней вложенным объектом:

f rmNew=CREATEOBJECT ( "FORM")

frmNew.Caption="Форма, созданная с помощью команд"

frmNew.Show()

frmNew.AddObject("Button", "CommandButton")

cmdButton=frmNew.Button

cmdButton.Visible=.Т.

cmdButton.Top=190

cmdButton.Left=120

cmdButton.Width=70

cmdButton.Height=3 0

cmdButton.Caption="Выход"

Команда frmNew.AddObject("Button", "CommandButton") создает В frmNew на основе базового класса CommandButton (Кнопка управления) новый объект Button (Кнопка). Следующая команда делает видимой созданную кнопку. На рис. 19.7 показана форма, созданная этими командами.

Совет

В прикладных программах объекты желательно сохранять невидимыми до полного определения всех их свойств.

Рис. 19.7. Форма с вложенным объектом — кнопкой


Использование базовых классов при создании форм

При создании форм мы широко использовали базовые классы, список которых содержится на панели инструментов конструктора формы. Для создания объектов на основе базового класса достаточно выбрать его на панели инструментов, поместить в требуемом месте, а затем определить свойства и методы созданных объектов. Созданный объект будет обладать всеми характеристиками базового класса. Пример создания объекта на основе базового класса Grid (Таблица) показан на рис. 19J.

Для создания новых объектов можно использовать не только конструктор форм, но и функцию CREATEOBJECT, которая имеет следующий синтаксис:

CREATEOBJECT(имяКласса [, параметр1, параиетр2, ...])

Функция CREATEOBJECT возвращает идентификатор созданного объекта, который вы можете применять для ссылки на него. Например, для создания формы, определения ее заголовка и отображения формы на экране необходимо выполнить следующую последовательность команд:

frmNew=CREATEOBJECT("FORM")

f rmNew. Caption="Заголовок формы"

f rmNew.Show()

Рис. 19.1. Создание объекта в конструкторе форм

Свойства объектов, созданных на основе базовых классов

Объект, созданный на основе базовых классов, наследует его свойства, методы и обрабатываемые события. Свойства подобны переменным, однако в отличие от последних, они не существуют вне объекта.

Возможность изменения свойств объектов в Visual FoxPro является мощным инструментом управления данными в интерактивном режиме. Например, вы можете:

  • изменить свойства формы (заголовок, размер, цвет, расположение и т. п.);
  • изменить цвета полей ввода, тип их отображения, цвет и формат выводимой в них информации;
  • запретить ввод информации в поля, переход на них или же сделать их невидимыми и многое другое.

Для того чтобы определить какое-либо из свойств объекта в интерактивном режиме, вам необходимо выделить требуемый объект, после чего выполнить одно из следующих действий:

  • в меню View (Вид) выбрать команду Properties (Свойства);
  • нажать правую кнопку мыши и из контекстного меню объекта выбрать команду Properties (Свойства).

В результате на экране появляется окно свойств текущего объекта (рис. 19.2). Свойства объектов могут принимать символьные, логические и числовые значения. Некоторые из них могут принимать произвольные значения (например, заголовок поля, его координаты). Другие свойства могут принимать значения из определенного списка.

Рис. 19.2. Окно свойств объекта

При программировании вы можете определить свойство объекта, указав имя объекта и имя свойства, которые разделяются точками. Для изменения свойства достаточно присвоить ему допустимое значение. Например:

* присваиваем заголовку формы значение переменной cName

frmNew. Caption = cName

Язык Visual FoxPro позволяет вам устанавливать не только свойства отдельных объектов, но и определенной группы объектов.

Для этого используется конструкция WITH .. . ENDWITH, которая имеет следующий синтаксис:

WITH имяОбгьекта [,имяОбгьекта]

[.имяСвойства = выражение]

ENDWITH

Например, вы можете установить одинаковый цвет для группы объектов:

WITH cmdNext, cmdPrev

.ForeColor=RGB(0,0,0)

.BackColor=RGB(255,255,255)

ENDWITH

Используя язык Visual FoxPro, можно изменять свойства объектов не только на этапе их создания, но и в процессе выполнения программы. Например, вы можете при переходе из режима просмотра в режим редактирования изменить заголовок формы "Просмотр списка клиентов", который является одним из свойств формы, на "Редактирование списка клиентов".

Замечание

Свойства, определенные для объектов с помощью окна свойств или программным путем, сохраняются в описании формы. Поэтому, если во время одного сеанса работы вы изменили свойства объектов, они сохранятся до следующего изменения. Изменение свойств объекта не приводит к генерации события, за исключением изменения свойства Value (Значение).

Visual FoxPro позволяет не только использовать свойства, наследованные из базового класса, но и создавать новые, которые можно использовать для хранения характеристик объекта и связанных с ним данных.

Чтобы создать новое свойство объекта, используйте диалоговое окно New Property (Новое свойство) (рис. 19.3), которое открывается при выполнении команды New Property (Новое свойство) из меню Form (Форма). В этом диалоговом окне необходимо задать имя создаваемого свойства и описание.

В диалоговом окне New Property (Новое свойство) находятся флажки, определяющие возможности, приведенные в табл. 19.4.

Таблица 19.4. Флажки диалогового окна New Property

Флажок | Назначение
Access Method (Метод доступа) | Если установлен этот флажок, то для данного свойства будет автоматически создан метод Access (Доступ)
Assign Method (Метод назначения} | Если установлен флажок, то для этого свойства будет автоматически создан метод Assign (Назначение)

Созданное вами свойство отображается на вкладке Other (Другие) окна свойств объекта. Далее вы можете присвоить созданному свойству требуемое значение в окне свойств объекта или программным путем и использовать его при выполнении приложения.

Рис. 19.3. Диалоговое окно New Property

Наследование событий и методов

Visual FoxPro является языком, управляемым по событиям. Событие представляет собой некоторое действие, которое активизирует стандартную реакцию объекта. В качестве события в Visual FoxPro могут рассматриваться нажатие кнопки мыши, выбор пункта меню или открытие таблицы.

Аналогично свойствам, наследуются события и методы базового класса, на основе которого создается объект. Список методов, определенных для объекта, можно просмотреть на вкладке Methods (Методы) окна свойств объекта (рис. 19.4).

Для каждого события определен соответствующий ему метод, который выполняется при возникновении данного события. Например, метод click (Нажатие) выполняется при нажатии кнопки мыши.

Список доступных методов обработки событий определяется базовым классом. Именно эти методы обеспечивают обработку всех действий пользователя (нажатие клавиш, управление мышью). Visual FoxPro предоставляет возможность модифицировать действия, выполняемые при обработке события данного объекта. Для редактирования метода установите курсор на этот метод в списке методов и дважды щелкните мышью. На экране откроется окно редактирования метода (рис. 19.5), в котором вы можете написать программу обработки события. Например, для кнопки формы вы можете определить программу перемещения по записям.

Для каждого события объекта выполняется определенное в базовом классе действие. В некоторых случаях вам может понадобиться запретить выполнение этих действий. Для этого используйте ключевое слово NODEFAULT в начале метода, связанного с этим событием.

Рис. 19.4. Вкладка Methods окна свойств объекта

Рис. 19.5. Окно редактирования методов

Замечание

Методы, выполняющиеся при наступлении событий, в окне свойств объекта в списке методов в дополнение к имени содержат слово Event (Событие).

Команда MOUSE позволяет вам программным путем имитировать события click (Нажатие), Doubleclick (Двойное нажатие), MouseMove (Перемещение мыши) и DragDrop (Перенести и оставить). Остальные события не могут имитироваться программно, но вы можете вызвать методы, связанные с этими событиями.

Кроме методов, связанных с событиями, объект может содержать и дополнительные методы, которые выполняются только при их вызове. Например, для формы могут быть определены методы перехода на следующую запись, удаления записи и т. п. Эти методы могут наследоваться из базового класса, но вы можете создавать новые методы и для отдельных объектов.

Для создания нового метода в меню Form (Форма) выберите команду New Method (Новый метод) и в открывшемся диалоговом окне New Method (Новый метод) (рис. 19.6) определите имя и краткое описание метода. Созданный вами метод добавляется в список методов объекта, и вы можете открыть окно редактирования метода для ввода программного кода.

Для выполнения метода необходимо не только указать имя метода, но и объект, к которому данный метод будет применяться. Имя объекта и имя метода разделяются точкой. Например, для выполнения метода CaicSum формы Sales необходимо выполнить команду Sales.CalcSumO .

Рис. 19.6. Диалоговое окно New Method

В табл. 19.5 и табл. 19.6 приведены события и методы, которые распознаются и используются Visual FoxPro, и их краткое описание.

Таблица. 19.5. События, распознаваемые Visual FoxPro

Событие | Возникает
Activate | При активизации объектов FormSet (Набор форм), Form (Форма), Page (Вкладка формы) или при отображении объекта Toolbar (Панель управления)
AfterBuilld | При перестроении проекта или приложения, а также при создании динамической библиотеки (dll) или выполняемого файла (ехе) на основе проекта
AfterCloseTables | После закрытия таблиц или представлений данных
AfterDock | После того, как фиксируется панель инструментов
AfterRowColChange | При переходе в другую строку или другой столбец объекта Grid (Таблица)
Bef oreDock | Имеет место перед фиксацией объекта ToolBar (Панель управления)
BeforeOpenTables | Перед открытием таблиц и представлений, связанных со средой данных формы, набора срорм или отчета
BeforeRowCoIChange | Перед тем, как пользователь изменяет активную строку или столбец объекта Grid (Таблица)
Click | При нажатии и отпускании левой кнопки мыши
CoramandTargetExec | При активизации программой-контейнером приложения типа Active Document (Активный документ)
CoinmandTarget Query | При изменении программой-контейнером пользовательского интерфейса
ContainerRelease | При закрытии программой-контейнером приложения типа Active Document (Активный документ)
DblClick | При двойном нажатии и отпускании левой кнопки мыши
Deactivate | Когда деакти визируется объект типа "форма"
Deleted | Когда пользователь удаляет пометку записи на удаление или когда выдается команда DELETE
Destroy | Когда освобождается объект
DownClick | При нажатии кнопки со стрелкой, направленной вниз на объектах типа ComboBox (Раскрывающийся список), ListBox (Список) и Spinner (Счетчик)
DragDrop | После завершения операции "перенести-и-оставить"
DragOver | Когда элемент управления, переносимый с помощью мыши, накрывает объект назначения
DropDown | В момент, когда после нажатия кнопки со стрелкой в элементе управления ComboBox (Раскрывающийся список) должен появиться список
Error | При возникновении ошибки
ErrorMessage | Используется для определения сообщения об ошибке, когда событие Valid (Корректный) возвращает значение False (Ложь)
GotFocus | Когда объект получает фокус в результате действий пользователя или выполнения программного кода
HideDoc | При переходе из активного документа
Init | При создании объекта, когда объект еще не выведен на экран
Interactive Change | При изменении значения элемента управления с помощью клавиатуры или мыши
KeyPress | При нажатии и отпускании клавиши
Load | Имеет место непосредственно перед созданием объекта
LostFocus | Когда объект теряет фокус
Message | Отображает сообщение в строке состояния, когда объект получает управление
MiddleClick | При нажатии средней кнопки мыши (для трехкнопочной мыши)
MouseDown | При нажатии кнопки мыши
MouseMove | При перемещении указателя мыши по объекту
MouseUp | При отпускании кнопки мыши
MouseWheel | При вращении колесика мыши, если в мыши оно есть
Moved | При перемещении объекта на новое место или когда значения свойства Тор (Верхняя позиция) или Left (Левая позиция) объекта-контейнера изменяются программным способом
OLECompleteDrag | Когда данные помещены на новое место или отменена операция "перенести-и-оставить"
OLEDragOver | Возникает в том случае, если свойство OLEDropMode имеет значение 1 и данные перенесены от источника к приемнику
OLEGiveFeedBack | После каждого события OLEDragOver
OLESetData | Возникает у источника данных при выполнении метода GetData, если нет данных в нужном формате
OLEStartDrag | В начале переноса данных с помощью механизма "перенести-и-оставить"
Paint | При перерисовывании формы или панели инструментов
ProgrammaticChange | При изменении в коде значения элемента управления
QueryAddFile | Перед добавлением файла в проект
QueryModifyFile | Перед изменением файла в проекте
QueryRemoveFile | Перед удалением файла из проекта
QueryRunFile | Перед выполнением файла или предварительным просмотром отчета или почтовой этикетки
QueryUnload | Перед выгрузкой объекта Form (Форма)
RangeHigh | Возвращает наибольшее значение счетчика или число элементов списка и имеет место, когда элемент управления Spinner (Счетчик) или TextBox (Поле ввода) теряет фокус и когда элемент управления comboBox {Раскрывающийся список) или ListBox (Список) получает фокус
RangeLow | Возвращает наименьшее значение счетчика или значение первого элемента списка и имеет место, когда элемент управления Spinner (Счетчик) или TextBox (Поле ввода) теряет фокус или когда элемент управления СошЬоВох (Раскрывающийся список) или ListBox (Список) получает фокус
ReadActivate | При активизации новой формы в наборе форм
ReadDeactivate | При деактивизации формы в наборе форм
ReadShow | Когда выдана команда SHOW GETS в активном объекте FormSet (Набор форм) активизируется объект FormSet (Набор форм)
ReadValid | Имеет место после деактивизации объекта FormSet (Группа форм)
ReadWhen | Имеет место после загрузки объекта FormSet (Группа форм)
Resize | При изменении размеров объекта
RightClick | При нажатии и отпускании правой кнопки мыши
Run | Имеет место, когда Active Document (Активный документ) готов к выполнению кода пользователя
Scrolled | При прокрутке данных в объекте управления Grid (Таблица)
ShowDoc | При переходе в активный документ
Timer | Когда истекает интервал времени, заданный свойством Interval (Интервал)
UIEnable | Имеет место для всех объектов, содержащихся внутри объекта Page (Вкладка формы), каждый раз, когда объект Page (Вкладка формы) активизируется или деактивизируется
UnDock | При перемещении объекта ToolBar (Панель управления) с помощью мыши
Unload | При освобождении объекта
UpClick | При нажатии кнопки с направленной вверх стрелкой на объектах управления типа СотЬоВох (Раскрывающийся список), ListBox (Список) и spinner (Счетчик)
Valid | Перед тем, как элемент управления теряет фокус
When | Перед тем, как элемент управления получает фокус

Таблица 19.6. Методы, используемые Visual FoxPro

Метод | Описание
ActivateCell | Активизирует ячейку в элементе управления Grid (Таблица)
AddColumn | Добавляет объект Column (Столбец) в элемент управления Grid (Таблица)
Add I tern | Добавляет новый элемент списка в объект СотЬоВох (Раскрывающийся список) или ListBox (Список), предоставляв при этом возможность задать индекс элемента
AddListltem | Добавляет новый элемент списка в объект СотЬоВох (Раскрывающийся список) или ListBox (Список), давая возможность задать идентификатор элемента
AddObject | Добавляет объект в контейнер на этапе выполнения
AddProperty | Добавляет новое свойство в объект
AddToSCC | Добавляет файл в проект
Box | Рисует прямоугольник в форме
Build | Перестраивает проект или создает приложение (арр), динамическую библиотеку (dli) или выполняемый файл (ехе) из проекта
Checkln | Запоминает изменения, осуществленные в выбранном файле проекта
Checkout | Выбирает файл из проекта для изменения
Circle | Рисует окружность или эллипс в форме
Cleanup | Очищает таблицу проекта, удаляя записи с пометкой на удаление и сжимая Memo-поля
Clear | Очищает содержимое элемента управления СотЬоВох (Раскрывающийся список) или ListBox (Список)
ClearData | Очищает все данные и форматы данных в объекте Dataobject (Объект данных). Доступен только в режиме выполнения программы
CloneObj ect | Создает копию объекта со всеми его свойствами, событиями и методами
Close | Закрывает проект и очищает объекты ProjectHook (Проект) и Project (Проект)
CloseTables | Закрывает таблицы и представления данных, связанные со средой
Cls | Удаляет графику и текст из формы
DataToClip | Копирует группу записей в текстовом виде в буфер обмена Windows
DeleteColumn | Удаляет объект Column (Столбец) из элемента управления Grid (Таблица)
Dock | Располагает объект ToolBar (Панель управления) у границы основного окна Visual FoxPro
DoCrad | Выполняет команду Visual FoxPro для сервера приложения Visual FoxPro
DoScroll | Моделирует работу пользователя с полосами прокрутки в объекте Grid (Таблица)
DoVerb | Выполняет команду для заданного OLE-объекта
Drag | Начинает, заканчивает или отменяет операцию переноса объекта с помощью мыши
Draw | Перерисовывает объект формы
Eval | Вычисляет выражение и возвращает результат
GetData | Заполняет данные из объекта DataObject (Объект данных). Доступен только в режиме выполнения программы
Get Format | Возвращает True (Истина), если заданный формат доступен для объекта DataObject (Объект данных). Доступен только в режиме выполнения программы
GetLatestVersion | Определяет последнюю версию файла проекта и копирует файл с пометкой только для чтения на диск
GoBack | Возникает при возврате назад в списке хронологии программы-контейнера
GoForward | Возникает при переходе вперед в списке хронологии программы-контейнера
Help | Открывает окно справки
Hide | Скрывает объект Form (Форма), FormSet (Набор форм) или ToolBar (Панель управления), присваивая его свойству visible значение False (Ложь)
IndexToItemID | Возвращает индекс элемента с указанным идентификатором для объектов типа ComboBox (Раскрывающийся список) и ListBox (Список)
Item | Возвращает объектную ссылку на определенный файл, проект или сервер в файловом, проектном, серверном сборнике
ItemlDToIndex | Возвращает индекс позиции элемента в списке данного элемента управления для объектов типа ComboBox (Раскрывающийся список) и ListBox (Список)
Line | Рисует линию в форме
Modify | Открывает файл проекта для редактирования в соответствующем конструкторе или редакторе
Move | Перемещает объект
NavigateTo | Active Document (Активный документ) перемещается в контейнере в определенное место
OLEDrag | Начинает операцию "леренести-и-оставить"
Point | Возвращает цвет в модели RGB (красный-зеленый-синий) для заданной точки формы
Print | Выдает в объекте Form (Форма) символьную строку, которую нужно напечатать
PSet | Устанавливает для точки формы или основного окна Visual FoxPro основной цвет символов
Quit | Завершает работу Visual FoxPro
ReadExpression | Возвращает выражение, введенное в качестве значения свойства в окне свойств
ReadMethod | Возвращает текст заданного метода
Refresh | Перерисовывает объект Form (Форма) или элемент управления, обновляя все значения
Release | Освобождает объект FormSet (Набор форм) или Form (Форма) из памяти
Remove | Удаляет файл из сборника файла и проекта
RemoveFromSCC | Удаляет файл из проекта
Remove I tern | Удаляет элемент из списка элемента управления типа ComboBox (Раскрывающийся список) или ListBox (Список)
RemoveListltem | Удаляет элемент из списка элемента управления типа ComboBox (Раскрывающийся список) или ListBox (Список)
RemoveObject | Удаляет заданный объект из объекта-контейнера на этапе выполнения
Requery | Повторно опрашивает источник строк, к которому привязан элемент управления типа ListBox (Список) или ComboBox (Раскрывающийся список)
RequestData | Создает массив, содержащий данные из таблицы Visual FoxPro
Reset | Сбрасывает элемент управления Timer (Таймер) в нулевое состояние
ResetToDefault | Восстанавливает принятые по умолчанию в Visual FoxPro значения свойств, событий или методов
Run | Запускает файл проекта на выполнение или предварительный просмотр
SaveAs | Сохраняет объект в виде файла с расширением SCX
SaveAsClass | Сохраняет экземпляр объекта в качестве определения класса в библиотеке классов
Set All | Присваивает установку некоторого свойства всем элементам управления данного объекта Container (Контейнер) или определенному классу таких элементов управления
SetData | Помещает данные в DataObject (Объект данных). Доступен в режиме выполнения программы
SetFocus | Устанавливает фокус в элементе управления
SetFormat | Помещает формат данных в DataObject (Объект данных). Доступен в режиме выполнения программы
SetMain | Делает текущий файл главным в проекте
SetVar | Создает переменную и хранит ее значение
SetViewPort | Определяет значения ViewPortLeft и viewPortTop для формы
Show | Отображает объект Form (Форма) и определяет его тип — модальный или немодальный
ShowWhatsThis | Отображает тему справочной системы, заданную свойством WhatsThisHelpID
TextHeight | Возвращает высоту текстовой строки, используя единицу измерения, устанавливаемую свойством ScaleMode объекта Form (Форма)
TextWidth | Возвращает ширину текстовой строки, используя единицу измерения, устанавливаемую свойством ScaleMode объекта Form (Форма)
UndoCheckOut | Отменяет все изменения, осуществленные в выбранном файле, и оставляет его в проекте в неизмененном виде
WhatsThisMode | Отображает курсор мыши в виде вопросительного знака и устанавливает режим whats This Help (Справка типа "что это?")
WriteExpression | Записывает символьную строку в таблицу свойств
WriteMethod | Записывает указанный текст в заданный метод
ZOrder | Помещает заданный объект Form (Форма) или элемент управления в заданную позицию данного объекта по отношению к другим объектам


Базовые классы Visual FoxPro

При создании объектов приложения вы можете использовать базовые классы Visual FoxPro, классы внешних библиотек, а также создавать новые классы.

Visual FoxPro содержит большое число базовых классов (табл. 19.1), которые можно использовать при создании форм любой сложности. Единственным недостатком базовых классов является невозможность их модификации, но вы можете использовать базовые классы для создания пользовательских классов, полностью вами управляемых. Далее при создании форм можно применять пользовательские классы вместо базовых.

Таблица 19.1. Базовые классы Visual FoxPro

Наименование | Назначение | Видимый | Контейнер
ActiveDoc | Активный документ | Нет | Нет
Checkbox | Флажок | Да | Нет
Column | Столбец | Да | Да
ComboBox | Раскрывающийся список | Да | Нет
CoiranandButton | Кнопка управления | Да | Нет
CommandGroup | Набор кнопок управления | Да | Да
Container | Контейнер | Да | Да
Control | Базовый визуальный класс | Да | Нет
Custom | Базовый невизуальный класс | Нет | Нет
EditBox | Поле редактирования | Да | Нет
Form | Форма | Да | Да
Forms et | Набор форм | Нет | Да
Grid | Таблица | Да | Да
Header | Заголовок столбцов таблицы | Да | Нет
HyperLink Object | Гиперссылка | Нет | Нет
Image | Изображение | Да | Нет
Label | Надпись | Да | Нет
Line | Линия | Да | Нет
ListBox | Список | Да | Нет
OleContainerControl | OLE-объект управления |  |
OleBoundControl | OLE-объект данных |  |
OptionButton | Переключатель | Да | Нет
OptionGroup | Набор переключателей | Да | Да
Page | Вкладка формы | Да | Да
Page Frame | Макет страницы | Нет | Да
ProjectHook | Проект | Нет | Да
Separator | Разделитель | Да | Нет
Shape | Обрамление | Да | Нет
Spinner | Счетчик | Да | Нет
TextBox | Поле ввода | Да | Нет
Timer | Таймер | Нет | Нет
ToolBar | Панель управления | Да | Да

Почти все базовые классы являются визуальными. Объекты, созданные на их основе, отображаются на экране. Некоторые из базовых классов невидимы. Они используются для объединения объектов (например, FormSet), обработки специальных событий (например, Timer) или создания невизуальных объектов (например, ProjectHook).

В Visual FoxPro широко применяется вложенность классов. Вложенным является класс, являющийся частью другого класса, называемого контейнером (container class). Наиболее яркий пример контейнера представляет собой таблица, компоненты которой — это столбцы и надписи к ним. При создании формы и после запуска ее на выполнение вы можете получить доступ ко всем компонентам контейнера.

Каждый базовый класс предназначен для выполнения определенных функций и обладает соответствующим набором свойств, методов и событий. Кроме свойств и событий, специфических для данного класса, каждый базовый класс содержит основной набор свойств (табл. 19.2) и событий (табл. 19.3).

Таблица 19.2. Минимальный набор свойств класса

Наименование | Описание
Class | Тип класса
BaseClass | Базовый класс, на основе которого создан данный класс
ClassLibrary | Библиотека классов, в которой хранится данный класс
ParentClass | Определенный пользователем класс, на основе которого создан данный класс

Таблица 19.3. Минимальный набор событий

Наименование | Описание
Init | Наступает при создании объекта
Destroy | Наступает при освобождении объекта из памяти
Error | Наступает при возникновении ошибки, связанной с объектом


Создание панели инструментов

Панели инструментов являются неотъемлемой частью приложений Windows. Visual FoxPro также позволяет разрабатывать класс панели инструментов и применять его при создании объекта панели инструментов. Этот объект может использоваться в формах для управления перемещением по записям, поиска данных и т. п.

В качестве примера создадим класс панели инструментов, предназначенный для просмотра данных таблицы. На панели содержатся кнопки перемещения по записям и выхода из формы. Выполните следующие действия:

  1. Откройте проект sales.
  2. В окне проекта перейдите на вкладку Classes (Классы) и нажмите кнопку New (Новый).
  3. В диалоговом окне New Class (Новый класс) выберите базовый класс Toolbar (Панель управления), введите имя класса bcTabieTooiBar и укажите пользовательскую библиотеку классов ForForms, а затем нажмите кнопку ОК. В окне конструктора классов появляется панель инструментов, не содержащая ни одного объекта.
  4. Используя ранее созданные классы кнопок, разместите на создаваемой панели инструментов графические кнопки перемещения по записям и выхода из формы (рис. 19.29).

Рис. 19.29. Создание класса панели управления для перемещения по записям таблицы

После создания класса панели инструментов нет необходимости размещать в формах кнопки перемещения по записям. Вместо них можно при инициализации формы создавать панель инструментов и использовать ее для перемещения по записям и выхода из формы. Рассмотрим пример создания формы, в которой для перемещения по записям используется панель инструментов:

  1. Откройте проект sales.
  2. В окне проекта перейдите на вкладку Classes (Классы) и нажмите кнопку New (Новый).
  3. В открывшемся диалоговом окне New Class (Новый класс) в поле ввода Class Name (Имя класса) введите имя создаваемого класса bcSingleTableToolbar. Из списка Based On (Базовый класс) выберите базовый класс Form (Форма), а затем в поле ввода Store In (Сохранить в) введите имя библиотеки классов Forms (Формы), в которой будет храниться создаваемый класс.
  4. Разместите в форме текст заголовка и объект Grid (Таблица).
  5. Нам необходимо создать в форме объект типа "панель" инструментов на основе созданного в предыдущем примере класса. Для этого определите новое свойство oTooiBar формы, выполнив команду New Property (Новое свойство) из меню Class (Класс), а затем в методе Activate (Активизация) формы создайте объект типа "панель инструментов" и отобразите его на экране:

* Создаем панель инструментов

_screen.ActiveForm.oToolBar=CREATEOBJECT("bcTableToolBar")

* Отображаем панель инструментов на экране

__screen.ActiveForm. oTooiBar. Show ()

  6. Сохраните созданный класс и закройте окно конструктора классов.
  7. Теперь приступим к созданию формы на основе созданного в этом примере класса. Для этого откройте диалоговое окно Options (Параметры), перейдите на вкладку Forms (Формы) и установите в поле ввода Form (Форма) имя пользовательского класса bcsingieTabieTooibar из библиотеки Forms (Формы).
  8. Откройте проект sales.
  9. В окне проекта выберите вкладку Documents (Документы), перейдите в раздел Forms (Формы) и нажмите кнопку New (Новый). На экране откроется окно конструктора форм, которое содержит объекты класса bcsingieTabieTooibar. Обратите внимание на то, что в форме панель инструментов отсутствует. Она создается при запуске формы на выполнение,
  10. Выберите текстовый объект, расположенный в верхней части формы, и измените его свойство caption (Надпись), введя Просмотр информации о клиентах,
  11. Добавьте в окружение формы таблицу customer.
  12. Установите свойства объекта Grid (Таблица). Для этого свяжите столбцы таблицы с полями таблицы customer и определите заголовки столбцов.
  13. На этом создание формы заканчивается. Сохраните ее и запустите на выполнение.

Совет

Если при запуске данной формы на выполнение появляется сообщение о том, что класс не найден, вам необходимо в методе Activate (Активизация) формы перед созданием объекта типа "панель инструментов" вставить команду SET CLASSLIB то с указанием папки расположения класса.


Управление классами

Для создания нового класса, изменения его имени, удаления его из библиотеки классов вы можете в окне Oass Browser (Обзор классов) использовать кнопки, описанные в табл. 19.10.

Рис. 19.28. Исходный текст описания класса

Таблица 19.10. Кнопки окна Class Browser

Наименование | Описание
Find (Поиск) | Открывает диалоговое окно Find (Найти) для поиска класса и элементов класса по имени, описанию
New Class (Новый класс) | Открывает диалоговое окно New Class (Новый класс) для создания нового класса
Rename (Переименовать) | Изменяет имя выбранного класса. Изменение имени может привести к ошибкам в формах, использующих данный класс
Redefine {Переопределить родительский класс) | Переопределяет родительский класс выбранного класса
Clean Up Class Library (Упаковать библиотеку классов) | Упаковывает библиотеку классов, удаляя из нее физически записи, помеченные для удаления
View Class Code (Просмотр кода класса) | Открывает диалоговое окно с исходным текстом описания класса (рис. 19.28). Вы можете использовать эту информацию при создании собственных классов программным путем


Средство Class Browser

В Visual FoxPro имеется удобное средство, предназначенное для работы с классами, — это Class Browser (Обзор классов), с помощью которого вы можете просматривать библиотеки классов, создавать новые классы и редактировать существующие.

Для открытия окна Class Browser (Обзор классов) выполните одно из следующих действий.

  • В меню Tools (Сервис) выберите команду Class Browser (Обзор классов).
  • В командном окне выполните команду DO (_BROWSER) .

Независимо от выбранного вами способа, будет запущено приложение Browser.app, которое открывает окно Class Browser (Обзор классов) (рис. 19.27), содержащее панель инструментов для управления классами и список объектов выбранной библиотеки.

После открытия библиотеки классов в левой части окна Class Browser (Обзор классов) будет отображен иерархический список классов выбранной библиотеки со значками, которые вы присвоили с помощью команды Class Info (Информация о классе) из меню Class (Класс). В правой части окна отображается список объектов, входящих в данный класс, его свойства и методы. В нижней части окна содержатся параметры выбранного класса или элемента класса.

Рис. 19.27. Окно Class Browser

Совет

Двойной щелчок на имени класса в левой области окна Class Browser (Обзор классов) автоматически открывает данный класс в конструкторе классов.

В окне Class Browser (Обзор классов) могут отображаться несколько библиотек классов. Для добавления новой библиотеки нажмите кнопку View Additional File (Просмотр дополнительного файла) на панели инструментов окна Class Browser (Обзор классов) и диалоговом окне Open (Открыть) выберите библиотеку классов.

Для просмотра любой другой библиотеки классов нажмите кнопку Open (Открыть) на панели инструментов и в диалоговом окне Open (Открыть) выберите требуемую библиотеку.

Замечание

В окне Class Browser (Обзор классов) могут отображаться не только библиотеки классов, но и формы.

Чтобы просмотреть классы одного типа (например, класс кнопок), выберите из раскрывающегося списка Class Type (Тип класса) наименование требуемого типа.


Использование формы для создания класса

В Visual FoxPro имеется возможность использования существующей формы для создания класса. Вы можете сохранить всю форму в виде класса или же выбрать определенные объекты формы и сохранить их в виде одного класса. Созданная в предыдущем примере форма содержит некоторую часть информации о клиентах. В создаваемом приложении могут понадобиться еще несколько форм для просмотра информации о клиентах, каждая из которых отображает определенную часть информации. В этом случае желательно иметь класс формы просмотра информации о клиентах, который содержит всего лишь два поля icdcustomer и ccompany таблицы Customer.

Для создания такого класса воспользуемся формой, созданной в предыдущем примере.

  1. Откройте окно конструктора для формы, созданной в предыдущем примере.
  2. В объекте Grid (Таблица) удалите все столбцы, за исключением столбцов с полями icdcustomer и ccompany (р ис . 19.26).

Рис. 19.26. Подготовка формы для создания класса

  3. В меню File (Файл) выберите команду Save As Class (Сохранить как класс).
  4. В открывшемся диалоговом окне Save As Class (Сохранить как класс) установите переключатель Save (Сохранить) в положение Current form (Текущая форма). В поле Name (Имя) укажите имя класса и имя библиотеки, в которой будет располагаться класс, а в поле Description (Описание) — его краткое описание. После ввода всех атрибутов нажмите кнопку ОК, в результате в указанной библиотеке будет создан новый класс.

Сове т

Для сохранения объектов формы в виде класса выделите их в форме, а затем в диалоговом окне Save As Class (Сохранить как класс) установите переключатель Save (Сохранить) в положение Selected controls (Выбранные элементы управления). Для сохранения набора форм в виде класса откройте окно конструктора для набора форм и в диалоговом окне Save As Class (Сохранить как класс) установите переключатель Save (Сохранить) в положение Entire form set (Набор форм).


Форма просмотра информации о клиентах на основе пользовательских классов

Рассмотрим создание формы просмотра информации о клиентах, используя класс bcsingieTabie, созданный в предыдущем примере.

  1. Откройте диалоговое окно Options (Параметры).
  2. На вкладке Forms (Формы) установите флажок Form (Форма).
  3. В открывшемся диалоговом окне Form Template (Шаблон формы) (см. рис. 19.23) выберите пользовательскую библиотеку Forms (Формы).
  4. В области Class Name (Имя класса) выберите требуемый класс bcSingleTable.
  5. Нажмите кнопку ОК.
  6. Вернувшись в диалоговое окно Options (Параметры), нажмите кнопку ОК для его закрытия.
  7. Откройте проект sales.
  8. В окне проекта выберите вкладку Documents (Документы), затем перейдите в раздел Forms (Формы) и нажмите кнопку New (Новый). На экране открывается окно конструктора форм, которое содержит объекты Класса bcSingleTable (рис. 19.24).

Рис. 19.24. Начальная стадия создания формы, основанной на пользовательском классе

  9. Выберите текстовый объект, расположенный в верхней части формы, и измените его свойство Caption (Надпись), введя Просмотр информации о клиентах.
  10. В окно окружения формы добавьте таблицу Customer.
  11. Установите свойства объекта Grid (Таблица). Для этого задайте количество столбцов в таблице, свяжите их с полями таблицы customer и определите заголовки полей. На этом создание формы заканчивается (рис. 19.25).
  12. Сохраните форму и запустите ее на выполнение.

Рис. 19.25. Форма просмотра информации о клиентах


Создание форм на основе пользовательских классов

С помощью вкладки Forms (Формы) (рис. 19.22) диалогового окна Options (Параметры) вы можете задать класс формы, который будет использоваться при создании новой формы.

Рис. 19.22. Выбор класса, используемого при создании формы

Для выбора класса, используемого при создании формы, выполните следующие действия:

  1. На вкладке Forms (Формы) диалогового окна Options (Параметры) в области Template classes (Шаблон классов) установите флажок Form (Форма).
  2. Откроется диалоговое окно Form Template (Шаблон формы) (рис. 19.23). Выберите библиотеку, а затем в области Class Name (Имя класса) — требуемый класс.
  3. Нажмите кнопку ОК.
  4. Вернувшись в диалоговое окно Options (Параметры), нажмите кнопку ОК для его закрытия.

Аналогичным образом вы можете установить и пользовательский класс для создания наборов форм.

Замечание

Пользовательский класс, используемый при создании набора форм, определяется аналогичным образом. Только на вкладке Forms (Формы) диалогового окна Options (Параметры) необходимо установить флажок Form set (Набор форм).

Рис. 19.23. Диалоговое окно Form Template


Формирование списка библиотек, используемых в конструкторах форм и классов

Для добавления библиотек классов на панель инструментов Form Controls (Элементы управления формы) можно использовать не только опцию Add (Добавить) всплывающего меню кнопки View Classes (Показать классы), но и вкладку Controls (Элементы управления) (рис. 19,21) диалогового окна Options (Параметры). Для его открытия выполните команду Options (Параметры) из меню Tools (Сервис).

Рис. 19.21. Вкладка Controls диалогового окна Options

Чтобы определить библиотеки классов, установите переключатель Visual class libraries (Библиотеки визуальных классов). Затем заполните список Selected (Выбранные) названиями библиотек классов, которые вы собираетесь отображать на панели инструментов. Идя добавления нового класса в этот список используется кнопка Add (Добавить), при нажатии на которую открывается диалоговое окно Open (Открыть). В этом окне найдите и выберите требуемую библиотеку классов. Удаление из списка выбранной библиотеки осуществляется нажатием кнопки Remove (Удалить). При нажатии кнопки Set As Default (Использовать по умолчанию) введенные установки будут использоваться и в следующих сеансах работы с Visual FoxPro.


Просмотр информации о классе и определение значка для его обозначения

Для просмотра информации о классе и определения значка для него используется диалоговое окно Class Info (Информация о классе), открываемое при выборе из меню Class (Класс) команды Class Info (Информация о классе).

Вкладка Class (Класс) содержит поля ввода изображений значков классов и поле редактирования Description (Описание), в которое можно ввести краткое описание класса.

На вкладке Members (Члены) (рис. 19.18) отображается список объектов класса, а также перечень методов и свойств. Столбец Class (Класс) содержит наименование объектов, а столбец Name (Наименование) — свойства и методы класса. С помощью параметра Visibility (Видимость), который может принимать одно из трех значений — Public (Открытый), Protected (Защищенный) и Hidden (Скрытый), вы можете установить степень защищенности объекта, а в столбце No Init (He инициализировать) указать, будет ли выполняться метод init (Инициализация) при создании объекта.

Рис. 19.18. Вкладка Members диалогового окна Class Info

Для каждого класса вы можете указать два значка, вид которых задается на вкладке Class (Класс) (рис. 19.19).

Рис. 19.19. Вкладка Class диалогового окна Class Info

Имя первого из них вводится в поле ввода Toolbar icon (Значок на панели инструментов) и в дальнейшем отображается на панели инструментов Form Controls (Элементы управления формы) в окнах конструктора форм и конструктора классов при выборе библиотеки классов, содержащей данный класс. Имя второго значка вводится в поле ввода Container icon (Значок контейнера) и отображается в диалоговом окне Class Browser (Обзор класса). Для задания значка вы можете ввести имя графического файла непосредственно в поля ввода или использовать кнопки выбора файла, расположенные справа от полей.

Совет

Настоятельно рекомендуется определять значки для создаваемых классов. В противном случае вам будет трудно выбирать пользовательские классы на панели инструментов Form Controls (Элементы управления формы), т. к. они будут иметь значки базовых классов и отличить один от другого можно только по всплывающей подсказке.

Рис. 19.20. Диалоговое окно Edit Property/Method

С помощью кнопки Modify (Модифицировать), расположенной на вкладке Members (Члены) диалогового окна Class Info (Информация о классе), вы можете изменить параметры объектов, свойств и методов объектов, входящих в класс. При нажатии на эту кнопку открывается диалоговое окно Edit Property/Method (Редактирование свойства/метода) (рис. 19.20), которое содержит таблицу с перечнем всех объектов, свойств и методов (табл. 19.9).

Таблица 19.9. Назначение столбцов таблицы диалогового окна Edit Property/Method

Столбец | Назначение
Name (Наименование) | Наименование объекта, свойства или метода
Туре (Тип) | Тип объекта: 0 — объект, М — метод, Р — свойство
Access (Доступ) | Данный столбец указывает, создан ли метод Access для свойства
Assign (Назначение) | Данный столбец указывает, создан ли метод Assign для свойства
Visibility (Видимость) | Определяет тип свойства или метода


Использование пользовательских классов для создания объектов формы

В данной главе был рассмотрен пример создания класса формы, причем при создании кнопок перемещения по записям и выхода использовался базовый класс кнопки. Теперь, после создания собственных классов кнопок, можно заменить базовые классы на пользовательские. Для этого выполните следующие действия:

  1. Откройте Проект Sales.
  2. В окне проекта перейдите на вкладку Classes (Классы), выберите в библиотеке Forms (Формы) класс bcSingieTabie и нажмите кнопку Modify (Модифицировать).
  3. В окне конструктора классов появится созданный нами ранее пользовательский класс формы для просмотра данных из одиночной таблицы.
  4. Удалите из него созданные ранее кнопки.
  5. Нажмите кнопку View Classes (Показать классы) WI на панели инструментов Form Controls (Элементы управления формы).
  6. На экране появляется меню кнопки, содержащее список библиотек классов, а также команду Add (Добавить), которая позволяет добавить в этот список новую библиотеку. Выберите команду Add (Добавить).
  7. В открывшемся диалоговом окне Open (Открыть) выберите созданную пользовательскую библиотеку Buttons (Кнопки) и нажмите Open (Открыть). В результате выбора наименования библиотеки классов в меню кнопки View Classes (Показать классы) появляется команда Buttons (Кнопки).
  8. Выберите команду Buttons (Кнопки). На панели инструментов Form Controls (Элементы управления формы) размещаются значки классов выбранной библиотеки. Теперь можно размещать эти объекты в классе обычным образом.
  9. Выберите на панели инструментов кнопки перемещения по записям и кнопку выхода из формы и разместите их в форме. Создание кнопок управления на этом заканчивается, т. к. действия, выполняемые ими, наследуются из классов кнопок. Вкладка Other (Другие) окна свойств содержит наименования класса объекта и библиотеки классов (рис. 19.17).

Рис. 19.17. Размещение объекта, основанного на пользовательском классе


ГЛАВА 19
Визуальное объектно-ориентированное программирование

Visual FoxPro — это полнофункциональный язык объектно-ориентированного программирования. Он предлагает мощные средства для интерактивной работы и создания приложений, предназначенных для управления реляционными базами данных. И, что не менее важно, этот язык прост в изучении. Кроме того, программы, написанные на языке Visual FoxPro 7.0, будут совместимы с программами, написанными на Visual FoxPro предыдущих версий.

Разработка объектно-ориентированных приложений начинается с моделирования реальных объектов, необходимых для выполнения конкретного задания. При создании приложения вы взаимодействуете с хорошо знакомыми объектами: таблицами баз данных, формами, цветовыми схемами. Создание каждого объекта предполагает использование Visual FoxPro. Вам предоставляется возможность скопировать созданные объекты из одного приложения в другое и тем самым сократить объем работы. Например, если вы создали кнопку, которая предназначена для поиска фамилии клиента в указанной таблице, то вы можете использовать эту же кнопку в другом приложении. Вам потребуется лишь изменить наименование поля и таблицы, в которых будет осуществляться поиск.

Visual FoxPro позволяет сэкономить ваше время и деньги на каждом этапе процесса создания приложения. На начальной стадии время, затраченное на разработку прототипов, не пропадает даром. Вы можете сохранить каждый прототип в качестве класса и использовать при создании новых форм. На следующих стадиях разработки приложения (и даже после того, как работа над приложением уже завершена) вы можете в любой момент вернуться к нужному объекту и изменить или расширить его свойства, не нарушая целостности других объектов. Сопровождение и модификация приложений, написанных на Visual FoxPro, осуществляется гораздо более эффективно и требует меньших затрат по сравнению с традиционными линейными программами.

Использование классов

Классы и объекты тесно связаны друг с другом, но, тем не менее, эти понятия не тождественны. Класс содержит информацию о том, как должен выглядеть объект и определяет выполняемые им действия. Объект является экземпляром класса, который наследует характеристики класса.


  • Использование классов
  • Базовые классы Visual FoxPro
  • Использование базовых классов при создании форм
  • Использование вложенных объектов
  • Создание пользовательских классов
  • Создание пользовательского класса на основе базовых классов Visual FoxPro в конструкторе классов
  • Создание класса типа "форма"
  • Библиотека классов
  • Создание подклассов
  • Использование пользовательских классов для создания объектов формы
  • Просмотр информации о классе и определение значка для его обозначения
  • Формирование списка библиотек, используемых в конструкторах форм и классов
  • Создание форм на основе пользовательских классов
  • Форма просмотра информации о клиентах на основе пользовательских классов
  • Использование формы для создания класса
  • Средство Class Browser
  • Управление классами
  • Создание панели инструментов


Вкладка Содержание

Первой вкладкой окна справочной системы является вкладка Содержание(см. рис. 2.9). Эта вкладка реализует наиболее традиционный подход к получению справочной информации.

Когда вы первый раз открываете вкладку Содержание, то видите перечень разделов справочной системы. Перед наименованием каждого раздела отображается значок. В начальный момент все разделы закрыты, чему соответствует значок закрытой книги.

Для открытия какого-либо из разделов установите курсор на открываемый раздел и нажмите кнопку мыши. В результате значок примет вид открытой книги. При повторном нажатии кнопки мыши на значке открытой книги раздел закрывается.

Открытый раздел может содержать подразделы и темы (рис. 2.10). Теме соответствует значок, имеющий вид открытой страницы. Для вывода содержимого определенной темы в правой области окна справки установите курсор на ее название или соответствующий ей значок и нажмите кнопку мыши.

Рис. 2.10. Перемещаясь по иерархии на вкладке Содержание, можно найти раздел с нужной справочной информацией

Вы можете последовательно получить справку по нескольким темам одного раздела, не прибегая к кнопкам справочной системы, поскольку в тексте справки имеются ссылки, по которым может быть осуществлен переход.


Окно справочной системы

На рис. 2.9 представлено окно справочной системы Visual FoxPro 7.0, открывающееся при выборе в меню Help (Справка) команды Microsoft VisualFoxPro Help (Справочная система Visual FoxPro).

Это окно разделено на две области. В левой области окна справочной системы расположены четыре вкладки, на которых осуществляется поиск требуемой информации. Правая область окна содержит информацию выбранного раздела.

С помощью курсора можно управлять шириной областей окна справки. Для этого выполните следующие действия:

  1. Установите курсор на разделительную полосу между областями.
  2. Когда курсор примет вид двунаправленной стрелки, нажмите левую кнопку мыши и, удерживая ее в нажатом состоянии, перемещайте в ту или иную сторону в зависимости от того, какую область вы расширяете.
  3. После задания нужного размера области отпустите кнопку мыши.

Рис. 2.9. Окно справочной системы Microsoft Visual FoxPro 7.0

Окно справочной системы имеет собственные меню и панель инструментов.

Левая область окна справочной системы содержит четыре вкладки, предназначенные для упрощения поиска необходимой информации (табл. 2.7).

Таблица 2.7. Назначение вкладок, предназначенных для упрощения поиска информации

Вкладка | Назначение
Содержание | Поиск информации по оглавлению справочной системы
Указатель | Поиск тем по начальным буквам названия темы
Поиск | Поиск ключевых слов и фраз в темах системы
Избранное | Содержит избранные темы справочной

Рассмотрим более подробно работу с вкладками справочной системы.


Справочная системаVisual FoxPro

При разработке приложений в Visual FoxPro, как и в любой другой системе, неоднократно возникает необходимость просмотра возможностей средств программирования, отдельных команд и функций. В Visual FoxPro, кроме традиционной справочной системы, вы можете найти интересующую вас информацию во встроенной документации, многочисленных примерах, а также на Web-страницах. Все эти средства вы можете выбрать из меню Help(Справка).

Подобно большинству наиболее популярных программ, Visual FoxPro имеет контекстно-зависимую справочную систему, т. е. вы можете получить справку по использованию средства, с которым работаете в настоящий момент. Для этого можно воспользоваться одним из следующих способов.

  • Выберите в меню Help (Справка) команду Microsoft Visual FoxPro Help (Справочная система Visual FoxPro).
  • Нажмите <F1> в любой момент сеанса работы с Visual FoxPro. Справочная система считает, что вас интересует информация о текущей операции, и соответственно выбирает раздел справочника.
  • Некоторые из диалоговых окон содержат на панели инструментов илинепосредственно в окне кнопку Help (Справка). Если кнопка Help(Справка) была нажата при работе в одном из них, Visual FoxPro сообщито том, как пользоваться этим диалоговым окном (рис. 2,8).

Рис. 2.8. Справочная система Visual FoxPro подсказывает, как работать с текущим диалоговым окном


Выход из Visual FoxPro

Чтобы завершить работу с программой Visual FoxPro, вам необходимо ее закрыть. Для этого воспользуйтесь одним из следующих способов:

  • выберите в меню File (Файл) команду Exit (Выход);
  • выберите команду Закрыть в системном меню главного окна VisualFoxPro;
  • щелкните на значке Visual FoxPro в заголовке главного окна;
  • введите в командном окне команду QUIT.

Если вы не сохранили форму, отчет, запрос или какой-либо другой объект приложения, Visual FoxPro предложит вам сохранить его. Для этого на экране появляется диалоговое окно, аналогичное представленному на рис. 2.7.

Рис. 2.7. Диалоговое окно, появляющееся при попытке выхода из Visual FoxPro без сохранения информации

Для продолжения операции нажмите одну из кнопок (табл. 2.6).

Таблица 2.6. Назначение кнопок диалогового окна, появляющегося при попытке выхода из Visual FoxPro без сохранения информации

Кнопка | Назначение
Yes (Да) | Сохранение файла и выход из Visual FoxPro; если файлу еще не присвоено имя, Visual FoxPro открывает диалоговое окно Save As(Сохранить как)
No (Нет) | Выход из Visual FoxPro без сохранения файла
Cancel (Отмена) | Закрытие текущего диалогового окна и возвращение в VisualFoxPro


Краткий обзор меню Visual FoxPro

При работе с Visual FoxPro вы можете использовать как кнопки панели инструментов, так и строку меню, все команды которого являются иерархическими. При выборе определенной команды открывается ее подменю.

При отсутствии в главном окне Visual FoxPro других открытых окон, строка меню содержит пункты File (Файл), Edit (Правка), View (Вид), Tools(Сервис), Program (Программа), Windows (Окна) и Help (Справка). При открытии окон в меню добавляются команды, применимые только к объектам данного окна. Например, при работе с таблицами в главное меню добавляется пункт меню Table (Таблица), при открытии на экране формы в меню появляется пункт Form (Форма).

Совет

При выборе команды в строке состояния появляется ее краткое описание.

Выполнение команд меню

Выполнение команд меню в Visual FoxPro осуществляется стандартными для Windows действиями. Вы можете использовать как мышь, так и клавиатуру. Перечислим возможные способы.

  • При использовании мыши установите курсор на пункт меню, содержащий выбираемую команду, и нажмите кнопку мыши. Если команда содержит подменю, выберите в нем требуемую команду.
  • При использовании клавиатуры сначала активизируйте строку меню нажатием клавиши <F10> или <Alt>. Затем установите указатель на требуемую команду с помощью стрелок и нажмите <Enter>.
  • Клавиша используется для перемещения на команду, находящуюся левее текущей. При нажатии на эту клавишу, когда текущая команда является самой левой, вы переместитесь в системное меню. Дальнейшее нажатие на клавишу установит указатель на самую правую команду строки меню. Остальные клавиши используются аналогично.
  • Для наиболее часто выполняемых команд вы можете запомнить связанные с ними "горячие" клавиши, которые состоят из комбинации символа<Alt> и подчеркнутого символа в имени команды. При использовании "горячих" клавиш не требуется нажимать клавишу <Enter>.

Отказ от выполнения команды меню

Если строка меню активизирована, но вы решили не выполнять команды меню, воспользуйтесь одним из следующих способов.

  • Нажмите клавишу <F10>.
  • Щелкните кнопкой мыши в любом свободном месте основного окна VisualFoxPro.

Если вы находитесь в подменю, для возврата в меню предыдущего уровня нажмите клавишу <Esc>.

Команды меню File

Меню File (Файл) содержит команды, связанные с доступом к файлам. Эти команды позволяют создавать новые файлы разных типов, открывать существующие файлы, закрывать, сохранять и печатать их.

Команда Save As HTML (Сохранить файл в формате HTML) открывает соответствующее диалоговое окно, позволяющее сохранить текущую форму, меню, отчет или таблицу в формате HTML (HyperText Markup Language).

Очень удобна команда Revert (Возвратить), позволяющая отменить все изменения файла, сделанные в текущем сеансе редактирования.

В нижней части меню располагаются имена последних четырех открывавшихся проектов, которые предоставляют возможность быстрого открытия любого из них. Последней командой этого меню является команда Exit (Выход). Она аналогична действию команды QUIT (Выход) в командном окне и предназначена для выхода из Visual FoxPro.

Команды меню Edit

Меню Edit (Правка) имеется во многих приложениях Windows. В VisualFoxPro команды этого меню используются при создании форм и отчетов, редактировании программ.

Команды Paste Special (Специальная вставка), Insert Object (Вставить объект), Object (Объект) и Links (Связи) применимы только к полям типа General и OLE-объектам. Остальные команды применяются при редактировании как программ, так и полей таблиц.

Незнакомой для вас по другим приложениям Windows может оказаться команда Go to Line (Переход на строку), предназначенная в Visual FoxPro для работы с программами. С помощью данной команды можно переходить к строке с указанным номером в тексте программы.

При вводе имени объекта, свойства, команды или функции после ввода активизирующего символа (как правило, точка, пробел или открывающая скобка) команда List Members Visual FoxPro активизирует список допустимых значений (свойств, методов, событий и объектов) для указанного в редакторе объекта.

Последняя в меню — команда Properties (Свойства), при выборе которой открывается диалоговое окно Edit Properties (Редактирование свойств), позволяющее задавать параметры сохранения программных файлов, просматривать их свойства, дату последнего редактирования и занимаемый объем на диске.

Команды меню View

Пункт меню View (Вид) содержит команды, управляющие просмотром текущего открытого файла. Если вы не просматриваете файл, то меню содержит всего одну команду Toolbars (Панели инструментов). Эта команда открывает диалоговое окно, в котором перечислены панели инструментов, используемые при работе в Visual FoxPro.

При работе в конструкторах в меню View (Вид) содержатся команды, управляющие отображением используемых в данном режиме работы панелей инструментов. Так, например, при работе в конструкторе форм в меню появляются команды для выбора следующих панелей: Color Palette (Цветовая палитра), Layout (Расположение), Form Designer (Конструктор форм) и Form Controls (Элементы управления формы).

При просмотре таблиц или редактировании форм, меню или отчетов в меню появляются дополнительные команды. Например, если вы работаете с таблицами, в меню появляется несколько новых команд. Команды Edit(Редактирование) и Browse (Обзор) переводят таблицу в режим просмотра и редактирования содержащихся в ней записей. Отличие между этими двумя командами состоит в стиле отображения содержимого таблицы.

Команды меню Format

Меню Format (Формат) содержит команды, управляющие характеристиками шрифта, выравниванием текста и объектов, определением интервалов между объектами. Однако при работе с различными конструкторами становятся доступными и дополнительные команды.

Команды меню Tools

Это меню содержит мастера и средства отладки программ.

Первой в меню Tools (Сервис) располагается команда Wizards (Мастера),открывающая список мастеров Visual FoxPro. Мастер — это программа, которая помогает пользователю в решении таких задач, как создание форм, отчетов, таблиц. Процесс создания при этом заключается в ответах на вопросы мастера относительно создаваемого объекта.

Далее в меню расположена команда Macros (Макрос), предназначенная для создания макросов.

Команда Debugger (Отладчик) предназначена для отладки. Она открывает диалоговое окно Visual FoxPro Debugger, в котором вы можете просмотреть значения переменных, элементов массива, полей, возвращаемые значения функциями Visual FoxPro и т. д,

Команда Component Gallery (Галерея компонентов) открывает окно Catalogs —Component Gallery (Каталоги — галерея компонентов) для работы в Галерее компонентов Visual FoxPro. Команда Coverage Profiler (Анализ выполнения)позволяет просмотреть информацию о выполненной программе. Команда Run Active Document (Запуск активного документа) открывает одноименное диалоговое окно для выбора активного документа и его запуска.

В Visual FoxPro 7.0 в меню Tools (Сервис) появились новые команды: ObjectBrowser (Обзор объектов), IntelHSense Manager (Менеджер IntelliSense), TaskList (Список заданий), Document View (Просмотр документа).

Команда Object Browser (Браузер объектов) открывает одноименное окно, позволяющее просматривать классы, свойства, методы, события и константы выбранных библиотек.

Команда IntelliSense Manager (Менеджер IntelliSense) открывает окно настройки параметров, управляющих анализом синтаксиса вводимых в окнередактора программных конструкций.

Команда Task List (Список заданий) позволяет запомнить место, в которое вы можете вернуться впоследствии нажатием оперативной клавиши. Кроме того, данная команда позволяет вводить список необходимых задач, аналогично Microsoft Outlook.

Команда Document View (Просмотр документа) открывает диалоговое окно, в котором отображается список процедур, функций и операторов для открытой в окне редактора программы. При выборе элемента списка осуществляется переход на этот элемент в окне редактора.

Последняя команда в меню Tools (Сервис) — Options (Параметры). С ее помощью можно настраивать конфигурацию Visual FoxPro

Команды меню Program

Меню Program (Программа) содержит команды, связанные с выполнением и компиляцией программ.

Команды меню Windows

В меню Windows (Окна) имеются команды, которые управляют открытыми на экране окнами. С помощью этих команд можно упорядочивать, скрывать, очищать окна и переходить из одного окна в другое. Кроме того, команды данного меню позволяют активизировать любое открытое окно.

Команда Command Window (Командное окно) из меню Windows (Окно) активизирует командное окно Command (Команда), позволяющее использовать команды при работе с Visual FoxPro.

Команда Properties Window (Окно свойств) открывает диалоговое окно Properties (Свойства), позволяющее просмотреть и изменить свойства объектов, расположенных в форме курсоров и отношений.

Для открытия окна Data Session (Окно данных), которое содержит список всех открытых в данном сеансе таблиц и отношений между ними (рис. 2.6),используется команда Data Session (Окно данных).

Рис. 2.6. Окно Data Session показывает рабочие области с открытыми таблицами и отношениями между ними

В центре окна Data Session (Окно данных) находятся кнопки управления таблицами. Кнопка Properties (Свойства) открывает окно, позволяющее просмотреть и изменить текущие свойства таблицы. Для открытия таблицы в новой рабочей области используется кнопка Open (Открыть). Кнопка Browse (Обзор таблицы) открывает таблицу для просмотра содержащихся в ней записей. Кнопка Close (Закрыть) окна Data Session (Окно данных) закрывает таблицу в текущей рабочей области, а кнопка Relations (Отношения) позволяет определить отношения между открытыми таблицами.

Команды меню Help

Help (Справка) — последнее меню главного окна. Табл. 2.5 содержит список команд, доступных в этом меню. Этот список претерпел некоторые изменения в Visual FoxPro 7.0 по сравнению с предыдущей версией программы.

Таблица 2.5, Назначение команд меню Help

Команда меню | Назначение
Microsoft Visual FoxProHelp (Справочная системаVisual FoxPro) | Открывает окно справочной системы Visual FoxPro 7.0
MSDN Search (Поиск в MSDN) | Ищет справочную информацию в MSDN
Technical support (Техническая поддержка) | Отображает информацию о технической поддержке,оказываемой Microsoft
Visual FoxPro on the Web (Visual FoxPro на Web-страницах) | Открывает Web-страницу Microsoft Visual FoxPro. Для использования этой команды необходим доступ в Интернет
About Microsoft VisualFoxPro (0 программеMicrosoft Visual FoxPro) | Открывает диалоговое окно About Microsoft Visual FoxPro, в котором содержится информация об авторских правах напрограмму, номер версии программы и ее идентисрикатор,имя файла ресурсов и используемый по умолчанию каталог. В этом окне можно также посмотреть разнообразнуюинформацию о компьютере, ресурсах системы


Знакомство со стандартной панелью инструментов Visual FoxPro

В Visual FoxPro имеется большое количество панелей инструментов, используемых при создании форм, отчетов и запросов. Мы их подробно рассмотрим в соответствующих главах. Сейчас вы познакомитесь со стандартной панелью инструментов (рис. 2.3), которая используется во всех режимах работы.

Рис. 2.3. Стандартная панель инструментов Visuai FoxPro

Назначение кнопок стандартной панели инструментов описано в табл. 2.3.

Таблица 2.3. Назначение кнопок стандартной панели инструментов

Название | Назначение
New (Новый) | Создает новый файл
Open (Открыть) | Открывает существующий файл
Save (Сохранить) | Сохраняет открытый файл
Print One Copy (Печатать одну копию) | Печатает содержимое активного окна
Print Preview (Просмотр печати) | Открывает окно предварительного просмотра печатаемого документа
Cut (Вырезать) | Удаляет выделенный текст или выделенные объекты и помещает их в буфер
Сору (Копировать) | Копирует в буфер выделенный текст или выделенные объекты, не удаляя их
Paste (Вставить) | Вставляет содержимое буфера. Действие этой кнопки зависит от того, в каком из режимов выработаете
Undo (Отменить) | Отменяет последнее выполненное действие
Redo (Восстановить) | Восстанавливает отмененные действия
Run (Выполнить) | Запускает на выполнение
Database (База данных) | Содержит список открытых баз данных
Command Window (Командное окно) | Открывает командное окно
Data Session Window (Окно сеансаданных) | Открывает окно Data Session (Сеанс данных)
Properties Window (Окно свойств) | Открывает окно Properties (Свойства), используемое для настройки свойств
Document ViewWindows (Окно просмотра документа) | Открывает окно Document View (Просмотр документа), в котором отображается список процедур, функций открытой в окне редактора программы
Class Browser (Обзор классов) | Открывает окно Class Browser (Обзор классов),предназначенное для работы с классами
Object Browser (Обзор объектов) | Открывает окно Object Browser (Обзор объектов),позволяющее просматривать классы, свойства, методы, события и константы выбранных библиотек

Замечание

Если по внешнему виду кнопки вы не можете определить ее назначение, установите курсор мыши на кнопку. При этом под курсором появится всплывающаяподсказка с ее наименованием, а в левой части строки состояния будет выведено краткое описание указанной кнопки.

По умолчанию в главном окне программы Visual FoxPro всегда присутствуетстандартная панель инструментов, если только вы не удалили ее с экрана.Если для работы вам необходима панель инструментов, а она не отображается на экране, выполните следующие действия:

  1. Выберите в меню View (Вид) команду Toolbars (Панели инструментов).Откроется диалоговое окно Toolbars (Панели инструментов) (рис. 2.4), в котором расположен список всех панелей инструментов программы Visual FoxPro.
  2. Установите флажки слева от наименований тех панелей, которые вы хотите разместить в главном окне.
  3. Нажмите кнопку ОК.

Используя флажки, расположенные в нижней части диалогового окна Toolbars (Панели инструментов), вы можете изменить вид кнопок панелей инструментов. Назначение этих флажков описано в табл. 2.4.

Таблица 2.4. Назначение флажков диалогового окна Toolbars

Флажок | Назначение
Color buttons {Цветные кнопки) | Кнопки на панели инструментов становятся цветными
Large buttons (Большие кнопки) | Увеличивается размер кнопок
ToolTips (Подсказка) | Выводится краткое описание кнопки при установке курсора на нее

Рис. 2.4. Диалоговое окно Toolbars

Рис. 2.5. Панель инструментов можно расположить в любом месте главного окна

После установки Visual FoxPro стандартная панель инструментов размещается в верхней части главного окна, но она, как и все остальные панели инструментов, может перемещаться в любое место экрана. Для этого установите курсор мыши в любое свободное от кнопок место на панели инструментов, нажмите кнопку мыши и, не отпуская ее, переместите панель на новое место. Если вы поместите панель инструментов не по краям главного окнаVisual FoxPro, то сможете изменять ее размер (рис. 2.5).


Системное меню и системные кнопки

Заголовок главного окна содержит уменьшенную копию значка программы, текст Microsoft Visual FoxPro и кнопки управления размерами главного окна. При щелчке на значке пиктограммы открывается системное меню, содержащее команды перемещения и изменения размеров главного окна. В табл. 2.1 приведены команды, доступные из системного меню.

Таблица 2.1. Назначение команд системного меню

Команда | Назначение
Восстановить | Восстанавливает предыдущий размер окна после минимизацииили максимизации
Переместить | Активизирует главное окно Visual FoxPro и позволяет перемещать его с помощью клавиш перемещения курсора
Размер | Активизирует главное окно Visual FoxPro и позволяет изменятьего размеры с помощью клавиш перемещения курсора
Свернуть | Свертывает главное окно FoxPro до размера кнопки и помещаетее на панель задач Windows
Развернуть | Развертывает главное окно Visual FoxPro во весь экран
Закрыть | Закрывает главное окно программы Visual FoxPro

Совет

Для быстрого закрытия программы Visual FoxPro дважды щелкните на уменьшенной копии значка программы в заголовке главного окна.

Текст Microsoft Visual FoxPro заголовка главного окна, в случае необходимости, можно легко изменить, присвоив главному окну Visual FoxPro любое другое название или удалив название вообще. Для этого введите в командном окне следующую команду:

MODIFY WINDOW SCREEN TITLE "Новый заголовок главного окна"

или

_SCREEN.caption = "Новый заголовок главного окна"

В правой стороне заголовка расположены кнопки управления окном. Их назначение описано в табл. 2.2.

Таблица 2.2. Назначение кнопок управления окном

Название | Назначение
Свернуть | Сворачивает главное окно FoxPro до размера кнопки и помещает ее на панель задач Windows
Восстановить | Уменьшает размер развернутого окна, позволяя в дальнейшем изменять его
Развернуть | Развертывает главное окно Visual FoxPro во весь экран
Закрыть | Закрывает главное окно Visual FoxPro, тем самым, прекращая работу программы


Главное окно Visual FoxPro

На рис. 2.2 показано главное окно Visual FoxPro, каким оно выглядит после запуска программы.

В нем можно выделить шесть основных областей: заголовок окна, строка меню, панель инструментов, строка состояния, рабочая область и командное окно Command (Команда).

Заголовок находится в верхней части главного окна и содержит три объекта: копию значка программы Visual FoxPro, заголовок главного окна и значки управления этим окном.

Рис.2.1. Запуск Microsoft Visual FoxPro 7.0 из главного меню Windows

Рис. 2.2. Главно е окно Visual FoxPro 7.0

Строка меню содержит иерархическое меню Visual FoxPro. Список пунктов меню зависит от типа активного окна.

Visual FoxPro предоставляет в распоряжение пользователя много самых разнообразных панелей инструментов для работы с базами данных, формами, отчетами и запросами. Эти панели инструментов содержат набор кнопок, причем этот набор зависит от назначения конкретной панели инструментов. После запуска Visual FoxPro на экране отображается стандартная панель инструментов.

В нижней части главного окна расположена строка состояния, в которую выводится информация о текущем состоянии активного окна, краткое описание выбранной кнопки панели инструментов или пункта меню. Вид отображаемой в строке состояния информации зависит от типа активного окна. Например, в окне конструктора форм в строке состояния выводится наименование активного объекта формы, а при просмотре таблицы в режиме Browse (Обзор таблицы) в левой части строки состояния отображается наименование открытой таблицы, в середине строки состояния — номер текущей записи и индикатор режима работы.

В процессе работы в главном окне Visual FoxPro открываются окна конструкторов форм, отчетов, запросов, проекта и другие окна. Все они являются дочерними по отношению к главному окну и закрываются при его закрытии. Кроме того, если при выходе из Visual FoxPro вы не закрыли окно проекта, с которым работали, то оно откроется по умолчанию в главном окне при следующем запуске программы.


Просмотр справочной информациив Интернете

Справочная система Visual FoxPro содержит огромный объем информации, необходимой для разработки приложений. Для получения последних новостей о Visual FoxPro вы можете открыть соответствующую Web-страницунепосредственно из главного окна Visual FoxPro. Используйте для этого команду Microsoft on the Web (Visual FoxPro на Web-страницах) меню Help(Справка).

Замечание

Просмотр Web-страниц невозможен, если вы не имеете доступа к Интернету. Для получения доступа необходимо установить на компьютере модем и зарегистрироваться у местного провайдера услуг Интернета.

На рис. 2.15 приведена страница новостей Visual FoxPro, поддерживаемая Microsoft. В левой части вы видите содержание разделов, которые найдете на других Web-страницах, посвященных Visual FoxPro. После щелчка на названии интересующего вас раздела начнет загружаться Web-страница, содержащая информацию по данному разделу.

Рис. 2.15. Страница новостей Visual FoxPro


Вкладка Избранное

Вкладка Избранное (рис. 2.14) позволяет сформировать список наиболее часто используемых тем справочной системы, выбор которых должен осуществляться достаточно просто.

По умолчанию данная вкладка пуста. Для добавления темы справки на вкладку Избранное вам необходимо выполнить следующие действия:

  1. Используя другие вкладки окна справочной системы, найдите тему, название которой хотите расположить на данной вкладке.
  2. Отобразите найденную информацию в правой области окна справки.
  3. Перейдите на вкладку Избранное. Название просматриваемой темы отображается в поле Текущий раздел данной вкладки.
  4. Нажмите кнопку Добавить. Наименование текущей темы справочной системы будет добавлено в список избранных тем.

Аналогичным образом добавьте в данную область все необходимые разделы справочной системы. Для удаления разделов с этой вкладки используйте кнопку Удалить.

Рис. 2.14. Вкладка Избранное


Вкладка Поиск

Для поиска по ключевым словам и фразам используется вкладка Поиск. В поле ввода Искать следующие слова введите слово или фразу, предназначенную для поиска. Если требуется найти фразу, вы должны заключить ее в одинарные или двойные кавычки. При поиске можно использовать также знаки "?" (для обозначения одного произвольного символа) и "*" (для обозначения любого количества символов).

Кроме того, для поиска вы можете использовать логические выражения, составленные из слов, применяя логические операторы, представленные в табл. 2.8.

Таблица 2.8. Логические операторы, используемые при построении выражений для поиска

Оператор | Пример выражениядля поиска | Результат
AND | properties AND formилиproperties & form | Отображаются только те темы справки, которые содержат оба слова
OR | properties OR formилиproperties | form | Отображаются темы справки, в которых содержится любое из двух слов
NEAR | properties NEAR form | Отображаются темы справки, в которых первое слово находится рядом со вторым словом в пределах восьми соседних слов
NOT | properties NOT formилиproperties ! form | Выбираются только те темы справки, в которых содержится первое слово и не содержится слово, расположенное после оператора NOT

Построив выражение для поиска, нажмите кнопку Разделы. Начнется поиск разделов, содержащих заданное выражение, и на вкладке Поиск в таблице Раздел отобразится их список.

Таблица Раздел состоит из трех столбцов. Столбец Заголовок содержит заголовки найденных тем справочной системы, столбец местонахождение —информацию о местонахождении темы справки, а столбец Ранг — частоту вхождения элемента поиска.

Рис. 2.13. Поиск по ключевым словам

В окончательном списке тем будут расположены первые 500 тем справок, удовлетворяющих заданному условию поиска. Для упорядочения тем справок таблицы Раздел можно использовать заголовки столбцов таблицы. Для этого щелкните на заголовке того столбца, по которому хотите осуществить упорядочение.

Из списка найденных тем выберите нужную и нажмите кнопку Показать. В правой области окна справки будет выведена информация по данной теме. В тексте темы справки будут выделены те слова, которые были заданы для поиска (рис. 2.13).

Для определения параметров поиска на вкладке добавлены флажки, при установке которых пользователю предоставляются дополнительные возможности (табл. 2.9).

Таблица 2.9. Назначение флажков для определения параметров поиска

Флажок | Назначение
Предыдущий поиск | Поиск среди тем справочной системы, которые были отобраны в предыдущем поиске
Похожие слова | Поиск не только слов, заданных в выражении поиска, но и слов, похожих на них
Только в заголовках | Поиск только в заголовках тем справок


Поиск справки по предметному указателю

Для поиска справки по предметному указателю откройте вкладку Указатель(рис. 2. 11. ) окна справочной системы. В верхней части вкладки расположено поле, предназначенное для ввода ключевого слова, по которому будет осуществляться поиск. Ниже него находится список ключевых слов, упорядоченный по алфавиту.

По мере ввода букв в поле ввода, в списке ключевых слов появляются разделы, первые буквы названий которых совпадают с уже введенными буквами.

Рис. 2.11. Вкладка Указатель для поиска раздела по начальным буквам названия темы

Вы можете просто просмотреть список ключевых слов с помощью полосы прокрутки, выделить нужный раздел, а затем нажать кнопку Показать. В правой области окна появится текст справки.

Для поиска информации с использованием вкладки Указатель введите начальные буквы темы, которую вы хотите найти. В качестве примера было введено properties (рис. 2.11). Если справочная система обнаружит в списке названия тем, начинающихся с указанной буквы, они будут выделены цветом или подсвечены. Если условию поиска удовлетворяет несколько тем, появится окно Найденные разделы (рис. 2.12) со списком разделов. Выберите из этого списка требуемую тему и нажмите кнопку Показать. Информация об указанной теме будет выведена в правой области окна справочной системы.

Рис. 2.12. Диалоговое окно Найденные разделы


ГЛАВА 2
Начало работы с Visual FoxPro

Вы приступаете к работе с Visual FoxPro 7.0. Многое из того, с чем вам придется работать (меню, панели инструментов, диалоговые окна), покажутся знакомыми, т. к. они характерны для среды Windows.

Запуск Visual FoxPro

Для запуска программы из главного меню Windows выполните следующие действия:

  1. Нажмите кнопку Пуск, расположенную в нижней части экрана.
  2. В открывшемся главном меню Windows выберите команду Программы. Появится меню данной команды.
  3. Выберите в меню команду Microsoft Visual FoxPro 7.0 (рис. 2.1). На экране откроется главное окно Visual FoxPro 7.0 (рис. 2.2).

Для более быстрого запуска программы Visual FoxPro 7.0 вы можете создать на Рабочем столе ярлык и назначить ему клавиши быстрого вызова. Тогда вам достаточно нажать заданную комбинацию клавиш, в каком бы окне Windows вы ни находились, и программа запустится. Кроме того, для удобства запуска приложения можно использовать панель Быстрый запуск системы Windows(см. рис. 2.1), поместив на нее значок программы Visual FoxPro.


  • Запуск Visual FoxPro
  • Главное окно Visual FoxPro
  • Системное меню и системные кнопки
  • Знакомство со стандартной панелью инструментов Visual Fox Pro
  • Краткий обзор меню Visual FoxPro
  • Выход из Visual FoxPro
  • Справочная система Visual FoxPro
  • Окно справочной системы
  • Вкладка Содержание
  • Поиск справки по предметному указателю
  • Вкладка Поиск
  • Вкладка Избранное
  • Просмотр справочной информации в Интернете


Использование буферов

Одним из мощных средств организации многопользовательской работы в Visual FoxPro является буферизация данных, которая позволяет лучше использовать локальные ресурсы и снижает нагрузку на сеть. При буферизации все сделанные вами изменения хранятся в оперативной памяти на рабочей станции и не обновляются на файл-сервере, пока вы не выполните соответствующую команду.

В Visual FoxPro используются два типа буферизации: буферизация таблиц и записей. При буферизации записей после завершения редактирования записи (при изменении позиции указателя записи или при вызове функции TABLEUPDATE), все изменения записываются в базу данных. При буферизации таблиц измененные данные' сохраняются в базе данных только при закрытии таблицы или вызове функции TABLEUPDATE (}.


Сеансы работы с данными

В Visual FoxPro для многопользовательской работы вы можете использовать сеансы работы с данными, которые представляют из себя среду окружения, связанную с формой или набором форм. С помощью сеансов работы с данными вы можете открывать одну и ту же форму на разных рабочих станциях или даже на одном компьютере (рис. 20.1), при этом каждая из них будет использовать отдельную копию данных.

Для управления сеансом работы с данными предназначено свойство DataSession (Окно данных) формы, которое можно установить равным 1 или 2. Если вы установите свойство DataSession равным 1, любые изменения, выполненные вами в форме, будут отображаться во всех остальных открытых формах. Это обычный режим работы. Дня открытия копии среды окружения установите значение 2, при этом изменения в данной форме не будут отображаться в других формах. Количество открытых сеансов ограничивается только доступной оперативной памятью и местом на жестком диске.

Рис. 20.1. Открытие сеансов работы на одном компьютере

Рис. 20.2. Выбор сеанса работы

Для выбора сеанса работы вы можете выполнить любое из следующих действий.

  • Открыть окно Data Session (Окно данных) и из раскрывающегося списка Current session (Текущий сеанс) выбрать требуемый сеанс работы (рис. 20.2).
  • Выполнить в командном окне команду SET DATASESSION ТО номерСеанса.


Снятие блокировок таблиц и записей

В большинстве случаев при переходе от одной записи к другой блокировка снимается. Однако, если вы заблокировали запись командами блокировки, ее необходимо разблокировать, чтобы к ней могли получить доступ другие пользователи. В табл. 20.2 описаны команды, используемые для снятия блокировок.

Таблица 20.2. Команды снятия блокировки с записей и таблиц

Команда | Описание
CLOSE | Снимает асе блокировки с записей и таблиц
CLOSE ALL | Снимает все блокировки с записей и таблиц
END TRANSACTION | Снимает все автоматически установленные блокировки
QUIT | Снимает все блокировки с записей и таблиц
UNLOCK | Снимает все блокировки с записей и таблиц в текущей рабочей области
UNLOCK ALL | Снимает все блокировки с записей и таблиц во всех рабочих областях
USE | Снимает все блокировки с записей и таблицы
SET MULTILOCKS OFF | Позволяет автоматическое снятие текущей блокировки при создании новой
FLOCK ( ) | Перед блокировкой файла снимает все блокировки находящихся в нем записей
TABLEUPDATE ( ) | Прежде чем обновить таблицу, снимает все блокировки

Наиболее часто для снятия блокировок с таблиц и записей используется команда UNLOCK, которая имеет следующий синтаксис:

UNLOCK [RECORD номерЗаписи] [IN < псевдонимТаблицы >] [ALL]

Команда UNLOCK без параметров сбрасывает блокировку с текущей записи или таблицы.

При снятии блокировки с таблицы опция RECORD не используется, задается только псевдоним таблицы. Если псевдоним не указан, снимается блокировка с текущей таблицы. Для разблокировки всех открытых таблиц используется параметр ALL. Для снятия блокировки с записи укажите параметр RECORD и номер записи.

Замечание

Блокировка записи или таблицы может сниматься только пользователем, установившим данную блокировку. Таблицы, открытые в режиме полной блокировки, с помощью команды UNLOCK разблокировать нельзя.


Установка режима повторных попыток блокировки данных

Если запись или таблица уже заблокированы, вам не удастся с первого раза установить блокировку. В этом случае вы можете использовать команду SET REPROCESS, которая задает количество дополнительных попыток заблокировать таблицу (или запись) или время, на протяжении которого будут выполняться дополнительные попытки блокировки.

Команда SET REPROCESS имеет следующий синтаксис:

SET REPROCESS ТО числоПопьггок [SECONDS] I TO AUTOMATIC

Если команда содержит опцию SECONDS, аргумент число попыток задает время в секундах, иначе — количество попыток. Аргумент число попыток может принимать целые значения в диапазоне от 1 до 32 000, по умолчанию его значение равно 0.

При использовании параметра то AUTOMATIC, а также, если значение аргумента число попыток равно 0, Visual FoxPro будет пытаться выполнить блокировку записи или таблицы до бесконечности. Во время выполнения попыток блокировки будет выводиться сообщение о том, что идет процесс блокировки. Пользователь может прервать процесс установки блокировки нажатием клавиши <Esc>.

При установке SET REPROCESS то -i Visual FoxPro также будет пытаться выполнить блокировку записи или таблицы до бесконечности. Но в этом случае пользователь не может прервать попытки заблокировать запись или таблицу.

Замечание

Успешная блокировка записи или таблицы, уже заблокированной другим пользователем, возможна только после того, как пользователь, установивший блокировку, снимет ее. Поэтому рекомендуется снимать блокировку сразу же после завершения операции, для выполнения которой требовалась блокировка.


Блокировка записей

По возможности рекомендуется использовать блокировку отдельных записей, а не таблицы в целом. Заблокированная запись может изменяться только установившим блокировку пользователем, остальные пользователи имеют к ней доступ только на чтение. Результат изменения записи будет виден другим пользователям только после снятия блокировки с записи.

Для блокировки записей используются взаимозаменяемые функции LOCK и RLOCK, синтаксис которых отличается только наименованием функции:

RLOCK([ рабочаяОбласть | псевдонимТаблицы]

| [номераЗаписей, рабочаяОбласть

| псевдонимТаблицы])

Для указания таблицы, записи которой вы собираетесь блокировать, можно использовать номер рабочей области или псевдоним таблицы. Если не указаны ни рабочая область, ни псевдоним, функция LOCK будет блокировать текущую запись таблицы, открытой в рабочей области.

Для блокировки группы записей предварительно выполните команду SET MULTILOCKS ON и с помощью аргумента номера Записей укажите номера блокируемых записей. Номера записей задаются в символьном виде и разделяются запятыми. Например, для блокировки третьей и пятой записи таблицы необходимо указать "3, 5".

Замечание

Для определения номеров записей используйте функцию RECNO ().

При успешной блокировке возвращается значение .т. (Истина) и заблокированные записи становятся доступными на чтение и запись пользователю, установившему блокировку. Остальные пользователи могут только просматривать заблокированные записи. При блокировке группы записей функция возвращает значение .т. (Истина) только в том случае, если удалось заблокировать все указанные записи. Тем не менее, записи, которые удалось блокировать, останутся заблокированными.

Если запись или таблица уже заблокированы другим пользователем, блокировка не будет выполнена и функция возвратит значение . F. (Ложь).

Совет

Для блокировки группы записей вы можете поочередно устанавливать указатель записи на блокируемую запись и выполнять команду LOCK.

Для выбора режима блокировки одной или группы записей используется команда SET MULTiLOCKS, которая имеет следующий синтаксис:

SET MULTILOCKS ON | OFF

Параметр ON разрешает блокировку группы записей, а параметр OFF разрешает блокировку только одной записи.

Замечание

Переключение установки MULTILOCKS из ON в OFF, или из OFF в ON приводит к снятию блокировки со всех записей во всех открытых таблицах.


Блокировка таблицы

Для установки блокировки изменений таблицы вы должны использовать функцию FLOCK, которая имеет следующий синтаксис:

FLOCK([псевдонимТаблицы])

Функция блокировки проверяет текущий статус таблицы. Если в результате теста определяется, что таблица не заблокирована, она блокируется, и пользователь может продолжать с ней работать. Функция при этом возвращает логическое значение .т. (Истина) и таблица становится доступной пользователю, выполнившему блокировку, на чтение и запись. Остальным пользователям таблица базы данных доступна только на чтение. Если таблица уже заблокирована другим пользователем, заблокировать таблицу не удается и функция возвращает значение .F. (Ложь). Для блокировки таблицы в текущей области псевдоним можно не указывать.

В приведенном ниже примере для блокировки таблицы customer используется команда FLOCK (). Если таблица успешно заблокирована, команда REPLACE ALL обновляет все записи в ней. После этого команда UNLOCK снимает блокировку файла. Если файл невозможно заблокировать (такая ситуация возникает, если файл уже заблокирован другим пользователем), появится сообщение об ошибке.

SET EXCLUSIVE OFF

SET REPROCESS TO 0

USE Customer

IF FLOCK()

REPLACE ALL cLastName WITH UPPER(cLastName)

UNLOCK

ELSE

WAIT "Файл занят, подождите" WINDOW NOWAIT

ENDIF

Если вы редактируете две или более связанных командой SET RELATION таблиц, вам необходимо блокировать каждую связанную таблицу самостоятельно, т. к. блокировка одной из связанных таблиц не блокирует связанные с ней таблицы. Возможны ситуации, когда вы изменяете данные только в одной таблице, а другие используются для отображения дополнительной информации и их не требуется блокировать.


Полная блокировка таблицы и блокировка изменений

В некоторых случаях, например, при изменении структуры данных, вам необходимо осуществить полную блокировку таблицы для получения исключительных прав на нее. В этом случае другим пользователям запрещается чтение, запись и изменение структуры указанной таблицы, и они не смогут получить к ней доступ. Вы не можете установить полную блокировку, если эта таблица уже открыта или для нее уже установлена блокировка.

В большинстве случаев вам достаточно ограничить изменение данных таблицы, т. е. установить блокировку изменений, которая запрещает запись, изменение структуры указанной таблицы, наложение блокировки изменений другими пользователями.

Для открытия таблицы в режиме полной блокировки используется команда SET EXCLUSIVE ON. После выполнения данной команды все открываемые таблицы будут находиться в режиме полной блокировки. Для снятия режима полной блокировки используйте команду SET EXCLUSIVE OFF. При этом полная блокировка открытых таблиц будет снята только после их закрытия. Для установки полной блокировки отдельной таблицы может быть использована опция EXCLUSIVE в команде открытия таблицы USE. Если таблица открыта в монопольном режиме, необходимость блокировки таблицы или ее записей отсутствует. После закрытия таблицы блокировка автоматически снимается.

Ниже приведены два примера установки полной блокировки таблицы. В первом примере используются две команды, а во втором — таблица открывается в режиме исключительного использования одной командой:

SET EXLUSIVE ON

USE CUSTOMER

или

USE CUSTOMER EXCLUSIVE

Некоторые команды, список которых приведен ниже, могут использоваться только в режиме полной блокировки:

  • ALTER TABLE
  • INDEX
  • INSERT [BLANK]
  • MODIFY STRUCURE
  • PACK
  • REINDEX
  • ZAP

Если вы попробуете применить одну из этих команд, не открыв таблицу для исключительного использования, FoxPro выдаст предупреждающее сообщение Exclusive Open of File Required.


Автоматическая блокировка

В Visual FoxPro может осуществляться автоматическая или ручная блокировка данных. При использовании определенных команд FoxPro попытается автоматически заблокировать записи или всю таблицу (табл. 20.1).

Таблица 20.1. Команды, автоматически блокирующие таблицу или записи

Команда | Что блокируется
ALTER TABLE | Вся таблица
APPEND | Вся таблица
APPEND BLANK | Заголовок таблицы
APPEND FROM | Вся таблица
APPEND FROM ARRAY | Заголовок таблицы
APPEND MEMO | Текущая запись
BLANK | Текущая запись
BROWSE | Текущая запись и все записи из одноименных полей в связанных таблицах
CHANGE | Текущая запись и все записи из одноименных полей в связанных таблицах
DELETE | Текущая запись
DELETE NEXT 1 | Текущая запись
DELETE <n> | Если л больше 1 , автоматически блокируется вся таблица
DELETE RECORD <n> | Автоматически блокирует п записей
DELETE SQL | Текущая запись
EDIT | Текущая запись и все записи из одноименных полей в связанных таблицах
GATHER | Текущая запись
INSERT | Вся таблица
INSERT SQL | Заголовок таблицы
MODIFY MEMO | Когда начинается редактирование записи, автоматически блокирует ее
READ | Текущая запись
RECALL | Текущая запись
RECALL NEXT 1 | Автоматически блокирует указанную запись
RECALL RECORD <n> | Блокирует п записей
RECALL <n> | Если п больше 1 , автоматически блокируется вся таблица
REPLACE | Текущая запись
REPLACE NEXT 1 | Автоматически блокирует указанную запись
REPLACE RECORD <n> | Блокирует п записей
SHOW GETS | Текущая запись
TABLEUPDATEO | Вся таблица
UPDATE | Вся таблица
UPDATE SQL | Вся таблица

Замечание

Все команды с автоматической блокировкой снимают ее после выполнения.


Использование транзакций

Под транзакцией в системах управления базами данных понимают логическую единицу работы, которая представляет собой последовательность нескольких операций, в процессе выполнения которых сохраняется целостное состояние базы данных. В процессе выполнения транзакции обновляемые данные временно хранятся в памяти или на локальном диске. Действительные изменения совершаются только после завершения транзакции. Если что-либо препятствует обновлению данных, все изменения отменяются и поэтому ваши данные остаются без изменения.

Для управления транзакциями используется три команды, представленные в табл. 20.7.

Таблица. 20.7. Команды, используемые для управления транзакциями

Команда | Назначение
BEGIN TRANSACTION | Инициирует транзакцию
ROLLBACK | Осуществляет откат, т. е. аннулирует все выполненные в течение транзакции действия
END TRANSACTION | Завершает транзакцию и сохраняет все выполненные действия в базе данных

В некоторых случаях вам может понадобиться использовать вложенные транзакции, при этом каждая из них должна начинаться командой BEGIN TRANSACTION и завершаться командой END TRANSACTION. Выполнение команды ROLLBACK действует только на транзакцию, внутри которой она выполняется. Команды BEGIN и END TRANSACTION могут находиться в разных функциях или процедурах.


Обнаружение и устранение конфликтов

При совместной работе с базой данных возможны конфликты, когда один или более пользователей пытаются заблокировать уже заблокированную другим пользователем запись. Возможны и взаимоблокировки, когда пользователь заблокировал одну запись или таблицу и пытается заблокировать вторую, которая уже заблокирована вторым пользователем. В то же время второй пользователь пытается заблокировать запись, заблокированную первым пользователем. Система буферизации записей и таблиц FoxPro упрощает разработку многопользовательских приложений и устранение возникающих конфликтов.

При попытке заблокировать уже заблокированную запись FoxPro выдает сообщение об ошибке. Для определения возникновения ошибки вы можете воспользоваться функцией TABLEUPDATE (), которая возвращает значение . F. (Ложь) при неудачной попытке сохранения данных. Кроме того, вы можете написать программу обработки ошибок и указать ее в команде ON ERROR. Для определения причины, по которой не удалось записать данные в базу данных, вы можете использовать значения кодов ошибок. Для определения кодов ошибок используется функция ERROR () или AERROR () .

При использовании буферизации данных в программе обработки ошибок вы можете определить, какие поля были изменены, каким было исходное значение поля и каким оно стало. Для определения изменения поля используется функция GETFLDSTATE (), которая по заданному номеру поля возвращает одно из значений, описанных в табл. 20.6.

Таблица 20.6. Значения, возвращаемые функцией GETFLDSTATE ()

Значение | Состояние
1 | Значение поля не изменялось
2 | Значение поля было изменено или поле было удалено
3 | Значение поля во вновь добавленной записи не изменялось
4 | Значение поля во вновь добавленной записи было изменено или поле было удалено


Блокировка при буферизации

В Visual FoxPro вы можете выбрать пессимистический и оптимистический режимы буферизации, которые определяют, как и когда будет осуществляться блокировка данных. В зависимости от типа решаемых задач, вы можете выбрать один из типов буферизации данных (табл. 20.3).

Таблица 20.3. Типы буферизации данных

Значение | Описание
1 | Буферы не используются
2 | Пессимистическая блокировка записей. Visual FoxPro блокирует запись сразу же после начала редактирования данных и освобождает блокировку только после перехода на следующую запись или при выполнении фуНКЦИИ TABLEUPDATE ( )
3 | Оптимистическая блокировка записей. Позволяет редактировать текущую запись в других сеансах работы и блокирует запись только при переходе на следующую запись или выполнении функции TABLEUPDATE ( }
4 | Пессимистическая блокировка таблицы. Блокируются все редактируемые записи, но их обновление в базе данных осуществляется только при вызове функции TABLEUPDATE ( )
5 | Оптимистическая блокировка таблицы. Позволяет редактировать записи в других сеансах работы и блокирует записи только при обновлении записей в базе данных с помощью функции TABLEUPDATE ( )

При выборе любого типа буферизации данных вы можете отказаться от выполненных изменений с помощью функции TABLEREVERT ().

Для установки типа буферизации вы можете использовать функцию CURSORSETPROPO, свойство BufferMode формы и свойство BufferModeOverride курсора, используемого в среде окружения формы.

Свойство BufferMode формы может принимать одно из значений, описанных в табл. 20.4.

Таблица 20.4. Значения свойства BufferMode

Значение | Описание
0 | Записи блокируются с момента начала редактирования, и значения полей записываются в базу данных при переходе к следующей записи
1 | Пессимистическая блокировка записей
2 | Оптимистическая блокировка записей

Для определения свойства Buf ferModeOverride откройте окно конструктора формы, выполните команду Data Environment (Среда окружения) из меню View (Вид). Далее в окне Data Environment (Среда окружения) выберите таблицу, нажмите правую кнопку мыши и из контекстного меню выберите команду Properties (Свойства). Откроется окно свойств, в котором выберите свойство BufferModeOverride (рис. 20.3) и установите одно из возможных значений (табл. 20.5).

Таблица 20.5. Значения свойства BufferModeOverride

Значение | Описание
0 | Буферы не используются
1 | Использует тип блокировки, заданный свойством BufferMode формы
2 | Пессимистическая блокировка записей
3 | Оптимистическая блокировка записей
4 | Пессимистическая блокировка таблицы
5 | Оптимистическая блокировка таблицы

Рис. 20.3. Определение значения свойства BufferModeOverride курсора

Рис. 20.4. Определение типа блокировки в диалоговом окне Work Area Properties

Функция CURSORSETPROP (), используемая для определения типа буферизации курсора, имеет следующий синтаксис:

CURSORSETPROP(Buffaring, типБуферизации,

псевдонимТаблицы | номерРабочейОбласти])

Для определения текущего типа буферизации воспользуйтесь свойством BufferModeOverride курсора или функцией CURSORGETPROP() .

При работе в интерактивном режиме вы можете установить тип блокировки в диалоговом окне Work Area Properies (Свойства рабочего пространства) (рис. 20.4), которое открывается при нажатии кнопки Properties (Свойства) в диалоговом окне Data Session (Данные сеанса),


ГЛАВА 20
Многопользовательская работа в локальной сети

В однопользовательской системе с данными работает только один человек, и ему нет необходимости думать о разделении доступа к файлам. Однако, с появлением пользователей, желающих получить доступ к одним и тем же данным, планирование разделения доступа к базе становится актуальным.

В многопользовательских приложениях необходимо обеспечить доступ к данным тем пользователям, которым он действительно нужен. При разработке сетевых приложений по управлению базами данных необходимо предусмотреть разрешение конфликтов, возникающих при попытке двух и более пользователей одновременно изменить одни и те же данные. Visual FoxPro предлагает несколько вариантов решения этой проблемы, позволяя пользователю использовать перед изменением таблиц или записей автоматические или ручные методы их блокировки. При доступе к записям таблицы блокировка запрещает кому-либо изменять заблокированную область, пока пользователь не завершит свои изменения и не разблокирует эти данные.

Эта глава ознакомит вас с концепциями разделения данных в сетевой среде и организацией интерфейса при совместной работе нескольких пользователей.

Типы блокировок

В Vi&ual FoxPro вы можете использовать два типа блокировок: блокировку таблицы и записи. Блокировка таблицы запрещает доступ другим пользователям ко всей таблице, пока вы редактируете одну или несколько записей. Применение блокировки записи не допускает изменения записи кем-либо, кроме пользователя, установившего блокировку.

По возможности следует использовать блокировку записи, потому что она запрещает изменение только одной записи, а не всей таблицы. Например, пока вы редактируете запись о покупателе Иванове, кто-нибудь может работать с записью о покупателе Петрове. И вы оба можете совершать изменения, не мешая друг другу и не беспокоясь за действия другого.


  • Типы блокировок
  • Автоматическая блокировка
  • Полная блокировка таблицы и блокировка изменений
  • Блокировка таблицы
  • Блокировка записей
  • Установка режима повторных попыток блокировки данных
  • Снятие блокировок таблиц и записей
  • Сеансы работы с данными
  • Использование буферов
  • Блокировка при буферизации
  • Обнаружение и устранение конфликтов
  • Использование транзакций


Использование объектно-ориентированного программирования

В Visual FoxPro для управления OLE-объектами можно использовать объектно-ориентированное программирование.

Замечание

Для создания OLE-объекта в Visual FoxPro предназначена команда CREATEOBJECT.


Удаление OLE-объекта

Чтобы удалить OLE-объект из поля типа General (Общий), выполните команду Clear (Очистить) из меню Edit (Правка).


Редактирование OLE-объекта

Большинство OLE-объектов можно редактировать. Для этого откройте окно редактирования поля типа General (Общий), содержащее, например, такие OLE-объекты, как электронная таблица Microsoft Excel, документ Word или рисунок Paint и дважды щелкните мышью. Откроется приложение-сервер для редактирования объекта.

Для редактирования точечных рисунков выберите команду Растровый рисунок Object (Объект) в меню Edit (Правка), а затем команду Изменить или Открыть, которые доступны в окне редактирования поля типа General (Общий). Для редактирования документа Word в меню Edit (Правка) появляется команда Документ Object, а для редактирования электронной таблицы — Лист Object (Объект).


Команда Paste Special

Для размещения в поле типа General (Общий) OLE-объекта со связью с помощью команды Paste Special (Специальная вставка) выполните следующие действия:

  1. Откройте приложение-сервер и запомните связываемый объект во временном буфере Windows.
  2. Откройте окно редактирования поля типа General (Общий).
  3. В меню Edit (Правка) выберите команду Paste Special (Специальная вставка). На экране открывается диалоговое окно Специальная вставка (рис. 21.11). Объект, находящийся во временном буфере Windows, описан в диалоговом окне как Источник. В списке Как перечислены допустимые форматы для этого объекта.

Рис. 21.11. Диалоговое окно Специальная вставка

  4. Чтобы связать объект с его оригиналом на сервере, выберите переключатель Вставить связь.
  5. Выберите из списка Как формат объекта. Ссылка на объект запоминается в поле типа General (Общий). При каждом изменении оригинала объекта на сервере объект, выводимый в приложении Visual FoxPro, будет автоматически обновляться. Если в момент изменения оригинала приложение Visual FoxPro не открыто, обновление произойдет при первом же открытии приложения Visual FoxPro.
  6. Нажмите кнопку ОК для закрытия диалогового окна Специальная вставка.

Ссылка на OLE-объект, запоминаемая в поле типа General (Общий), содержит имя файла (включая путь к нему) оригинала объекта на сервере. Если вы измените имя этого файла, перенесете или удалите его, связь разрывается. Для восстановления связи необходимо воспользоваться командой Links (Связи) из меню Edit.

Совет

Для изменения объекта в поле типа General (Общий) со связанного на внедренный необходимо удалить объект из поля с помощью команды Cut (Вырезать) из меню Edit (Правка), а после этого вставить объект обратно в поле, но без связывания.

Если OLE-объект был размещен со связью, диалоговое окно Связи позволяет изменить или удалить установленную связь (рис. 21.12). Для его просмотра откройте требуемую таблицу, перейдите в поле со связанным объектом и в меню Edit (Правка) выберите команду Links (Связи).

Рис. 21.12. Диалоговое окно Связи

В списке Связи представлены все связи объекта в табличном виде с указанием пути и имени файла источника, а также типа объекта и режима обновления связи.

В диалоговом окне размещены кнопки, имеющие назначение, описанное в табл. 21.1.

Таблица 21.1. Назначение кнопок диалогового окна Связи

Кнопка | Назначение
Обновить сейчас | Обновляет выделенную связь
Открыть источник | Открывает исходный файл для выделенной связи
Сменить источник | Заменяет исходный файл для выделенной связи с помощью диалогового окна Смена источника
Разорвать связь | Разрывает указанную связь. В результате объект становится статическим, не допускающим изменения или обновления

Переключатель Обновление определяет режим обновления связи и содержит два переключателя: Автоматическое, Вручную. При установленной опции Автоматическое обновление связанных объектов осуществляется автоматически. Если установлена опция Вручную, тогда для обновления объектов необходимо нажать кнопку Обновить сейчас.


Команда Insert Object

Для размещения в поле таблицы Visual FoxPro OLE-объекта со связью с помощью команды Insert Object (Вставить объект) выполните следующие действия:

  1. Откройте таблицу Goods в режиме Browse (Обзор).
  2. Перейдите в поле типа General (Общий) и дважды щелкните на нем для его открытия.
  3. Выберите в меню Edit (Правка) команду Insert Object (Вставить объект).
  4. В диалоговом окне Вставка объекта выберите переключатель Создать из файла.
  5. Нажмите кнопку Обзор.
  6. В открывшемся диалоговом окне Обзор выберите необходимый файл и нажмите кнопку Открыть.
  7. В диалоговом окне Вставка объекта установите флажок Связь (рис. 21.9) и нажмите кнопку ОК.

Рис. 21.9. Установлен флажок Связь

Рис. 21.10. Связывание OLE-объекта

  8. В результате этих действий в окне просмотра поля типа General (Общий) появится значок файла (рис. 21.10).
  9. Чтобы изменить размещенный OLE-объект с использованием OLEсервера, откройте окно просмотра OLE-объекта и дважды щелкните кнопкой мыши на значке.


Связывание OLE-объекта

Чтобы связать OLE-объект с основной копией объекта на сервере, можно воспользоваться командой Insert Object (Вставка объекта) или Paste Special (Специальная вставка) из меню Edit (Правка). Рассмотрим оба варианта.


Внедрение OLE-объекта из файла

Для внедрения в поле таблицы OLE-объекта из файла выполните следующие действия.

  1. Откройте таблицу в режиме Browse (Обзор).
  2. Установите курсор на поле типа General (Общий) и дважды щелкните кнопкой мыши. Откроется окно редактирования поля.
  3. В меню Edit (Правка) выберите команду Insert Object (Вставить объект).
  4. В открывшемся диалоговом окне Вставка объекта выберите переключатель Создать из файла. Окно примет вид, представленный на рис. 21.7.

Рис. 21.7. Диалоговое окно Вставка объекта при выбранном переключателе Создать из файла

  5. Нажмите кнопку Обзор.
  6. В открывшемся диалоговом окне Обзор (рис. 21.8) выберите файл, содержащий необходимый объект. Для установки требуемого типа объекта необходимо использовать список Тип файлов, расположенный в нижней части диалогового окна. Выбрав файл, нажмите кнопку Открыть.
  7. Возвратившись в диалоговое окно Вставка объекта, нажмите кнопку ОК. OLE-объект будет размещен в поле типа General (Общий).

Рис. 21.8. Диалоговое окно Обзор


Внедрение нового OLE-объекта

Рассмотрим процедуру внедрения нового OLE-объекта на примере поля gimage таблицы Goods.

  1. В окне проекта установите курсор на таблицу Goods базы данных sales. Данная таблица содержит поле gimage типа General (Общий), в котором вы предполагаете разместить изображение товара.
  2. Чтобы открыть окно просмотра, выполните команду Browse (Обзор) из меню View (Вид) или нажмите кнопку Browse (Обзор) окна проекта.
  3. Для вставки OLE-объекта установите курсор на поле типа General (Общий) и дважды щелкните на нем. Откроется окно редактирования поля.
  4. Выполните команду Insert Object (Вставить объект) из меню Edit (Правка).
  5. В открывшемся диалоговом окне Вставка объекта в списке Тип объекта перечислены все OLE-серверы, установленные в вашей системе. В качестве примера выберите Рисунок Paintbrush.
  6. Нажмите кнопку ОК. Visual FoxPro откроет указанное вами приложение и разместит его меню и панели инструментов в своем главном окне.
  7. Создайте изображение товара, которое будет использовано в качестве нового OLE-объекта (рис. 21.4).

Рис. 21.4. Создание изображения товара

  8. Закройте сервер OLE. Для этого щелкните в любом месте окна вне области редактирования, после чего созданный вами объект будет размещен в поле типа General (Общий) (рис. 21.5).

Рис. 21.5. Размещение в поле таблицы нового OLE-объекта

Если вам потребуется внести изменения во встроенный OLE-объект, откройте таблицу в режиме Browse (Обзор) и дважды щелкните на требуемом значении. В результате откроется окно редактирования поля типа General (Общий). Для редактирования изображения используется команда Точечный рисунок Object (Объект) из меню Edit (Правка).

Данная команда имеет собственное меню, которое содержит опции Изменить и Открыть, определяющие режим редактирования изображения (см. рис. 21.5). При выборе опции Изменить меню и панели инструментов OLEсервера внедряются непосредственно в Visual FoxPro (см. рис. 21.4). При выборе опции Открыть открывается приложение OLE-сервера (рис. 21.6), в котором вы можете редактировать изображение поля типа General (Общий).

Рис. 21.6. Открытое приложение OLE-сервера для редактирования изображения


Использование данных из Visual FoxPro в Microsoft Word

Данные, содержащиеся в таблицах Visual FoxPro, можно использовать в других приложениях Windows. Например, в Microsoft Word вы можете подготовить этикетки для наклейки на конверты для рассылки своим клиентам, используя для этого данные, размещенные в таблице Customer.

Для слияния данных из Visual FoxPro и Microsoft Word необходимо использовать мастер. Чтобы его запустить, в меню Tools (Сервис) выберите команду Wizards (Мастера) и в появившемся подменю — Mail Merge (Составление писем). Слияние данных осуществляется с помощью мастера за несколько шагов.

  1. На первом шаге мастер предлагает выбрать таблицу и поля, используемые для слияния. Перенесите необходимые поля в список Selected fields (Выбранные поля) и нажмите кнопку Next (Далее).

Совет

Перед запуском мастера закройте базу данных.

  2. На втором шаге необходимо указать, с каким редактором вы будете работать далее. По умолчанию установлена опция Microsoft Word. Нажмите кнопку Next (Далее) для перехода к следующему шагу.
  3. На третьем шаге мастер предлагает поместить данные в новый или уже существующий документ (рис. 21.23). При выборе переключателя Use existing document (Существующий документ) становится доступной кнопка File (Файл), открывающая диалоговое окно Open (Открыть) для выбора ранее подготовленного документа.
  4. Если вы хотите разместить данные во вновь создаваемом документе, то на четвертом шаге мастера необходимо определить тип создаваемого файла, выбрав один из переключателей группы Select a document type (Выбор типа документа). В табл. 21.3 описаны переключатели группы Select a document type (Выбор типа документа) и типы создаваемых файлов.

Таблица 21.3. Переключатели группы Select a document type

Переключатель | Тип создаваемого документа
Form Letter | Письмо
Label | Этикетка
Envelope | Конверт
Catalog | Каталог

Выбрав необходимую опцию, нажмите кнопку Next (Далее) для перехода к последнему шагу мастера.

  5. На последнем шаге работы мастера следует нажать кнопку Finish (Готово). Если установлен драйвер ODBC, то все завершится успешно. Запустится Microsoft Word и откроется документ Word, в котором будет установлена связь с выбранными данными.
  6. Разместите текст в документе. Для вставки полей установите курсор в требуемое место, нажмите кнопку Добавить поле слияния и выберите из раскрывающегося списка то поле, которое нужно. Поясняющий текст вставляется непосредственно в область ввода.
  7. Нажмите кнопку Объединить. Откроется окно Слияние, в котором вы можете указать параметры слияния. В нашем примере выберите из списка Назначение опцию Новый документ и оставьте остальные параметры без изменения. Возможность отбора записей не представляет большого интереса, т. к. средства создания запроса в Visual FoxPro намного богаче. Для окончательного объединения данных нажмите кнопку Объединить.


Импорт данных

В настоящем разделе мы обсудим импорт данных из форматов других приложений в таблицу Visual FoxPro. Для импорта данных воспользуемся услугами мастера.

  1. Чтобы запустить мастера импорта данных в таблицу Visual FoxPro, в меню Tools (Сервис) выберите команду Wizards (Мастера), а затем Import (Импорт).

Совет

Для запуска мастера импорта вы также можете воспользоваться командой Import (Импорт) из меню File (Файл). В этом случае на экране открывается диалоговое окно Import (Импорт), в котором необходимо нажать кнопку Import Wizard (Мастер импорта).

  2. На первом шаге импорта данных с помощью мастера (рис. 21.17) вы указываете формат импортируемого файла, используя список File Type (Тип файла). С помощью кнопки Locate (Определить) вы задаете в поле Source File (Файл источника) имя исходного файла. Затем установкой соответствующей опции вам необходимо указать, в новую таблицу вы импортируете файл или в существующую, и задать имя таблицы.

Завершив установку параметров, нажмите кнопку Next (Далее).

Рис. 21.17. Первый шаг работы мастера: выбор типа импортируемого файла

  3. На втором шаге работы мастера вам необходимо указать, создается свободная таблица или таблица, входящая в базу данных. Установите соответствующую опцию. Если импортируемая таблица будет размещена в базе данных, то укажите ее название и расположение.
  4. На следующих двух шагах вы можете просмотреть содержимое импортируемого файла, определить заголовки и типы создаваемых полей.
  5. На пятом шаге работы мастера импорта задаются форматы отображения дат, кодовых страниц, денежных единиц и чисел.
  6. После завершения установок на последнем шаге работы мастера нажмите кнопку Finish (Готово), и на основе данных импортируемого файла будет создана таблица Visual FoxPro.


Передача данных из Visual FoxPro в другие приложения

Используя команды Export (Экспорт) и Import (Импорт) из меню File (Файл), можно осуществлять обмен данными между Visual FoxPro и текстовыми файлами, а также наиболее популярными базами данных и электронными таблицами.

Для экспорта данных из таблицы Visual FoxPro выполните команду Export (Экспорт) из меню File (Файл). Открывается диалоговое окно Export (Экспорт) (рис. 21.14), в котором из списка Туре (Тип) вам необходимо выбрать тип экспортируемого формата. Допустимые типы форматов приведены в табл. 21.2.

Рис. 21.14. Диалоговое окно Export

Таблица 21.2. Типы экспортируемых форматов

Тип | Кодовое обозначение | Назначение
Visual FoxPro 3.0 (DBF) |  | Копирование одной таблицы в другую
FoxPro для Windows 2.x (DBF) | FOX2X | Экспорт в формат FoxPro для Windows 2.x
FoxBASE+ (DBF) | FOXPLUS | Экспорт в формат FoxBASE+
dBASE IV (DBF) |  | Экспорт в формат dBASE IV
Delimited Text |  | Экспорт в текстовый файл с разделителями
Microsoft Excel 5.0 (XLS) | XLS | Экспорт в формат электронной таблицы Microsoft Excel 5.0
Microsoft Excel 2.0, 3.0 и 4.0 (XLS) | XLS | Экспорт в формат электронных таблиц Microsoft 2.0, 3.0 и 4.0
Lotus 1-2-3 2.x (WK1) | WK1 | Экспорт в формат электронной таблицы Lotus 1-2-3 2.x
Lotu s 1-2-31 -A (WKS) | WKS | Экспорт в формат электронной таблицы Lotus 1-2-3 1-А
Symphony 1.10 (WR1) | WR1 | Экспорт в формат электронной таблицы Symphony 1.10
Symphony 1.01 (WRK) | WRK | Экспорт в формат электронной таблицы Symphony 1.01
MultiPlan 4.01 (MOD) | MOD | Экспорт в формат электронной таблицы MultiPlan 4.01
Data Interchange Format (DIF) | DIF | Экспорт в текстовый файл, используемый приложением VisiCalc
System Data Format (SDF) | SDF | Экспорт в стандартный текстовый файл
Symbolic Link Format | SYLK | Экспорт в текстовый файл, используемый электронной таблицей MultiPlan

В поле ввода From (Форма) диалогового окно Export (Экспорт) необходимо указать имя экспортируемой таблицы, а в поле То (В) — имя файла, в который будет записываться результат экспорта.

После того как вы указали имя исходной таблицы, становится доступной кнопка Options (Параметры), при нажатии на которую открывается диалоговое окно Export Options (Параметры экспорта) (рис. 21.15). В этом диалоговом окне для выбора записей таблицы, экспортируемых в выходной файл, вы можете использовать кнопки Scope (Граница), For (Для), While (Пока).

Рис. 21.15. Диалоговое окно Export Options

С помощью кнопки Fields (Поля) можно открыть диалоговое окно Field Picker (Выбор поля), в котором выбрать поля исходной таблицы для экспорта (рис. 21.16).

Рис. 21.16. Диалоговое окно Field Picker


Передача данных в Microsoft Excel с помощью OLE

В рассматриваемом примере используем данные из таблицы cntcust для построения диаграммы распределения клиентов по городам в программе Microsoft Excel с помощью OLE-объектов,

  1. В меню File (Файл) выберите команду New (Новый), установите опцию Program (Программа) и нажмите кнопку New file (Новый файл). Откроется новое окно редактирования программ.
  2. Для установления связи с Microsoft Excel, передачи в него данных и построения диаграммы введите следующие команды:

* Создание OLE-объекта

obj ExcelSheet=CreateObject("Excel.Sheet")

objExcelSheet.Application.Visible=.Т.

objExcelSheet = objExcelSheet.Sheets[1]

* Передача данных из таблицы CntCust в Excel

SELECT CNTCUST

nRow=0

SCAN

nRow=nRow+l

objExcelSheet.Cells(nRow,1).ValueCntCust.City

objExcelSheet.Cells(nRow,2).Value=CntCust.Quant

ENDSCAN

objChart = objExcelSheet.ChartObjects.Add{100, 100, 400, 200)

* Выделение данных и создание диаграммы

objExcelSheet.chartObjects(1).Chart.;

chartwizard(objExcelSheet.Range(objExcelSheet.Cells(1,1) ,;

objExcelSheet.Cells(nRow,2)),;

-4100,4,1,0,1,1,"","","","")

objExcelSheet.chartObjects(1).Select

objExcelSheet.chartObjects(1).Copy

* Закрытие сервера

objExcelSheet.application.quit

release objExcelSheet

  3. Проверьте синтаксис и запустите программу на выполнение. Результат выполнения программы представлен на рис. 21.13.

Замечание

Наиболее простым способом формирования команд для выполнения действий над OLE-объектами является запись соответствующего макроса на сервере приложении и использование текста этого макроса в Visual FoxPro.

Рис. 21.13. Создание диаграммы с помощью OLE


ГЛАВА 21
Связывание и внедрение объектов, экспорт и импорт данных

В Visual FoxPro имеется возможность хранить в таблицах сами объекты или связь с объектами, которые созданы в приложении, поддерживающем механизм связывания и внедрения (OLE). Основное отличие между связыванием и внедрением состоит в том, каким образом данные запоминаются и обновляются после того, как их поместили в базу данных.

При связывании данные обновляются, когда изменяется исходный файл. Связанные данные запоминаются в исходном файле; в базе данных сохраняются только сведения о месте расположения исходного файла. Внедренные объекты сохраняются в базе данных. Если установить на внедренный объект указатель и дважды щелкнуть мышью, откроется приложение, в котором объект был создан. В нем можно редактировать внедренный объект, при этом измененные данные записываются в базу данных.

Объект, который внедряется или связывается, называется OLE-объектом. Исходное приложение, в котором был создан OLE-объект, называется приложением-сервером, а приложение, в которое внедряется или с которым связывается OLE-объект, — приложением-клиентом.

Visual FoxPro и OLE-объекты

В Visual FoxPro OLE-объекты могут храниться и отображаться только в полях типа General (Общий). Для внедрения OLE-объекта в таблицу Visual FoxPro выполните следующие действия:

  1. Создайте в таблице, предназначенной для хранения OLE-объекта, поле типа General.
  2. Откройте таблицу в режиме Browse (Обзор) (рис. 21.1), выполнив команду Browse (Обзор) из меню View (Вид) или нажав кнопку Browse (Обзор) окна проекта. Откроется окно просмотра таблицы.

Замечание

Если поле типа General (Общий) пусто, то при просмотре таблицы в нем появляется пометка gen. Если поле содержит OLE-объект, то пометка принимает вид Gen.

Рис. 21.1. Просмотр в режиме Browse таблицы, содержащей поля типа General

  3. Для вставки OLE-объекта дважды щелкните на поле типа General (Общий), содержащем значение gen. Откроется окно редактирования этого поля (рис. 21.2).
  4. В меню Edit (Правка) выберите команду Insert Object (Вставить объект). Откроется диалоговое окно Вставка объекта (рис. 21.3).
  5. Это диалоговое окно содержит два переключателя, предоставляющих два варианта включения OLE-объекта:
  • Создать новый — позволяет создать новый OLE-объект и вставить его в поле;
  • Создать из файла — позволяет разместить в поле таблицы OLE-объект из файла.

При выборе переключателя Создать новый выберите из предложенного списка Тип объекта сервер, который хотите использовать для создания объекта, и нажмите кнопку ОК. Откроется приложение, в котором создайте объект, после чего вернитесь в Visual FoxPro.

Для использования существующего объекта выберите переключатель Создать из файла. Диалоговое окно примет другой вид. Воспользовавшись кнопкой Обзор, найдите необходимый файл и вставьте его содержимое в поле таблицы.

Замечание

В Visual FoxPro для хранения сложных текстов можно использовать поле типа General (Общий), внедрив в него или связав с ним документ текстового процессора.

Рис. 21.2. Окно редактирования поля типа General

Рис. 21.3. Диалоговое окно Вставка объекта


  • Visual FoxPro и OLE-объекты
  • Внедрение нового OLE-объекта
  • Внедрение OLE-объекта из файла
  • Связывание OLE-объекта
  • Команда Insert Object
  • Команда Paste Special
  • Редактирование OLE-объекта
  • Удаление OLE-объекта
  • Использование объектно-ориентированного программирования
  • Передача данных в Microsoft Excel с помощью OLE
  • Передача данных из Visual FoxPro в другие приложения
  • Импорт данных
  • Использование данных из Visual FoxPro в Microsoft Word


Особенности использования удаленных представлений данных для электронных таблиц Microsoft Excel

При использовании ODBC-драйвера Microsoft Excel для создания удаленного представления данных создается таблица Visual FoxPro или курсор. Эта таблица содержит выбранные данные из электронной таблицы Microsoft Excel. Однако, если ячейка таблицы содержит текст, в таблице Visual FoxPro он отображается в виде Memo-поля.

Это связано с тем, что ODBC-драйвер передает текстовые данные в виде строки длиной 255 символов. Так как Visual FoxPro не может отображать в текстовом поле более 254 символов, любые текстовые данные помещаются в Memo-поле. Приемлемым решением этой проблемы является создание новых текстовых полей и копирование в них информации из Memo-полей командой, аналогичной следующей:

REPLACE ALL sqlchar WITH TRIM(sqlntemo)

Замечание

При обновлении данных в многоуровневом представлении изменения отражаются в том представлении, на котором основано представление верхнего уровня. Если нужно обновить базовые таблицы многоуровневого представления, то необходимо применить команду TABLEUPDATE для каждого представления многоуровневой структуры.

Замечание

Visual FoxPro автоматически выполняет команду TABLEUPDATE при закрытии представления. При этом представления верхнего уровня закрываются первыми, поэтому вам придется обновлять представления с каждого верхнего уровня на каждый последующий нижний уровень. После закрытия последнего (самого нижнего уровня) представления базовые таблицы для данных представлений будут содержать полный список всех выполненных обновлений.


Использование команды CREATE SQL VIEW

Для создания удаленных представлений данных вы можете использовать команду CREATE SQL VIEW, синтаксис которой приведен ниже:

CREATE SQL VIEW [имяПредставления] [REMOTE]

[CONNECTION имяСоединения

|CONNECTION имяИсточникаДанных]

Для создания удаленного представления данных необходимо указать признак удаленного представления с помощью ключевого слова REMOTE. Имя удаленного соединения или источника данных задается с помощью параметра CONNECTION.

Вы также можете задать определение представления с помощью SQL выражения, которым может быть любой допустимый оператор SQL SELECT, который не следует заключать в кавычки.

Например, чтобы создать удаленное представление данных для таблицы Goods, расположенной в базе данных Microsoft SQL Server и для которой определено соединение SQLServer, вы можете использовать следующие команды:

OPEN DATABASE SALES

CREATE SQL VIEW SQLServerGoods

CONNECTION SQLServer

AS SELECT * FROM GOODS


Использование конструктора представлений

Для создания удаленного представления с помощью конструктора представлений в диспетчере проектов из списка Databases (Базы данных) выберите раздел Remote Views (Удаленные представления), а затем нажмите кнопку New (Новый). На экране появится диалоговое окно выбора источника данных Select Connection or Data Source (Выбрать соединение или источник данных).

Выберите источник данных или соединение, введите идентификатор и пароль доступа к базе данных. Далее, как и при создании локального представления данных, выберите используемые в представлении данных таблицы и поля выбранных таблиц.

При создании удаленных представлений данных необходимо обратить внимание на вкладку Update Criteria (Критерии обновления), в которой задаются условия обновления представлений.

На этой вкладке из списка Table (Таблица) выбирается таблица, для которой определяются установки вкладки Update Criteria (Критерии обновления). Флажок Send SQL updates (Отправить SQL-обновление) указывает, должны ли данные в действительности обновляться на диске.

Область SQL WHERE clause includes (Включение в запрос операторов предложения WHERE) содержит опции, позволяющие задать способ формирования предложения WHERE.

Таблица 22.7. Опции области SQL WHERE clause includes

Опция | Назначение
Key fields only (Только ключевые поля) | Указывает, что предложение WHERE, используемое для обновления удаленных таблиц, включает только поля, входящие в список Field name (Имя поля)
Key and updateable fields (Ключевые и доступные для изменения поля) | Указывает, что предложение WHERE, используемое для обновления удаленных таблиц, включает поля, входящие в список Field name (Имя поля), а также все обновляемые поля
Key and modified fields (Ключевые и модифицированные поля) | Указывает, что предложение WHERE, используемое для обновления удаленных таблиц, включает поля, входящие в список Field name (Имя поля), и все остальные изменившиеся поля
Key and timestamp (Ключевые поля и отметки времени) | Указывает, что предложение WHERE, используемое для обновления удаленных таблиц, включает первичные поля, входящие в список Field name (Имя поля), а также сравнение по отметкам времени

В области Update using (Строка обновления) задается способ обновления полей на сервере базы данных (табл. 22.8).

Таблица 22.8. Опции области Update using

Опция | Назначение
SQL DELETE then INSERT | Указывает, что сначала исходная запись таблицы базы данных будет удалена, а затем будет добавлена новая запись
SQL UPDATE | Указывает, что запись таблицы базы данных будет модифицироваться


Использование мастера удаленных представлений

Мастер удаленных представлений создает представления с использованием удаленных данных (ODBC). Предлагая ответить на ряд простых вопросов, мастер помогает вам выполнить процедуру в несколько этапов; при этом вы должны задать базы данных, таблицы и поля, которые хотите использовать в своем представлении. Перед этим вы должны создать базу данных, в которой будет сохранено представление, а также определить источник данных или соединение.

Для запуска мастера удаленных представлений в меню Tools (Сервис) выберите команду Wizards (Мастера), а затем опцию Query (Запрос), потом в открывшемся диалоговом окне Wizard Selection (Выбор мастера) выберите значение Remote View Wizard (Мастер удаленного представления) (рис. 22.9).

Рис. 22.9. Выбор мастера удаленных представлений

На первом шаге вы выбираете источник данных из списка имеющихся источников данных или созданных вами именованных соединений (рис. 22.10).

Если удаленный источник данных требует идентификации пользователя, то на экране открывается диалоговое окно ввода имени пользователя и пароля (рис. 22.11).

Введите имя пользователя и пароль входа в базу данных. После этого откроется диалоговое окно выбора полей (рис. 22.12), помещаемых в создаваемое представление. Вы можете выбирать поля из нескольких таблиц или представлений базы данных, с которой вы соединились. Вначале выберите одну таблицу и перенесите поля выбранной таблицы в список Selected Fields (Выбранные поля), а затем выберите поля из другой таблицы или другого представления.

Рис. 22.10. Выбор источника данных

Рис. 22.11. Ввод имени пользователя и пароля

Рис. 22.12. Выбор полей удаленного представления

Если вы выберете более одной таблицы, вам необходимо определить отношения между таблицами (рис. 22.13). Для этого выберите нужные поля из приведенных списков и нажмите кнопку Add (Добавить).

Рис. 22.13. Определение отношения между таблицами

Рис. 22.14. Отображение списка удаленных представлений

На следующих двух шагах создания удаленного представления укажите порядок сортировки информации и фильтр для ограничения выбираемых данных. На последнем шаге укажите режим завершения процесса создания и введите имя создаваемого удаленного представления. Вы можете просто сохранить его, открыть для просмотра или открыть в конструкторе представлений. После создания удаленного представления его имя появится в разделе Remote Views (Удаленные представления) (рис. 22.14). После того как удаленное представление сохранено, его можно открыть и модифицировать в конструкторе представлений, как любое другое представление.

Для просмотра данных созданного удаленного представления выберите его из раздела Remote Views (Удаленные представления) и нажмите кнопку Browse (Обзор).

Замечание

Если удаленный источник данных требует идентификации пользователя, то при открытии удаленного представления данных на экране открывается диалоговое окно ввода имени пользователя и пароля.


Создание удаленного представления данных

После того как был определен источник данных или именованное соединение, можно создать удаленное представление. Для этого выполните одно из следующих действий:

  • откройте базу данных и вызовите мастера удаленных представлений;
  • в диспетчере проектов из списка Databases (Базы данных) выберите раздел Remote Views (Удаленные представления), затем нажмите кнопку New (Новый) для вызова конструктора представлений;
  • используйте команду CREATE SQL VIEW с предложением REMOTE и/или CONNECTION.

Рассмотрим каждый из этих вариантов создания удаленного представления данных на примерах использования электронной таблицы Microsoft Excel и базы данных Microsoft SQL Server.


Настройка параметров удаленных представлений и соединений в диалоговом окне Options

Прежде чем запускать мастера удаленных представлений, вы можете установить опции для принимаемых по умолчанию параметров удаленных представлений и соединений, используя вкладку Remote Data (Удаленные данные) диалогового окна Options (Параметры) (рис. 22.8).

Рис. 22.8. Настройка параметров удаленных представлений и соединений

Область Remote view defaults (Удаленное представление по умолчанию) содержит параметры (табл. 22.5), используемые по умолчанию при создании удаленных представлений.

Таблица 22.5. Параметры удаленного представления

Параметр | Описание
Share connection (Совместное подключение) | Указывает, что в новых представлениях будет использоваться текущее совместно используемое соединение
Fetch memo (Выборка Memo-поля) | Указывает, что Memo-поле не будет выбираться из источника данных до тех пор, пока оно не будет активизировано в представлении данных
SQL updates: Criteria (Критерии SQL-обновления) | Задает критерий обновления данных
SQL updates: Method (Методы SQL-обновления) | Задает метод обновления данных
Records to fetch at a time (Выборка записей за промежуток времени) | Задает количество записей, возвращаемых за один раз из удаленного источника данных
Maximum records to fetch (Максимальная выборка записей за промежуток времени) | Ограничивает общее число записей, возвращаемых в представлении
Use memo for fields >= (Использовать перевод символьных данных в Мемо-поля) | Задает условие преобразования длинных символьных полей в Memo-поля в выводе представления
Records to batch update (Количество обновляемых одновременно записей) | Задает число записей, подлежащих обновлению в одной команде

Область Connection defaults содержит параметры, используемые при создании именованных соединений (табл. 22.6).

Таблица 22.6. Параметры именованного соединения

Параметр | Описание
Asynchronous execution (Асинхронное выполнение) | Задает признак асинхронной обработки
Display warnings (Показывать предупреждения) | Задает режим выдачи предупреждающих сообщений
Batch processing (Пакетная обработка) | Обеспечивает пакетную обработку. Если установить этот переключатель, Visual FoxPro не будет возвращать результаты вызова SQLEXEC ( ) до тех пор, пока не поступят все отдельные результирующие наборы
Automatic transactions (Автоматические транзакции) Show login (Показывать окно приглашения) | Определяет, каким образом соединение управляет ходом транзакций в удаленной таблице о тображает диалоговое окно ввода регистрационного приглашения только в том случае, если в определении соединения или представления не задана информация регистрации
Connection timeout (sec) (Ожидание соединения) | Задает интервал времени (в секундах), в течение которого допускается ожидание установки соединения с удаленным сервером. Если в течение этого времени соединение не устанавливается, Visual FoxPro генерирует ошибку
Idle timeout (min) (Холостой режим) | Задает интервал времени (в минутах), в течение которого допускается простаивание, прежде чем соединение будет прекращено. Если в течение этого времени не был сделан запрос к серверу, Visual FoxPro разрывает соединение. Однако, если сделать запрос к серверу по истечении интервала тайм-аута для соединения, Visual FoxPro автоматически попытается его восстановить
Query timeout (sec) (Ожидание запроса) | Задает интервал времени (в секундах), в течение которого допускается ожидание от сервера ответа на запрос. Если сервер тратит на обра. ботку больше заданного числа секунд, Visual FoxPro генерирует ошибку
Wait time (ms) (Время ожидания завершения запроса) | Задает интервал времени (в миллисекундах) между проверками на завершение запроса


Конструктор соединений

Окно конструктора соединений (рис. 22.5) позволяет вам задать параметры именованного соединения в интерактивном режиме.

Рис. 22.5. Окно конструктора соединений

Область Specify data source (Определить источник данных) содержит переключатели Data source, userid, password (Источник данных, идентификатор пользователя, пароль) и Connection string (Строка соединения), определяющие способ соединения с источником данных. При выборе первой опции в области отображаются поля ввода (табл. 22.1).

Таблица 22.1. Назначение полей ввода области Specify data source

Поле | Назначение
Data source (Источник данных) | Имя источника данных из списка установленных источников данных ODBC
Userid (Идентификатор пользователя) | Идентификатор пользователя для выбранного источника данных
Password (Пароль) | Пароль пользователя
Database (База данных) | Имя базы данных

При выборе переключателя Connection string (Строка соединения) вместо приведенных выше полей ввода отображается только одно поле ввода Connect string (Строка соединения), в котором можно ввести строку соединения с источником данных.

Кнопка Verify Connection (Проверить соединение) предназначена для проверки соединения с указанным источником данных. Кнопка New Data Source (Новый источник данных) позволяет определить новый источник данных непосредственно из конструктора соединений.

Область Display ODBC login prompts (Отображение окна доступа к ODBC источнику) содержит переключатели, определяющие, когда будет открываться диалоговое окно Data Source Login (Доступ к источнику данных) (табл. 22.2).

Таблица 22.2. Переключатели области Display ODBC login prompts

Наименование | Назначение
When login info is not specified (Когда параметры доступа не определены) | Диалоговое окно Data Source Login (Доступ к источнику данных) открывается только в том случае, если заданный идентификатор пользователя и пароль не найдены в определении именованного соединения
Always (Всегда) | Указывает, что Visual FoxPro всегда открывает для пользователя диалоговое окно Data Source Login (Доступ к источнику данных), в котором можно выбрать другой регистрационный идентификатор и другой пароль из числа хранящихся в именованном соединении
Never (Никогда) | Указывает, что Visual FoxPro никогда не открывает диалоговое окно входа в базу данных

В области Data processing (Обработка данных) определяются свойства, связанные с обработкой данных соединения (табл. 22.3).

Таблица 22.3. Опции области Data processing

Наименование | Назначение
Asynchronous execution (Асинхронное выполнение) | Задает признак асинхронного соединения
Display warnings (Показывать предупреждения) | Задает признак отображения неперехватываемых предупреждений
Batch processing (Пакетная обработка данных) | Задает пакетный режим обработки данных
Automatic transactions (Автоматические транзакции) | Задает автоматическую обработку транзакций
Packet size (Размер пакета данных) | Задает размер пакета данных, передаваемого от сервера базы данных

Замечание

Для определения значений параметров области Data processing (Обработка данных) вы можете использовать функцию DBSETPROP ().

Область Timeout intervals (Интервалы времени) содержит опции, устанавливающие временные параметры обработки данных (табл. 22.4).

Таблица 22.4. Опции области Timeout intervals

Наименование | Назначение
Connection (sec) (Соединение) | Задает интервал тайм-аута соединения в секундах
Query (sec) (Запрос) | Задает интервал тайм-аута запроса в секундах
Idle (min) (Холостой режим) | Задает интервал тайм-аута холостого режима в минутах. Активные соединения по истечении этого интервала времени деактивизируются
Wait time (ms) (Время ожидания) | Задает промежуток времени в миллисекундах, по истечении которого Visual FoxPro может определить, завершено ли выполнение оператора SQL

Замечание

Для определения значений параметров области Data processing (Обработка данных) вы можете использовать функцию DBSETPROP ().

По умолчанию для именованного соединения задается имя Connect 1. При закрытии окна конструктора соединений открывается диалоговое окно Save (Сохранить) (рис. 22.6), предлагающее ввести подходящее имя соединения.

Рис. 22.6. Ввод имени соединения

Все созданные вами именованные соединения отображаются в разделе Connections (Соединения) списка Database (База данных). Например, на рис. 22.7 приведены именованные соединения с источниками данных Access, Microsoft SQL Server и Microsoft Excel.

Рис. 22.7. Именованные соединения

Для изменения параметров именованного соединения выберите требуемое соединение и нажмите кнопку Modify (Модифицировать). Откроется окно конструктора соединений, в котором вы можете изменить любые параметры соединения.


Именованное соединение

Удобным средством для работы с удаленными данными является именованное соединение, которое хранится в базе данных и на которое можно ссылаться по имени при создании удаленного представления.

Рис. 22.4. Раздел Connections списка Database

Вы также можете устанавливать свойства именованного соединения для оптимизации связи между Visual FoxPro и удаленным источником данных. При активизации удаленного представления его соединение становится каналом, ведущим к удаленному источнику данных.

Для создания именованного соединения выполните любое из следующих действий:

  • в диспетчере проектов из списка Databases (Базы данных) выберите раздел Connections (Соединения) (рис. 22.4), затем нажмите кнопку New (Новый), чтобы вызвать конструктор соединений;
  • откройте базу данных и используйте команду CREATE CONNECTION, чтобы открыть конструктор соединений;
  • используйте команду CREATE CONNECTION (Создать соединение) с именем соединения в качестве параметра.


Настройка представления с помощью словаря базы данных

Так как сведения о представлении хранятся в словаре базы данных, вы можете определить для него следующие свойства:

  • заголовок поля;
  • комментарии для представления и его полей;
  • значения полей, принимаемые по умолчанию;
  • правила проверки достоверности данных на уровне поля и записи,

Для определения свойств полей представления данных в окне конструктора представления перейдите на вкладку Fields (Поля) и нажмите кнопку Properties (Свойства). Откроется диалоговое окно View Field Properties (Показать свойства поля).

Раскрывающийся список Field (Поле) в этом диалоговом окне содержит перечень всех полей представления. Для определения свойств поля необходимо сначала выбрать его из этого списка.

В области Field validation (Проверка достоверности данных поля) вы можете задать условия проверки достоверности данных на уровне поля при вводе данных (табл. 22.9).

Таблица 22.9. Поля области Field validation

Поле | Назначение
Rule (Правило) | Задает правило проверки достоверности данных на уровне поля
Message (Сообщение) | Задает сообщение об ошибке, которое будет выдаваться, если введенные данные не согласуются с правилом уровня поля
Default value (Значение по умолчанию) | Задает для поля значение по умолчанию

Для удаленных данных правило проверки достоверности данных на уровне поля задается средствами сервера базы данных. Вы можете задать локальное правило для:

  • уменьшения времени отклика системы;
  • уменьшения загрузки сетевых ресурсов;
  • проверки данных перед их пересылкой удаленному источнику данных.

Visual FoxPro не сравнивает локальное и удаленное правило проверки достоверности данных.

В области Display (Отобразить) вы можете задать условия проверки достоверности данных на уровне поля при отображении и вводе данных (табл. 22.10).

Таблица 22.10. Поля области Display

Поле | Назначение
Format (Формат) | Задает формат отображения данных. Этот формат используется в окне Browse, отчетах и формах
Input mask (Маска ввода) | Задает маску ввода данных
Caption (Описание) | Задает описательное имя поля. Название отображается в качестве заголовка столбца при просмотре таблицы. Оно может включать до 128 символов

Если вы планируете использовать представление данных в формах, то можете использовать опции области Map field type to classes (Установить соответствие между типами полей и классами) для задания типа объекта управления, создаваемого в форме при размещении данного поля.

Для удаленных представлений данных вы можете определить тип и размер поля представления данных. Используйте для этого опции области Data mapping (Соответствие типов данных).

Поле редактирования Comment (Комментарий) содержит описательный комментарий о данном поле. Все, что вы здесь введете, при выборе поля будет отображено в качестве описания в нижней части диспетчера проектов.

Замечание

Для определения свойств полей представления данных вы можете использовать функцию DBSETPROP ( )


Комбинирование в представлении локальных и удаленных данных

Актуальной задачей при разработке приложений, использующих удаленные данные, является комбинирование в представлении локальных и удаленных данных. В Visual FoxPro данная задача решается достаточно просто. Прежде всего, вы должны создать удаленные представления для данных, которые будут использоваться совместно с локальными.

Затем в диспетчере проектов выберите раздел Local Views (Локальные представления) и нажмите кнопку New (Новый), чтобы открыть конструктор представлений. Добавьте в новое представление любую комбинацию таблиц, локальных и удаленных представлений. Например, вы можете объединить в одном представлении данные из локальной таблицы Ordsaied и удаленного представления данных Microsoft SQL, содержащего список товаров.

Для создания комбинированного представления вы можете использовать также команду CREATE SQL VIEW, Например, чтобы создать локальное представление, комбинирующее информацию из локальной таблицы ordsaiem и удаленной таблицы customer (расположенной на сервере базы данных SQL Server), используйте следующий код:

OPEN DATABASE SALES

CREATE SQL VIEW localORDSALEM _ remoteCUSTOMER;

AS SELECT * FROM SQLSERVERCUSTOMER, ORDSALEM

WHERE SQLSERVERCUSTOMER.iCdCustcmer =

ORDSALEM. iCdCustomer


Совместно используемые соединения

При создании удаленных представлений вы можете воспользоваться совместно используемыми соединениями. В этом случае одно активное соединение используется как информационный канал для нескольких удаленных представлений.

При совместном использовании активного соединения:

  • уменьшается нагрузка на ресурсы системы;
  • уменьшается количество связей на удаленном сервере;
  • уменьшаются накладные расходы на связи с серверами.

Для определения разделяемого соединения воспользуйтесь любым из следующих способов:

  • в диспетчере проектов выберите в меню Tools (Сервис) команду Options (Параметры). Откройте вкладку Remote Data (Удаленные данные), установите флажок Share Connection (Совместное подключение), расположенный в области Remote View Defaults (Значение по умолчанию для удаленных представлений), и нажмите ОК;
  • в окне конструктора представлений в меню Query (Запрос) выберите команду Advanced Options (Дополнительные параметры) и в открывшемся диалоговом окне Advanced Options (Дополнительные параметры) установите флажок Share Connection (Совместное подключение);
  • используйте команду CREATE SQL VIEW с ключевым словом SHARE.


ГЛАВА 22
Удаленные представления данных

Информация, используемая в разрабатываемом приложении, может находиться не только в таблицах Visual FoxPro, но и в электронных таблицах Microsoft Excel, в текстовом виде, в файлах базы данных Paradox или же на сервере базы данных типа SQL Server. Все такие данные называются удаленными данными, несмотря на то, что они могут находиться даже на одном компьютере с Visual FoxPro.

Для доступа к удаленным данным используется стандартный протокол доступа к базам данных (ODBC). Все базы данных, а также электронные таблицы имеют драйверы ODBC, с помощью которых вы можете соединяться с ними и получать доступ к их содержимому.

Определение источника данных ODBC

После установки драйверов ODBC вы можете определить для него один или несколько источников данных ODBC.

Для добавления источника данных ODBC выполните следующие действия:

  1. Выберите на Панели управления Windows пиктограмму Источники данных (ODBC).
  2. Далее в диалоговом окне ODBC Data Source Administrator (Администрирование источника данных ODBC) (рис. 22.1) нажмите кнопку Add (Добавить).
  3. На экране появится диалоговое окно Create New Data Source (Создать новый источник данных) (рис. 22.2). Выберите нужный драйвер из представленного в диалоговом окне списка и нажмите кнопку Готово.
  4. В следующем диалоговом окне ODBC Setup (Установка ODBC) (рис. 22.3) установите необходимые значения параметров соединения и нажмите кнопку ОК.

Замечание

Вид диалогового окна настройки параметров соединения зависит от типа источника данных. Тем не менее, для всех источников данных необходимо в поле ввода Name (Имя) указать имя источника данных, которое в дальнейшем используется для ссылки на источник данных. Поле ввода Description (Описание) содержит краткое описание источника данных. Если при определении значений остальных полей возникнут проблемы, обратитесь к администратору базы данных, к которой вы собираетесь определить доступ.

Рис. 22.1. Диалоговое окно ODBC Data Source Administrator

Рис. 22.2. Диалоговое окно Create New Data Source

Рис. 22.3. Диалоговое окно определения параметров соединения


  • Определение источника данных ODBC
  • Именованное соединение
  • Конструктор соединений
  • Настройка параметров удаленных представлений и соединений в диалоговом окне Qptions
  • Создание удаленного представления данных
  • Использование мастера удаленных представлений
  • Использование конструктора представлений
  • Использование команды CREATE SQL VIEW
  • Особенности использования удаленных представлений данных для электронных таблиц Microsoft Excel
  • Совместно используемые соединения
  • Комбинирование в представлении локальных и удаленных данных
  • Настройка представления с помощью словаря базы данных


Выбор переносимых таблиц

На третьем этапе вы выбираете наращиваемые таблицы. Чтобы обеспечить правильность экспортируемых данных, мастер пытается открыть все таблицы базы данных, выбранной для наращивания, в режиме эксклюзивного пользования. Если какие-либо открытые таблицы находятся в совместном пользовании, мастер закрывает их и вновь открывает в эксклюзивном режиме, что может вызвать потерю некоторых временных отношений, установленных с помощью команды SET RELATION или SET SKIP. Все таблицы, которые не удастся открыть в эксклюзивном режиме, не смогут принять участие в наращивании.

Вы не можете изменить принимаемое по умолчанию соответствие для поля ключа, если новый тип данных не позволит индексировать это поле. Вы можете изменить соответствие для поля, входящего в состав ключа индекса, если выберете тип данных, допускающий индексирование; однако после этого вы, возможно, захотите для единообразия изменить типы данных для остальных полей ключа. Visual FoxPro выдает предупреждающее сообщение при попытке изменить соответствие для поля, которое не является полем ключа, но используется в индексе Visual FoxPro. Если вы сделали ошибку, нажмите кнопку Reset To Defaults (Сброс) — произойдет сброс типов данных.

При переносе мастером наращивания таблиц Visual FoxPro имена полей и типы данных автоматически преобразуются в поля SQL Server.

Мастер показывает вам устанавливаемое по умолчанию преобразование типов данных. При необходимости вы можете изменить тип данных на сервере базы данных с помощью раскрывающегося списка Server Type (Тип сервера).


Выбор базы данных и источника данных

На первом этапе работы с мастером наращивания вам необходимо выбрать и открыть локальную базу данных, которая будет переноситься в базу данных SQL Server (рис. 23.1).

Рис. 23.1. Выбор локальной базы данных с исходными таблицами

На втором этапе необходимо выбрать источник данных. Если вы используете именованное соединение для доступа к источнику данных, мастер наращивания будет связывать это именованное соединение со всеми удаленными представлениями, создаваемыми в процессе наращивания. Если при регистрации в источнике данных вы вместо имени соединения используете имя источника данных, а в дальнейшем задаете создание удаленных представлений, мастер наращивания создает именованное соединение с именем Upsize (или Upsize2, Upsize3 и т. д., если определение соединения с предлагаемым именем уже существует).

При нажатии кнопки Next (Далее) мастер откроет диалоговое окно ODBC Login (ODBC Логин). Если вы используете именованное соединение с сохраненным паролем, мастер зарегистрирует вас на выбранном сервере SQL Server, не требуя ввести регистрационную информацию ODBC.


Установка драйвера ODBC

Перед запуском мастера наращивания необходимо установить драйвер ODBC для выбранной базы данных и определить источник данных для связи с базой данных. Также желательно определить именованное удаленное соединение.

Замечание

Установку драйверов ODBC, определение источника данных и создание именованного удаленного соединения мы рассмотрели в главе 22.


Отображение правил и ссылочной целостности мастером наращивания

В табл. 23.5 описываются триггеры, создаваемые мастером наращивания. Каждый конкретный триггер может содержать код, эмулирующий какиелибо (или все) функциональные возможности Visual FoxPro из числа указанных.

Таблица 23.5. Триггеры, создаваемые мастером наращивания

Триггер | Эмулируемые функциональные возможности Visual FoxPro
UPDATE | Правила проверки достоверности (на уровне полей и на уровне записей). Ссылочная целостность
INSERT | Правила проверки достоверности (на уровне полей и на уровне записей). Ссылочная целостность (только триггеры дочерних таблиц)
DELETE (только родительские таблицы) | Ссылочная целостность


Отображение объектов мастером наращивания

В табл. 23.4 показано, как отображаются объекты из Visual FoxPro в SQL Server: Таблица 23.4. Отображение объектов мастером наращивания

Объект Visual FoxPro | Объект SQL Server
База данных | База данных
Таблица | Таблица
Индексы | Индексы
Поле | Поле
Значение по умолчанию | Значение по умолчанию
Правило проверки достоверности таблицы | Хранимые процедуры SQL Server, вызываемые ИЗ триггеров UPDATE И INSERT
Правило проверки достоверности поля | Хранимые процедуры SQL Server, вызываемые ИЗ триггеров UPDATE И INSERT
Постоянные отношения (там, где они используются в качестве ограничений ссылочной целостности) | Триггеры UPDATE, INSERT И DELETE


Отображение типов индексов мастером наращивания

Индексы SQL Server и индексы Visual FoxPro очень похожи. В табл. 23.3 показано, как типы индексов Visual FoxPro преобразуются в типы индексов SQL Server.

Таблица 23.3. Сопоставление типов индекса Visual FoxPro типам индекса SQL Server

Тип индекса Visual FoxPro | Тип индекса SQL Server
Первичный | Кластеризованный уникальный
Кандидат | Уникальный
Уникальный, обычный | Неуникальный

Мастер наращивания использует имена индексов Visual FoxPro в качестве имен индексов в SQL Server. Если имя индекса оказывается зарезервированным ключевым словом, мастер наращивания изменяет это имя, присоединяя к нему символ "_".

Замечание

SQL Server не поддерживает убывающие и возрастающие индексы и не разрешает использовать выражения в индексах сервера. Мастер наращивания в ходе наращивания индекса удаляет выражения Visual FoxPro из выражений индекса; на сервер передаются только имена полей.


Отображение выражений из Visual FoxPro в SQL Server мастером наращивания

Несмотря на то, что Visual FoxPro и Transact-SQL имеют несколько общих функций, многие функции Visual FoxPro не поддерживаются в SQL Server. Выражения Visual FoxPro, содержащиеся в правилах проверки достоверности на уровне полей и на уровне записей, а также в значениях по умолчанию мастер наращивания пытается преобразовать в выражения TransactSQL, используя соответствия, представленные в табл. 23.2.

Таблица 23.2. Отображение выражений из Visual FoxPro в SQL Server

Выражение Visual FoxPro | Выражение SQL Server
Истина (.Т.) | 1
Ложь (.F.) | 0
# | <>
.AND. | AND
.NOT. | NOT
.NULL. | NULL
.OR. | OR
= <; | <=
= > | >=
ASCO | ASCII ()
AT() | CHARINDEX ( )
CDOW ( ) | DATENAME(dw, . . . )
CHR() | CHAR ( )
CMONTH ( ) | DATENAME (mm, . . • )
CTODO | CONVERT {datetime, . . . )
CTOT ( ) | CONVERT (datetime, . . . )
DATE ( ) | GET DATE ( )
DATETIME ( } | GETDATE ( )
DAY () | DATEPART{dd, . . . )
DOW() | DATEPART (dw, . . . )
DTOC ( ) | CONVERT (varchar, ...)
DTOR ( ) | RADIANS ( )
DTOT ( ) | CONVERT (datetime, ...)
HOUR ( ) | DATEPART (hh, . . . )
LIKEO | PATINDEX ( )
MINUTE () | DATEPART (mi, . . . )
MONTH ( ) | DATEPART (mm, . . . )
MTON ( ) | CONVERT (money, . . . )
NTOM ( ) | CONVERT (float, . . . )
RTOD ( ) | DEGREES ( )
SUBSTRO | SUBSTRING ()
ТТОС ( ) | CONVERT (char, , . . )
TTOD{) | CONVERT (ciatetime, . . , )
YEAR ( ) | DATEPARTfyy, ...}

Следующие функции имеют одинаковый вид и в Visual FoxPro, и в SQL Server.

CEILING ()

LOG (

LOWER ()

LTRIM(

RIGHT()

RTRIM()

SOUNDEX()

SPACE ()

STR()

STUFF ()

UPPER ()


Соответствие типов данных

Соответствие типов данных Visual FoxPro и MS SQL Server представление в табл. 23.1.

Таблица 23.1. Соответствие типов данных

Сокращенное обозначение | Тип данных Visual FoxPro | Тип данных SQL Server
С | Character | char
Y | Currency | money
D | Date | datetime
Т | DateTime | datetime
В | Double | float
F | Float | float
G | General | image
I | Integer | int
L | Logical | bit
М | Memo | text
М (binary) | Memo binary | image
С (binary) | Character binary | binary
N | Numeric | float
Р | Picture | image


Определение базы данных назначения и ее параметров

На следующем этапе определяется база данных назначения. Если вы хотите добавить таблицы Visual FoxPro в существующую базу данных SQL Server, то можете задать наращивание до масштабов существующей базы данных. В этом случае мастер сразу переходит к восьмому этапу.

Если вы решили создать новую удаленную базу данных, ее имя может состоять не более чем из 30 символов, включая буквы, цифры и символы "#", "$" и "_". Пробелы не разрешаются.

Предупреждение

Для создания новой базы данных вы должны обладать соответствующими полномочиями. При возникновении проблем обратитесь к администратору базы данных SQL Server.

На шестом и седьмом этапах определяются устройство и размер для базы данных и журнала транзакций. Размер новой базы данных должен быть не менее 2 Мбайт: это минимальный размер, допускаемый в SQL Server. SQL Server создает для вашей базы данных журнал транзакций, который можно использовать для восстановления базы данных в случае серьезных ошибок в системе. В идеальном варианте базу данных и соответствующий ей журнал следует размещать на устройствах, находящихся на разных физических дисках. Эти устройства должны быть созданы до запуска мастера наращивания, поскольку он создает все новые устройства на одном и том же физическом диске, на котором расположено главное устройство базы данных.

По умолчанию мастер наращивания экспортирует структуру таблицы и ее содержимое. Наряду с именами полей и типами данных, вы также можете экспортировать индексы, значения по умолчанию, отношения (ограничения целостности на уровне ссылок) и правила.

Индексы и значения по умолчанию Visual FoxPro становятся индексами и значениями по умолчанию SQL Server. Если вы решили экспортировать правила, мастер наращивания пытается экспортировать в SQL Server правила уровня поля и правила уровня строки, в результате чего они превращаются в хранимые процедуры, вызываемые из триггеров SQL Server. Экспортированные табличные отношения также становятся частью этих триггеров.

Замечание

Если вы наращиваете табличные отношения, не забудьте выполнить и наращивание индексов, иначе производительность может заметно снизиться.

Если у вас только один физический диск, вы должны разместить базу данных и ее журнал на разных устройствах, чтобы можно было пользоваться командой сервера SQL DUMP TRANSACTION.

Рис. 23.2. Проект с информацией о переносе данных

Рис. 23.3. Часть отчета о выполнении наращивания базы данных

На последнем этапе вы можете выбрать следующие варианты завершения наращивания:

  • провести наращивание, не генерируя код SQL;
  • сгенерировать только код SQL для наращивания;
  • провести наращивание и сгенерировать код SQL.

Первый и третий варианты доступны только в том случае, если вы обладаете на сервере SQL полномочием CREATE TABLE. Если вы выбрали один из вариантов, предусматривающий сохранение сгенерированного кода SQL, то весь код SQL, генерируемый мастером наращивания, будет сохранен на вашем жестком диске.

Мастер наращивания создает проект Report (Отчет) (рис. 23.2), который содержит таблицы, использующиеся для переноса данных из таблиц Visual FoxPro, а также отчеты о переносе данных (рис. 23.3).


ГЛАВА 23
Перенос данных из Visual FoxPro на платформу клиент-сервер

В последнее время перед разработчиками все чаще возникает необходимость переноса приложений, созданных для базы данных Visual FoxPro, на платформу клиент-сервер. Наиболее простым способом переноса данных является использование мастера наращивания.

Мастер наращивания создает базу данных SQL Server, которая дублирует, насколько это возможно, функциональный диапазон базы данных Visual FoxPro. С помощью мастера наращивания вы можете:

  • преобразовывать локальные базовые таблицы и локальные представления в удаленные базовые таблицы и удаленные представления;
  • перемещать локальные данные на удаленный сервер;
  • переносить локальные приложения в среду клиент-сервер.

Предупреждение

Наращивание может занимать много времени; это зависит от количества данных, объема сетевого трафика и числа параллельных запросов, обрабатываемых сервером. Для больших таблиц наращивание может выполняться в течение нескольких часов.

В данной главе рассмотрим использование мастера наращивания для переноса данных из Visual FoxPro в базу SQL Server.

Использование мастера наращивания для переноса данных в базу данных SQL Server

Прежде чем приступить к процессу переноса данных из Visual FoxPro в SQL Server, рассмотрим особенности и ограничения, связанные с переносом полей таблиц, выражений, правил поддержки целостности.


  • Использование мастера наращивания для переноса данных в базу данных SQL Server
  • Соответствие типов данных
  • Отображение выражений из Visual FoxPro в SQL Server мастером наращивания
  • Отображение типов индексов мастером наращивания
  • Отображение объектов мастером наращивания
  • Отображение правил и ссылочной целостности мастером наращивания
  • Установка драйвера ODBC
  • Выбор базы данных и источника данных
  • Выбор переносимых таблиц
  • Определение базы данных назначения и ее параметров


Редактирование созданной Web-страницы

Файл с расширением НТМ, полученный в результате работы мастера Web Publishing (Web-публикация), может быть отредактирован средствами редактора программы Visual FoxPro. Для открытия данного файла в меню File (файл) выберите команду Open (Открыть), в списке Тип файлов укажите расширение НТМ, выберите требуемый файл на диске и нажмите кнопку ОК. После того как редактирование завершено, сохраните изменения, нажав на панели инструментов кнопку Save (Сохранить). Для просмотра отредактированной Web-страницы в браузере запустите обозреватель Internet Explorer и в строке адреса укажите местоположение и название файла.


Настройка параметров

После того как данные подготовлены, можно приступать к формированию Web-страницы:

  1. Откройте базу данных проекта, содержащую созданное локальное представление данных GoodsCount.
  2. В меню Tools (Сервис) выберите команду Wizards (Мастера), а затем опцию — Web Publishing (Web-публикация).
  3. На первом шаге мастера из нижнего списка области Databases and tables (Базы данных и таблицы) выберите представление GoodsCount. Затем перенесите все поля представления из списка Available fields (Доступные поля) в список Selected fields (Выбранные поля). Чтобы перейти к следующему шагу, нажмите кнопку Next (Далее).
  4. Открывается окно мастера, позволяющее задать макет Web-страницы и стиль отображения объектов (см. рис. 24.3). По умолчанию из списка Data layouts (Расположение данных) выбрано значение Static List View (Статическая таблица). Оставьте данное значение.
  5. Чтобы добавить на Web-страницу бегущую строку и заголовок, нажмите кнопку Advanced (Дополнительно). Открывается одноименное диалоговое окно (см. рис. 24.7).
  6. Нажмите кнопку Add (Добавить), расположенную в области Additional HTML items (Добавленные HTML-элементы).
  7. Из списка Туре (Тип) открывшегося диалогового окна HTML Item (HTML-элемент) выберите значение Marquee (Бегущая строка).
  8. В поле Text (Текст) введите текст бегущей строки. Например, Мы рады приветствовать Вас на своем сайте!.
  9. Чтобы задать наименование шрифта, нажмите кнопку с тремя точками, расположенную справа от поля Font name (Наименование шрифта). Открывается диалоговое окно Pick Font (Выберите шрифт). Используя содержащийся в нем список, укажите используемый в бегущей строке шрифт и нажмите кнопку ОК.
  10. С помощью списка Size (Размер) задайте размер шрифта.
  11. Используя списки Backcolor (Цвет фона) и Forecolor (Цвет надписи), укажите цвет фона и текста бегущей строки.
  12. Нажмите кнопку ОК. Диалоговое окно HTML Item (HTML-элемент) закрывается, а в список Additional HTML items (Добавленные HTMLэлементы) добавляется одно значение. Бегущая строка размещена на Web-странице. Теперь добавим на страницу заголовок.
  13. Снова нажмите кнопку Add (Добавить), расположенную в области Additional HTML items (Добавленные HTML-элементы).
  14. В списке Туре (Тип) открывшегося диалогового окна HTML Item (HTML-элемент) оставьте установленное по умолчание значение Text (Текст).
  15. В поле Text (Текст) введите текст заголовка. Например, Продажи товара за ноябрь 2001 года.
  16. Из списка Heading (Заголовок) выберите размер заголовка.
  17. Используя список Forecolor (Цвет надписи), укажите цвет заголовка.
  18. Нажмите кнопку ОК. Диалоговое окно HTML Item (HTML-элемент) закрывается, а в список Additional HTML items (Добавленные HTMLэлементы) добавляется второе значение. Заголовок размещен на Webстранице.
  19. Закройте диалоговое окно Advanced (Дополнительно), нажав кнопку Done (Применить).
  20. Для перехода к заключительному шагу мастера нажмите кнопку Next (Далее).
  21. В заключительном окне мастера установите требуемую опцию из предлагаемых и нажмите кнопку Finish (Готово).
  22. В открывшемся диалоговом окне Save as (Сохранить как) укажите имя файла и папку, в которой хотите сохранить созданную Web-страницу. Создание Web-страницы завершено.


Подготовка данных

Прежде чем приступить к созданию Web-страницы, необходимо подготовить размещаемые на ней данные. Это могут быть таблицы, содержащие требуемые данные, локальные или удаленные представления. Мы будем использовать локальное представление Goods count, в котором содержатся сведения о продажах различных товаров фирмы за истекший месяц. Требуемая нам информация содержится в таблицах ordsaled и Goods. Создадим представление данных:

  1. Откройте окно конструктора представлений. Для этого на вкладке Data (Данные) окна конструктора проекта перейдите в раздел Local Views (Локальные представления данных) выбранной базы данных и нажмите кнопку New (Новый).
  2. Добавьте в него таблицы ordsaled и Goods, используемые для создания представления.
  3. Установите связи между размещенными в окне конструктора таблицами по коду товара.
  4. В список Selected fields (Выбранные поля) перенесите код, наименование и описание товара.
  5. Добавьте в список Selected fields (Выбранные поля) вычисляемое поле содержащее количество продаж: SUM(Ordsaled.nquant)
  6. На вкладке Group By (Группировка) конструктора задайте группировку данных по коду товара.
  7. Упорядочите данные по наименованию товара, используя для этого вкладку Order By (Сортировка).
  8. Для сохранения представления данных в меню File (Файл) выберите команду Save As (Сохранить как). В поле View Name (Имя представления) открывшегося диалогового окна Save (Сохранить) укажите имя создаваемого представления данных GoodsCount и нажмите кнопку ОК.
  9. Просмотрите созданное представление данных, чтобы убедиться, что оно содержит требуемые данные. Для этого нажмите кнопку Run (Выполнить) на стандартной панели инструментов. 10. Закройте окно конструктора представлений.


Создание Web-страницы

Мы рассмотрели работу мастера Web Publishing (Web-публикация). Теперь создадим с его помощью Web-страницу, которая будет содержать бегущую строку, заголовок и данные из представления GoodsCount.


Диалоговое окно Advanced

При нажатии кнопки Advanced (Дополнительно) на третьем шаге мастера появляется одноименное диалоговое окно, показанное на рис. 24.7. Оно позволяет использовать при создании Web-страницы внешние таблицы стилей (ess), созданные с помощью других программ, задать фон страницы, разместить на Web-странице HTML-элементы, такие как заголовок, текст, бегущая строка, линия и т. д.

Рис. 24.7. Диалоговое окно Advanced

В верхнем левом углу диалогового окна Advanced (Дополнительно) расположено поле Cascading style sheet (Внешняя таблица стилей), позволяющее указать расположение внешней таблицы стилей, используемой для оформления Web-страницы.

Область Body (Тело) содержит два элемента. Список Color (Цвет) позволяет задать фон Web-страницы. Этот параметр имеет более высокий приоритет по отношению к цвету, установленному с помощью макета данных или визуального стиля. Поле Image (Изображение) позволяет указать расположение графического файла, размещаемого на странице.

Установленный флажок Copy Graphics to HTML output location (Копировать графику) указывает, что любой графический файл, используемый для размещения на странице, копируется в папку, в которой сохраняется Webстраница.

В области Additional HTML items (Добавленные HTML-элементы) содержится список элементов, используемых в оформлении Web-страницы. Находящиеся здесь же кнопки имеют назначение, описанное в табл. 24.2.

Таблица 24.2. Назначение кнопок области Additional HTML Items

Кнопка | Назначение
Add (Добавить) | Открывает диалоговое окно HTML Item (HTML-элемент) (рис. 24.8), позволяющее добавить элемент оформления на Web-страницу
Edit (Правка) | Открывает диалоговое окно HTML Item (HTML-элемент) для редактирования выбранного из списка текущей области элемента оформления Web-страницы
Remove (Удалить) | Удаляет выделенный HTML-элемент из списка

В нижней части окна расположены следующие три кнопки (табл. 24.3).

Таблица 24.3. Кнопки окна Advanced

Кнопка | Назначение
Save Settings (Сохранить параметры) | Открывает диалоговое окно Save Settings (Сохранить параметры), в котором можно указать название созданного визуального стиля
Load Settings (Загрузить параметры) | Открывает диалоговое окно Load Settings (Загрузить параметры), в котором содержится список сохраненных визуальных стилей
Done (Применить) | Сохраняет и применяет к создаваемой Web-странице настройки окна

Используя область Additional HTML items (Добавленные HTML-элементы), можно сформировать список элементов оформления Web-страницы. Для добавления в список нового элемента предназначено диалоговое окно HTML Item (HTML-элемент) (рис. 24.8), открываемое при нажатии кнопки Add (Добавить).

Рис. 24.8. Диалоговое окно HTML Item

В его верхней части находится список Туре (Тип), содержащий типы HTML-элементов, которые могут быть размещены на Web-странице с помощью мастера, а список Location (Расположение) — его расположение на странице. Диалоговое окно HTML Item (HTML-элемент) позволяет добавить на Web-страницу следующие элементы:

  • Text — обычный текст, заголовки различных уровней;
  • Hyperlink — гиперссылка;
  • Image — графическое изображение;
  • Marquee — бегущая строка текста;
  • Horizontal Rule — горизонтальная линия;
  • Line Break — линия разрыва;
  • Tag — тег.

Количество доступных в диалоговом окне HTML Item (HTML-элемент) объектов интерфейса зависит от типа добавляемого элемента. Так, например, для текста можно указать сам текст, используемый при его отображении шрифт, размер, цвет, способ выравнивания информации. Для гиперссылки кроме перечисленных выше параметров можно также указать адрес, на который с помощью нее осуществляется переход, и т. д.


Диалоговое окно Layout Options

Диалоговое окно Layout Options (Параметры расположения) (рис. 24.5) предназначено для настройки параметров данных, отображаемых на Webстранице из таблицы или представления данных. Оно открывается при нажатии на третьем шаге работы мастера кнопки Options (Параметры) и содержит несколько вкладок. Находящиеся в окне Layout Options (Параметры расположения) вкладки, а также отображаемые на них параметры зависят от значения, выбранного из списка Data layouts (Расположение данных), т. е. от макета данных.

Рис. 24.5. Диалоговое окно Layout Options

Вкладки диалогового окна Layout Options (Параметры расположения) позволяют настроить следующие параметры Web-страницы:

  • Border (Граница) — для данных, отображаемых в виде таблицы, цвет обрамления и фона, толщину границ. Поле Background image (Фоновое изображение) позволяет использовать в качестве фона область, в которой располагаются данные, графическое изображение;

Рис. 24.6. Вкладка Relations диалогового окна Layout Options

  • Font (Шрифт) — задает семейство шрифтов (наименование, размер и цвет), которые будут использоваться при открытии Web-страницы, если у пользователя отсутствует шрифт, используемый при создании этой страницы;
  • Other (Другие) — используемый для оформления страницы HTML-класс. Кроме того, вкладка содержит параметры, специфичные для разных макетов данных. Так, например, с помощью объектов интерфейса этой вкладки строки или группы строк табличных данных можно выделить разными цветами. Или, например, задать цвет строки, на которой установлен курсор;
  • Relations (Отношения) (рис. 24.6) — данная вкладка присутствует в окне Options (Параметры) только для макета типа Tabular Hierarchical (Табличная иерархия). Она позволяет создавать иерархические таблицы. Например, вы можете отобразить на странице список покупателей и выполненные ими заказы. Web-страница, созданная с использованием настроек вкладки Relations (Отношения),.


Настройка параметров Web-страницы с помощью мастера

Мы рассмотрели создание Web-страницы с помощью мастера Web Publishing (Web-публикация). Теперь более подробно остановимся на параметрах, настраиваемых на третьем шаге работы мастера (см. рис. 24.3).


ГЛАВА 24
Публикация данных на Web-сервере

Все больше в нашу жизнь входит Интернет. В связи с этим во многие программные продукты добавляются средства создания Web-страниц. Не является исключением и FoxPro. В Visual FoxPro имеется мастер Web Publishing (Web-публикация), позволяющий формировать Web-страницы на основе баз данных. При этом пользователь может выбирать стили оформления страницы, предлагаемые мастером, а также использовать внешние таблицы стилей, созданные в других программных продуктах. Данные, размещаемые на странице, могут находиться в таблицах, локальных или удаленных представлениях базы данных. Рассмотрим работу мастера, а также предлагаемые им элементы оформления Web-страницы.

Мастер Web Publishing

Чтобы создать Web-страницу с помощью мастера, выполните следующие действия:

  1. Откройте базу данных проекта, содержащую таблицу, локальное или удаленное представление, информацию из которых хотите разместить на Web-странице.
  2. В меню Tools (Сервис) выберите команду Wizards (Мастера), а затем опцию — Web Publishing (Web-публикация).
  3. Запускается мастер и появляется его первое диалоговое окно, в котором необходимо указать используемую таблицу или представление, и выбрать поля этой таблицы, размещаемые на Web-странице. В области Databases and tables (Базы данных и таблицы) окна мастера расположены два списка. Верхний список содержит название открытой базы данных, нижний — список ее таблиц и представлений. Выберите из нижнего списка требуемую таблицу. При этом в списке Available fields (Доступные поля) будут отображены все поля текущей таблицы (рис. 24.1).
  4. Перенесите из списка Available fields (Доступные поля) в Selected fields (Выбранные поля) поля, которые хотите расположить на Web-странице. Для перехода к следующему шагу в работе мастера нажмите кнопку Next (Далее).

Рис. 24.1. Первое окно мастера

  5. На втором шаге задается критерий сортировки данных (рис. 24.2). Поля, по которым будет осуществляться упорядочение, необходимо разместить в списке Selected fields (Выбранные поля). Для переноса полей из списка Available fields or index tag (Имеющиеся поля и индексы) в список Selected fields (Выбранные поля) можно использовать кнопку Add (Добавить) или мышь. Опции Ascending (По возрастанию) и Descending (По убыванию) определяют, по возрастанию или по убыванию будут упорядочиваться данные в указанном поле.

Задав сортировку данных, нажмите кнопку Next (Далее).

Рис. 24.2. Указание сортировки данных

  6. На третьем шаге задается макет Web-страницы и стиль отображения объектов (рис. 24.3). Диалоговое окно мастера содержит два списка. С помощью списка Data layouts (Расположение данных), содержащего пять значений, определяется расположение данных на странице, т. е. макет данных. Получаемый вид страницы в зависимости от выбранного макета данных можно просмотреть в области просмотра, расположенной в правом верхнем углу окна мастера. Список Visual styles (Визуальные стили) содержит флажки, позволяющие настроить стиль оформления Webстраницы установкой требуемых флажков.

Рис. 24.3. Задание стиля оформления

Диалоговое окно мастера содержит кнопки следующего назначения:

  • Options (Параметры) — открывает диалоговое окно для настройки параметров отображения данных на Web-странице;
  • Advanced (Дополнительно) — открывает диалоговое окно, позволяющее настроить параметры всей Web-страницы, разместить на ней помимо данных из таблицы, HTML-элементы (заголовки, текст, линии, бегущую строку и т. д.);
  • Preview (Просмотр) — загружает оформленную в соответствии с заданными стилями Web-страницу в обозреватель Internet Explorer без выхода из мастера. Вы можете просмотреть созданную страницу, в случае необходимости с помощью мастера изменить параметры настройки и снова просмотреть результат своей работы.

Используя расположенные в этом окне мастера объекты интерфейса, настройте параметры создаваемой Web-страницы и для перехода к следующему шагу нажмите кнопку Next (Далее).

Замечание

Настройка параметров, осуществляемая на данном шаге мастера, будет рассмотрена чуть позже.

  7. На заключительном шаге создания Web-страницы с помощью мастера (рис. 24.4) укажите предполагаемые действия с созданной страницей, используя опции, описанные в табл. 24.1.

Таблица 24.1. Опции окна Web Publishing Wizard Step 4

Опция | Действие
Save web page for later use (Сохранить Web-страницу) | Созданная Web-страница сохраняется на диске в файле с расширением НТМ
Save web page and modify it in the text editor (Сохранить Web-страницу и открыть для модификации в текстовом редакторе) | Созданная Web-страница сохраняется на диске в файле с расширением НТМ и открывается в текстовом редакторе для модификации
Save web page and open it in a browser (Сохранить Web-страницу и открыть для просмотра в Webбраузере) | Созданная Web-страница сохраняется на диске в файле с расширением НТМ и открывается для просмотра в Web-браузере
Create script for generating web page (Создать скрипт генерации Web-страницы) | Созданная Web-страница сохраняется в виде скрипта, т. е. генерируется программный файл с расширением PRG, при запуске которого на выполнение динамически создается Web-страница

Рис. 24.4. Заключительное окно мастера

Диалоговое окно содержит флажок Save style (Сохранить стиль). При его установке в расположенное справа поле можно ввести имя файла, в котором будет сохранен стиль, полученный при создании Web-страницы.

  8. После того как все параметры заданы, нажмите кнопку Finish (Готово). Откроется диалоговое окно Save as (Сохранить как), в котором укажите имя файла и папку, в которой созданная Web-страница должна быть сохранена. На этом создание Web-страницы завершено.


  • Мастер Web Publishing
  • Настройка параметров Web-страницы с помощью мастера
  • Диалоговое окно Layout Options
  • Диалоговое окно Advanced
  • Создание Web-страницы
  • Подготовка данных
  • Настройка параметров
  • Редактирование созданной Web-страницы


View

С помощью флажков вкладки View (Вид) (рис. 25.10) можно определить, что требуется показывать на экране (табл. 25.17).

Таблица 25.17. Назначение флажков вкладки View

Флажок | Назначение
Status bar (Строка состояния) | Включает отображение строки состояния в нижней части экрана. Если строка состояния выключена, сообщения FoxPro выдаются в окно Wait (Ожидание) в верхнем правом углу экрана
Clock (Часы) | Отображает время в строке состояния
Command results (Результаты команд) | Выводит результаты выполнения команд в строку состояния
System messages (Системные сообщения) | Включает или отключает вывод некоторых системных сообщений. Этот флажок соответствует команде SET NOTIFY
Open last project on startup (Открывать последний проект при запуске) | Заставляет Visual FoxPro при запуске автоматически открывать тот проект, который был открыт последним в предыдущем сеансе работы

Рис. 25.10. Вкладка View диалогового окна Options

Счетчик Most Recently Used list contains (Наиболее часто используемый список содержит) позволяет указать, сколько имен последних открывавшихся проектов должно отображаться в меню File (Файл).


Remote Data

Вкладка Remote Data (Удаленные данные) (рис. 25.9) определяет работу Visual FoxPro с удаленными данными.

Область Remote view defaults (Удаленные представления данных по умолчанию) определяет по умолчанию параметры для удаленных представлений данных. Расположенные в этой области флажки имеют назначение, описанное в табл. 25.13.

Рис. 25.9. Вкладка Remote Data диалогового окна Options

Таблица 25.13. Назначение флажков области Remote view defaults

Флажок | Назначение
Share connection (Совместное подключение) | Позволяет ODBC открывать не одно, а несколько представлений данных
Fetch memo (Выборка Мемополя) | Позволяет загружать Memo-данные только в случае активизации пользователем соответствующего поля, т. к. пересылка Memo-полей по локальной сети значительно увеличивает объем пересылаемой информации и уменьшает скорость работы

Список Criteria (Условие) определяет условия модификации исходных таблиц и содержит четыре значения:

  • Key Fields Only (Только ключевые поля) — допускает модификацию только ключевых полей;
  • Key and Updatable Fields (Ключевые и изменяемые поля) — допускает модификацию ключевых и изменяемых полей;
  • Key and Modified Fields (Ключевые и модифицированные поля) — допускает модификацию ключевых и измененных полей;
  • Key and Timestamp (Ключевые поля и время изменения) — допускает модификацию ключевых полей и времени изменения.

Список Method (Метод) определяет метод изменения таблиц. В зависимости от выбранной из него команды производится либо модификация нужной записи, либо удаление старой записи и добавление новой.

В табл. 25.14 приведены счетчики вкладки Remote Data и их назначение.

Таблица 25.14. Назначение счетчиков вкладки Remote Data

Счетчик | Назначение
Records to fetch at a time (Выборка записей в единицу времени) | Позволяет уменьшить нагрузку на локальную сеть, ограничивая число одновременно пересылаемых записей. Дополнительные блоки записей считываются с сервера по мере необходимости
Maximum records to fetch (Максимальное число выбираемых записей) | Определяет верхний предел общего числа записей, возвращаемых запросом, позволяя ограничить объем выбираемых данных при неправильном формировании условий запроса
Use memo for fields >= (Использовать Мемо-поле для полей) | Определяет число символов, при превышении которого поле автоматически преобразуется в Memo - поле. Поскольку максимальная длина символьного поля составляет 254 символа, этот счетчик обычно содержит число 255
Records to batch update (Количество записей в пакете обновления) | Определяет число записей, посылаемых на сервер при выполнении одной команды модификации, позволяя оптимизировать пересылки по сети

Флажки области Connection defaults (Установки соединения по умолчанию) определяют, как ваша прикладная программа будет связываться с данными на сервере (табл. 25.15).

Таблица 25.15. Назначение флажков области Connection defaults

Флажок | Назначение
Asynchronous execution (Асинхронное выполнение) | Определяет, возвращается ли управление к вашей прикладной программе сразу после начала сетевой операции. При синхронном обмене программа всегда дожидается окончания операции обмена по сети. Если установлен асинхронный обмен, то программа может выполнять различные операции и во время обмена по сети
Display warnings (Показывать предупреждения) | Разрешает выдавать на экран сообщения об ошибках сетевых операций
Batch processing (Пакетная пересылка) | Разрешает пакетные пересылки по сети
Automatic transactions (Автоматические транзакции) | Определяет, будут ли транзакции обработаны автоматически или же ваша прикладная программа должна включать собственные функции SQLCOMMIT и SQLROLLBACK

Раскрывающийся список Show login (Показывать окно входа в систему) позволяет указать, когда нужно показывать диалоговое окно входа в систему для пользователя: перед обращением к данным, всегда, никогда, или только по необходимости.

Счетчики области Connection defaults (Установки соединения по умолчанию) выполняют функции, описанные в табл. 25.16.

Таблица 25.16. Назначение счетчиков области Connection defaults

Счетчик | Назначение
Connection timeout (Ожидание подключения) | Определяет число секунд ожидания опознавания соединения сервером
Idle timeout (Время простоя) | Определяет, сколько минут будет поддерживаться соединение без действий. Значение по умолчанию 0 вызывает немедленный разрыв соединения по окончании обмена
Query timeout (Ожидание результатов запроса) | Определяет время ожидания результатов запроса в минутах. Если результат не получен по истечении этого времени, выдается сообщение об ошибке
Wait time (Время ожидания) | Определяет число миллисекунд между проверками завершения обмена по сети


Regional

Вкладка Regional (Региональные) (рис. 25.8) служит для настройки форматов дат, времени, валюты и условных обозначений чисел в прикладных программах.

Если флажок Use System Settings (Использовать системные установки) установлен, будут действовать системные настройки, и вы не сможете устанавливать параметры вкладки.

Параметры отображения даты и времени задаются в области Date and Time (Дата и время). Раскрывающийся список Date Format (Формат даты) содержит форматы разных стран. Можно выбрать устраивающее вас значение из этого списка или создать и сохранить свой собственный формат.

Форматы отображения валюты и чисел устанавливаются в области Currency and Numbers (Валюта и числа). Список Currency Format (Формат валюты) указывает размещение символа валюты относительно его значения и заменяет Команды SET CURRENCY LEFT или SET CURRENCY RIGHT. В поле Currency Symbol (Символ валюты) задается символ валюты. Здесь можно использовать любой символ, допустимый в текущем наборе символов, или их комбинацию. Соответствует команде SET CURRENCY то. Символ из поля 1000 Separator (Разделитель) появляется перед каждой третьей цифрой слева в целой части числа, отделяя тысячи от миллионов и т. д. Соответствует команде SET SEPARATOR.

Рис. 25.8. Вкладка Regional диалогового окна Options

Символ в поле ввода Decimal Separator (Десятичный разделитель) отделяет целую часть числа от дробной.

Значение счетчика Decimal Digits (Десятичные знаки) определяет минимальное число десятичных знаков, используемых для вывода выражения. Это число может иметь значения от 0 до 18. Соответствует команде SET DECIMALS TO.

Списки Week Starts on (Неделя начинается с) и First Week of Year (Первая неделя года) определяют по умолчанию день начала недели и первую неделю года.


Projects

Вкладка Projects (Проекты) (рис. 25.7) определяет параметры работы конструктора проектов. Область Project double-click action (Действие при двойном щелчке мыши в проекте) данной вкладки содержит две опции:

  • Run selected file (Выполнить выбранный файл) — при двойном щелчке на имени файла в конструкторе проектов файл запускается на выполнение;
  • Modify selected file (Модифицировать выбранный файл) — при двойном щелчке на имени файла в конструкторе проектов файл открывается для модификации.

Флажок Prompt for Wizards (Запрос на использование мастеров) управляет отображением запроса при использовании мастера во время создания нового файла из конструктора проектов.

При установленном флажке Display user-defined container icons (Отображать значки, определенные пользователем) в окне проекта отображаются значки, определенные пользователем.

Установкой флажка Project class (Класс проекта) можно задать класс, который будет использоваться по умолчанию при создании нового проекта. Введите класс в расположенное рядом с флажком поле. Для ввода класса можно воспользоваться кнопкой с правой стороны поля ввода, открывающей диалоговое окно для поиска нужной библиотеки классов на диске.

Остальные флажки данной вкладки были подробно описаны в главе 13,

Рис. 25.7. Вкладка Projects диалогового окна Options


Forms

Вкладка Forms (Формы) диалогового окна Options (Параметры) (рис. 25.6) предназначена для настройки параметров работы конструктора форм.

Рис. 25.6. Вкладка Forms диалогового окна Options

Область Grid (Сетка) используется для управления линиями сетки и выравнивания объектов (табл. 25.11).

Таблица 25.11. Назначение флажков области Grid

Флажок | Назначение
Grid lines (Линии сетки) | Определяет отображение линий сетки в форме
Snap to grid (Выровнять по сетке) | При установке данного флажка при изменении положения объекта в форме, он автоматически устанавливается в ближайшую точку пересечения линий сетки. Флажок не влияет на положение объектов, перемещенных до его установки

Эта область содержит также два счетчика (табл. 25.12).

Таблица 25.12. Назначение счетчиков области Grid

Счетчик | Назначение
Horizontal spacing (pixels) (Расстояние по горизонтали) | Определяет число точек между горизонтальными линиями сетки
Vertical spacing (pixels) (Расстояние по вертикали) | Определяет число точек между вертикальными линиями сетки

Для отображения в строке состояния положения и размера текущего объекта формы установите флажок Show position (Показывать положение).

Список Tab ordering (Перемещение при нажатии на клавишу <Та b >), содержащий два элемента Interactive (Интерактивное) и By List (По списку), определяет, каким образом будет устанавливаться последовательность перехода между объектами формы при нажатии клавиши <Та b >:

  • Interactive (Интерактивно) — порядок переключения объектов можно устанавливать кнопкой мыши при нажатой клавише <Shift>;
  • By List (По списку) — последовательность переключения объектов отображается в списке, элементы которого можно менять местами.

Для определения размеров и положения объектов в Visual FoxPro могут использоваться две единицы измерения: пикселы и фокселы. Выбор единицы измерения осуществляется с помощью списка Scale units (Единицы измерения).

Список Maximum design area (Максимальная область проектирования) используется для согласования разрешающих способностей пользовательского монитора и драйвера монитора. Значение списка ограничивает максимальный размер создаваемых форм с тем, чтобы они поместились на пользовательском экране с меньшей разрешающей способностью.

Предупреждение

Разрабатывая заказные прикладные программы, избегайте разработки экранных форм со слишком большим разрешением. Это может вызвать проблемы при установке такой программы на компьютер пользователя с низкой разрешающей способностью монитора.

Для выбора классов, используемых по умолчанию как шаблоны при создании форм и набора форм, используется область Template classes (Классы шаблонов). При установке флажков Form set (Набор форм) или Form (Форма) становятся доступны кнопки с правой стороны одноименных текстовых полей, открывающие список доступных библиотек классов, выбранных на вкладке Controls (Элементы управления). Из этого списка можно выбрать класс, который будет использоваться по умолчанию при создании форм или набора форм.

Установка флажка Builder lock (Закрепление построителя) ведет к автоматическому запуску построителей при добавлении объектов в форму.

Флажок Prompt to save changes before running form (Подтверждать запись изменений до запуска формы на выполнение) используется для вывода на экран сообщения о необходимости сохранения формы перед запуском ее на выполнение.


File Locations

FoxPro в своей работе использует много файлов, находящихся в разных каталогах. Расположение двадцати различных групп файлов определяется с помощью вкладки File Locations (Расположение файлов) (рис. 25.4).

Рис. 25.4. Вкладка File Location диалогового окна Options

Информация на данной вкладке представлена в виде таблицы, состоящей из двух столбцов. Первый столбец содержит наименование группы файлов, а второй — ее местоположение. В табл. 25.10 приведены типы файлов и варианты их настроек.

Таблица 25.10. Типы файлов окна File Location

Тип файла | Назначение | Имя по умолчанию
ActiveDoc Launcher | Определяет имя и расположение приложения, которое вызывается при выборе команды Run Active Document (Запуск активного документа) из меню Tools (Сервис) | Runactd.prg
Beautify | Определяет имя и расположение приложения, которое вызывается при выборе команды Beautify (Улучшить) из меню Tools (Сервис) | Beautify, app
Builders | Определяет имя и расположение приложения-построителя объектов | Builder.app
Class Browser | Определяет имя и расположение приложения, вызываемого командой Class Browser (Обзор класса) из меню Tools (Сервис) | Browser.app
Component Gallery | Определяет имя и расположение приложения для просмотра Галереи компонентов | Gallery.app
Converter | Определяет имя и расположение приложения, преобразующего объекты типа форм и отчетов, разработанные в более ранних версиях FoxPro, в формат Visual FoxPro 7.0 | Converter.app
Coverage Profiler | Определяет имя файла приложения, предназначенного для статистического анализа разработанного вами приложения | Coverage.app
Cross Tab Generator | Определяет имя и расположение программы, создающей перекрестные таблицы | Vfpxtab.fxp
Default Directory | Определяет по умолчанию имя каталога, в котором Visual FoxPro будет пытаться разместить таблицы и программные файлы |
Default Include File | Определяет имя и расположение файла, который используется для задания констант | He задано
Expression Builder | Определяет имя и расположение приложения построителя выражений | He задано
FoxCode Tabl | Определяет имя и расположение таблицы, используемой при функционировании IntelliSense. Эта опция соответствует свойству FoxCode | Foxcode.dbf
FoxTask Table | Определяет имя и расположение таблицы со списком заданий. Эта опция соответствует системной переменной FoxTask | Foxcode.dbf
HTML Generator | Определяет имя и расположение приложения, которое используется для сохранения приложения в формате HTML. По умолчанию имя приложения | Gethtml.app
Help File | Определяет имя и расположение файла справки | Foxhelp.chm
IntelliSense Manager | Определяет имя и расположение программы, поддерживающей Visual FoxPro IntelliSense | Foxcode.app
Menu Builder | Определяет имя и расположение построителя меню |
Resource File | Определяет имя файла ресурсов с информацией о режимах работы, установках редактора, размерах окон, палитрах и т. д. |
Samples Directory | Определяет папку, в которой расположены примеры Visual FoxPro |
Search Path | Определяет каталог, в котором будет производиться поиск файлов, не найденных в текущем каталоге. Здесь можно указать несколько каталогов, разделив их точками или точками с запятой |
Startup Program | Определяет имя и расположение приложения, которое вызывается при запуске Visual FoxPro | VfpGstrt.app
Task List | Задает имя и расположение программы, управляющей списком задач. Эта опция соответствует системной переменной TASKLIST | Tasklist.app
Temporary Files | Определяет каталог для создания временных файлов на диске |
Wizards | Определяет имя и расположение мастеров Visual FoxPro | Wizard. app

Для изменения значения столбца Location (Расположение) выберите строку и выполните одно из следующих действий:

  • нажмите кнопку Modify (Модифицировать) данной вкладки;
  • дважды щелкните кнопкой мыши на данной строке.

На экране открывается диалоговое окно Change File Location (Изменить расположение файла) (рис. 25.5), в котором вы можете выбрать файл или папку.

Рис. 25.5. Диалоговое окно Change File Location


Data

Вкладка Data (Данные) (рис. 25.3) предназначена для задания параметров, связанных с доступом к данным, методами сортировки и поиска, размером блока для Memo-полей, частотой обновления информации и многим другим.

Рис. 25.3. Вкладка Data диалогового окна Options

В верхней части вкладки содержатся флажки, описанные в табл. 25.6.

Таблица 25.6. Назначение флажков вкладки Data

Флажок | Назначение
Open exclusive (Открывать в монопольном режиме) | Определяет режим открытия таблицы. Когда он установлен, Visual FoxPro открывает таблицу в монопольном режиме, т. е. никто кроме вас не сможет ее в дальнейшем открыть
Show field names (Показывать наименования полей) | Соответствует команде SET HEADINGS и определяет, будет ли имя поля появляться в виде заголовка столбца данных при выполнении таких команд, как AVERAGE, DISPLAY, LIST и SUM
Prompt for code page (Напоминание о кодовой странице) | Определяет, запрашивать ли пользователей относительно кодовой страницы. Кодовые страницы, если они включены, выполняют преобразования кодов символов
Ignore deleted records (Игнорировать удаленные записи) | Определяет, как Visual FoxPro будет обрабатывать записи, помеченные для удаления. Этот флажок соответствует команде SET DELETED
Rushmore optimization (Оптимизация) | Включает методику оптимизации поиска, называемую Rushmore, Этот флажок соответствует команде SET OPTIMIZE
Unique records in indexes (Использовать только уникальные индексы) | Влияет на создание индексных файлов. Если он сброшен, то индексы могут содержать повторяющиеся указатели. Флажок соответствует команде SET UNIQUE

Раскрывающийся список Collating sequence (Схема упорядочения) позволяет изменить порядок символов при сортировке, чтобы приспособиться под различные наборы символов в разных странах. По умолчанию используются ASCII-коды. Эта опция соответствует команде SET COLLATE.

На данной вкладке расположены счетчики, приведенные в табл. 25.7.

Таблица 25.7. Назначение счетчиков вкладки Data

Счетчик | Назначение
Record counter interval (Частота отображения количества обработанных записей) | Определяет частоту сообщений выдачи числа обработанных записей при выполнении команд REINDEX, PACK. Соответствует команде SET ODOMETER
Memo block size (bytes) (Длина Мемо-поля) | Определяет длину Memo-поля в байтах и соответствует команде SET BLOCKS IZE
Browse refresh interval (sec) (Частота обновления данных в окне Browse) | Определяет, как часто данные, отображаемые в окне Browse (Обзор), будут синхронизироваться с фактическими данными в таблице. Соответствует команде SET REFRESH
Table refresh interval (sec) (Частота обновления данных на экране) | Определяет, как часто данные, отображаемые в любом окне, будут синхронизироваться с фактическими данными в таблице

Для управления процессом сравнения строк используется область String comparisons (Сравнение строк), содержащая флажки, описанные в табл. 25.8.

Таблица 25.8. Назначение флажков области String comparisons

Флажок | Назначение
SET NEAR on | Определяет действия при неудавшемся поиске. Если флажок не установлен, FoxPro оставляет указатель записи в конце файла, в противном случае — указатель устанавливается на следующую по алфавиту запись после той, в которой ожидалось найти нужное значение
SET EXACT on | Управляет поиском символьных строк. Если он установлен, то требуется точное совпадение образца с полем записи, т. е. совпадение длин строк и совпадение всех их символов. При сброшенном флажке строки сравниваются до длины той из них, которая в условии сравнения стоит справа
SET AN SI on | При сравнении двух строк разной длины дополняет более короткую пробелами, чтобы длины строк стали одинаковыми. Когда флажок сброшен, строки сравниваются до длины более короткой из них

При работе в многопользовательском режиме вам необходимо в области Locking and buffering (Блокировка и буферизация) установить режимы блокировки файлов и записей с помощью флажков, приведенных в табл. 25.9.

Таблица 25.9. Назначение флажков области Locking and buffering

Флажок | Назначение
Automatic file locking (Автоматическое блокирование файла) | Этот флажок установлен всегда, за исключением случаев, когда вы намерены обрабатывать все блокировки в собственной программе. Соответствует команде SET LOCK
Multiple record locks (Блокировка нескольких записей) | Этот флажок устанавливается, когда требуется заблокировать сразу несколько записей и изменять их одновременно. Соответствует команде SET MULTILOCKS

Для установки режима буферизации используется раскрывающийся список Buffering (Буферизация), а для определения количества попыток блокировки — Reprocessing (Повторное выполнение).


Controls

Вкладка Controls (Элементы управления формы) (рис. 25.2) позволяет выбирать библиотеки классов и ActiveX-компоненты. Библиотека классов содержит один или более определенных пользователем классов, которые определяются исходя из основных классов FoxPro. ActiveX-компоненты обеспечивают связь с другими приложениями, поддерживающими OLE. Выбранные на данной вкладке библиотеки классов и ActiveX-компоненты появляются на панели инструментов Form Controls (Элементы управления формы) при нажатии на кнопку View Classes (Просмотр классов) этой панели.

Рис. 25.2. Вкладка Controls диалогового окна Options


IDE

С помощью вкладки IDE (рис. 25.14) настраиваются параметры интерактивной среды разработки.

Рис. 25.14. Вкладка IDE диалогового окна Options

Область Specify file/window (Задать параметры файла/окна) позволяет задать тип файла/окна, настраиваемого с помощью данной вкладки. Список Туре (Тип) содержит возможные типы файлов. Поле Extensions (Расширения) показывает допустимые расширения выбранного типа файлов. Флажок Override individual settings (Перезаписать настройки по умолчанию) позволяет аннулировать настройки, заданные по умолчанию.

Область Indentation (Размеры отступов) позволяет определить размеры табуляции и отступа. По умолчанию используются значения в 4 символа.

Область Save options (Параметры сохранения) содержит флажки, позволяющие определить, каким образом файл выбранного типа будет сохраняться:

  • Make backup (Создать резервную копию) — при установке флажка сохранение файла ведет к созданию резервной копии;
  • Save with line feeds — текущий тип файла сохраняется с символами новой строки CHR(13)+CHR(10);
  • Save with end-of-ffle marker (Сохранить с маркером конца файла) — текущий тип файла сохраняется с символом Ctrl+Z в конце файла;
  • Compile before saving (Компилировать перед сохранением) — перед сохранением данного типа файла осуществляется его компиляция.

Область Appearance and behavior (Отображение и поведение) позволяет задать, как будет выглядеть текст настраиваемого типа файла. Список Alignment (Выравнивание) определяет тип выравнивания информации: по левому краю, по центру, по правому краю. Поле Font (Шрифт) указывает шрифт, стиль оформления и размер символов текущего типа файла. Флажки области имеют следующее назначение:

  • Drag-and-drop editing (Правка механизма перенести-и-оставить) — указывает, будет ли настраиваемый тип файла поддерживать механизм "перенести-и-оставить";
  • Automatic indent (Автоматический отступ) — позволяет автоматически делать отступ при переходе на новую строку;
  • Show line/column position (Показывать позицию курсора) — управляет отображением в строке состояния главного окна позиции курсора в Memo-полях;
  • Word wrap (Перенос слов) — управляет переносом слов в окне редактирования файла;
  • Syntax coloring (Выделять синтаксические конструкции) — установленный флажок позволяет использовать выделение цветом текста в программе, в соответствии с результатами синтаксической проверки;
  • Embedded hyperlinks (Включить гиперссылки) — указывает, можно ли включать гиперссылки в настраиваемый тип файла;
  • Display white space (Показывать непечатаемые символы) — управляет отображением на экране заданных непечатаемых символов (табуляции, отступов и т. д.).

Кнопка Apply (Применить установки) сохраняет параметры, заданные на вкладке IDE, а кнопка Reset All (Восстановить все) — восстанавливает параметры, задаваемые по умолчанию Visual FoxPro.


Field Mapping

С помощью вкладки Field Mapping (Связь типов элементов управления с типами полей таблиц) (рис. 25.13) вы можете установить тип объекта, который будет создаваться в форме при размещении в ней полей таблицы заданного типа.

Таблица для определения соотношения между типом объекта и типом поля содержит три столбца:

  • Туре (Тип) — типы полей таблиц;
  • Class Library (Библиотека класса) — имя библиотеки, из которой выбирается тип объекта;
  • Class Name (Имя класса) — имя класса объекта, определяющего тип создаваемого объекта.

При нажатии на кнопку Modify (Модифицировать) открывается диалоговое окно Modify Field Mapping (Связь типов элементов управления с типами полей таблиц), в котором вы можете установить связь между типом поля таблицы базы данных и типом объекта.

Рис. 25.13. Вкладка Field Mapping диалогового окна Options

В области Database options (Параметры базы данных) вкладки Field Mapping (Связь типов элементов управления с типами полей таблиц) расположены четыре флажка (табл. 25.21).

Таблица 25.21. Назначение флажков области Database options

Флажок | Назначение
Drag and drop field caption (Перенести-и-оставить подпись поля) | При выборе этой опции имя поля таблицы будет размещено в форме в качестве надписи к создаваемому объекту
Copy field comment {Копировать комментарии к полю) | Копирует примечание поля базы данных в свойство comment (Комментарий) создаваемого объекта
Copy field input mask (Копировать маску ввода поля) | Копирует маску ввода поля базы данных в свойство inputMask (Маска ввода) создаваемого объекта
Copy fie Id format (Копировать формат поля) | Копирует маску ввода поля базы данных в свойство Format (Формат) создаваемого объекта


Debug

Вкладка Debug (Отладка) (рис. 25.12) диалогового окна Options (Параметры) Visual FoxPro позволяет настроить параметры работы отладчика, такие как:

  • шрифт и цвета;
  • отработка событий таймера;
  • нумерация строк кода на экране;
  • сохранение в файле содержимого окна Debug Output (Выходные данные отладки).

Рис. 25.12. Вкладка Debug диалогового окна Options

Раскрывающийся список Environment (Окружение) содержит два значения:

  • Debug Frame (Область отладки) — при установке данного значения все окна отладчика открываются в отдельном от основного окна Visual FoxPro окне. При установке этой опции вы можете открыть окно отладчика с помощью команды Debugger (Отладчик) из меню Tools (Сервис);
  • FoxPro Frame (Область FoxPro) — отладчик встраивается в основное окно Visual FoxPro. При установке данного значения в меню Tools (Сервис) вместо пункта меню Debugger (Отладчик) появляется пять пунктов меню, открывающих отдельные окна трассировки программы, просмотра переменных.

Для отображения событий таймера в окне Trace (Трассировка) установите флажок Display Timer Events (Показывать события таймера).

С помощью переключателя области Specify Window (Задать параметры окна) и расположенных ниже объектов настраиваются параметры окон отладки:

  • Call Stack (Стек вызова). Определяются параметры окна Call Stack (Стек вызова) (табл. 25.18);
  • Output (Выходные данные). Задаются параметры окна Debug Output (Выходные данные отладки) (табл. 25.19);
  • Trace (Трассировка). Задаются параметры окна Trace (Трассировка) (табл. 25.20).

Таблица 25.18. Назначение флажков области Call Stack

Флажок | Назначение
Show call stack order (Показывать стек вызова) | При установке флажка показывается глубина вложенности программы
Show current line indicator (Показывать индикатор текущей строки) | Устанавливает режим выделения текущей строки в окне Call Stack (Стек вызова)
Show call stack indicator (Показывать индикатор стека вызова) | Управляет выделением стрелкой процедуры, отображаемой в окне Trace (Трассировка)

Таблица 25.19. Назначение флажков области Debug Output

Флажок | Назначение
Log Debug Output (Записать данные отладки) | Результат отладки записывается в текстовый файл
Append (Добавлять) | Информация окна Debug Output (Выходные данные отладки) добавляется к содержимому заданного текстового файла
Overwrite (Обновлять) | Информация окна Debug Output (Выходные данные отладки) обновляет содержимое заданного текстового файла

Таблица 25.20. Назначение флажков области Trace

Опция | Назначение
Show line numbers (Показывать нумерацию строк) | Отображается нумерация строк
Trace between breakpoints (Трассировка между точками останова) | Устанавливается замедленный режим выполнения программы между точками останова
Pause between line execution (Пауза между выполнением строк программы) | Задает задержку в секундах между выполнением каждой строки программы

С помощью кнопки Font (Шрифт) и раскрывающихся списков области Colors (Цвета) устанавливаются гарнитура шрифта, его цвет и фон.


Editor

Вкладка Editor (Редактор) (рис. 25.11) диалогового окна Options (Параметры) позволяет настроить параметры редактора Visual FoxPro.

Рис. 25.11. Вкладка Editor диалогового окна Options

В верхней области вкладки расположены три флажка:

  • Selection margin (Область выборки) — при установке флажка в левой части окна редактора появляется область, в которой можно устанавливать признак точки останова или заметки;
  • Drag Drop between words (Перенести-и-оставить между словами) — устанавливает режим, в котором при использовании механизма "перенести-иоставить" выделенную область можно вставить только между словами;
  • Enable hyperlinks (Доступны гиперссылки) — определяет, будет ли редактор распознавать "http:/" как гиперссылку.

Поле Comment string (Строка комментария) содержит символы, совокупность которых в программе идентифицирует строку с комментарием. По умолчанию используется набор символов *!*.

Счетчик List display count (Количество элементов в списке) определяет максимальное количество элементов в раскрывающемся списке.

Счетчик Highlight duration (Интервал подстветки) определяет количество миллисекунд, в течение которого при закрытии круглой или квадратной скобки содержащийся в скобках текст будет выделен. Вы можете выбрать значение из списка или ввести его вручную.

Раскрывающийся список Area (Область) области Syntax color settings (Цветовое выделение синтаксических конструкций) содержит перечень программных элементов Visual FoxPro (зарезервированных слов, операторов, переменных, комментариев и т. д.). Выбирая из этого списка значение программного элемента, можно, используя список Font style (Стиль шрифта), задать стиль его отображения, а используя списки Foreground (Цвет шрифта) и Background (Цвет фона) — цвет шрифта и цвет фона.

Кнопка Reset All (Восстановить все) позволяет восстановить предыдущее состояние цветов и стилей программных элементов.


ГЛАВА 25
Настройка параметров Visual FoxPro

Visual FoxPro содержит множество разнообразных параметров настройки. Вы можете указать расположение системных файлов, форматы отображения данных и многое другое. Для их настройки используется диалоговое окно Options (Параметры) (рис. 25.1), которое открывается при выполнении команды Options (Параметры) из меню Tools (Сервис).

Для облегчения настройки параметров они сгруппированы по функциональному назначению, причем каждая группа отображается на отдельной вкладке. Перечень вкладок и их назначение приведены в табл. 25.1.

Таблица 25.1. Назначение вкладок диалогового окна Options

Вкладка | Назначение
General (Общие) | Содержит параметры настройки звука, программирования, ввода данных
View (Вид) | Содержит флажки, определяющие, будут ли отображаться на экране строка состояния, часы, системные сообщения и информация общего характера
Data (Данные) | Содержит параметры для управления данными в таблицах
Remote Data (Удаленные данные) | Осуществляет настройку средств удаленного доступа к данным
File Locations (Расположение файлов) | Содержит расположение каталогов и файлов Visual FoxPro
Forms (Формы) | Настраивает конструктор форм
Projects (Проекты) | Настраивает окно проекта
Controls (Элементы управления) | Содержит параметры настройки визуальных классов и OLE-объектов
Regional (Региональные параметры) | Содержит форматы отображения дат, времени, денежных единиц и чисел
Debug (Отладка) | Содержит параметры отладки и трассировки
IDE (Интерактивная среда разработки) | Содержит параметры, позволяющие настроить свойства интерактивной среды разработки Visual FoxPro
Editor (Редактор) | Настраивает параметры редактора Visual FoxPro
Field Mapping (Связь типов элементов управления с типами полей таблиц) | Задает тип объекта, который по умолчанию создается в форме при переносе в нее таблицы или поля из окон конструктора базы данных, проекта и среды окружения

После настройки параметров вы можете нажать кнопки ОК или Set As Default (По умолчанию). При нажатии кнопки ОК установленные значения будут действовать только в текущем сеансе работы с Visual FoxPro, а при нажатии кнопки Set As Default (По умолчанию) — во всех последующих сеансах.

Рис. 25.1. Вкладка General диалогового окна Options

Параметры вкладок окна Options

General

Вкладка General (Общие) (рис. 25.1) содержит флажки и опции, влияющие на совместимость с предыдущими версиями программ, на установку цвета, звуковых сигналов и ввод данных.

Область Warning sound (Предупреждение звуком) данной вкладки позволяет выбрать тип звукового сигнала, звучащего при достижении пользователем конца поля или вводе недопустимых данных, путем установки одной из трех опций (табл. 25.2).

Таблица 25.2. Назначение опций области Warning sound

Опция | Назначение
Off (Выкл.) | Звуковой сигнал выключен
Default (По умолчанию) | Частота и длительность звукового сигнала устанавливаются по умолчанию (частота 512 Гц, продолжительность - 2 с)
Play (Проигрывать) | Проигрывает звуковой файл

При выборе опции Play (Проигрывать) можно воспользоваться кнопкой, расположенной права от поля ввода, и выбрать файл звукового сигнала с расширением WAV.

С правой стороны вкладки расположены четыре флажка (табл. 25.3).

Таблица 25.3. Назначение флажков для выбора файла звукового сигнала

Флажок | Назначение
dBASE compatibility (Совместимый с dBASE) | Флажок управляет совместимостью Visual FoxPro с другими Xbase языками. Если флажок установлен, то Visual FoxPro иначе интерпретирует команды, перечисленные в табл. 25.2
Use Visual FoxPro color palette (Использовать цветовую палитру Visual FoxPro) | При установленном флажке Visual FoxPro использует по умолчанию собственную цветовую палитру при отображении растровых изображений. При сброшенном флажке применяется палитра, использовавшаяся при его создании. Этот флажок соответствует команде SET PALETTE
Confirm file replacement (Подтверждать перезапись файла) | Определяет, будет ли выдаваться предупреждающее сообщение перед перезаписью уже существующего файла. Этот флажок соответствует команде SET SAFETY
Browse I ME Control (Отображать окно редактора) | Используется для открытия окна редактора при работе в режиме, когда каждый символ отображается двумя байтами

Таблица 25.4. Команды, действие которых изменяется командой SET COMPATIBLE

Команда | В состоянии On | В состоянии Off
@ . . . GET . . . RANGE | Всегда проверяет предел | Проверяет предел, только если изменяются данные
@ . , . SAY | CHR(7) вызывает звуковой сигнал | CHR (7 ) не вызывает звуковой сигнал
@ . . . SAY | Вывод информации на экран вызывает сдвиг экрана вверх | Вывод информации на экран прекращается при достижении нижнего правого угла
@ . . . SAY | Крайняя правая цифра при использовании PICTURE округляется | Крайняя правая цифра при использовании PICTURE отсекается
ACTIVATE SCREEN | Делая активным экран, устанавливает курсор в позицию 0,0 | Делая активным экран, не изменяет позицию курсора
ACTIVATE WINDOW | Делая активным окно, устанавливает курсор в позицию 0,0 | Делая активным окно, не изменяет позицию курсора
APPEND MEMO | Использует по умолчанию расширение ТХТ | Расширения по умолчанию нет
DECLARE | Создает одномерный или двумерный массив | (Используйте вместо нее команду DIMENSION)
DIMENSION | Создает одномерный или двумерный массив |
FSIZE | Возвращает размер файла | Возвращает размер поля
GO/GOTO (если было SET TALK ON) | Выводит сообщение о текущей рабочей области и номере записи | Не выводит сообщений
INKEY ( ) | Клавиши <Ноте> и <Shift>+ +<Ноте> возвращают код 26. Клавиши <Ctrl>+«-> возвращают 1 | Клавиши <Ноте> и <Shift>+ +<Ноте> возвращают 1 . Клавиши <Ctrl>+«-> возвращают 26
LASTKEY { ) | Возвращает целое число в соответствии с кодом последней нажатой клавиши | (Используйте вместо нее функциюINKEY ( ) )
LIKEO | Лидирующие пробелы в строках отсекаются перед сравнением | Лидирующие пробелы сохраняются и считаются значимыми
MENU И POPUP | Меню помещается в текущее окно вывода, курсор позиционируется согласно команде | Меню помещается в свое собственное окно, курсор остается в текущем окне вывода
Вложенные операторы | Подразумевается выполнение команды CLEAR GETS При возврате на более высокий уровень | Текущие GETS остаются при переходе на более высокий уровень
PLAY MACRO | Подразумевается добавление клавиши <Alt>+<F10> перед макрокомандами, которые начинаются на A— Z. Перед макросами <F1>— <F9> добавляется <Alt> | Ничего не добавляется
READ | Проверяет значение оператором VALID при нажатии клавиши <Esc> | При нажатии <Esc> проверок VALID не выполняется
RUN | Перед началом вывода курсор передвигается в первую позицию 24-й строки. После завершения экран сдвигается на 3 строки вверх | Вывод на экран начинается с текущей позиции курсора, а после завершения экран сдвигается на две строки
SELECT () | Возвращает номер наибольшей неиспользуемой рабочей области | Возвращает номер текущей рабочей области
SET COLOR TO | Устанавливает цвета окон и меню, определенных пользователем | (Пользуйтесь вместо нее командой COLOR OF SCHEME)
SET BORDER | Определяет границу вокруг различных полей, меню и окон |
SET FIELDS | Определяет поля, к которым возможен доступ |
SET MEMOWIDTH | Определяет ширину Memoполей и символьных выражений |
SET MESSAGE | Выдает сообщение в нижней строке экрана | Сообщение выдается, если была команда SET STATUS ON
SET PRINTER TO | По умолчанию выходной файл имеет расширение PRT | Выходной файл не имеет расширения по умолчанию
STORE | Не может присвоить значения всем элементам массива | Может присвоить значения сразу всем элементам массива
SUM | Использует установленное КОМаНДОЙ SET DECIMALS ЧИСЛО десятичных цифр | Используемое число десятичных цифр определяется суммируемым полем
SYS (2001, 'COLOR' ) | Возвращает значение, установленное последней командой SET COLOR | Возвращает значение цветовой пары для оператора SET COLOR TO
TRANSFORM | Возвращает строку символов из символьного или числового выражения |
USE | Если установлен путь VFP и в команде указано устройство, то поиск срайла производится только на указанном устройстве | Если установлен путь VFP и в команде указано устройство, то вначале производится поиск на заданном устройстве, а затем — по указанному пути

Область Programming (Программирование) вкладки General (Общие) содержит три флажка, связанных с программированием (табл. 25.5).

Таблица 25.5. Назначение флажков вкладки General

Флажок | Назначение
Cancel programs on escape (Останавливать программу при нажатии <Esc>) | Позволяет прерывать выполнение программы нажатием клавиши <Esc>
Log compilation errors (Регистрировать ошибки компиляции) | Позволяет ошибки, возникающие при компиляции файла, регистрировать в специальном файле
SET DEVELOPMENT (Компилировать при изменении) | При установке данного флажка перед выполнением уже скомпилированного файла Visual FoxPro проверяет, был ли исходный файл изменен, и в случае изменения — повторно компилирует его

В области Data entry (Входные данные) вкладки General (Общие) содержатся три команды, связанные с вводом данных:

  • Список Navigation keys (Кнопки навигации) соответствует команде SET KEYCOMP;
  • Флажок Fill new records with current values (Заполнить новые записи текущими значениями) вызывает перенос содержимого текущей записи в новую запись и соответствует команде SET CARRY;
  • Установка флажка Enter or tab to exit fields (Выход из поля нажатием <Enter> или <Tab>) разрешает пользователю переходить в следующее поле только нажав клавишу <Enter> или <ТаЬ>. Флажок соответствует команде SET CONFIRM. Установка флажка несколько замедляет ввод данных, но при этом предотвращает случайное изменение полей записи.

Замечание

Команда SET CARRY может содержать фразу то, которая позволяет указать поля, переносимые из старых записей в новую.

В области Year 2000 Compliance (Соглашение по 2000 году) вкладки General (Общие) содержится раскрывающийся список Strict Date Level (Строгая проверка данных типа "дата и время"), который используется для анализа ошибок и неоднозначности данных типа "дата".


  • Параметры вкладок окна Options
  • General
  • Controls
  • Data
  • File Locations
  • Forms
  • Projects
  • Regional
  • Remote Data
  • View
  • Editor
  • Debug
  • Field Mapping
  • IDE


Формирование списка отчетов

Вкладка Reports (Отчеты) (рис. 3.15) диалогового окна Application Builder

(Построитель приложения) позволяет сформировать список отчетов проекта.

Рис. 3.15. Вкладка Reports диалогового окна Application Builder

Если для входящих в проект таблиц на вкладке Data (Данные) в столбце Report (Отчет) вы установили флажки и нажали кнопку Generate (Построить),мастер создаст отчеты, а их названия поместит на вкладку Reports (Отчеты).Вы можете добавить в этот список отчеты, созданные ранее, используя для этого диалоговое окно Open (Открыть), открываемое при нажатии кнопки Add (Добавить).

Поле ввода Name (Имя) содержит имя выбранного в списке отчета. Флажок Appear in Print Reports dialog (Добавить в диалоговое окно печати отчетов)указывает, нужно ли отображать имя отчета в диалоговом окне Print Reports(Печать отчетов).

На вкладке расположены кнопки, имеющие следующее назначение (табл. 3.12).

Таблица 3.12, Назначение кнопок вкладки Reports диалогового окна Application Builder

Кнопка | Назначение
Add (Добавить) | Открывает диалоговое окно Open для добавления в проект существующего отчета
Edit (Правка) | Запускает конструктор отчетов и открывает в нем для модификации текущий отчет
Remove (Удалить) | Удаляет из проекта выбранный в списке отчет


Формирование списка форм проекта

Вкладка Forms (Формы) (рис. 3.14) предназначена для создания списка форм проекта.

Рис. 3.14. Вкладка Forms диалогового окна Application Builder

Если для входящих в проект таблиц вы установили в столбце Form (Форма)вкладки Data (Данные) соответствующие флажки и нажали кнопку Generate(Построить), то мастер создаст формы, причем их названия будут отображаться в списке форм на вкладке Forms (Формы). Вы можете добавить в этот список формы, созданные ранее, используя для этого диалоговое окно Open (Открыть), открываемое при нажатии кнопки Add (Добавить).

В правой части вкладки расположено поле ввода и флажки, которые определяют свойства форм, выбранных из списка.

Поле ввода Name (Имя) содержит название формы. Устанавливая следующие флажки, можно задать такие свойства формы (табл. 3.10).

Таблица 3.10. Назначение флажков вкладки Forms диалогового окна Application Builder

Флажок | Назначение
Single instance (Один экземпляр) | Пользователь сможет открыть форму в приложении не больше одного раза
Use Navigation toolbar (Использовать панель навигации) | При открытии формы на экране появляется панель инструментов, позволяющая перемещаться по записям
Use Navigation menu (Использовать меню навигации) | Во время выполнения формы в строку меню добавляется пункт Go, содержащий команды для управления работой формы
Appear in File New dialog (Показывать в диалоговом окне команды New из меню File) | Имя формы добавляется в список, вызываемый при выборе команды New (Новый) из меню File(Файл) проекта
Appear in File Open dialog (Показывать в диалоговом окне команды Open из меню File) | Имя формы добавляется в список, вызываемый при выборе команды Open (Открыть) из меню File (Файл)

Для того чтобы добавить, изменить или удалить форму проекта, на вкладке размещены специальные кнопки (табл. 3.11).

Таблица 3.11. Назначение кнопок вкладки Forms диалогового окна Application Builder

Кнопка | Назначение
Add (Добавить) | Открывает диалоговое окно Open (Открыть), позволяющее добавить в проект существующую форму
Edit (Правка) | Открывает форму в конструкторе форм для ее модификации
Remove (Удалить) | Удаляет из проекта форму, выбранную в списке


Формирование списка баз данных и таблиц, используемых в проекте

Вкладка Data (Данные) (рис. 3.12) диалогового окна Application Builder(Построитель приложения) позволяет сформировать список баз данных и таблиц, включаемых в проект. В список, представленный на вкладке в табличном виде, можно добавлять как новые, так и уже существующие базы данных и таблицы (табл. 3.8).

Рис. 3.12. Вкладка Data диалогового окна Application Builder

Таблица 3.8. Назначение столбцов вкладки Data диалогового окна Application Builder

Столбец | Назначение
Datasource (Источник данных) | Имя таблицы
Form {Форма} | Содержит флажок, установка которого указывает на необходимость автоматического создания формы для данной таблицы
Report (Отчет) | Содержит флажок, установка которого указывает на необходимость автоматического создания отчета для данной таблицы

Для добавления в проект таблиц, их удаления и других действий над ними на вкладке расположены следующие кнопки (табл. 3.9).

Таблица 3.9. Назначение кнопок вкладки Data диалогового окна Application Builder

Кнопка | Назначение
 | Запускает мастера баз данных, который создает для проекта новую базу данных
 | Запускает мастера таблиц для создания новой таблицы
Select (Выбрать) | Открывает диалоговое окно для выбора уже существующей базы данных или таблицы
Clear (Очистить) | Очищает диалоговое окно от таблиц, которые были добавлены в проект
Generate (Построить) | При нажатии кнопки происходит добавление в проект всех размещенных на вкладке таблиц, осуществляется создание форм и отчетов для тех таблиц, в которых установлены соответствующие флажки. После всех выполненных действий список таблиц очищается

Для форм, создаваемых мастером проекта, можно задать стиль оформления, используя раскрывающийся список Form Style (Стиль формы), находящийся непосредственно под таблицей. На рис. 3.13 представлена форма, созданная с использованием стиля Embossed (Рельефный).

При создании отчета, как и при создании форм, можно применять различные стили. Для задания стиля отчета используется раскрывающийся список Report Style (Стиль отчета).

Рис. 3.13. Форма, созданная с использованием стиля Embossed


Задание информации о разработчиках проекта

На вкладке Credits (Об авторе) (рис. 3.11) диалогового окна Application Builder

(Построитель приложения) указывается следующая информация: список авторов, предприятие, номер версии, права и торговая марка приложения.

Рис. 3.11. Вкладка Credits диалогового окна Application Builder

Для ввода этих данных используются поля, перечисленные в табл. 3.7.

Таблица 3,7. Назначение полей вкладки Credits диалогового окна Application Builder

Поле ввода | Назначение
Author (Автор) | Список разработчиков приложения
Company (Предприятие) | Наименование предприятия
Version (Версия) | Версия приложения
Copyright (Права) | Права по использованию приложения
Trademark (Торговая марка) | Торговая марка приложения


Задание общих параметров проекта

Вкладка General (Общие) (см. рис. 3.10) предназначена для задания таких параметров проекта, как его имя, размещаемый в проекте рисунок, тип создаваемого приложения, общие диалоговые окна, значок проекта.

Поле ввода Name (Имя) позволяет задать имя приложения, отображаемое в его заголовке, диалоговом окне О программе, а также внутри приложения.

В поле ввода Image (Рисунок) можно задать имя файла рисунка, который будет появляться в окне при запуске приложения и в диалоговом окне Опрограмме.

Область Application Type (Тип приложения) позволяет задать тип создаваемого приложения (табл. 3.5).

Таблица 3.5, Опции области Application Type

Опция | Тип приложения
Normal (Обычное) | Созданное приложение будет запускаться в главном окне Visual FoxPro, заменяя все окружение и системное меню VisualFoxPro
Module (Автономное) | Приложение добавляется в существующий проект или будет вызываться из другого приложения. Меню приложения добавляется в системное меню и его функции используются как компоненты другого приложения
Top-Level (Верхний уровень) | Приложение будет запускаться как отдельное приложение Microsoft Windows

Устанавливая флажки группы Common Dialogs (Общие диалоги), можно сформировать список общих диалоговых окон приложения с информацией о разработчиках, правами доступа к файлам приложения (табл. 3.6).

Таблица 3.6. Назначение флажков группы Common Dialogs

Флажок | Назначение
Splash screen (Всплывающий экран) | При запуске приложения появляется окно, содержащее логотип приложения и сведения об авторе
About dialog (О программе) | Приложение содержит диалоговое окно О программе, в котором будет содержаться логотип приложения и сведения о разработчиках
Quick start (Быстрый старт) | Проект содержит диалоговое окно Quick Start, в котором определяются права доступа к документам приложения и остальным файлам
User logins (Окно ввода пароля) | При установленном флажке в проект добавляется форма, предназначенная для ввода пароля при запуске приложения

В области Icon (Значок) можно определить значок приложения.


Использование мастера при создании проекта

В Visual FoxPro 7.0 при создании проекта с помощью мастера вы можете включить в него таблицы, формы, отчеты, которые на разных шагах создания вам предлагает мастер, а также добавить в проект элементы, созданные ранее.

Чтобы создать новый проект с помощью мастера, выполните следующие действия:

  1. В меню File (Файл) выберите команду New (Новый) или нажмите кнопку New (Новый) на панели инструментов.
  2. Откроется диалоговое окно New (Новый), в котором выберите опцию Project (Проект) и нажмите кнопку Wizard (Мастер).
  3. Откроется диалоговое окно, представленное на рис. 3.9. В поле ввода Project name (Имя проекта) этого окна необходимо задать имя создаваемого проекта, а в поле ввода Project file (Файл проекта) указать его расположение. Для выбора папки, в которой вы хотите разместить проект, можно использовать кнопку Browse (Обзор), открывающую диалоговое окно, позволяющее найти на компьютере необходимую папку.

Рис. 3.9. Задание имени проекта и его расположения

  4. После определения имени файла и его расположения нажмите кнопку ОК для создания нового проекта. Мастер переходит к созданию нового проекта, и на экране появляется диалоговое окно построителя приложения Application Builder (Построитель приложения) (рис. 3.10).

Нижняя часть диалогового окна содержит следующие кнопки:

  • Help — открывает файл справки;
  • Cancel — отменяет работу мастера;
  • ОК — создает новый проект.

Рис. 3.10. Диалоговое окно построителя приложения

Кроме того, диалоговое окно содержит шесть вкладок, на которых определяется следующая информация (табл. 3.4).

Таблица 3,4. Вкладки диалогового окна Application Builder

Вкладка | Информация
General (Общие) | Основные параметры создаваемого проекта
Credits (Об авторе) | Информация об авторах проекта
Data (Данные) | Параметры создания баз данных и таблиц
Forms (Формы) | Информация о формах, входящих в проект
Reports (Отчеты) | Информация об отчетах, входящих в проект
Advanced (Дополнительные) | Параметры создания справочной системы, меню проекта


Управление элементами проекта

Для управления элементами проекта используются кнопки, расположенные в правой части окна проекта. Часть кнопок можно применять при работе с файлами всех типов, а часть — только с определенными. В табл. 3.3 приведен список кнопок, которые вы можете использовать для всех типов файлов проекта.

Таблица 3.3. Назначение кнопок меню Project

Кнопка | Назначение
New (Новый) | Создает новый файл, который после создания автоматически добавляется в проект
Add (Добавить) | Добавляет созданный ранее файл в проект
Modify (Модифицировать) | Модифицирует выбранный файл проекта
Remove (Удалить) | Удаляет файл из проекта

Для выполняемых файлов (формы, отчеты, запросы, программы и меню)может использоваться кнопка Run (Выполнить), которая запускает выбранный файл проекта на выполнение. Для таблиц вы можете выбрать кнопку Browse (Обзор), чтобы просмотреть данные, содержащиеся в таблице.


Управление проектом с помощью меню

При открытии окна проекта в основное меню Visual FoxPro добавляется новый пункт меню Project (Проект), который содержит команды, позволяющие работать с файлами, входящими в проект. Назначение этих команд описано в табл. 3.2.

Таблица 3.2. Назначение команд меню Project

Команда | Назначение
New File (Новый файл) | Создает новый файл, который автоматически добавляется в проект
Add File (Добавить файл) | Добавляет созданные ранее файлы в проект
Modify File (Модифицировать файл) | Модифицирует выбранный файл проекта
Browse File (Просмотр файла в табличном виде) | Открывает таблицу в режиме Browse
Preview File (Просмотр файла) | Открывает файл в окне предварительного просмотра
Remove File (Удалить файл) | Удаляет файл из проекта
Rename File (Переименовать файл) | Переименовывает файл, входящий в проект
Run File (Выполнить файл) | Запускает файл на выполнение
Exclude (Исключить) | Исключает файл из проекта
Include (Включить) | Включает файл в проект
Set Main (Основная программа) | Устанавливает файл в качестве основной программы проекта
Edit Description (Правка описания) | Открывает окно редактирования описания файла
Project Info (Информация проекта) | Отображает информацию о проекте
Errors (Ошибки) | Отображает ошибки, возникшие при построении проекта
Build (Построить) | Перестраивает проект
Refresh (Обновить) | Обновляет информацию в окне проекта
Clean Up Project (Упаковать) | Упаковывает проект, очищая его от удаленных файлов

Для работы с файлами проекта можно использовать контекстное меню, раскрываемое при щелчке по нему правой кнопкой мыши (рис. 3.8) и содержащее некоторые команды из меню Project (Проект), а также команду Expand All (Раскрыть все), раскрывающую все уровни вложенности данных в окне Project Manager (Менеджер проекта).

Рис. 3.8. Контекстное меню для выбранного файла проекта


Настройка дополнительных параметров проекта

Вкладка Advanced (Дополнительные) (рис. 3.16) позволяет задать дополнительные параметры настройки проекта.

Рис. 3.16. Вкладка Advanced диалогового окна Application Builder

Поле ввода Help file (Файл справки) используется для указания имени и расположения файла справки приложения. Имя файла можно ввести вручную или выбрать из списка, воспользовавшись кнопкой, расположенной справа от поля ввода.

В поле ввода Default data directory (Каталог данных по умолчанию) отображается название папки, в которой будут размещены базы данных и таблицы.

В области Menus (Меню) расположены флажки, управляющие отображением панели инструментов и строки меню (табл. 3.13).

Таблица 3.13. Назначение флажков вкладки Advanced диалогового окна Application Builder

Флажок | Назначение
Standard toolbar (Стандартная панель) | Флажок управляет отображением в приложении стандартной панели инструментов
Favorites menu {Меню Избранное) | При установленном флажке в строку меню добавляется пункт Favorites, содержащий список наиболее часто используемых форм и отчетов приложения

С помощью кнопки Cleanup (Привести в соответствие) вы можете очистить таблицу проекта от записей, содержащих ссылки на удаленные элементы проекта.


ГЛАВА 3
Проект как средство объединения элементов приложения

При создании приложения используется проект, который объединяет элементы приложения Visual FoxPro и группирует их по типам. Информация о проекте хранится в специальной таблице, которая, в отличие от обычных таблиц Visual FoxPro, имеет расширение PJX. Memo-поля таблицы содержат наименование элемента проекта, его описание и другие текстовые атрибуты. Файл с Memo-полями таблицы имеет расширение PJT. Использование проекта упрощает разработку приложения, т. к. в проекте базы данных, программы, формы, отчеты, запросы и другие элементы приложения располагаются в соответствующих разделах, а также запоминается расположение каждого включенного в проект элемента.

.Создав проект и определив входящие в него элементы, вы можете использовать его для сборки приложения, построив файл с расширением АРР, или для создания исполняемого файла с расширением ЕХЕ. При построении приложения из проекта осуществляется поиск и сборка файлов, на которые ссылаются элементы приложения, отслеживаются версии файлов, входящих в проект.

Создание проекта приложения

Приступая к разработке нового приложения, прежде всего создайте проект приложения. В дальнейшем вы будете добавлять в него созданные вами элементы приложения. Для создания нового проекта вы можете использовать мастер Application Wizard (Мастер приложения) или команду New (Новый) из меню File (Файл).

При выполнении команды New (Новый) на экране открывается соответствующее диалоговое окно с перечислением всех типов элементов приложения, которые возможны в Visual FoxPro (рис. 3.1). По умолчанию установлена опция Project (Проект).

Для создания нового проекта выполните следующие действия:

1. Нажмите кнопку New file (Новый файл).

Рис. 3.1. Диалоговое окно New, в котором можно указать тип создаваемого файла

2. В поле ввода Enter project (Введите имя проекта) диалогового окна Create (Создать) задайте имя создаваемого проекта, убедившись, что в поле Тип файла установлен тип сохраняемого файла Project (Проект), а в поле Папка правильно выбрана папка, в которой вы хотите расположить свой проект (рис. 3.2).

Рис. 3.2. Диалоговое окно Create для задания имени создаваемого проекта

4. Для сохранения созданного проекта нажмите кнопку Сохранить. VisualFoxPro создаст файлы проекта и запишет их в указанное место. После этого откроется окно проекта Project Manager (Менеджер проекта)(рис. 3.3).

Рис. 3.3. Окно проекта Project Manager

В верхней части окна проекта находятся вкладки, которые управляют отображением определенных типов файлов проекта, значительно облегчая работу по разработке приложения (табл. 3.1).

Таблица 3.1. Вкладки окна Project Manager

Вкладка | Отображаемые файлы
All (Все) | Все файлы
Data (Данные) | Базы данных, таблицы, запросы, представления данных, хранимые процедуры
Documents (Документы) | Формы, отчеты и этикетки
Classes (Классы) | Классы
Code (Коды) | Программы и библиотеки
Other (Остальные) | Меню, файлы переменных памяти, клавишные макрокоманды

В Visual FoxPro используется иерархическое отображение элементов проекта. На самом верхнем уровне находятся категории элементов проекта: Data(Данные), Documents (Документы), Class Libraries (Библиотека классов),Code (Исходный код) и Other (Другие).

Примечание

Для каждой категории элементов в окне проекта имеется отдельная вкладка.

На следующем уровне находятся типы файлов данной категории. Например, для категории Documents (Документы) имеются следующие типы файлов:

  • Forms — формы;
  • Reports — отчеты;
  • Labels — этикетки.

Некоторые типы файлов могут иметь следующие уровни иерархии. Например, база данных может содержать таблицы, представления данных, а каждая таблица — поля.

Каждый иерархический список может находиться в свернутом или развернутом состоянии. Если элемент иерархического списка содержит элементы следующего уровня, то в свернутом состоянии с левой стороны наименования элемента отображается знак плюс. На рис. 3.3 видно, что все элементы списка, кроме Class Libraries (Библиотеки классов), содержат вложенные уровни элементов. Для раскрытия списка элементов следующего уровня необходимо щелкнуть мышью на знаке плюс. При раскрытии списка знак плюс изменяется на знак минус. На рис. 3.4 приведен пример иерархического списка Data (Данные), имеющего глубину в четыре уровня. Для свертывания вложенного списка элементов необходимо щелкнуть мышью на знаке минус.

В окне проекта имеется одна очень интересная и полезная кнопка. Расположена она в правом верхнем углу окна проекта и содержит направленную вверх стрелку. При нажатии на эту кнопку окно проекта сворачивается, остаются видимыми только наименования вкладок, а значок кнопки меняется на стрелку, направленную вниз. Тем самым на экране освобождается место для других окон (рис. 3.5).

Рис. 3.4. Иерархический список элементов проекта

Рис. 3.5. Свернутое окно проекта

Рис. 3.6. Одна вкладка проекта раскрыта

Рис. 3.7. Перемещение открытых вкладок по экрану

При этом вкладки проекта остаются активными и при нажатии на них открывается часть окна проекта, содержащая информацию выбранной вкладки(рис. 3.6). Для возврата окна проекта в развернутый вид нажмите кнопку, содержащую стрелку, направленную вниз.

Visual FoxPro 7.0 предоставляет возможность перемещать открытую вкладку по экрану. Для этого щелкните на ярлыке и, не отпуская кнопки мыши, переместите вкладку в любое место главного окна Visual FoxPro (рис. 3.7).


  • Создание проекта приложения
  • Управление проектом с помощью меню
  • Управление элементами проекта
  • Использование мастера при создании проекта
  • Задание общих параметров проекта
  • Задание информации о разработчиках проекта
  • Формирование списка баз данных и таблиц, используемых в проекте
  • Формирование списка форм проекта
  • Формирование списка отчетов
  • Настройка дополнительных параметров проекта


Создание таблицы в конструкторе таблицы

Мы рассмотрели назначение основных параметров окна конструктора таблицы. Теперь можно приступать к созданию таблицы.

Рассмотрим последовательность действий при создании таблицы customer(рис. 4.13), содержащей сведения о клиентах, из конструктора базы данных sales, предназначенной для учета заказов клиентов.

  1. Откройте проект sales.
  2. В иерархической структуре конструктора проекта установите курсор на базу данных sales и нажмите кнопку Modify (Модифицировать). На экране откроется окно конструктора базы данных.
  3. Находясь в конструкторе базы данных, нажмите кнопку New Table(Новая таблица) на панели инструментов Database Designer (Конструктор базы данных).
  4. В поле Enter table (Введите имя таблицы) диалогового окна Create(Создать) задайте имя таблицы customer и нажмите кнопку Сохранить. На экране появится окно конструктора таблицы Table Designer (Конструктор таблицы). Курсор находится в строке ввода столбца Name (Имя). Вы можете вводить имя, тип и ширину полей создаваемой таблицы.

Рис. 4.13. Структура таблицы Customer

  5. В строке ввода столбца Name (Имя) введите наименование поля, содержащего код клиента icdcustomer. Для перехода в следующий столбец воспользуйтесь мышью или нажмите клавишу <Tab>. Нажмите кнопку раскрытия списка Туре (Тип) и выберите значение Integer (Целое число).Кроме того, вы можете изменить тип поля с помощью клавиш. Ширина поля типа Integer равна 4. Данное значение устанавливается автоматически, и вы не можете его изменить.
  6. Перейдите в поле Caption (Надпись), расположенное в области Display(Отображение), и укажите заголовок поля Код клиента. В поле Fieldcomment (Комментарий) введите краткое описание поля.
  7. Аналогичным образом определите остальные поля. Для перехода с одного поля на другое используйте клавишу <Та b >, клавиши-стрелки или мышь. Для изменения ширины поля используйте кнопки изменения ширины поля, расположенные в правой части поля, а также клавиши.

Замечание

В процессе создания структуры вы можете изменить порядок следования полей в таблице. Для этого используйте кнопку с двунаправленной стрелкой, расположенную с левой стороны имени поля.

  8. При описании поля ccountry, указывающего страну, определите значение, вводимое в поле по умолчанию при добавлении новой записи. Для этого перейдите в поле Default value (Значение по умолчанию) и введите Россия.
  9. После завершения определения структуры таблицы нажмите кнопку ОК.

Замечание

В окне конструктора вы можете отказаться от создания новой таблицы или введенных в ее структуру изменений. Для этого нажмите кнопку Cancel(Отмена). На экране появится запрос системы об отмене или принятии изменений (рис. 4.14). Выберите значение Yes (Да).

Рис. 4.14. Запрос системы об отмене изменений структуры таблицы

  10. На экране появляется запрос, будете ли вы сейчас вводить данные в созданную таблицу. Если вы готовы приступить к вводу данных, нажмите кнопку Yes (Да). Созданная таблица откроется в режиме Edit (Ввод),позволяя вводить данные. При нажатии кнопки No (Нет) окно конструктора таблицы закрывается.


Определение свойств таблицы

Для определения свойств самой таблицы предназначена вкладка Table(Таблица) конструктора (рис. 4.12).

В ее верхней части расположено поле Name (Имя), в котором вы можете задать длинное имя таблицы. Это имя будет отображаться в окне проекта, а также использоваться при создании форм, запросов и отчетов. При создании несвободной таблицы в строке Database (База данных) указывается имя базы данных, в которую будет входить создаваемая таблица. Это поле доступно только для чтения.

Используя поле Table Comment (Описание таблицы) вкладки Table(Таблица), вы можете ввести текстовое описание таблицы. Для определения условия проверки правильности ввода информации на уровне записей, гарантирующих достоверность вводимых в таблицу данных, и создания триггеров для добавления, изменения и удаления записей таблицы, предназначены поля областей Record validation (Достоверность записей) и Triggers(Триггеры).

Определение свойств таблицы будет рассмотрено в главе 14.

Рис. 4.12. Вкладка Table конструктора таблицы


Определение полей таблицы

При определении полей таблицы используется вкладка Fields (Поля), позволяющая ввести наименование поля, тип данных, размещаемых в поле, и ширину. При определении числовых полей необходимо также задать количество десятичных знаков.

Помимо основных параметров, в нижней части вкладки Fields (Поля) для каждого поля можно определить дополнительные параметры, которые будут определять условия ввода в него данных, а также краткое описание, которое поможет разработчику при модификации таблицы в процессе создания приложения или его сопровождения.

Ввод наименований полей

Наименования полей таблицы вводятся на вкладке Fields (Поля) в строке ввода столбца Name (Имя). При задании наименований полей вы можете использовать буквы, цифры и знак подчеркивания. Ваши попытки ввести специальные символы Visual FoxPro проигнорирует.

Длина наименования поля ограничивается 128-ю символами. Вряд ли вы воспользуетесь возможностью задавать такие длинные имена. Обычно для имен полей используют краткие названия, которые более наглядны и легко читаемы.

Visual FoxPro не позволяет иметь в таблице поля с одинаковыми именами. При вводе имени, уже имеющегося в таблице, программа выдает предупреждение, указывающее, что поле с таким именем в таблице уже существует.

Типы полей

Поля таблицы предназначены для хранения в них данных. Это могут быть числа, текстовая информация, даты, графические файлы и т. д. Для определения типа данных, размещаемых в поле, используются тип поля, его ширина и количество знаков после запятой. Для их ввода предназначены столбцы Туре (Тип), Width (Ширина) и Decimal (Десятичные) вкладки Fields(Поля) конструктора таблицы.

В Visual FoxPro допустимыми являются типы полей, перечисленные в табл. 4.6.

Таблица 4.6, Типы полей Visual FoxPro

Тип | Наименование | Отображаемые данные
Текстовый | Character, Character(binary) | Текстовые поля могут содержать буквы, цифры и специальные символы. Максимальная ширина поля составляет 254 символа. тип Character (binary) используется в том случае, если не требуется учитывать кодовую страницу отображаемых данных
Числовой | Integer, Numeric, Float, Double | Integer отображает целые числа от-2 147 483 647 до +2 147 483 646. Числовые поля типа Numeric и Float отображают данные с фиксированной точкой в диапазоне от-0.9999999999x1 (Г19 до +0.9999999999х10+2°. Тип данных Double используется для хранения данных с высокой точностью в диапазоне от±4.9406564854 1247x1 (Г324 до±1 .797693 13486232x1 (Г308
Денежный | Currency | В поле денежного типа могут содержаться числа от -922 337 203 685 477.5807 до922 337 203 685 477.5807
Дата | Date | В поле типа Date может содержаться любая дата от 01. 01. 0001 до 31. 12.9999
Дата и время | DateTime | В поле типа DateTime может содержаться любая дата от 01.01.0001 до 31.12.9999 и время от 00:00:00 а.m.. до 11 :59:59 р.m.
Логический | Logical | Содержит логическое значение True (Т.)(Истина) или False (.F.) (Ложь)
Текстовое поле произвольной длины | Memo, Memo(binary) | Memo-поле содержит символьные данные большого объема
Двоичное поле произвольной длины | General | Поле данного типа предназначено для хранения в таблицах изображений и других двоичных данных

Задание свойств полей

В нижней части вкладки Fields (Поля) конструктора расположены поля, позволяющие задать для каждого поля таблицы свойства, которые будут использоваться при вводе в них данных.

Область Display (Отображение) содержит поля, позволяющие задать форматы ввода и отображения данных (табл. 4.7).

Таблица 4.7. Назначение полей области Display вкладки Fields

Поле | Назначение
Format (Формат) | Задает формат отображения данных в формах, отчетах и окне Browse
Input mask (Маска ввода) | Задает формат ввода данных
Caption (Надпись) | Определяет заголовок поля

Область Map field type to classes (Используемые типы полей для классов)предназначена для указания библиотеки и имени класса, который будет использоваться для создания объектов при размещении данного поля таблицы в форме (табл. 4.8).

Таблица 4.8. Назначение полей области Map field type to classes вкладки Fields

Поле | Назначение
Display library (Показывать библиотеку) | Задает местоположение и имя файла библиотеки классов
Display class (Показывать класс) | Задает имя класса из выбранной библиотеки

Область Field validation (Проверка правильности ввода) позволяет задать параметры, описанные в табл. 4.9.

Таблица 4.9. Назначение полей области Field validation вкладки Fields

Поле | Назначение
Rule (Условие) | Условие правильности ввода данных
Message (Сообщение) | Сообщение, выводимое при неправильном вводе данных в поле
Default Value (Значение по умолчанию) | Значение, вводимое в поле по умолчанию

В текстовом поле Field comment (Комментарий) можно ввести краткое описание поля, которое может потребоваться при последующих модификациях структуры таблицы и сопровождении проекта.

Свойство NULL

Для каждого поля вы можете определить признак, разрешающий при вводе данных оставлять это поле пустым. Для этого используется свойство NULL в описании поля таблицы. 'Более подробно определение свойств полей будет рассмотрено в главе 14.

Назначение кнопок окна конструктора таблицы

Ввод полей в окне конструктора таблицы осуществляется последовательно. После определения всех необходимых параметров первого поля вы переходите на новую строку и вводите информацию для следующего поля таблицы. На вкладке Fields (Поля) справа расположены четыре кнопки. Кнопка ОК предназначена для закрытия окна конструктора таблицы и сохранения всех изменений, внесенных в структуру таблицы.

Если вы изменили структуру таблицы, но хотите от этого отказаться, вам необходимо воспользоваться кнопкой Cancel (Отмена).

Для добавления в таблицу нового поля установите курсор на поле, выше которого вы предполагаете разместить новое, и нажмите кнопку Insert(Вставить). Будет добавлена пустая строка, в которую вы можете ввести информацию о новом поле.

Для удаления поля таблицы перейдите на строку с описанием данного поля и нажмите кнопку Delete (Удалить).

Кнопки Insert (Вставить) и Delete (Удалить) на вкладке Indexes (Индексы)позволяют добавлять в таблицу новые индексы и удалять существующие.


Окно конструктора таблицы

Конструктор таблицы предоставляет разработчику более широкие возможности при создании таблицы, чем мастер.

В конструктор таблицы вы можете перейти из мастера по созданию таблицы или непосредственно из диалогового окна New Table (Новая таблица) (см. рис. 4.4), нажав кнопку New Table (Новая таблица) и введя в диалоговом окне Create (Создать) имя создаваемой таблицы. В результате выполнения этих действий откроется окно конструктора таблицы Table Designer(Конструктор таблицы).

Окно конструктора таблицы Table Designer (Конструктор таблицы)(рис. 4.11) содержит три вкладки, предназначенные для определения следующих параметров:

  • Fields (Поля) — полей таблицы;
  • Indexes (Индексы) — индексов;
  • Table (Таблица) — условий достоверности вводимых данных, а также триггеров добавления, удаления и модификации.

Рис. 4.11. Окно конструктора таблицы Table Designer


Создание таблицы с помощью мастера

Для создания таблицы с помощью мастера из конструктора базы данных выполните следующие действия:

  1. Откройте диалоговое окно New Table (Новая таблица) (рис. 4.4), выполнив любое из следующих действий:
  • выберите команду New Table (Новая таблица) из меню Database (База данных);
  • выберите команду New Table (Новая таблица) контекстного меню;
  • нажмите кнопку New Table (Новая таблица) на панели инструментов Database Designer (Конструктор базы данных).

Рис. 4.4. Диалоговое окно New Table

  2. В диалоговом окне New Table (Новая таблица) нажмите кнопку Table Wizard (Мастер таблицы). На экране появляется первое диалоговое окно мастера.
  3. Visual FoxPro предлагает целый ряд таблиц, которые вы можете использовать в качестве прототипов, что позволит сэкономить время и обеспечить стандартные имена и типы данных для полей создаваемой таблицы.

На первом шаге вам необходимо, используя предлагаемые Visual FoxPro прототипы таблиц и их поля, сформировать список полей создаваемой таблицы (рис. 4.5). Для этого из списка Sample Tables (Примеры таблиц)выберите таблицу, которую хотите взять за основу при создании своей таблицы. При этом в списке Available Fields (Имеющиеся поля) отобразятся поля выбранной таблицы.

Рис. 4.5. Формирование списка полей

Замечание

Содержимое списка Sample Tables (Примеры таблиц) можно изменять, используя расположенные под ним опции. Для создания таблиц делового содержания установите опцию Business (Деловые). В списке будут отображаться таблицы Accounts, Customers и т. д. При создании таблиц, содержащих данные личного характера, установите опцию Personal (Личные).

  4. Перенесите из списка Available Fields (Имеющиеся поля) в список Selected Fields (Выбранные поля) поля, которые вы хотите разместить в создаваемой таблице. Для переноса полей используйте кнопки, описанные в табл. 4.3.

Таблица 4.3. Назначение кнопок диалогового окна Table Wizard-Step 1

Назначение
Переносит текущее поле из списка Available Fields (Имеющиеся поля)в список Selected Fields (Выбранные поля)
Переносит все поля из списка Available Fields (Имеющиеся поля) в список Selected Fields (Выбранные поля)
Возвращает текущее поле из списка Selected Fields (Выбранные поля)в список Available Fields (Имеющиеся поля)
Переносит все поля из списка Selected Fields (Выбранные поля) в список Available Fields (Имеющиеся поля)

Замечание

Если в качестве прототипа при создании таблицы вы хотите использовать одну из созданных вами ранее таблиц, нажмите кнопку Add (Добавить), расположенную в левом нижнем углу, и в открывшемся диалоговом окне Open(Открыть) выберите требуемую таблицу. Наименование этой таблицы будет размещено в списке Sample Tables (Примеры таблиц) окна мастера.

Закончив формирование списка полей, нажмите кнопку Next (Далее).

  5. На следующем шаге работы мастера (рис. 4.6) вам необходимо указать, создаете вы свободную таблицу или данная таблица будет добавлена в базу данных. Для этого воспользуйтесь опциями, назначение которых описано в табл. 4.4.

Таблица 4.4. Назначение опций диалогового окна Table Wizard Step 1

Опция | Назначение
Create my table as a stand-alone freetable (Создать свободную таблицу) | При выборе этой опции создается свободная таблица
Add my table to the following database (Добавить таблицу в базу данных) | При выборе опции создаваемая таблица будет добавлена в базу данных

По умолчанию установлена опция Create my table as a stand-alone free table (Создать свободную таблицу). Для размещения создаваемой таблицы в базе данных установите опцию Add my table to the following database

(Добавить таблицу в базу данных) и выберите из расположенного ниже списка ее наименование. Если в списке не окажется необходимой вам базы данных, нажмите кнопку, расположенную справа от списка. Затем в открывшемся на экране диалоговом окне Open (Открыть) выберите нужную базу данных. Ее имя будет размещено в раскрывающемся списке.

Если вы хотите задать внутреннее имя таблицы, отображаемое внутри базы данных, воспользуйтесь полем Table Name (Имя таблицы). Завершив установки параметров в текущем окне мастера, нажмите кнопку Next(Далее) для перехода к следующему шагу.

Рис. 4.6. Указание типа создаваемой таблицы

  6. В следующем диалоговом окне мастера (рис. 4.7) можно изменить наименования выбранных полей, их тип и размеры, используя для этого поля Field Name (Имя поля), Туре (Тип), Width (Ширина) и Decimals(Десятичные). Можно также, используя поле ввода Caption (Надпись),задать для каждого поля заголовок, который будет использоваться при просмотре таблицы и в качестве надписи к полю таблицы при создании форм с помощью мастера.

Флажок Allow null values (Разрешать нулевые значения) позволяет указать, может ли поле быть пустым, т. е. не содержать значений.

Чтобы определить для поля ввода маску, в соответствии с которой в него будут вводиться данные, используйте переключатель Input Mask (Маска ввода), содержащий следующие опции:

  • Pre-defined (Предопределенная);
  • Custom mask (Пользовательская маска).

Для использования маски, предлагаемой Visual FoxPro, установите опцию Pre-defined (Предопределенная), а затем из раскрывающегося списка, расположенного справа от опции, выберите требуемое вам значение.

В том случае, если ни одно из значений списка вам не подходит, установите опцию Custom mask (Пользовательская маска) и введите в расположенное справа поле выражение для маски. Для указания формата поля можно использовать значения раскрывающегося списка Format (Формат).Установите в диалоговом окне все необходимые значения поочередно для всех полей таблицы и нажмите кнопку Next (Далее) для перехода к следующему шагу.

Рис. 4.7. Модификация полей

  7. На третьем шаге в работе мастера (рис. 4.8) с помощью раскрывающегося списка Primary Key (Первичный ключ), содержащего список всех полей таблицы, задайте первичный ключ таблицы. При этом вы должны помнить, что поле может использоваться для задания первичного ключа таблицы только в том случае, если оно содержит неповторяющиеся значения. Например, для таблицы customer, содержащей список клиентов, в качестве первичного ключа можно использовать поле customerio с кодами клиентов.

Используя список Field Name (Имя поля), укажите дополнительные индексы для таблицы, установив соответствующие флажки слева от наименования полей. Затем нажмите кнопку Next (Далее).

Рис. 4.8..Окно мастера для определения первичного ключа и индексов таблицы

  8. Если вы создаете не свободную таблицу, а таблицу, входящую в базу данных, то на следующем шаге мастера определяются связи между новой таблицей и таблицами базы данных (рис. 4.9).

Рис. 4.9. Задание связей между создаваемой таблицей и таблицами базы данных

В списке My new <имя_таблицы> table (Моя новая таблица) диалогового окна содержится перечень всех существующих и возможных связей для новой таблицы. Используя данный список и диалоговое окно Relationships(Отношения), открываемое при нажатии кнопки Relationships (Отношения), задайте тип связи между создаваемой таблицей и остальными таблицами базы данных.

  9. На последнем шаге работы мастера (рис. 4.10) указывается режим дальнейшей работы с таблицей. Для этого необходимо выбрать одну из трех опций, назначение которых описано в табл. 4.5.

Таблица 4.5. Назначение опций диалогового окна Table Wizard Step 4

Опция | Назначение
Save table for later use {Сохранить таблицу) | Сохраняет созданную таблицу
Save table and browse it (Сохранить таблицу и открыть для просмотра) | Сохраняет созданную таблицу и открывает ее в режиме Browse для просмотра содержимого
Save table and modify in the Table Designer (Сохранить таблицу и открыть в окне конструктора для модификации) | Сохраняет созданную таблицу и открывает ее в конструкторе таблицы для модификации

Выбрав одну из трех опций, нажмите кнопку Finish (Готово). На экране открывается диалоговое окно Save as (Сохранить как) для задания имени таблицы. Введите в поле Enter Table (Введите имя таблицы) имя таблицы, укажите папку, в которой ее сохраняете, и нажмите кнопку Сохранить.

Рис. 4.1 0 . Задание режима дальнейшей работы с таблицей

Таблица создана и, в зависимости от установленной опции, откроется в режиме Browse (Обзор) или в конструкторе таблицы для дальнейшей модификации.


Имена таблиц

Таблицы, как и любые другие объекты в Visual FoxPro, имеют имена. Как было сказано выше, таблицы бывают свободные и входящие в базу данных. Для таблиц, входящих в базу данных, вы можете задать два имени. Одно вводится в диалоговом окне Create (Создать), а второе — на вкладке Table(Таблица) окна конструктора таблицы. Имя, вводимое в диалоговом окне Create (Создать) при создании таблицы, является именем файла, в котором таблица сохраняется на диске. При задании этого имени необходимо придерживаться ограничений, накладываемых операционной системой на количество символов в имени файла. Второе имя таблицы является внутренним и хранится в базе данных. Внутреннее имя таблицы может содержать до 128 символов. Оно вводится в поле Name (Имя) вкладки Table (Таблица) окна конструктора таблицы.

Наименование таблицы может содержать буквы, цифры и знак подчеркивания. Создавая новую таблицу, необходимо помнить, что в базе данных не может быть двух таблиц, имеющих одинаковые имена. Если в базе данных уже имеется таблица с таким именем, на экране появляется запрос, заменить ли существующую таблицу новой.

Замечание

При работе в окне конструктора базы данных внутреннее имя таблицы отображается в заголовке окна таблицы. В том случае, если таблица не имеет внутреннего имени, вместо него отображается имя файла, в котором данная таблица сохранена.

Предупреждение

В наименовании таблицы недопустимо использование пробелов и специальных символов.


Таблицы — основа базы данных

Таблицы составляют основу вашей базы данных. В них будет храниться вся необходимая информация. В дальнейшем данные в таблице будут дополняться новыми данными, редактироваться или исключаться из таблицы. Вы сможете просматривать данные таблиц с помощью форм или упорядочивать их по заданному критерию. Информация, содержащаяся в таблицах, может быть использована для составления отчетов. Кроме того, используя диаграммы, вы можете графически представить информацию, содержащуюся в базе данных.

Таблица состоит из строк и столбцов и имеет уникальное имя в базе данных. В каждой из таблиц содержится информация о каких-либо объектах одного типа.

В Visual FoxPro 7.0 вы можете создавать как таблицы, входящие в базу данных, так и отдельные таблицы, называемые свободными, аналогичные создаваемым в предыдущих версиях FoxPro. В данной главе мы остановимся на создании таблиц, входящих в состав базы данных, поскольку в этом случаев сможете использовать все средства, предоставляемые Visual FoxPro для работы с таблицами.


Создание базы данных вне проекта

Visual FoxPro позволяет создавать базу данных вне проекта. Для этого воспользуйтесь одним из предложенных ниже способов.

  • Выберите в меню File (Файл) команду New (Новый). В открывшемся диалоговом окне New (Новый) выберите опцию Database (База данных),а затем нажмите кнопку New File (Новый файл). На экране откроется диалоговое окно Create (Создать), в поле Enter (Введите) которого задайте имя создаваемой базы данных и нажмите кнопку Сохранить. Созданный файл получит расширение DBC.
  • Введите в командном окне Command (Команда) команду CREATEDATABASE, имеющую следующий синтаксис:

CREATE DATABASE [имяБазыДанных | ?]

В том случае, если вы не укажете имя создаваемой базы данных имя Базы-данных, на экране откроется диалоговое окно Create (Создать), позволяющее его ввести.

Замечание

Базу данных, созданную вне проекта, можно использовать в разных проектах.


Целостность данных

Целостность данных является одним из самых важных требований, предъявляемых к базам данных. Рассмотрим такой пример. База данных sales оптового магазина содержит таблицу customer со списком клиентов и таблицу ordsalem, в которой размещены данные о клиентах и сделанных ими заказах. Если окажется, что в таблице ordsalem содержатся коды клиентов, которые отсутствуют в таблице Customer, то невозможно определить, кому был отпущен товар по этому заказу. Или еще такой пример. Вы удалили из таблицы клиентов, которые перестали пользоваться услугами вашего магазина, а потом обнаружили, что один из них не возвратил вам кредит. Но вся информация о нем в базе данных отсутствует.

Для определения условий целостности данных в базе данных проекта могут быть использованы установленные между таблицами отношения.

Проверка целостности данных может осуществляться как программными средствами, так и средствами базы данных. Например, при вводе в таблицу

Ordsalem нового заказа можно использовать программу, которая будет проверять, имеется ли информация об этом клиенте в таблице customer. В случае отсутствия клиента в таблицу Customer будет добавляться новая запись.

Рис. 4.23. Диалоговое окно Referential Integrity Builder для определения условия целостности данных

Для определения условия целостности данных используется окно построителя условий целостности данных Referential Integrity Builder (Построитель целостности данных) (рис. 4.23), которое содержит перечень всех установленных отношений между таблицами. Для его открытия выполните одно из следующих действий.

  • В окне конструктора базы данных установите курсор на линию, отображающую отношения таблиц, и выберите в контекстном меню команду Edit Referential Integrity (Редактирование целостности данных).
  • В меню Database (База данных) выберите команду Edit Referential Integrity (Редактирование целостности данных).
  • В диалоговом окне Edit Relationship (Редактирование отношений) нажмите кнопку Referential Integrity (Целостность данных).

Замечание

Если база данных содержит помеченные на удаление объекты, при открытии окна построителя условий целостности данных Referential Integrity Builder(Построитель целостности данных) Visual FoxPro попросит очистить базу данных. В этом случае в меню Database (База данных) выберите команду CleanUp Database (Очистка базы данных), после чего повторно выполните команду, открывающую окно построителя условий целостности данных.

Таблица описания условий содержит имена родительской и дочерней таблиц, наименования индексов, используемых для связи, а также типы действий, выполняемых при модификации данных: добавлении и удалении записей.

В центре диалогового окна находятся переключатели, предназначенные для указания типа выполняемого действия. В нижней части диалогового окна отображается краткая справка о возможном выборе действий. Кроме того, вы можете выбрать тип действия из раскрывающегося списка непосредственно в полях Update (Изменить), Delete (Удалить) и Insert (Вставить).

Рассмотрим возможные действия программы Visual FoxPro при изменении значения первичного ключа или ключа типа Candidate (Кандидат) в родительской таблице в зависимости от используемой опции (табл. 4.11.).

Таблица 4.11. Описание действий Visual FoxPro в зависимости от выбранной опции при изменении значения первичного ключа или ключа типа Candidate

Наименование опции | Описание
Cascade (Каскадное изменение) | При изменении значений полей первичного ключа или ключа-кандидата в родительской таблице, автоматически осуществляется каскадное изменение всех соответствующих значений в дочерней таблице. Например, если это правило применить к отношению между таблицами Customer и Ordsalem, при изменении кода клиента в таблице Customer автоматически будут изменены коды и в Таблице Ordsalem
Restrict (Запрет изменения) | Не позволяет изменять значения полей первичного ключа или ключа-кандидата в родительской таблице, если в дочерней таблице имеется хотя бы одна запись, содержащая ссылку на изменяемую запись. Данное правило также можно применить к отношению между таблицами Customer и Ordsalem, если в создаваемом приложении коды клиента определяются на этапе ввода нового клиента и в дальнейшем не редактируются
Ignore (Игнорировать) | Позволяет изменять значения полей первичного ключа или ключа-кандидата в родительской таблице независимо от существования связанных записей в дочерней таблице. Целостность данных при этом не поддерживается

При удалении записи из родительской таблицы возможны следующие действия программы Visual FoxPro в зависимости от установленной в диалоговом окне Referential Integrity Builder (Построитель целостности данных) опции (табл. 4.12).

Таблица 4.12. Описание действий Visual FoxPro, в зависимости от выбранной опции, при удалении записи из родительской таблицы

Наименование опции | Описание
Cascade (Изменять каскадно) | При удалении записи из родительской таблицы автоматически осуществляется каскадное удаление всех записей из дочерней таблицы, связанных с удаляемой записью
Restrict (Ограничивать) | Не позволяет удалять записи в родительской таблице, если в дочерней таблице имеется хотя бы одна запись, содержащая ссылку на удаляемую запись. При попытке удаления записи возникает ошибка, которую вы можете обработать программно
Ignore (Игнорировать) | Позволяет удалять записи в родительской таблице независимо от существования связанных записей в дочерней таблице. Очевидно, что целостность данных при этом не поддерживается

Используя опции диалогового окна Referential Integrity Builder (Построитель целостности данных), можно задать действия, выполняемые Visual FoxPro при добавлении новой записи в дочернюю таблицу или редактировании в ней существующей (табл. 4.13).

Таблица 4.13. Описание действий Visual FoxPro, в зависимости от выбранной опции, при добавлении новой записи в родительскую таблицу

Наименование опции | Описание
Restrict (Ограничивать) | Не позволяет вводить запись, если значение индексного выражения дочерней таблицы не соответствует одной из записей в родительской таблице
Ignore (Игнорировать) | При вводе данных в дочернюю таблицу не анализируется значение индексного выражения. Целостность данных при этом не поддерживается

После завершения определения в диалоговом окне Referential IntegrityBuilder (Построитель целостности данных) условий целостности данных вся введенная информация сохраняется в базе данных. Определим условия целостности данных для таблиц Customer и Ordsalem.

  1. Откройте окно конструктора базы данных.
  2. Создайте отношение между родительской таблицей customer и дочерней таблицей Ordsalem.
  3. Выделите линию, соединяющую таблицы.
  4. Нажмите правую кнопку мыши и выберите команду контекстного меню Edit Referential Integrity (Редактировать целостность данных). На экране откроется диалоговое окно Referential Integrity Builder (Построитель целостности данных).
  5. Предположим, что в процессе эксплуатации нашего приложения коды клиента могут изменяться, поэтому в поле update (Изменить) установите тип действий cascade (Каскадное изменение).
  6. Для обеспечения целостности данных при удалении записей в таблице
  7. Customer в поле Delete (Удалить) установите тип действий Restrict (Запрет изменения).

На рис. 4.24 представлен результат описанных действий, которые необходимы для обеспечения целостности данных. Для сохранения выполненных действий нажмите кнопку ОК.

Рис. 4.24. Диалоговое окно Referential Integrity Builder


Создание отношений между таблицами

Как правило, в Visual FoxPro при создании форм, отчетов и запросов используется несколько таблиц, между которыми установлены постоянные отношения. Такие таблицы называются связанными. Из двух связанных таблиц одна является главной, а другая — подчиненной. Главную таблицу называют родительской, а подчиненную — дочерней. При создании индексов для родительской таблицы должен быть определен ключ типа Primary

(Первичный) или типа Candidate (Кандидат), а для дочерней таблицы — индекс для связи с родительской таблицей типа Regular (Обычный).

Рассмотрим, например, отношения между таблицей Customer, содержащей список клиентов, и таблицей Phoncust, в которой размещены данные о телефонах, по которым можно связываться с клиентами. Таблица customer является родительской по отношению к таблице PhonCust. В свою очередь, таблица PhonCust является дочерней по отношению к таблице Customer. При создании отношений между этими таблицами для customer должен быть определен первичный ключ, а для таблицы PhonCust — создан индекс по полю, содержащему код клиента, по которому осуществляется связь между таблицами.

Для создания отношений между таблицами customer и PhonCust выполните следующие действия:

  1. Откройте окно конструктора базы данных, в которой эти таблицы размещены.
  2. Откройте таблицу customer в конструкторе таблицы. Для этого щелкните на ней правой кнопкой мыши и в контекстном меню выберите команду Modify (Модифицировать).
  3. На вкладке Indexes (Индексы) создайте первичный ключ для поля icdCustomer. Для этого в поле столбца Name (Имя) введите наименование индекса icdCustomer. Для простого индекса в качестве его имени удобно использовать наименование поля, по которому индекс создается.
  4. В столбце Туре (Тип) выберите из списка значение Primary (Первичный).
  5. В столбце Expression (Выражение) нажмите кнопку построителя. В открывшемся диалоговом окне Expression Builder (Построитель выражения) в списке Fields (Поля) дважды щелкните мышью на поле icdCustomer. Оно будет перенесено в поле Expression (Выражение). Нажмите кнопку ОК для закрытия диалогового окна.
  6. Индекс для таблицы customer создан. Нажмите кнопку ОК для закрытия окна конструктора таблицы.
  7. Откройте в конструкторе таблицу PhonCust.
  8. Перейдите на вкладку Indexes (Индексы) и создайте ключ типа Regular

(Обычный) для поля icdCustomer.

  9. Нажмите кнопку ОК для закрытия окна конструктора таблицы.
  10. Выберите родительскую таблицу. В нашем примере это таблица Customer.
  11. Установите курсор мыши на первичный ключ таблицы icdCustomer.

Замечание

Таблицы в конструкторе базы данных обозначаются прямоугольниками, в нижней части которых после надписи Indexes (Индексы) расположен список индексов, созданных для данной таблицы. Первичный ключ в этом списке выделяется значком ключа, расположенным с левой стороны от наименования индекса.

  12. Нажмите кнопку мыши и, не отпуская ее, переместите курсор мыши на индекс дочерней таблицы Phoncust, по которому устанавливается связь.
  13. Отпустите кнопку мыши.
  14. Открывается диалоговое окно Edit Relationship (Редактирование отношения) (рис. 4.20), в котором слева приведено наименование родительской таблицы и расположен раскрывающийся список индексов таблицы, а справа размещена аналогичная информация о дочерней таблице. Используя раскрывающиеся списки, можно изменять индексы, по которым связываются таблицы. В этом диалоговом окне указан также тип установленного отношения между таблицами. Для сохранения отношения нажмите кнопку ОК, а для отказа — кнопку Cancel (Отмена).

Рис. 4.20. Диалоговое окно Edit Relationship для установления отношений между таблицами

Диалоговое окно Edit Relationship (Редактирование отношения) закрывается, а в окне конструктора базы данных отображается в виде линии созданное отношение между таблицами (рис. 4.21).

Установите курсор на линию, соединяющую связываемые таблицы. Толщина линии увеличивается. При щелчке по ней правой кнопкой мыши появляется контекстное меню, содержащее четыре команды (рис. 4.22). команда Remove Relationship (Удалить отношение) удаляет установленное между таблицами отношение. При выборе команды Edit Relationship (Редактирование отношения) открывается диалоговое окно Edit Relationship (Редактирование отношения), позволяющее изменить установленное отношение. Команда Edit Referential Integrity (Редактирование целостности данных) открывает диалоговое окно Referential Integrity Builder (Построитель целостности данных). Об этом окне речь пойдет в следующем разделе.

Рис. 4.21. Отображение связи между таблицами

Рис. 4.22. Контекстное меню


Отношения между таблицами

Между таблицами существует четыре типа отношений. Это "один-к-одному", "один-ко-многим", "много-к-одному", "много-ко - многим". Все эти типы отношений поддерживаются в Visual FoxPro.

Отношение "один-к-одному" означает, что каждая запись в одной таблице соответствует только одной записи в другой таблице. В качестве примера можно рассмотреть отношения между списком служащих предприятия и таблицей, содержащей их служебные характеристики.

Наиболее часто встречающимся является тип отношения "один-ко-многим". В качестве примеров могут быть рассмотрены отношения между покупателем и купленными им товарами, между предприятием и работающими на нем сотрудниками.

Отношение "много-к-одному" можно сравнить с отношением "один-ко-многим", рассматриваемое с другой точки зрения. Например, между клиентами и сделанными им заказами существует отношение "один-ко-многим". С другой стороны, если в качестве исходной точки рассматривать заказы, то между сделанными заказами и клиентами получается отношение "много-к-одному".

В качестве примера отношения "много-ко-многим" можно привести пример магазина оптовой торговли. Данный тип отношений существует между списком товаров, производимых предприятиями-поставщиками, и списком товаров, заказанных потребителями.


Создание составного индекса

Рассмотрим создание индекса для таблицы customer, который будет упорядочивать данные в таблице по фамилии, имени и отчеству. Для создания такого индекса воспользуемся индексным выражением.

  1. Откройте окно Table Designer (Конструктор таблицы) для таблицы customer и перейдите на вкладку Indexes (Индексы).
  2. В поле Name (Имя) введите имя индекса custName.
  3. Из списка возможных типов индекса в поле Туре (Тип) выберите значение Regular (Обычный).
  4. Для задания индекса нажмите кнопку открытия построителя выражений для поля Expression (Выражение). В окне построителя сформируйте следующее выражение:

cLastName + cFirstName + cSecondName

  5. Проверьте синтаксис выражения, воспользовавшись кнопкой Verify(Проверить), и закройте окно построителя выражений.
  6. Для завершения создания индекса нажмите кнопку ОК.


Создание первичного ключа для таблицы

Рассмотрим последовательность ваших действий при создании первичного ключа для таблицы customer. Так как первичный ключ таблицы должен быть уникальным, для его создания можно использовать поле icdcustomer таблицы, содержащее коды клиентов. Это поле было добавлено в таблицу специально, т. к. значения остальных полей не являются уникальными.

  1. Откройте окно конструктора таблицы для таблицы Customer. Для этого в окне проекта установите курсор на модифицируемую таблицу и нажмите кнопку Modify (Модифицировать) конструктора проекта.
  2. В окне Table Designer (Конструктор таблицы) перейдите на вкладку Indexes (Индексы).
  3. В поле Name (Имя) введите имя индекса icdcustomer.
  4. Из списка возможных типов индекса в поле Туре (Тип) выберите значение Primary (Первичный).
  5. Перейдите в поле Expression (Выражение) и введите выражение для индекса icdCustomer.
  6. Установите переключатель столбца Order (Упорядочение) в значение По возрастанию. Результат создания первичного ключа представлен на рис. 4.19.
  7. Для завершения создания индекса нажмите кнопку ОК.

Рис. 4.19. Первичный ключ таблицы Customer


Индексы

Среди требований, предъявляемых к СУБД, основное место занимает возможность быстрого поиска необходимой информации. Прекрасным средством, позволяющим решить эту проблему, является использование индексов, которые, в зависимости от количества полей, применяемых при их создании, делятся на простые и составные.

Замечание

В отличие от многих реляционных баз данных, при определении составного индекса в Visual FoxPro можно использовать не просто список индексных полей, а индексное выражение, при формировании которого применяемых наименования полей таблицы.

Индексы в Visual FoxPro предназначаются также для создания первичных ключей, используемых при определении отношений между таблицами и условий целостности данных. В этом случае индексы должны быть уникальными. Это означает, что если для создания уникального индекса применяется простой индекс, значения поля должны быть неповторяющимися, т. е. уникальными. Часто для создания уникального индекса используется составной индекс, т. е. он может состоять из нескольких полей. В этом случае каждое поле в отдельности может содержать повторяющиеся значения, но индексное выражение, в состав которого входят эти поля, должно быть уникальным.

Значения индексов хранятся в индексном файле, в котором для каждого значения индекса существует уникальная ссылка, указывающая на местонахождение в таблице записи, соответствующей индексу, что обеспечивает при поиске нужной информации прямой доступ к записи на основании упорядоченных значений индекса, а не последовательный просмотр всей таблицы. Это, естественно, ускоряет поиск.

Для создания индекса таблицы используется вкладка Indexes (Индексы)(рис. 4.17) окна конструктора таблицы Table Designer (Конструктор таблицы).

Рис. 4.17. Вкладка Indexes конструктора таблицы, предназначенная для создания индексов

Все индексы в Visual FoxPro имеют имена, задаваемые в поле Name (Имя).Слева от имени индекса в столбце Order (Упорядочение) располагается переключатель, определяющий порядок, в котором будут выстраиваться значения индексного выражения. По умолчанию при создании индекса в данном поле появляется стрелка, направленная вверх. Это означает, что значения индексного выражения упорядочены по возрастанию. Если стрелка направлена вниз, это говорит о том, что значения упорядочены по убыванию. Для изменения способа упорядочения можно нажать клавишу <Пробел>или щелкнуть кнопкой мыши.

Список Туре (Тип) используется для задания типа создаваемого индекса и содержит значения, описанные в табл. 4.10.

Таблица 4.10. Описание типов индекса

Тип индекса | Описание
Regular(Обычный) | Создается индекс, в котором для каждой записи таблицы хранится значение индексного выражения. Если несколько записей имеют одинаковое значение индексного выражения, то каждое значение хранится отдельно и содержит ссылку на связанную с ней запись
Unique(Уникальный) | Создается индекс, в котором хранятся только неповторяющиеся значения индексного выражения. Если две или более записей содержат одинаковое значение индексного выражения, то будет храниться только одно значение и ссылка на первую из записей с одинаковым значением индексного выражения. Таблица может иметь несколько уникальных индексов
Candidate(Кандидат) | Создается уникальный индекс, который не содержит полей с пустыми значениями. Этот индекс обладает всеми качествами первичного ключа и не является им только по той причине, что таблица не может содержать более одного первичного ключа
Primary(Первичный) | Создается уникальный индекс, который используется для связывания таблиц и определения условий целостности данных. Поля, входящие в первичный ключ, не должны допускать ввода пустых значений. В отличие от уникального индекса, таблица может иметь только один первичный ключ

Значение индекса или индексного выражения вводится в поле Expression(Выражение). Вы можете ввести индексное выражение непосредственно в поле ввода или для формирования выражения использовать диалоговое окно конструктора выражений Expression Builder (Построитель выражения), представленное на рис. 4.18. Для открытия данного окна нажмите кнопку, расположенную справа от поля Expression (Выражение).

При использовании в индексном выражении полей разных типов вы должны проверять допустимость введенного выражения. Например, для таблицы customer вы можете создать индекс для упорядочения данных по стране проживания и по коду клиента:

cCountry + STR(icdCustomer)

В поле Filter (Фильтр) конструктора таблицы вы можете определить фильтр, используемый для ограничения формируемых индексных значений. В этом случае результат выражения должен иметь логический тип.

Рис. 4.18. Диалоговое окно Expression Builder

Замечание

Без индексов в Visual FoxPro не обойтись. Однако при их создании вы должны помнить, что если вы используете индекс, в состав которого входят поля большой ширины, индексный файл может оказаться очень больших размеров. Visual FoxPro не разрешает при создании индексов использовать Memo-поля и поля, содержащие графические изображения.


Модификация таблицы

Структуру таблицы, созданную с помощью мастера или конструктора таблицы, можно модифицировать, т. е. изменить наименование любого поля и его тип, вставить новое поле или удалить существующее, изменить порядок следования полей в таблице.

Чтобы модифицировать таблицу, откройте ее в конструкторе таблицы. Для этого выполните одно из следующих действий.

  • В окне проекта установите курсор на модифицируемую таблицу и нажмите кнопку Modify (Модифицировать).
  • В окне проекта установите курсор на модифицируемую таблицу, нажмите правую кнопку мыши и в появившемся на экране контекстном меню выберите команду Modify (Модифицировать).
  • При открытии конструктора таблицы из окна конструктора базы данных выделите модифицируемую таблицу и нажмите кнопку Modify Table(Модифицировать таблицу) на панели инструментов Database Designer(Конструктор базы данных) или выберите команду Modify (Модифицировать) в меню Database (База данных).

В результате на экране открывается диалоговое окно Table Designer (Конструктор таблицы), содержащее структуру модифицируемой таблицы.

Изменение наименований полей и их типов

Ошибки, допущенные при задании имени поля или его типа, легко устраняются. Установите курсор на имя поля, которое хотите изменить, и, используя клавишу <Backspace> или <Del>, удалите ошибочные символы. После этого введите правильное имя поля.

Для изменения типа поля установите курсор в столбец Туре (Тип) и выберите из списка требуемое значение.

Предупреждение

Изменение типов полей таблицы, содержащей данные, может привести к потере информации.

Добавление и удаление полей

Для добавления нового поля в таблицу выполните следующие действия:

  1. С помощью клавиш-стрелок или мыши установите курсор на строку, перед которой вы хотите вставить пропущенное поле. При этом курсор может находиться в любом столбце Name (Имя), Туре (Тип) или Width(Размер).
  2. Нажмите кнопку Insert (Вставить).
  3. Visual FoxPro вставляет пустую строку с именем NewF l d. Введите требуемое имя поля.
  4. Используя значения списка Туре (Тип), задайте тип поля.
  5. В столбце Width (Размер) введите размер нового поля.

Для удаления поля из структуры таблицы установите курсор на поле, которое требуется удалить, и нажмите кнопку Delete (Удалить) окна конструктора.

Изменение порядка расположения полей

Порядок расположения полей, заданный при создании структуры таблицы, можно изменить. Для этого выполните следующие действия:

  1. Установите курсор на поле, расположение которого хотите изменить. На кнопке появляется значок перемещения поля в виде двунаправленной стрелки.
  2. Установите курсор на значок перемещения.
  3. Нажмите кнопку мыши и, удерживая ее нажатой, переместите значок вверх или вниз на требуемое место в структуре.
  4. Отпустите кнопку мыши. Поле изменило свое местоположение.


Режимы просмотра таблицы

В Visual FoxPro существует два режима просмотра таблицы: Edit (Ввод)(рис. 4.15) и Browse (Обзор).

В режиме Edit (Ввод) (рис. 4.15) поля таблицы располагаются в столбец друг под другом. Записи таблицы отделяются горизонтальными линиями.

По умолчанию после создания структуры таблицы Visual FoxPro предлагает вам вводить данные в таблицу в режиме Edit (Ввод). В этом режиме пользователю нет необходимости после ввода информации во все поля одной записи заботиться о добавлении новой пустой записи. Visual FoxPro автоматически добавляет следующую запись, и пользователь продолжает вводить информацию.

В режиме Browse (Обзор) (рис. 4.16) таблица более наглядна. Поля расположены в один ряд. Одна строка соответствует одной записи таблицы, а записи размещены одна под другой.

Рис. 4.15. Просмотр таблицы в режиме Edit

Рис. 4.16. Просмотр таблицы в режиме Browse

При вводе данных в таблицу, представленную в режиме Browse (Обзор), после ввода одной записи пользователю необходимо самому добавлять новую пустую запись, используя для этого команду Append New Record (Добавить новую запись) из меню Table (Таблица) или комбинацию клавиш <Ctrl>+<Y>.

Замечание

Для перехода в режимы просмотра таблицы Edit (Ввод) и Browse (Обзор) можно использовать одноименные команды из меню View (Вид).


ГЛАВА 4
Создание базы данных проекта

База данных в Visual FoxPro — это совокупность таблиц , отношений между таблицами, индексов, триггеров и хранимых процедур.

Создание базы данных в Visual FoxPro осуществляется в интерактивном ре-. жиме с помощью конструктора базы данных, который позволяет:

  • создавать и модифицировать таблицы, хранимые процедуры, представления данных;
  • добавлять созданные ранее таблицы;
  • определять для таблиц индексы;
  • устанавливать отношения между таблицами, которые будут поддерживаться при создании форм и отчетов.

Описание структуры базы хранится в словаре базы данных, представляющем собой совокупность системных файлов.

Создание базы данных в окне проекта

База данных является частью проекта, поэтому ее целесообразно создавать в окне проекта. Для создания базы данных выполните следующие действия:

  1. Откройте созданный проект.
  2. Выберите в верхней части окна конструктора проектов вкладку Data(Данные). Курсор по умолчанию устанавливается в начале вкладки назначении Databases (Базы данных).
  3. Нажмите кнопку New (Новый) в окне проекта.
  4. В открывшемся диалоговом окне New Database (Новая база данных) нажмите кнопку New Database (Новая база данных).
  5. В поле ввода Enter database (Введите имя базы данных) появившегося на экране диалогового окна Create (Создать) задайте имя создаваемой базы данных, убедившись, что в поле Тип файла установлен тип сохраняемого файла Database (База данных), а в раскрывающемся списке Папка правильно указана папка, в которой вы хотите расположить создаваемую базу данных.
  6. Для сохранения созданной базы данных нажмите кнопку Сохранить. После этого откроется пустое окно базы данных Database Designer(Конструктор базы данных) (рис. 4.1). Используя панель инструментов Designer (Конструктор базы данных), команды меню Database(База данных) и контекстное меню, в окне конструктора базы данных вы можете создавать новые таблицы, модифицировать существующие, создавать для них индексы, устанавливать отношения между таблицами.

Замечание

Если панель инструментов Database Designer (Конструктор базы данных) невидна на экране, в меню View (Вид) выберите команду Toolbars (Панели инструментов). Открывается диалоговое окно Toolbars (Панель инструментов), в котором установите флажок Database Designer (Конструктор базы данных).

Рис. 4.1. Пустое окно конструктора базы данных

В начале создания базы данных окно конструктора базы данных пусто. На рис. 4.2 показано, как выглядит это окно с размещенными в нем таблицами.

Рис. 4.2. Окно конструктора базы данных Sales с размещенными в нем таблицами

Для создания в конструкторе базы данных новых таблиц и модификации существующих вы можете использовать:

  • команды меню Database (База данных) (табл. 4.1);
  • команды контекстного меню, появляющегося при нажатии правой кнопки мыши в окне конструктора базы данных;
  • панель инструментов Database Designer (Конструктор базы данных).

Таблица 4.1. Назначение команд меню Database

Команда | Назначение
New Table (Новая таблица) | Создает новую таблицу
Add Table (Добавить таблицу) | Добавляет созданную таблицу в базу данных
New Remote View (Новое удаленное представление) | Создает удаленное представление данных
New Local View (Новое локальное представление) | Создает локальное представление данных
Modify (Модифицировать) | Открывает таблицу в конструкторе таблицы
Browse (Обзор таблицы) | Показывает содержимое таблицы в режиме Browse
Remove (Удалить) | Удаляет таблицу из базы данных
Find Object (Найти объект) | Находит указанный вами объект в окне конструктора базы данных
Rebuild Table Indexes (Перестроить индексы) | Перестраивает индексы
Remove Deleted Records (Удалить помеченные записи) | Физически удаляет из таблицы помеченные для удаления записи
Edit Relationship (Редактирование отношения) | Редактирует отношения между таблицами
Edit Referential Integrity (Редактирование условия целостности) | Определяет условия целостности данных
Edit Stored Procedures (Редактирование хранимых процедур) | Открывает окно редактирования хранимой процедуры
Connections (Соединения) | Выводит на экран диалоговое окно Connections(Соединения), в котором вы можете создавать или модифицировать соединения с удаленными данными
Arrange (Упорядочить) | Упорядочивает объекты по имени или типу и выравнивает их по горизонтали или вертикали
Refresh (Обновить) | Обновляет информацию в окне конструктора базы данных
Properties (Свойства) | Выводит на экран диалоговое окно Database Properties (Свойства базы данных)
Clean Up Database (Очистка базы данных) | Очищает базу данных от помеченных на удаление объектов

Для работы в окне конструктора базы данных можно использовать контекстное меню, содержащее наиболее часто используемые команды из меню Database (База данных), команду вызова справочной системы, а также команды Expand All (Развернуть все) и Collapse All (Свернуть все), предназначенные, соответственно, для раскрытия и свертывания уровней вложенности объектов в окне конструктора базы данных.

Панель инструментов Database Designer (Конструктор базы данных) содержит кнопки для выполнения наиболее часто используемых операций над базой данных. Вид панели инструментов приведен на рис. 4.3, а описание кнопок панели инструментов — в табл. 4.2.

Рис. 4.3. Панель инструментов Database Designer

Таблица 4.2. Назначение кнопок панели инструментов Database Designer

Название | Назначение
New Table (Новая таблица) | Создает новую таблицу
Add Table (Добавить таблицу) | Добавляет ранее созданную таблицу в базу данных
Remove Table (Удалить таблицу) | Удаляет таблицу из базы данных
New Remote View (Новое удаленное представление) | Создает удаленное представление данных
New Local View (Новое локальное представление) | Создает локальное представление данных
Modify Table (Модифицировать таблицу) | Открывает таблицу в конструкторе таблицы
Browse Table (Обзор таблицы) | Показывает содержимое таблицы в режиме Browse
Edit Stored Procedures (Редактирование хранимых процедур) | Открывает окно для редактирования хранимых процедур
Connections (Соединения) | Создает связь с удаленными данными


  • Создание базы данных в окне проекта
  • Создание базы данных вне проекта
  • Таблицы — основа базы данных
  • Имена таблиц
  • Создание таблицы с помощью мастера
  • Окно конструктора таблицы
  • Определение полей таблицы
  • Определение свойств таблицы
  • Создание таблицы в конструкторе таблицы
  • Режимы просмотра таблицы
  • Модификация таблицы
  • Индексы
  • Создание первичного ключа для таблицы
  • Создание составного индекса
  • Отношения между таблицами
  • Создание отношений между таблицами
  • Целостность данных


Удаление объектов из формы

Для удаления из формы выделенных объектов выполните одно из следующих действий.

  • В меню Edit (Правка) выберите команду Cut (Вырезать).
  • Нажмите клавишу <Backspace>.
  • Нажмите клавишу <Del>.


Перемещение объектов в форме

Visual FoxPro позволяет перемещать один или несколько объектов формы одновременно как мышью, так и клавишами-стрелками. Использование клавиш-стрелок применяется, когда требуется точное позиционирование, т. к. одно нажатие клавиши приводит к перемещению объекта на один пиксель. Если требуется переместить объекты на большое расстояние, можно комбинировать оба этих способа: сначала вы перемещаете объекты мышью, а затем с помощью клавиш-стрелок задаете их точное расположение.


Отмена выделения с объектов

Если вы хотите отменить выделение со всех объектов формы, щелкните мышью вне выделенных объектов. Для снятия выделения с отдельных объектов выполните следующие действия:

  1. Нажмите и удерживайте клавишу <Shift>.
  2. Щелкните мышью поочередно на объектах, с которых хотите снять выделение.


Выделение объектов формы

Чтобы управлять объектом, вы сначала должны его выделить. Для выделения одного объекта достаточно щелкнуть на нем. Для выделения нескольких объектов выполните одно из следующих действий.

  • Нажмите клавишу <Shift>. Удерживая ее в нажатом состоянии, щелкните мышью поочередно на всех выделяемых объектах.
  • Выберите кнопку Select Objects (Выбрать объекты) на панели инструментов Form Controls (Элементы управления формы). Установите указатель в форму. Не отпуская кнопку мыши, нарисуйте рамку выделения так, чтобы внутри нее оказались все необходимые объекты.

Замечание

Второй способ применим в том случае, если все выделяемые объекты размещены в форме компактной группой.

Для выделения всех объектов в форме можно воспользоваться командой Select All (Выделить все) из меню Edit (Правка) или комбинацией клавиш<Ctrl>+<A>. После того как объекты выделены, вы можете управлять ими как единым целым.


Действия, выполняемые с объектами формы

В процессе создания формы вы можете перемещать, удалять объекты или изменять их размеры и свойства.


Объекты формы

Откройте созданную с помощью мастера форму в конструкторе форм(рис. 5.10). Для этого выделите форму в окне проекта и выполните одно из следующих действий.

  • Нажмите кнопку Modify (Модифицировать) окна проекта.
  • Дважды щелкните на ее наименовании.
  • Выберите команду Modify File (Модифицировать файл) из меню Project(Проект).
  • Нажмите кнопку Modify Form (Модифицировать форму) стандартной панели инструментов.

Замечание

В последнем диалоговом окне мастера при установке опции Save form andmodify it in the Form Designer (Сохранить форму и открыть для модификации в конструкторе форм) созданная с помощью мастера форма сразу открывается в конструкторе форм.

Рис. 5.10. Так выглядит в конструкторе форм созданная с помощью мастера форма

Все объекты, размещенные в форме (заголовок, поля, надписи, кнопки, линии), характеризуются свойствами, которые вы можете настроить в соответствии со своими требованиями. Помимо свойств, для объектов существуют встроенные методы, выполняемые при наступлении связанных с ними событий. Для просмотра свойств и методов объекта, размещенного в форме, выделите его, а затем выполните одно из следующих действий.

  • Выберите команду Properties (Свойства) из меню View (Вид).
  • Нажмите правую кнопку мыши и выберите пункт контекстного меню Properties (Свойства).
  • Нажмите кнопку Properties Window (Окно свойств) на панели инструментов Form Designer (Конструктор форм).

В результате откроется окно Properties (Свойства) со свойствами и методами выбранного объекта (рис. 5.11).

Раскрывающийся список в верхней части окна Properties (Свойства) содержит перечень всех объектов формы. Его можно использовать для выбора объекта вместо выделения нужного объекта в форме. Вкладки, расположенные ниже списка, содержат названия сгруппированных по типам свойств и методов объектов формы (табл. 5.3).

Рис. 5.11. Окно Properties

Таблица 5.3. Назначение вкладок окна Properties

Вкладка | Назначение
All (Все) | Содержит список всех свойств и методов формы в алфавитном порядке
Data (Данные) | Содержит свойства объекта, связанные с источником данных
Methods (Методы) | Содержит список всех методов объекта
Layout (Расположение) | Содержит свойства объекта, связанные с его оформлением
Other (Другие) | В данную вкладку собраны все свойства, не вошедшие во вкладки Data (Данные) и Layout (Расположение)

Для изменения какого-либо свойства объекта необходимо открыть окно Properties (Свойства) и перейти на строку, содержащую данное свойство. Значение свойства отобразится в столбце, расположенном правее наименования свойства, а для редактирования его значения используется поле ввода, расположенное над списком всех свойств объекта. При изменении значения свойства возможны варианты действий, описанные в табл. 5.4.

Рис. 5.12. Выбор значения свойства объекта из списка

Таблица 5.4. Действия пользователя в зависимости от типа свойства

Тип свойства | Состояние поля ввода значения свойства
Свойство доступно только для чтения | Поле значения свойства недоступно для ввода. Информация в поле выделена курсивом. Примером такого свойства на рис. 5.11 является свойство BaseClass(Базовый класс). Данное свойство не редактируется
Свойство может редактироваться | Поле значения свойства активно, в него можно ввести с клавиатуры требуемое значение. Примером такого свойства является Caption (Надпись)
Возможны два или более различных вариантов значений свойства | При выборе такого свойства в поле ввода значения появляется кнопка раскрытия списка, позволяя для ввода нового значения использовать элементы списка. На рис. 5.12 показан список для изменения значения свойства Alignment (Выравнивание)
Возможен выбор свойств с помощью окна настройки | При выборе свойства рядом с полем значения свойства появляется кнопка открытия диалогового окна, из которого выбираются необходимые значения. На рис. 5.13 показано диалоговое окно Цвет для изменения значения свойства BackColor (Цвет фона)

Рис. 5.13. Настройка свойства BackColorс использованием диалогового окна Цвет

Слева от поля ввода свойства находятся три кнопки, которые предназначены для выполнения функций, описанных в табл. 5.5.

Таблица 5.5. Назначение кнопок окна Properties

Назначение
Вызывает построитель выражений для определения значения свойства
Нажатие этой кнопки подтверждает ввод значения свойства
Кнопка используется для отказа от введенного в поле ввода значения


Запуск формы

Форма, созданная в Visual FoxPro, не требует генерации программных кодов, как это было в FoxPro для Windows. Ее можно сразу запустить на выполнение.

Для запуска формы в Visual FoxPro существует много способов. Если вы находитесь в конструкторе форм, то выполните одно из следующих действий.

  • Выберите в меню Form (Форма) команду Run Form (Запустить форму).
  • Выполните команду Run Form (Запустить форму) контекстного меню.
  • Нажмите кнопку Run (Запустить) на стандартной панели инструментов Visual FoxPro.
  • Нажмите комбинацию клавиш <Ctrl>+<E>.
  • При нахождении в окне конструктора проекта для запуска формы установите курсор на ее имя и нажмите кнопку Run (Запустить).

Вы можете также запустить форму как программу. Для этого выполните следующие действия:

  1. В меню Program (Программа) выберите команду Do (Выполнить).
  2. В открывшемся диалоговом окне Do (Выполнить) установите тип выполняемого файла (в данном случае — Form (Форма)) и выберите из списка файлов необходимую форму.
  3. Нажмите кнопку Do (Выполнить).


Создание формы с помощью мастера

Рассмотрим создание формы с помощью мастера формы Form Wizard (Мастер формы). Он позволяет создавать формы как для одиночных, так и связанных таблиц, а также настраивать поля, стиль их отображения, тип кнопок управления, размещаемых в форме. В настоящей главе мы ограничимся рассмотрением использования мастера для создания однотабличных форм. К использованию мастера для связанных таблиц мы вернемся в главе 15.

Форму, созданную с помощью мастера, можно использовать для просмотра и редактирования информации, содержащейся в таблицах Visual FoxPro. Она содержит в нижней части кнопки для выбора режима просмотра, добавления и удаления записей, сохранения введенной информации и печати данных.

Для запуска мастера выполните одно из следующих действий.

  • Выберите в меню Tools (Сервис) команду Wizards (Мастера), а затем в открывшемся меню команды значение Form (Форма).
  • Нажмите кнопку Form Wizard (Мастер формы) в диалоговом окне NewForm (Новая форма), открываемом при создании новой формы из окна проекта.
  • Нажмите кнопку Wizard (Мастер) в диалоговом окне New (Новый), которое открывается при нажатии кнопки New (Новый) стандартной панели инструментов или выборе команды New (Новый) из меню File (Файл).Рассмотрим создание формы с помощью мастера из окна проекта.
  1. Откройте базу данных проекта. Для этого на вкладке Data (Данные) установите курсор на ее название и нажмите кнопку Open (Открыть) окна проекта. При этом на стандартной панели инструментов в списке Databases (Базы данных) появится название открытой базы данных.
  2. Щелкните на ярлыке Documents (Документы) для перехода на вкладку Documents (Документы) (рис. 5.1).
  3. Выберите группу Forms (Формы) и нажмите кнопку New (Новый) окна конструктора проекта. Откроется диалоговое окно New Form (Новая форма) (рис. 5.2).
  4. Нажмите кнопку Form Wizard (Мастер формы).
  5. После запуска мастера форм на экране открывается диалоговое окно Wizard Selection (Выбор мастера) (рис. 5.3). Значение Form Wizard (Мастер формы) используется для создания однотабличной формы, a One-to-ManyForm Wizard (Мастер форм один-ко-многим) — для нескольких связанных. По умолчанию установлено первое значение. Нажмите кнопку ОК для запуска мастера по созданию однотабличной формы.

Рис. 5.1. Окно проекта

Рис. 5.2. Диалоговое окно New Form

Замечание

Чтобы создать форму с помощью мастера, необходимо ответить на задаваемые вопросы в появляющихся на экране диалоговых окнах. Для перехода к следующему шагу мастера используется кнопка Next (Далее). Если вы решили изменить параметры, установленные в предыдущих шагах, можете вернуться назад, воспользовавшись кнопкой Back (Назад). Для отказа от продолжения создания формы нажмите кнопку Cancel (Отмена).

Рис. 5.3. Диалоговое окно для задания типа создаваемой формы: однотабличной или многотабличной

  6. Появляется первое диалоговое окно мастера (рис. 5.4), в котором необходимо указать таблицу, для которой вы создаете форму, и выбрать поля этой таблицы, размещаемые в форме. В области Databases and tables(Базы данных и таблицы) расположены два списка. В верхнем списке содержится перечень открытых баз данных, в нижнем — перечень таблиц выбранной базы. Выберите из верхнего списка необходимую базу данных, а из нижнего — таблицу, для которой создаете форму.

Замечание

Может оказаться, что в диалоговом окне мастера списки области Databasesand tables (Базы данных и таблицы) пусты или содержат не те данные, которые вы предполагаете использовать для построения формы. Такая ситуация возникает в том случае, если предварительно вы не открыли необходимую базу данных. Ничего страшного. Для выбора базы данных и входящих в нее таблиц нажмите кнопку, расположенную рядом со списком баз данных, и в открывшемся диалоговом окне Open (Открыть) найдите таблицу, которая будет использоваться при создании формы (рис. 5.5).

Рис. 5.4. Первый шаг в создании формы с помощью мастера

Рис. 5.5. Диалоговое окно Open

  7. После выбора таблицы список Available fields (Имеющиеся поля) будет содержать перечень всех полей таблицы. Вам необходимо из данного списка перенести в Selected fields (Выбранные поля) поля, которые вы хотите разместить в создаваемой форме. Для переноса полей используйте кнопки, расположенные между списками. После создания списка полей, отображаемых в форме, нажмите кнопку Next (Далее) для перехода к следующему шагу.
  8. В появившемся диалоговом окне мастера следует установить стиль отображения объектов формы и типы кнопок управления (рис. 5.6).

Рис. 5.6. Окно для выбора стиля отображения полей и управляющих кнопок

Для объектов формы мастер предлагает на выбор девять различных вариантов их оформления, которые выбираются из списка Style (Стиль). При выборе каждого из стилей вы можете просмотреть, как будут выглядеть объекты вашей формы, воспользовавшись областью просмотра в верхней части диалогового окна.

Переключатель Button type (Тип кнопки) содержит опции, позволяющие задать тип отображения размещаемых в форме кнопок управления (табл. 5.1).

Таблица 5.1. Опции переключателя Button type

Опция | Тип отображения
Text buttons {Текстовые кнопки) | Кнопки управления содержат текстовые надписи
Picture buttons (Графические кнопки) | Кнопки управления содержат графические изображения
No buttons (Нет кнопок) | Кнопки управления в форме отсутствуют
Custom (Другие) | В форме размещается пять кнопок управления: Find(Поиск), Print (Печать), Add (Добавить), Delete (Удалить),Exit (Выход). Перемещение по записям осуществляется с помощью располагаемой в форме линейки прокрутки

Установите необходимые опции и нажмите кнопку Next (Далее).

  9. На следующем (третьем) шаге задается критерий сортировки данных, отображаемых в форме (рис. 5.7).

Рис. 5.7. Установка критерия сортировки данных

Поля, по которым будет осуществляться упорядочение, вам необходимо разместить в списке Selected fields (Выбранные поля). Для переноса полей из списка Available fields or index tag (Имеющиеся поля и индексы) в список Selected fields (Выбранные поля) можно использовать кнопку Add(Добавить) или мышь. Установите курсор на поле, по значению которого требуется упорядочение данных, и дважды щелкните кнопкой мыши или нажмите кнопку Add (Добавить). Поле будет перенесено в список Selected fields (Выбранные поля). Если вы ошибочно перенесли не то поле, для его удаления из списка Selected fields (Выбранные поля) установите на него курсор и дважды щелкните кнопкой мыши или нажмите кнопку Remove (Удалить). Поле будет возвращено в список Available fields or index tag (Имеющиеся поля и индексы).

Опции Ascending (По возрастанию) и Descending (По убыванию) определяют, по возрастанию или по убыванию будут упорядочиваться данные в указанном поле.

Чтобы перейти к следующему шагу, нажмите кнопку Next (Далее).

  10. На заключительном шаге создания формы с помощью мастера (рис. 5.8)вы можете задать заголовок формы в поле Type a title for your form (Тип заголовка формы), а также указать предполагаемые действия с созданной формой, используя опции, описанные в табл. 5.2.

Рис. 5.8. Задание заголовка формы и выбор одного из возможных вариантов продолжения работы с ней

Таблица 5.2. Опции окна Form Wizard Sfep 4

Опция | Действие
Save form for later use (Сохранить форму) | Созданная форма сохраняется на диске
Save and run form (Сохранить и запустить форму на выполнение) | Созданная форма сохраняется и запускается на выполнение
Save form and modify it in the FormDesigner (Сохранить и открыть для модификации в конструкторе форм) | Созданная форма сохраняется и открывается в конструкторе форм для модификации

В последнем диалоговом окне мастера расположены флажки:

  • Use field mappings (Использовать связь полей с типами объектов) —при установке этого флажка объекты формы, соответствующие полям таблицы, будут создаваться на основе параметров, заданных на вкладке Field mapping (Связь полей с типами объектов) диалогового окна Options (Параметры), открываемого при выборе команды Options(Параметры) из меню Tools (Сервис). В противном случае объекты в форме будут создаваться исходя из информации, содержащейся в базе данных.
  • Override with DBC field display classes (Пересоздать, используя классы отображения полей) — для создания элементов формы используются классы отображения полей таблицы, заданные в конструкторе таблиц.
  • Add pages for fields that do not fit (Добавить вкладки для не поместившихся полей) — при установке флажка для объектов, не поместившихся в форме, будут автоматически создаваться вкладки.

Воспользовавшись кнопкой Preview (Просмотр), вы сможете просмотреть, как будет выглядеть создаваемая форма, и если что-то не так, вернуться к предыдущим шагам в работе мастера и изменить установленные параметры.

После того как все параметры введены, нажмите кнопку Finish (Готово).Откроется диалоговое окно Save as (Сохранить как), в котором укажите имя файла и папку, в которой она должна быть размещена.

На рис. 5.9 представлена форма, созданная с помощью мастера. Если вам потребуются дополнительные средства для управления формой, вы можете модифицировать ее в конструкторе форм.

Рис. 5.9. Форма, созданная с помощью мастера форм

Замечание

Посмотрите на созданную мастером форму. При размещении надписей мастер использовал наименования полей, введенные в поле Caption (Надпись)конструктора таблиц Table Designer (Конструктор таблиц). Если информация в этих полях отсутствует, то надписи в форме будут совпадать с именами полей таблицы.


Режим с использованием списка объектов

Если в диалоговом окне Options (Параметры) для опции Tab Ordering(Упорядочение объектов) установлено значение By List (По списку), при выборе команды Tab Order (Порядок объектов) из меню View (Вид) открывается диалоговое окно Tab Order (Порядок объектов), в котором объекты формы размещены в соответствии с текущим порядком обхода объектов в форме (рис. 5.16).

Рис. 5.16. Диалоговое окно Tab Order

С помощью кнопок By Column (По столбцам) и By Row (По строкам) вы можете задать порядок обхода объектов по столбцам или по строкам соответственно. Кроме того, можно определить собственный порядок обхода, расположив соответствующим образом элементы списка. Для перемещения элементов списка нажмите кнопку, расположенную слева от названия объекта, и переместите ее в требуемое место списка объектов.


Интерактивный режим

Если в диалоговом окне Options (Параметры) для опции Tab Ordering(Упорядочение объектов) установлено значение Interactive (Интерактивный), то при выборе команды Tab Order (Порядок объектов) в левом верхнем углу всех объектов формы появляется квадрат с указанием его порядкового номера обхода. Для указания нового порядка обхода объектов в форме выполните следующие действия:

  1. Нажмите и удерживайте клавишу <Shift>.
  2. Щелкайте на объектах в форме в той последовательности, в которой они должны выбираться при нажатии клавиши <Та b >.
  3. После завершения определения порядка обхода объектов отпустите клавишу <Shift> и щелкните в любом месте формы.


Изменение последовательности ввода информации в поля формы

При вводе информации в поля формы переход от одного поля к другому осуществляется с помощью клавиши <Та b > в соответствии с заданным в форме порядком объектов. Он может отличаться от реального расположения объектов.

Рис. 5.15. Отображение порядковых номеров объектов формы

Для того чтобы посмотреть порядковые номера объектов, выберите в меню View (Вид) команду Tab Order (Порядок объектов). В результате ваша форма будет иметь вид, представленный на рис. 5.15. В левом верхнем углу объектов отображаются их номера.

Каждому новому добавляемому в форму объекту присваивается номер, несвязанный с его реальным расположением в форме и определяющий лишь очередность размещения объекта в форме. Он на единицу больше максимального номера объектов формы.

Для изменения имеющегося порядка обхода объектов предназначена команда Tab Order (Порядок объектов) из меню View (Вид), которая переводит форму в режим изменения текущего порядка обхода.

В Visual FoxPro поддерживаются два режима установки порядка обхода объектов интерактивный и из списка. Выбор того или иного используемого режима осуществляется с помощью списка Tab ordering (Упорядочение объектов) на вкладке Forms (Формы) диалогового окна Options (Параметры).

Замечание

Для открытия диалогового окна Options (Параметры) в меню Tools (Сервис)выберите команду Options (Параметры).


Линии сетки

Для точного позиционирования объектов в форме удобно использовать сетку, которая отображается на экране при выборе команды Grid Line (Линии сетки) из меню View (Вид). Размер ячейки сетки в горизонтальном и вертикальном направлениях устанавливается с помощью двух полей ввода в диалоговом окне Set Grid Scale (Установка размера сетки) (рис. 5.14). Для его открытия в меню Format (Формат) используется команда Set Grid Scale(Установка размера сетки).

Рис. 5.14. Диалоговое окно Set Grid Scale для настройки параметров сетки

При установленной в меню Format (Формат) опции Snap to Grid (По сетке)вы не можете расположить объект в произвольном месте формы. Все операции размещения объектов, их перемещения и изменения размеров будут выполняться с учетом размера ячейки сетки.

Замечание

Линии сетки, установленные в форме командой Grid Line (Линия сетки) из меню View (Вид), не видны при выполнении формы.


Изменение размеров объектов и их выравнивание

Для изменения размера одного выделенного в форме объекта можно использовать маркеры управления, представляющие собой черные квадратики по углам и сторонам.

Если требуется установить точные размеры объекта, лучше использовать свойства Height и width, определяющие его высоту и ширину соответственно. Для этого откройте окно свойств объекта Properties (Свойства) и с помощью клавиатуры введите необходимые значения в поля свойств. Для улучшения внешнего вида размещенные в форме объекты выравнивают относительно друг друга и сетки формы. Для выравнивания можно использовать команды меню Format (Формат), а также панель инструментов Layout

(Расположение), содержащую кнопки, которые наиболее часто используются при выравнивании объектов и изменении их размеров.

В табл. 5.6 приведены все команды выравнивания объектов из меню Format(Формат), а в табл. 5,7 — команды изменения их размеров.

Таблица 5.6. Команды выравнивания объектов

Команда | Назначение
Align Left Sides (По левому краю) | Выравнивает выбранные объекты по левому краю самого левого объекта
Align Right Sides {По правому краю) | Выравнивает выбранные объекты по правому краю самого правого объекта
Align Top Edges (По верхнему краю) | Выравнивает выбранные объекты по верхнему краю самого верхнего объекта
Align Bottom Edges (По нижнему краю) | Выравнивает выбранные объекты по нижнему краю самого нижнего объекта
Align Vertical Centers (По вертикальной оси) | Выравнивает выбранные объекты по вертикальной оси
Align Horizontal Centers (По горизонтальной оси) | Выравнивает выбранные объекты по горизонтальной оси
Center Vertically (По вертикальному центру) | Центрирует выбранный объект относительно вертикального центра формы
Center Horizontally (По горизонтальному центру) | Центрирует выбранный объект относительно горизонтального центра формы

Таблица 5.7. Команды изменения размеров объектов

Команда | Назначение
Size To Fit (В границах) | Устанавливает размер объекта таким образом, чтобы его содержимое помещалось в границах объекта
Size To Grid (По сетке) | Приводит размер объекта в соответствие с шагом сетки
Size To Tallest (По высокому) | Устанавливает высоту объектов равной высоте самого высокого из выбранных объектов
Size To Shortest (По низкому) | Устанавливает высоту объектов равной высоте самого низкого из выбранных объектов
Size To Widest (По длинному) | Устанавливает длину объектов равной длине самого длинного из выбранных объектов
Size To Narrowest (По короткому) | Устанавливает длину объектов равной длине самого короткого из выбранных объектов

Для управления расстоянием между выбранными объектами в горизонтальном и вертикальном направлениях используются следующие дополнительные опции команд Horizontal Spacing (Расстояние по горизонтали) и VerticalSpacing (Расстояние по вертикали) (табл. 5.8).

Таблица 5.8. Опции команд Horizontal Spacing и Vertical Spacing

Опция | Действие
Make Equal (Одинаковое расстояние) | Устанавливает одинаковое расстояние между выбранными объектами
Increase (Увеличить) | Увеличивает расстояние между выбранными объектами
Decrease (Уменьшить) | Уменьшает расстояние между выбранными объектами

В меню Format (Формат) также содержатся команды, управляющие отображением объекта в форме (табл. 5.9).

Таблица 5.9. Команды меню Format

Команда | Действие
Bring to Front (Позади) | Направляет выбранный объект на самый нижний слой формы
Send to Back (Поверх) | Направляет выбранный объект на самый верхний слой формы


ГЛАВА 5
Форма как средство ввода и редактирования данных

В Visual FoxPro для просмотра, ввода и редактирования данных, хранящихся в таблицах, используются формы, являющиеся более наглядным средством представления информации. Рассмотрим, например, приложение, предназначенное для работы с бухгалтерскими документами, которые имеют стандартный вид. Естественно, что формы, предназначенные для ввода документов, должны выглядеть на экране монитора точно так же, как стандартные бланки этих документов. Другим важным преимуществом форм является то, что они позволяют работать не с одной, а с несколькими связанными таблицами, что, в свою очередь, также увеличивает наглядность.

Пользователю приложения нет необходимости знать, что такое VisualFoxPro, какие команды используются для добавления или удаления записей в таблицах. Он может даже вообще не знать, с использованием каких программных средств создавалось приложение. Для него главным является перемещение по таблице, добавление новых записей, редактирование и удаление имеющихся. Все эти возможности имеются в формах.

Форма предназначенная для ввода и просмотра списка товаров магазина мелкооптовой торговли. В форме размещен иерархический список. В полях формы, находящихся справа, отображается краткое наименование товара и его описание. В верхней части экрана расположена панель, позволяющая управлять формой: перемещаться по записям таблицы, добавлять и удалять записи, осуществлять поиск необходимой информации, печатать отчет.

Замечание

В Visual FoxPro (в отличие от FoxPro для Windows) форма существует как функционально полный объект проектирования, который не требует предварительной генерации программного кода. Поэтому теперь вы не можете редактировать сгенерированный код и должны все действия, связанные с данной формой, описать в ней самой.

При создании форм в Visual FoxPro разработчик может использовать следующие средства:

  • Form Wizard — мастер форм;
  • Form Builder — построитель формы;
  • Builder — построитель объектов формы;
  • AutoFormat Builder — построитель авто формата;
  • Form Designer — конструктор форм.

Чтобы создать форму для одной или связанных таблиц с возможностью задания отображаемых в форме полей, стиля их отображения и указания типа кнопок управления, можно использовать мастер создания форм.

Для самостоятельной разработки формы с заданными свойствами или изменения формы, созданной с помощью мастера, вам необходимо использовать конструктор форм.

Для облегчения размещения в конструкторе форм полей и надписей, оформленных в соответствии с выбранным стилем, можно использовать построитель формы. Помимо этого, в конструкторе форм для большинства объектов (полей, списков, переключателей, таблиц и т. д.) существуют построители, позволяющие размещать в форме заданные объекты и настраивать их свойства. Кроме того, в Visual FoxPro имеется построитель авто формата, позволяющий задать одинаковый стиль оформления выделенных элементов формы.


  • Форма как средство ввода и редактирования данных
  • Создание формы с помощью мастера
  • Запуск формы
  • Объекты формы
  • Действия, выполняемые с объектами формы
  • Выделение объектов формы
  • Отмена выделения с объектов
  • Перемещение объектов в форме
  • Удаление объектов из формы
  • Изменение размеров объектов и их выравнивание
  • Линии сетки
  • Изменение последовательности ввода информации в поля формы
  • Интерактивный режим
  • Режим с использованием списка объектов


Размещение объектов в форме

После того как вы определили параметры формы, разместили в окружении используемые таблицы, можно приступать к размещению объектов в форме.


Последовательность действий при настройке параметров формы

Теперь рассмотрим последовательность действий для определения окружения и задания основных свойств формы.

  1. Откройте проект Sales.
  2. Выберите вкладку Documents (Документы), перейдите в окне проекта в группу Forms (Формы) и нажмите кнопку New (Новая).
  3. В открывшемся диалоговом окне New Form (Новая форма) выберите опцию New Form (Новая форма). Откроется окно конструктора форм для создания новой формы.
  4. Откройте окно окружения формы Data Environment (Среда окружения),выбрав команду Data Environment (Среда окружения) из меню View (Вид).
  5. Для размещения таблицы в среде окружения выберите команду Add(Добавить) из меню Data Environment (Среда окружения).
  6. В открывшемся диалоговом окне Add Table or View (Добавить таблицу или представление данных) выберите из списка таблиц открытой базы данных таблицу, для которой создаете форму, и нажмите кнопку ОК.
  7. Откройте окно свойств таблицы, размещенной в окне окружения. Для этого установите на нее курсор, нажмите правую кнопку мыши и выберите из контекстного меню команду Properties (Свойства),
  8. Выделите свойство order (Упорядочение). Для упорядочения данных форме в поле коррекции свойства нажмите кнопку раскрытия списка и из списка индексов таблицы выберите индекс, по которому хотите упорядочить данные.
  9. Закройте окно определения среды окружения.
  10. Для задания свойств формы установите курсор в форму, нажмите правую кнопку мыши и выберите из контекстного меню команду Properties(Свойства). Открывается окно Properties (Свойства). В его верхнем списке, указывающем название объекта, для которого осуществляется настройка свойств, содержится текст Form1 (Форма 1).
  11. В окне Properties (Свойства) скорректируйте свойство caption (Надпись), введя в текстовом поле заголовок формы.
  12. Задайте цвет фона формы. Для этого используйте свойство формы BackColor (Цвет фона). Щелкните на нем мышью. Затем нажмите расположенную с правой стороны поля редактирования свойства кнопку ив открывшемся диалоговом окне Цвет выберите цвет, который хотите использовать для фона.
  13. Свойство AutoCenter (Автоцентр) должно иметь значение True (Истина), чтобы форма располагалась в центре экрана.
  14. Для изменения размера формы установите курсор в ее нижний правый угол. Когда он примет вид двунаправленной стрелки, нажмите кнопку мыши и, удерживая ее, измените размер формы. Установив необходимый размер формы, отпустите кнопку мыши.
  15. Измените свойства FontName (Наименование шрифта), Fontsize (Размер шрифта), выбрав подходящий шрифт из установленных на вашем компьютере и его размер.
  16. Сохраните форму на диске.


Среда окружения формы

При создании формы, предназначенной для редактирования или просмотра информации, содержащейся в таблицах, в конструкторе форм необходимо определить среду окружения, т. е. задать таблицы, используемые в форме, и установить связи между ними.

Замечание

При создании форм с помощью мастера и размещении объектов в форме с помощью построителя среда окружения создается Visual FoxPro без участия разработчика.

При определении среды окружения вы выполняете следующие действия:

  • добавляете все таблицы, используемые в форме;
  • устанавливаете для таблиц индексы;
  • устанавливаете между таблицами отношения, необходимые для создания формы.

Вся эта информация, относящаяся к среде окружения, хранится в файле описания формы.

Для создания среды окружения формы предназначено диалоговое окно DataEnvironment (Среда окружения), открыть которое можно одним из следующих способов:

  • выбрать команду Data Environment (Среда окружения) из меню View(Вид);
  • нажать кнопку Data Environment (Среда окружения) на панели инструментов Form Designer (Конструктор форм);
  • выбрать команду контекстного меню формы Data Environment (Среда окружения).

Замечание

При открытии окна среды окружения Data Environment (Среда окружения) в основное меню добавляется соответствующий пункт.

Для работы в окне Data Environment (Среда окружения) можно использовать команды из меню Data Environment (Среда окружения) или контекстное меню (рис. 6.4), позволяющие добавить в окружение таблицы, просмотреть их в режиме Browse (Обзор), открыть окно свойств окружения для задания различных параметров.

Для добавления новой таблицы в среду окружения можно выполнить одно из следующих действий:

  • выбрать команду контекстного меню Add (Добавить);
  • выбрать команду Add (Добавить) из меню Data Environment (Среда окружения).

При этом открывается диалоговое окно Add Table or View (Добавить таблицу или представление данных) (рис. 6.5), содержащее список таблиц открытой базы данных. Опция Views (Представления данных) области Select (Выбор)позволяет разместить в среде окружения созданные в базе данных представления данных.

Рис. 6.4. Диалоговое окно Data Environment с контекстным меню

Рис. 6.5. Диалоговое окно Add Table or View

После размещения таблиц в среде окружения формы вам необходимо упорядочить данные, находящиеся в таблицах. Для этого выполните следующие действия:

  1. Выделите таблицу, в которой хотите упорядочить данные.
  2. Откройте окно свойств таблицы. Для этого установите на нее курсор, нажмите правую кнопку мыши и выберите из контекстного меню команду Properties (Свойства).
  3. Выделите свойство Order (Упорядочение).
  4. В поле коррекции свойства нажмите кнопку раскрытия списка. Из списка индексов таблицы выберите тот, по которому хотите упорядочить данные в форме.

При размещении в форме связанных таблиц они переносятся в окружение формы вместе со связями, установленными в базе данных. Вам необходимо убедиться, что связи установлены должным образом. Для этого выполните следующие действия:

  1. Выделите линию, соединяющую таблицы. При этом в окне Properties(Свойства) будут отображаться свойства, характеризующие установленную между таблицами связь.

Рис. 6.6. Диалоговое окно Data Environment с размещенными таблицами

  2. Проверьте, какая из таблиц является родительской, а какая дочерней по отношению к ней. Для этого просмотрите свойства ChildAlias(Дочерняя таблица) и ParentAlias (Родительская таблица).
  3. Посмотрите выражение, используемое для связи таблиц, воспользовавшись свойством RelationalExpr (Выражение отношения). Оно должно совпадать с выражением, используемым при создании индекса, по которому таблицы связаны.

На рис. 6.6 представлено диалоговое окно Data Environment (Среда окружения) с размещенными в нем таблицами customer и Phoncust и открытым окном свойств для установленной между таблицами связи.


Стиль обрамления формы

Стиль обрамления формы задается с помощью свойства Borderstyle (Стиль рамки) и может принимать значения, описанные в табл. 6.4.

Таблица 6.4. Значения стиля обрамления формы

Значение | Описание
0-No border (Нет рамки) | Форма не имеет рамки
1-Fixed Single (Одинарная рамка) | Неизменяемая одинарная рамка
2-Fixed Dialog (Двойная рамка) | Неизменяемая двойная рамка
3-Sizable (Default)(Изменяемая) | Изменяемая рамка (размеры формы можно изменять при выполнении)

Свойство BackCoior (Цвет фона) позволяет задать цвет фона формы.

Свойство windowstate (Состояние окна) определяет размер формы при ее вызове и может принимать одно из значений, описанных в табл. 6.5.

Таблица 6.5. Значения свойства windowstate

Значение | Описание
Normal (Обычное) | Форма имеет размеры, определенные его свойствами
Minimized (Windows only)(Минимизированное) | Форма сворачивается в значок
Maximized (Максимизированное) | Форма распахивается на весь экран


Заголовок формы

Для задания текста заголовка формы, располагающегося в строке заголовка, предназначено свойство Caption (Надпись) окна свойств. Чтобы отредактировать заголовок, откройте окно Properties (Свойства), выделите свойство Caption (Надпись) и в поле ввода, ставшее активным, введите заголовок формы.

Если вы хотите, чтобы форма вообще не содержала заголовок, установителя свойства TitieBar (Строка заголовка) значение off (Выкл.)


Расположение формы

Новая форма по умолчанию располагается в верхнем левом углу основного окна Visual FoxPro. Для изменения ее положения можно использовать свойства Left (Левый) и тор (Верхний), указывающие расстояние в пикселях от левого и верхнего края, соответственно, а также мышь. При использовании мыши для изменения положения формы установите курсор на заголовок формы, нажмите кнопку мыши и, удерживая ее, переместите форму в окне конструктора в место ее предполагаемого расположения (рис. 6.3).

Для изменения размера формы можно использовать свойства Height(Высота) и widht (Ширина), определяющие высоту и ширину формы, а также мышь. При использовании мыши для изменения размера формы установите курсор в ее нижний правый угол. Когда он примет вид двунаправленной стрелки, нажмите кнопку мыши и, удерживая ее, измените размер формы. Установив необходимый размер, отпустите кнопку мыши.

Рис. 6.3. Расположение формы в центре главного окна Visual FoxPro

Совет

Для размещения формы в центре главного окна Visual FoxPro необходимо в окне свойств установить для свойства AutoCenter (Авто центр) значение True(Истина).


Настройка параметров формы

Форма, как и все располагаемые в ней объекты, имеет свойства, используя которые можно задать ее размер, координаты верхнего левого угла, стиль рамки обрамления, заголовок, цвет и т. д.

Настройка параметров формы осуществляется в окне свойств Properties(Свойства), для открытия которого установите курсор на свободную от объектов поверхность формы, нажмите правую кнопку мыши и выберите из контекстного меню команду Properties (Свойства).


Линии и контуры

Visual FoxPro позволяет размещать в форме линии, прямоугольники, скругленные прямоугольники, круги, эллипсы, используемые для объединения в группу схожих по смыслу объектов и улучшения внешнего вида формы.

Линия

Для добавления в форму вертикальной или горизонтальной линии выполните следующие действия:

  1. Нажмите кнопку Line (Линия) на панели инструментов Form Controls (Элементы управления формы).
  2. Установите указатель мыши в то место, где должна начинаться линия, и, не отпуская кнопку мыши, переместите его до получения линии нужной длины.
  3. Используя свойство Borderwidth (Толщина линии), введите число, которое будет определять толщину линии.
  4. Если линия вертикальная, для задания ее длины используйте свойство Height (Высота). Для задания длины горизонтальной линии предназначено свойство width (Ширина).
  5. Для задания цвета линии используйте свойство BorderCo l or (Цвет линии).
  6. С помощью свойства Borderstyle (Стиль линии) укажите стиль линии, используя значения, описанные в табл. 6.17.

Таблица 6.17. Описание стилей линии в зависимости от свойства Borderstyle

Значение | Стиль линии
0-Transparent | Линия отсутствует (имеет цвет фона)
1-Solid (Default) | Тонкая линия
2-Dash | Штриховая линия
3-Dot | Пунктирная линия
4-Dash-Dot | Штрих-пунктир
5-Dash-Dot-Dot | Штрих-двойной пунктир
6-Inside Solid | Непрерывная линия

Контуры

Для добавления в форму контура и настройки его свойств выполните следующие действия:

  1. Нажмите кнопку Shape (Контур) Е1 на панели инструментов FormControls (Элементы управления формы).
  2. Установите указатель мыши в то место, где должен начинаться объект, и переместите указатель мыши до получения квадрата или прямоугольника нужного размера.
  3. Для придания созданному объекту формы, отличной от прямоугольника или квадрата, используйте свойство curvature (Изгиб), которое может принимать целочисленные значения в диапазоне от 1 до 99.
  4. Используя свойство Backstyle (Стиль фона), задайте, будет ли созданный объект прозрачным.
  5. С помощью свойства Filistyle (Стиль заполнения) задайте узор заполнения (табл. 6.18).

Таблица 6.18. Описание узоров заполнения в зависимости от свойства Filistyle

Значение | Узор заполнения
0-Solid | Сплошное заполнение
1-Transparent (Default) | Нет заполнения
2-Horizontal Line | Горизонтальная штриховка
3-Vertical Line | Вертикальная штриховка
4-Upward Diagonal | Штриховка по диагонали слева направо
5-Downward Diagonal | Штриховка по диагонали справа налево
6-Cross | Горизонтально-вертикальная штриховка
7-Diagonal Cross | Штриховка по диагонали в обоих направлениях
  6. Используя свойство Fillcolor (Цвет заполнения), задайте цвет узора заполнения объекта.
  7. Свойство Borderstyle (Стиль рамки) предназначено для задания стиля рамки объекта. Оно содержит те же значения, что и для линии.
  8. Для придания контуру объемности используйте свойство SpecialEffect(Специальные эффекты).


Счетчики

Чтобы разместить в форме поле для ввода числовых значений, которые изменяются в заданном диапазоне, вы можете использовать объект типа spinner, называемый счетчиком. Разместим в форме счетчик, выполнив следующие действия.

  1. Нажмите кнопку Spinner (Счетчик) на панели инструментов FormControls (Элементы управления формы).
  2. Щелкните в том месте формы, где предполагаете расположить поле-счетчик.
  3. Откройте окно Properties (Свойства) для размещенного в форме объекта.
  4. В поле ввода значения свойства controisource (Источник данных) нажмите кнопку раскрытия списка и выберите поле таблицы, для которого счетчик создается.
  5. Используя свойства объектов spinner HighValue (Наибольшее значение счетчика) и spinnerLowValue (Наименьшее значение счетчика), задайтемаксимальное и минимальное значения, которые можно установить припомощи кнопок изменения значения самого поля.
  6. Используя свойство KeyboardHighValue (Максимальное значение, вводимое с клавиатуры), задайте максимальное значение, которое можно ввести в поле, используя клавиатуру.
  7. В поле свойства KeyboardLowValue (Минимальное значение, вводимое с клавиатуры) введите число, определяющее минимальное значение, вводимое в поле с клавиатуры.

Замечание

При вводе в поле числа, выходящего за установленные с помощью свойств KeyboardHighValue и KeyboardLowValue границы, на экран будет выводиться сообщение о допустимых пределах вводимого числа.

  8. Используя свойство increment (Шаг), задайте шаг, с которым будет изменяться значение поля.
  9. Создайте текстовую надпись для поля.
  10. Сохраните форму с размещенным в ней счетчиком и запустите ее на выполнение.
  11. Попробуйте вводить с помощью счетчика информацию, используя для этого кнопки поля, клавиши и , а также цифры на клавиатуре.

На рис. 6.33 представлена форма, содержащая счетчик для ввода значения скидки, которая может быть предоставлена клиенту, если он является постоянным покупателем. При вводе в поле значения больше допустимого, Visual FoxPro выдает соответствующее предупреждение с указанием диапазона вводимого значения.

Рис. 6.33. Счетчик, размещенный в форме


Использование построителя для создания раскрывающегося списка

Для размещения в форме раскрывающегося списка удобно применять построитель раскрывающегося списка. Рассмотрим его использование для создания объекта типа comboBox (Раскрывающийся список) и настройки его свойств.

  1. Нажмите кнопку Combo Box (Раскрывающийся список) на панели инструментов Form Controls (Элементы управления формы).
  2. Щелкните в том месте формы, в котором вы предполагаете расположить поле.
  3. Для запуска построителя нажмите правую кнопку мыши и выберите команду Builder (Построитель) контекстного меню. Открывается диалоговое окно Combo Box Builder (Построитель раскрывающегося списка)(рис. 6.28), содержащее вкладки List Items (Список объектов), Style(Стиль), Layout (Расположение) и Value (Значение), в которых вы можете задать формат, стиль и источник данных для поля ввода.

Совет

Для запуска построителя объекта ComboBox (Раскрывающийся список) можно сначала нажать на панели инструментов Form Controls (Элементы управления формы) кнопку Builder Lock (Закрепитель построителя), а затем — кнопку Combo Box (Раскрывающийся список). В этом случае при размещении объекта в форме сразу запускается построитель.

Рис. 6.28. Вкладка List Items построителя объекта ComboBox

Рассмотрим назначение вкладок диалогового окна Combo Box Builder(Построитель раскрывающегося списка). Вкладка List Items (Список объектов) позволяет задать тип источника данных для заполнения списка. На ней расположен раскрывающийся список Fill the list with (Заполнение списка),содержащий значения, описанные в табл. 6.16.

Таблица 6.16. Назначение опций раскрывающегося списка Fill the list with

Опция | Назначение
Fields from a table or view (Поля таблицы или представления) | Указывает, что источником данных являются поля таблицы или представления данных
Data entered by hand (Значения из списка) | Указывает, что источником данных является заданный список значений
Values from an array (Значения из массива) | Указывает, что источником данных является массив

При использовании значения Fields from a table or view (Поля таблицы или представления) сначала необходимо в списке Databases and tables (Базы данных и таблицы) выбрать таблицу, поле которой будет являться источником данных, а затем перенести нужное поле из списка Available fields(Имеющиеся поля) в список Selected fields (Выбранные поля).

Рис. 6.29. Вкладка List Items построителя раскрывающегося списка при установленном значении Values from an array

При выборе других значений из списка Fill the list with (Заполнение списка)вкладка List Items (Список объектов) изменяется. На рис. 6.29 представлена эта вкладка, когда источником данных является массив. Вам необходимо указать наименование массива и, в том случае, если он используется не весь, ввести количество строк и столбцов в размещаемом списке.

Завершив ввод параметров на вкладке List Items (Список объектов), для задания стиля отображения перейдите на вкладку Style (Стиль) построителя объекта Combo Вох (Раскрывающийся список) (рис. 6.30). Она содержит три группы переключателей. Переключатели Three-dimensional (Объемный) и Plain(Плоский) позволяют задать объемный или плоский стиль отображения поля, определяемый значением свойства SpeciaiEffect (Специальный эффект).

Рис. 6.30. Вкладка Style построителя раскрывающегося списка

Переключатели второй группы имеют следующее назначение:

  • Drop-down combo — указывает, что создаваемый объект будет раскрывающимся списком, из которого пользователь может выбрать значение или ввести его в поле ввода списка;
  • Drop-down list — указывает, что объект будет раскрывающимся списком, из которого можно только выбирать значения.

Переключатели третьей группы задают значение свойства incrementaisearch и имеют следующее назначение:

  • Yes, enable incremental searching (Да, возможен поиск значения) — указывает, что при вводе каждой буквы в поле ввода списка будет осуществляться поиск подходящего значения;
  • No, don't enable incremental searching (Нет, не возможен поиск значения) — указывает, что при вводе каждой буквы в поле ввода списка поиск подходящего значения не будет осуществляться.

Установив необходимые опции на вкладке Style (Стиль), перейдите на вкладку Layout (Расположение) (рис. 6.31). Флажок Adjust the width of the combo box to display all columns (Увеличить ширину раскрывающегося списка для отображения всех колонок) задает значение свойства width (Ширина)объекта ComboBox (Раскрывающийся список). При установке флажка ширина раскрывающегося списка увеличивается, чтобы поместились значения всех элементов списка.

Таблица данной вкладки содержит реальные данные и позволяет задать значения свойства columnwidths (Ширина колонки). Для изменения ширины колонки установите курсор на правую границу столбца и перемещайте в ту или иную сторону.

Рис. 6.31. Вкладка Layout построителя раскрывающегося списка

Вкладка Value (Значение) построителя (рис. 6.32) предназначена для указания источника данных и задает значение свойства controisource (Источник данных) объекта.

Рис. 6.32. Вкладка Value построителя раскрывающегося списка

Завершив установку параметров, нажмите кнопку ОК для закрытия окна построителя. В том случае, если вам опять потребуется его помощь, выделите созданный объект типа ComboBox (Раскрывающийся список), нажмите правую кнопку мыши и выберите из контекстного меню команду Builder(Построитель).


Раскрывающиеся списки

В Visual FoxPro существуют два вида списков. Один из них мы рассмотрели в предыдущем примере. Второй вид списка — объект типа comboBox(Раскрывающийся список) или раскрывающийся список. Этот тип списка удобно использовать в том случае, если вводимых значений много, а места в форме для расположения обычного списка не хватает.

Опишем процедуру создания раскрывающегося списка для ввода и редактирования наименования города проживания клиента таблицы customer. В отличие от предыдущего примера, в качестве источника данных будем использовать не таблицу со списком стран, а строку с наименованиями городов.

  1. Откройте в окне конструктора форму для ввода информации о клиентах.
  2. Удалите список для ввода названия города, созданный ранее.
  3. Нажмите кнопку Combo Box (Раскрывающийся список) на панели инструментов Form Controls (Элементы управления формы).
  4. Щелкните на месте удаленного объекта. Объект типа ComboBox (Раскрывающийся список) разместится в форме.
  5. Откройте окно Properties (Свойства) для размещенного в форме раскрывающегося списка.
  6. Свяжите раскрывающийся список с полем ccity таблицы customer, используя свойство controisource (Источник данных).
  7. Из списка возможных значений свойства RowSourceType (Тип источника данных списка) выберите Value (Значение).
  8. Введите в поле ввода значения свойства RowSource (Источник данных списка) перечень допустимых элементов списка через запятую: Москва, Одесса, Новосибирск, Свердловск, Черноголовка (рис. 6.26).
  9. Запустите форму на выполнение. Теперь при редактировании списка покупателей для ввода в таблицу customer названия города, в котором проживает клиент, нажмите кнопку раскрытия созданного списка и выберите из него нужное значение. Это значение будет введено в поле ccity таблицы (рис. 6.27).

Рис. 6.26. Определение свойств раскрывающегося списка

Рис. 6.27. Выбор наименования города из раскрывающегося списка


Списки

Visual FoxPro для отображения в форме одного и того же поля позволяет использовать разные объекты. Например, в предыдущем примере для ввода информации в поле, указывающее страну проживания, мы использовали переключатель. Если вводимых в поле значений много, удобно применять списки, называемые объектами типа ListBox (Список).

Списки в Visual FoxPro используются для отображения в форме элементов, которые могут быть заданы с помощью массива, меню, списка файлов, значений поля таблицы и т. д. Для указания источника данных для списка применяется свойство RowSourceType (Тип источника данных), имеющее значения, описанные в табл. 6.14.

Таблица 6.14. Значения свойства RowSourceType

Значение | Источник данных
0 (None) | Значения элементов списка определяются программно с помощью методов Additem (Добавить объект) или AddListltem(Добавить объект списка)
1 (Value) | Список задается в виде строки, элементы в которой разделяются запятыми
2 (Alias) | В качестве источника данных используется таблица. Количество выводимых полей таблицы определяется значением свойства ColumnCount (Количество полей)
3 (SQLStatement) | Список содержит данные, полученные в результате выполнения SQL-оператора
4 (Query) | Список содержит данные, полученные в результате выполнения указанного запроса. Запрос задается именем файла с расширением QPR
5 (Array) | Источником данных является заданный массив
6 (Fields) | Значения элементов списка определяются полями таблицы
7 (Files) | Список содержит перечень файлов текущей папки. В свойстве RowSource (Источник данных списка) вы можете задать шаблон выбора файлов
8 (Structure) | В качестве источника данных используется структура таблицы
9 (Popup) | Список содержит пункты всплывающего меню

Объекты типа ListBox имеют также свойства, которые отсутствовали у ранее рассмотренных объектов (табл. 6.15).

Таблица 6.15. Свойства объектов типа ListBox, отсутствовавшие у рассмотренных ранее объектов

Свойство | Назначение
ColumnCount(Количество колонок) | Определяет число колонок в списке
FirstElement(Первый элемент) | Задает первый элемент массива, который будет отображаться в списке
Number Of Elements(Количество элементов) | Определяет количество элементов массива, отображаемых в списке
RowSource(Источник данных списка) | Указывает источник данных списка

Разместим в форме, предназначенной для редактирования списка клиентов из таблицы customer, список, который будем применять для ввода названия города проживания клиента. В качестве источника данных для списка будем использовать таблицу.

  1. Создайте дополнительную таблицу city, содержащую одно поле Nmcity и введите в нее названия всех городов предполагаемых клиентов фирмы.
  2. Откройте в окне конструктора форму для ввода информации о клиентах.
  3. Откройте окно окружения формы, выбрав из меню View (Вид) команду Data Environment (Окружение). Для добавления в окружение формы таблицы с наименованиями городов выберите команду Add (Добавить) контекстного меню. На экране откроется диалоговое окно Add Table or View (Добавить таблицу или отображение), в котором выберите таблицу city.
  4. Удалите из формы поле ввода города покупателя, поскольку в данном примере для ввода значения города проживания клиента будет использоваться список.
  5. Нажмите кнопку List Box (Список) на панели инструментов FormControls (Элементы управления формы).
  6. Щелкните на месте удаленного поля ввода.
  7. Откройте окно Properties (Свойства) размещенного в форме списка.
  8. Чтобы связать созданное поле с полем таблицы customer, выберите свойство controisource (Источник данных). В поле ввода значения свойства воспользуйтесь кнопкой раскрытия списка и из списка всех полей открытой таблицы customer выберите поле ccity.
  9. Скорректируйте свойство RowSourceType (Тип источника данных), которое указывает тип источника данных. Выберите из списка значение Fields(Поля), поскольку список городов располагается в поле Nmcity таблицы City.

Рис. 6.25. Использование в форме списка

  10. Скорректируйте свойство RowSource (Источник данных списка), задав в поле ввода значения свойства city NmCity.
  11. Запустите форму на выполнение. Теперь при редактировании списка клиентов в поле ccity таблицы customer будет заноситься значение, выбираемое из списка (рис. 6.25).


Создание формы

Процесс создания формы включает следующие действия:

  • настройка параметров формы;
  • определение среды окружения, т. е. выбор используемых в форме таблиц и установка связей между ними;
  • размещение в форме объектов: текста, полей различных типов, линий, рисунков, кнопок управления;
  • настройка свойств размещенных в форме объектов.

Начнем создание формы в конструкторе форм с настройки ее параметров.


Что такое переключатель

Объекты типа Optioncroup (Переключатель) называются переключателями, т. к. они позволяют выбрать одно из нескольких значений поля или переменной. Переключатели широко используются не только в Visual FoxPro, но и в других приложениях Windows. Объекты типа optionGroup (Переключатель) представляют собой составные объекты, содержащие элементы, наделенные собственными свойствами, основные из которых приведены в табл. 6.13.

Таблица 6.13. Назначение основных свойств объекта типа optionGroup

Свойство | Назначение
ButtonCount (Количество опций) | Задает количество опций в переключателе
Style (Стиль) | Определяет вид переключателя
Left (Слева), Тор (Сверху) | Расстояние между кнопками
BorderStyle (Стиль обрамления) | Стиль обрамления

Рассмотрим процесс создания переключателя для просмотра и редактирования поля, указывающего страну проживания клиента. Например, данное поле может принимать одно из трех значений: Россия/Украина/Беларусь.

  1. Откройте в конструкторе форму для ввода списка клиентов. Расположите в ней все поля, за исключением поля, указывающего страну.
  2. Нажмите кнопку Option Group (Переключатель) на панели инструментов Form Controls (Элементы управления формы).
  3. Щелкните в том месте формы, в котором вы предполагаете расположить поле для ввода названия страны.
  4. Откройте окно Properties (Свойства) для созданного объекта.
  5. Скорректируйте свойство ButtonCount (Количество опций). Задайте количество опций, равное 3.
  6. Свяжите созданное поле формы с полем таблицы, содержащим информацию о стране проживания клиента. Для этого используйте свойство controlsource (Источник данных).
  7. Откройте в верхней части окна Properties (Свойства) список объектов и выберите из него первую опцию переключателя Option 1 (Опция 1). На рис. 6.23 показано, что при этом объект выделяется штриховой рамкой, т. е. переходит в режим редактирования.
  8. Для объекта option1 (Опция 1) скорректируйте свойство caption(Надпись), введя название страны Россия.
  9. Для объекта option1 (Опция 1) скорректируйте свойства Forecolor(Цвет надписи), BackCoior (Цвет фона), FontName (Наименование шрифта), определяющие цвет шрифта, цвет фона переключателя и наименование шрифта.
  10. Аналогично скорректируйте свойства для остальных двух объектов.
  11. Воспользовавшись кнопкой Label (Метка) на панели инструментов FormControls (Элементы управления формы), создайте над переключателем надпись Страна.

Рис. 6.23. Выбор объекта Option1 для коррекции

Рис. 6.24. Форма, содержащая переключатель

  12. Сохраните форму с размещенным в ней переключателем.

На рис. 6.24 представлена форма с переключателем, использующимся для ввода информации в поле Страна.

Теперь при вводе информации в список клиентов в поле таблицы, содержащее страну проживания, будет заноситься значение, которое вы установите с помощью переключателя.

Замечание

По умолчанию опции в переключателе расположены вертикально. Для расположения опций горизонтально перейдите в режим редактирования переключателя и, используя мышь и клавиши-стрелки, измените их расположение.


Использование в форме флажков

Для размещения в форме полей, которые могут иметь только одно из двух допустимых значений, используются объекты типа checkbox (Флажок), называемые флажками. Объекты данного типа могут использоваться в форме по одному или группами.

Рассмотрим следующий пример. Таблица со списком клиентов может содержать поле, указывающее, является ли данный клиент постоянным покупателем. При установке флажка значение в поле будет соответствовать 1, а при сбросе флажка — 0 (табл. 6.12).

Рассмотрим подробно процедуру создания флажка для редактирования поля, указывающего, является ли покупатель постоянным клиентом. Это поле имеет тип Logical (Логический) и может принимать значения 0 или 1.

  1. Откройте в окне конструктора проекта форму, позволяющую просматривать список клиентов.
  2. Нажмите кнопку Check Box (Флажок) 0?J на панели инструментов FormControls (Элементы управления формы).
  3. Щелкните в месте предполагаемого размещения флажка. Объект разместится в форме.
  4. Откройте окно Properties (Свойства) для объекта типа checkBox(Флажок).
  5. Для связывания флажка с полем таблицы скорректируйте свойство controlsource (Источник данных), задав в качестве источника данных поле типа Logical (Логический) таблицы Customer.
  6. Введите в поле свойства caption (Надпись) текст Постоянный покупатель. Данный текст будет размещен справа от флажка в окне конструктора форм, а также в форме.
  7. Флажок создан. Запустите форму на выполнение. Для установки признака постоянного покупателя установите флажок (рис. 6.22).

Замечание

Для размещенного в форме флажка вы можете скорректировать свойства ForeColor (Цвет надписи), BackStyle (Стиль фона) и FontName(Наименование шрифта), определяющие цвет, фон, наименование шрифта.

Рис. 6.22. Использование в форме объекта типа CheckBox


Размещение в форме объекта типа General

Размещение графического поля типа General (Общий) рассмотрим на примере таблицы Goods, содержащей список товаров базы данных sales. В таблице имеется поле данного типа с изображением товара, предлагаемого клиенту.

  1. Для добавления в форму графического поля типа General (Общий) нажмите кнопку ActiveX Bound Control (ActivX-объект) на панели инструментов Form Controls (Элементы управления формы).
  2. Установите указатель мыши в место предполагаемого расположения поля данного типа. Удерживая кнопку мыши нажатой, создайте рамку требуемого размера.
  3. Откройте окно свойств для размещенного объекта.
  4. Используя свойство controisource (Источник данных), свяжите созданное поле с полем таблицы. Для этого в поле ввода свойства нажмите кнопку раскрытия списка и из списка полей таблицы Goods выберите поле image (Изображение), имеющее тип General (Общий) и содержащее изображения товаров.
  5. Запустите созданную форму на выполнение, выбрав в меню Form(Форма) команду Run Form (Запустить форму). Если рисунок не помещается в рамке целиком, увеличьте размер рамки в конструкторе форм.


Размещение изображений в форме

В форме можно размещать различные изображения, используя кнопку Image (Изображение) на панели инструментов Form Controls (Элементы управления формы). Для размещения изображения в форме выполните следующие действия:

  1. Нажмите кнопку Image (Изображение) на панели инструментов FormControls (Элементы управления формы).
  2. Установите указатель мыши в том месте формы, где собираетесь разместить изображение, и, удерживая кнопку мыши в нажатом состоянии, переместите курсор по диагонали так, чтобы получилась рамка требуемого размера.
  3. Откройте окно свойств Properties (Свойства) для созданного объекта. Для этого выделите его и выберите в контекстном меню команду Properties(Свойства).
  4. Для задания имени графического файла предназначено свойство Picture(Изображение). Выберите данное свойство или нажмите кнопку, расположенную рядом с полем для ввода значения свойства. Откроется диалоговое окно Open (Открыть) (рис. 6.20).

Рис. 6.20. Диалоговое окно Open для выбора графического изображения

  5. Выберите графический файл. Просмотрите его в области Picture(Изображение), установив флажок Preview (Просмотр), и нажмите кнопку ОК. Изображение разместится в форме (рис. 6.21).

Рис. 6.21. Размещение графического изображения в форме

  6. Для настройки свойств размещенного в форме графического объекта можно использовать свойство stretch (Масштабирование). Оно содержит три значения:
  • clip (Обрезать рисунок) — изображение размещается в форме, сохраняя свой исходный размер;
  • isometric (Масштабировать, сохраняя форму) — изображение масштабируется с сохранением пропорций;
  • stretch (Масштабировать, заполняя рамку) — изображение занимает отведенный ему размер без сохранения пропорций.

Совет

Если вы захотите использовать изображение в качестве фона формы, прибегните к свойству Picture (Изображение) формы.


Кнопки управления

Как правило, в полях формы отображается информация об одной записи. Для просмотра всех записей таблицы необходимо добавить в форму средства перемещения по записям. В Visual FoxPro имеются удобные инструменты, предназначенные для этих целей, — кнопки.

Для размещения кнопок управления в форме можно использовать две кнопки панели инструментов Form Controls (Элементы управления формы) (табл. 6.11).

Таблица 6.11. Кнопки панели инструментов Form Controls

Наименование | Назначение
Command Button (Кнопка) | Создание одиночной кнопки
Command Group (Группа кнопок) | Создание набора кнопок

Размещение одиночных кнопок

Для размещения в форме одной кнопки выполните следующие действия:

  1. Нажмите кнопку Command Button (Кнопка) на панели инструментов Form Controls (Элементы управления формы) и щелкните мышью в месте предполагаемого размещения создаваемой кнопки.
  2. Откройте окно свойств созданного объекта.
  3. Кнопка может содержать текст или графическое изображение. При создании кнопки, содержащей текст, скорректируйте свойство Caption(Надпись), разместив в поле ввода значения текст, который будет отображаться на кнопке. Например, при создании кнопки для закрытия формы введите Выход.
  4. При создании кнопки, содержащей графическое изображение, для задания изображения, размещаемого на кнопке, воспользуйтесь свойством picture. Нажмите кнопку, расположенную справа от поля ввода значения свойства. В результате откроется диалоговое окно Open (Открыть) (рис. 6.15), используя которое, вы можете выбрать файл на диске, содержащий изображение, и просмотреть его в области Picture (Изображение). Чтобы это можно было сделать, необходимо установить флажок Preview (Просмотр). После выбора файла нажмите кнопку ОК для перенесения изображения на кнопку.

Рис. 6.15. Диалоговое окно Open, предназначенное для выбора изображения на кнопке

  5. Кнопка размещена в форме. Теперь необходимо, используя автоматически вызываемый при нажатии на кнопку метод объекта click (Нажатие),определить действия, выполняемые при нажатии на эту кнопку. Отобразите в окне свойств объекта список всех методов. Для этого в окне Properties (Свойства) выберите вкладку Methods (Методы).
  6. Установите курсор на метод click (Нажатие) и щелкните мышью. На экране откроется окно процедур (рис. 6.16).
  7. Введите команды, которые должны выполняться при нажатии на данную кнопку. Например, если вы создаете кнопку для выхода из формы, это могут быть следующие команды, использующие функцию MESSAGEBOX ():

* Запрос для выхода из формы

IF MESSAGEBOX("Выходить из формы?", 4+32+256, "Выход")=6

_screen.ActiveForm.Release{)

ELSE

_screen.ActiveForm.Refresh()

ENDIF

  8. Закройте окно процедур. Кнопка создана.

Рис. 6.16. Окно процедур для метода Click

Редактирование составных объектов

Некоторые объекты Visual FoxPro, такие как commandGroup (Группа кнопок)и optionGroup (Переключатель), являются составными объектами, т. к. они содержат несколько объектов, имеющих свои собственные свойства. Для работы с составными объектами Visual FoxPro предоставляет в распоряжение разработчика контекстное меню, содержащее команду Edit (Правка),переводящую объект в режим редактирования и позволяющую управлять входящими в его состав простыми объектами: перемещать их внутри рамки, изменять размеры, цвет, настраивать другие свойства. В режиме редактирования вокруг составного объекта появляется заштрихованная рамка(рис. 6.17).

Для выхода из режима редактирования необходимо щелкнуть вне области составного объекта.

Рис. 6.17. Объект CommandGroup в режиме редактирования

Создание группы кнопок

Для размещения в форме группы из нескольких кнопок можно использовать инструмент Command Group (Группа кнопок) на панели инструментов Form Controls (Элементы управления формы). Создаваемый при этом объект является составным и обладает свойством ButtonCount (Количество кнопок), определяющим количество входящих в его состав кнопок.

Воспользуемся данным инструментом для размещения в форме кнопок перемещения по записям таблицы и кнопки выхода из формы.

  1. Для создания набора кнопок нажмите кнопку Command Group (Группа кнопок) на панели инструментов Form Controls (Элементы управления формы) и щелкните в месте их предполагаемого размещения в форме.
  2. Откройте окно свойств для размещенного составного объекта.
  3. Свойство ButtonCount (Количество кнопок) объекта определяет количество кнопок, размещаемых в объекте (по умолчанию 2). Скорректируйте его, задав необходимое количество кнопок, например 5.
  4. Увеличьте с помощью мыши размеры рамки, окружающей созданный объект, чтобы в ней можно было расположить горизонтально все пять кнопок.
  5. Переведите объект в режим редактирования. Для этого установите на него курсор, нажмите правую кнопку мыши и выберите из контекстного меню команду Edit (Редактировать).
  6. Выделяя поочередно кнопки, переместите их, расположив горизонтально в одну линию.
  7. Выйдите из режима редактирования, щелкнув вне области объекта CommandGroup (Группа кнопок).
  8. Скорректируйте размер рамки, окружающей составной объект.

Совет

Для более точного задания размера рамки составного объекта выделите свойство AutoSize (Авто размер) и установите для него значение True (Истина).

  9. Откройте окно свойств объекта типа CommandGroup (Группа кнопок).Нажмите кнопку раскрытия списка в верхней части данного окна(рис. 6.18). Отметьте, что этот список содержит все объекты, размещенные в форме, а также все элементы, входящие в составной объект, под именами Command1, Command2, Command3, Comman d 4, Command 5 . Выбирая поочередно элементы в этом списке, можно изменить свойства каждой кнопки.

Рис. 6.18. Окно свойств объекта типа CommandGroup

  10. Используя свойство Caption (Надпись) каждого элемента составного объекта, задайте названия кнопок: Первая, Следующая, Предыдущая, Последняя и Выход.
  11. Для задания цвета фона, на котором располагаются кнопки, используйте свойство Backcolor (Цвет фона) объекта CommandGroup (Группа кнопок).Если вы хотите, чтобы он совпадал с цветом фона формы, установите для свойства Backstyle (Стиль фона) значение Transparent (Прозрачный).
  12. Теперь необходимо определить команды, которые будут выполняться при нажатии на данные кнопки. Для этого, открывая поочередно окно процедур метода click (Нажатие) каждого элемента, входящего в составной объект, введите следующие команды:
  • для кнопки Первая:

* Переходим на первую запись и обновляем информацию в форме

IF !BOF()

GO TOP

ENDIF

_screen.ActiveForm.Refresh()

  • для кнопки Следующая:

* Переходим на следующую запись и обновляем информацию в форме

IF !EOF()

SKIP

ENDIF

_screen.ActiveForm.Refresh()

  • для кнопки Предыдущая:

* Переходим на предыдущую запись и обновляем информацию в форме

IF !BOF ( )

SKIP - 1

ENDIF

_screen. ActiveForm. Refresh ()

  • для кнопки Последняя:

* Переходим на последнюю запись и обновляем информацию в форме

IF !EOF()

GO BOTTOM

ENDIF

_screen.ActiveForm.Refresh( )

  • для кнопки Выход:

* Запрашиваем и выходим, если Да

IF MESSAGEBOX("Выходить из формы?",4+32+256, "Выход")=6

_screen.ActiveForm.Release()

ELSE

_screen.ActiveForm.Refresh()

ENDIF

  13. После ввода команд закройте окна процедур.
  14. Набор кнопок для перемещения по записям таблицы и выхода из формы создан. Запустите форму на выполнение по команде Run Form(Запустить форму) из меню Form (Форма). Для перемещения по записям таблицы и закрытия формы используйте кнопки, находящиеся в нижней части окна (рис. 6.19).

Рис. 6.19. Форма с размещенной группой кнопок


Поле редактирования

Поля Edit Box (Поле редактирования) очень удобны для редактирования символьных полей большого размера и Memo-полей. Чтобы разместить поле редактирования в форме, выполните следующие действия:

  1. Нажмите кнопку Edit Box (Поле редактирования) на панели инструментов Form Controls (Элементы управления формы).
  2. Щелкните в том месте формы, где вы предполагаете разместить поле редактирования.
  3. Откройте окно свойств Properties (Свойства) для размещенного объекта.
  4. При использовании поля данного типа для просмотра и редактирования полей большого размера, в его правой части можно расположить вертикальную полосу прокрутки, предназначенную для просмотра информации, не поместившейся в окне просмотра. Для этого необходимо в свойстве scrollsars (Полоса прокрутки) задать значение vertical (Вертикальная). При установке значения None (Нет) полоса прокрутки у поля будет отсутствовать.

Остальные свойства поля редактирования аналогичны свойствам поля ввода, которые описаны выше.


Использование построителя для создания поля ввода

В Visual FoxPro для большинства размещаемых в форме объектов имеются построители объектов, которые помогут вам при настройке их свойств. Рассмотрим использование построителя для создания в форме поля ввода.

Для размещения в форме поля ввода с помощью построителя выполните следующие действия:

  1. Нажмите кнопку Text Box (Поле ввода) на панели инструментов Form Controls (Элементы управления формы).
  2. Щелкните в том месте формы, в котором вы предполагаете разместить поле. При этом поле ввода примет размер по умолчанию. Если вы хотите определить размер поля ввода при его размещении, нажмите кнопку мыши и, не отпуская ее, нарисуйте рамку требуемого размера.
  3. Для запуска построителя нажмите правую кнопку мыши и выберите команду контекстного меню Builder (Построитель). Открывается диалоговое окно Text Box Builder (Построитель поля ввода) (рис. 6.12), содержащее вкладки Format (Формат), Style (Стиль) и Value (Значение). Используя данное диалоговое окно, вы можете задать формат, стиль оформления поля и связать его с полем таблицы.

Рис. 6.12. Вкладка Format позволяет задать формат поля ввода

Замечание

Используя построитель, вы можете не только разместить поле, но и изменить свойства поля, уже размещенного в форме.

  4. Вкладка Format (Формат) содержит раскрывающийся список Data Type(Тип данных), используя который вы можете задать тип данных поля. На вкладке также расположены флажки, описанные в табл. 6.9.

Таблица 6.9. Назначение флажков вкладки Format

Флажок | Назначение
Enable at run time (Доступно для ввода) | Устанавливает признак разрешения доступа к полю ввода при запуске формы. Данный флажок связан со свойством объекта Enabled (Доступен)
Alphabetic characters only {Только буквы алфавита) | Разрешает ввод в поле только букв, что равносильно установке для свойства Format (Формат) значения формата А
Make read-only (Только для чтения) | Используется для запрета ввода данных в поле
Select on entry (Выбор при входе) | При перемещении курсора в поле выделяет все поле целиком
Hide selection (Скрывать выбор) | Устанавливает свойство объекта HideSelection(Скрывать выбор), управляющее выделением объекта после того, как фокус с него перейдет на другой объект
Display leading zeros (Отображать ведущие нули) | Отображает ведущие нули при их выводе в поле ввода

В нижней части вкладки расположен раскрывающийся список для задания шаблона ввода данных. Вы можете ввести любой из возможных шаблонов или выбрать из списка.

  5. Установив параметры на вкладке Format (Формат), перейдите на вкладку Style (Стиль) (рис. 6.13), чтобы задать стиль отображения создаваемого поля. Она содержит четыре параметра (табл. 6.10).

Таблица 6.10. Назначение параметров вкладки Style

Параметр | Назначение
Special effect (Специальный эффект) | Этот переключатель содержит опции 3D (Объемный) или Plain (Плоский). При выборе значения 3D(Объемный) поле будет иметь объемный вид. Определяет значение свойства SpecialEffect (Специальный эффект)
Border (Рамка) | Данный переключатель позволяет установить одно из двух значений: single или None. Определяет значение свойства BorderStyle (Стиль рамки)
Character alignment (Выравнивание символов) | Этот список позволяет задать тип выравнивания данных внутри поля и определяет значения свойства Alignment (Выравнивание)
Size text box to fit (Подходящий размер поля ввода) | При установке данного флажка ширина поля определяется автоматически на основе шаблона ввода или длины поля источника данных
  6. Для связывания поля ввода с полем таблицы перейдите на вкладку Value(Значение) (рис. 6.14). Из раскрывающегося списка Field name (Имя поля) выберите поле таблицы, с которым хотите связать поле ввода.
  7. После установки всех параметров, для завершения формирования свойств поля ввода нажмите кнопку ОК.

Рис. 6.13. Окно, предназначенное для установки параметров стиля поля

Рис. 6.14. Связывание создаваемого поля с полем таблицы

Совет

Для автоматического вызова построителя при размещении объектов в форме необходимо на панели инструментов Form Controls (Элементы управления формы) нажать кнопку Builder Lock (Закрепитель построителя).


Поле ввода

Для отображения информации из таблиц в форме используются поля различных типов. Наиболее простым типом поля является поле ввода. Для размещения поля ввода в форме выполните следующие действия:

  1. Нажмите кнопку Text Box (Поле ввода) на панели инструментов Form Controls (Элементы управления формы).
  2. Щелкнете в том месте формы, в котором вы предполагаете расположить поле ввода.
  3. Откройте окно свойств для созданного объекта.
  4. Чтобы связать созданное поле с полем таблицы, выберите на вкладке Dta (Данные) свойство Controisource (Источник данных). В поле ввода свойства воспользуйтесь кнопкой раскрытия списка и из списка всех полей открытой таблицы выберите поле, которое хотите добавить в форму(рис. 6.10).

Рис. 6.10. Связывание поля формы с полем таблицы

  5. Используя свойство Alignment (Выравнивание), задайте вариант выравнивания информации в поле: по центру, по левому или правому краю поля.
  6. Для задания стиля и цвета рамки поля используйте свойства Borderstyle(Стиль рамки) и BorderColor (Цвет рамки) соответственно.
  7. С помощью свойства DisabiedBackCoior (Цвет фона неактивного поля)задайте цвет фона неактивного поля.
  8. Применяя свойство comment (Описание), вы можете задать краткое описание назначения размещенного объекта. Это описание будет полезно при разработке приложения и его сопровождении.
  9. Используя свойства FontName (Наименование Шрифта) и FontSize (Размер шрифта), задайте используемый при отображении информации шрифт и его размер.
  10. С помощью свойства ForeColor (Цвет надписи) задайте цвет, которым будет отображаться информация в поле ввода.
  11. Для отображения полей ввода в заданном формате используйте свойство Format (Формат).

Допустимые форматы и их назначения приведены в табл. 6.7.

Таблица 6.7. Форматы данных

Код | Назначение
! | Преобразует буквы к верхнему регистру
$ | Выводит на экран текущий денежный символ
^ | Отображает числа в экспоненциальном виде
А | Разрешает ввод только текстовых символов
D | Для редактирования данных типа даты использует текущий формат SET DATE (например, BRITISH, GERMAN и т. д.)
Е | Редактирует данные, рассматривая их как европейские (BRITISH) даты
К | Выделяет все поле целиком, когда курсор перемещается в данное поле
L | Отображает ведущие нули при их выводе в поле ввода
М | Задает несколько предопределенных значений на выбор
R | Содержит маску формата для поля ввода. Символы маски отображаются на экране, но не сохраняются в источнике данных
Т | Удаляет начальные и конечные пробелы в форме
YS | Отображает дату в кратком формате, используя установки Windows
YL | Отображает дату в полном формате, используя установки Windows
Z | Отображает 0 как пробел, за исключением случая, когда фокус установлен на объекте
  12. Свойство inputMask (Маска ввода) позволяет задать шаблон. Символы, которые могут быть использованы в шаблоне, представлены в табл. 6.8.

Таблица 6.8. Коды шаблонов PICTURE

Код | Назначение
X | Допускает ввод любых символов
9 | В случае символьных данных позволяет вводить только цифры. В случае числовых данных позволяет вводить цифру и знак
# | Позволяет вводить цифры, пробелы и знак
$ | Выводит на экран текущий денежный символ (определяемый при помощи команды SET CURRENCY). По умолчанию этот символ помещается непосредственно до или после поля. Однако денежный символ и его позиция (SET CURRENCY), разделительный символ (SET SEPARATOR) и символ десятичного знака (SET POINT) могут быть переопределены
$$ | Отображает плавающий денежный символ, положение которого определяется расположением цифр в поле ввода или счетчике
* | Перед числовыми значениями выводятся звездочки. Используется со знаком доллара $
. | Задает позицию десятичной точки
, | Используется для отделения цифр, стоящих слева от десятичной точки
  13. Если вы создаете поле, информация которого должна быть доступна только для чтения, необходимо установить значение свойства Readonly(Только чтение) равным True (Истина).
  14. Используя свойство specialEffect (Специальный эффект), задайте стиль отображения поля из трех предложенных вариантов: обычный, с эффектом объемности или принимающий объемный вид при перемещении курсора мыши над ним.
  15. Для поля можно задать длинные поясняющие надписи, выводимые в строку состояния при установке на поле курсора мыши. Для этого используется свойство statusBarText (Текст строки состояния). На рис. 6.11 представлена форма с полем код клиента, при определении которого было использовано данное свойство.
  16. Visual FoxPro позволяет с помощью свойства ToolTipText (Текст подсказки) создавать текст краткого пояснения, появляющийся ниже курсора, когда он установлен на поле. Чтобы текст заданного поясненияотображался, установите для свойства ShowTips (Показывать подсказки)формы значение True (Истина).
  17. При добавлении новой записи в поле по умолчанию можно вводить наиболее часто встречающееся значения. Для этого используется свойство value (Значение).

Рис. 6.11. Отображение в строке состояния информации, задаваемой свойством StatusBarText


Текстовая информация

Размещение в форме текста (заголовков, надписей к полям, поясняющей информации) осуществляется с помощью кнопки Label (Метка), находящейся на панели инструментов Form Controls (Элементы управления формы).

Для размещения текста выполните следующие действия:

  1. Нажмите кнопку Label (Метка) на панели инструментов Form Controls(Элементы управления формы). Если данная панель отсутствует на экране, для ее отображения выберите в меню View (Вид) команду Form Controls Toolbar (Панель элементов управления формы).
  2. Установите указатель мыши на место предполагаемого расположения текстового объекта и нажмите кнопку мыши. В форме появляется объект, в названии которого содержится слово Label1.
  3. Для открытия окна свойств созданного объекта выделите его и выберите из контекстного меню команду Properties (Свойства). Откроется окно Properties (Свойства).
  4. Фон текстового объекта определяется свойством Backstyle (Стиль фона).Если вы хотите, чтобы фон текста не отличался от фона формы, установите для свойства BackStyle (Стиль фона) значение Transparent (Прозрачный).
  5. Текст задается свойством caption (Надпись). Выделите данное свойство, после чего в поле ввода свойства введите нужную текстовую информацию и нажмите клавишу <Enter>.
  6. Задайте с помощью свойств FontName (Наименование шрифта) и Fonsize (Размер шрифта) вид и размер шрифта.
  7. Используя свойство ForeColor (Цвет надписи), задайте цвет текстовой информации.
  8. Скорректируйте размер объекта, чтобы в нем помещалась вся надпись. Для этого используйте маркеры выделения или установите значение True(Истина) в поле свойства AutoSize (Авто размер).


Размещение полей таблиц и надписей к ним с использованием построителя формы

Для размещения в форме полей таблицы и надписей к ним в конструкторе форм можно использовать построитель формы.

Чтобы запустить построитель форм, выберите команду Builder (Построитель)контекстного меню формы или нажмите кнопку Form Builder (Построитель формы) на панели инструментов Form Designer (Конструктор форм). Откроется диалоговое окно Form Builder (Построитель формы), содержащее две вкладки (табл. 6.6).

Таблица 6.6. Назначение вкладок окна Form Builder

Вкладка | Назначение
Field Selection (Выбор поля) | Выбор полей, которые будут размещены в форме (рис. 6.7)
Style (Стиль) | Задание стиля отображения объектов формы (рис. 6.8)

Рис, 6.7. Вкладка для выбора полей, размещаемых в форме с помощью построителя

Рис. 6.8. Вкладка для определения стиля объектов, размещаемых с помощью построителя

Используя вкладку Field Selection (Выбор поля) диалогового окна FormBuilder (Построитель формы), сформируйте список полей таблицы, размещаемых в форме. Для этого из верхнего списка области Databases and tables

(Базы данных и таблицы) выберите необходимую базу данных, а из нижнего — таблицу, поля которой размещаете в форме. Затем из списка Availablefields (Имеющиеся поля) перенесите в Selected fields (Выбранные поля) поля, которые вы хотите разместить в создаваемой форме. Для переноса полей используйте кнопки, расположенные между списками.

Сформировав список полей, перейдите на вкладку Style (Стиль). Используя расположенный здесь список Style (Стиль), задайте стиль оформления объектов, размещаемых в форме. Завершив установку параметров на обеих вкладках, нажмите кнопку ОК. В форме будут размещены поля и надписи к ним (рис. 6.9).

Замечание

Построитель может размещать в форме все поля, включая также поля типа General.

Рис. 6.9. Форма с объектами, размещенными с помощью построителя

Замечание

При размещении в форме объектов с помощью построителя нет необходимости размещать таблицы в окне окружения, т. к. их разместит там сам построитель .


ГЛАВА 6
Конструктор форм

Вы уже познакомились с созданием формы с помощью мастера форм. В данной главе рассмотрим создание формы в окне конструктора форм.

Окно конструктора форм

Любая форма в Visual FoxPro состоит из объектов, каждый из которых имеет характерные свойства. Для любого объекта вы можете указать действия, выполняемые программой при наступлении определенных событий. Процесс создания формы в конструкторе форм состоит в размещении в форме объектов и определении свойств, а также связанных с ними событий и выполняемых действий.

Для открытия окна конструктора форм при создании новой формы воспользуйтесь одним из следующих способов.

  • Выполните команду New (Новый) из меню File (Файл). В открывшемся диалоговом окне New (Новый) выберите опцию Form (Форма) и нажмите кнопку New File (Новый файл).
  • Нажмите кнопку на стандартной панели инструментов Visual FoxPro. В открывшемся диалоговом окне New (Новый) выберите опцию Form(Форма) и нажмите кнопку New File (Новый файл).
  • Для размещения создаваемой формы в проекте выберите вкладку Documents (Документы), перейдите в группу Forms (Формы) и нажмите кнопку New окна проекта. Затем в открывшемся окне New Form (Новая форма) нажмите одноименную кнопку.

На рис. 6.1 показано окно конструктора форм, содержащее панели инструментов Color Palette (Цветовая палитра), Layout (Расположение), Form Designer (Конструктор форм) и Form Controls (Элементы управления формы),используемые при работе в конструкторе. В окне конструктора размещена новая форма, с которой вы можете работать.

В том случае, когда необходимые панели инструментов отсутствуют, для их отображения на экране выберите соответствующие команды в меню View(Вид) (рис. 6.2) или установите флажки выбора панелей инструментов в диалоговом окне Toolbars (Панели инструментов).

Рис. 6.1. Окно конструктора форм с панелями инструментов

Рис. 6.2. Установленные метки в опциях меню View для отображения на экране панелей инструментов

Панель инструментов Form Controls (Элементы управления формы) используется для размещения в форме объектов. Краткое описание кнопок этой панели приведено в табл. 6.1. Более подробно назначение этих кнопок будет рассмотрено ниже.

Таблица 6.1. Кнопки панели инструментов Form Controls

Наименование | Назначение
Select Objects (Выбор объектов) | Указатель выделения. Позволяет выбирать в форме объекты
View Classes (Просмотр классов) | Позволяет выбрать класс для создаваемых в форме объектов
Label (Метка) | Создает в форме текстовый объект
Text Box (Поле ввода) | Создает в форме поле ввода
Edit Box (Поле редактирования) | Создает в форме поле редактирования
Command Button (Кнопка) | Создает в форме кнопку управления
Option Group (Переключатель) | Создает в форме переключатель
Check Box (Флажок) | Создает в форме флажок
Grid (Таблица) | Создает в форме для размещения полей объект в виде таблицы
Combo Box (Раскрывающийся список) | Создает в форме раскрывающийся список
List Box (Список) | Создает в форме список
Spinner (Счетчик) | Создает в форме поле ввода значения в виде счетчика
Line (Линия) | Создает в форме линию
Shape (Контур) | Создает в форме контур
Container (Контейнер) | Создает в форме контейнер
Image (Изображение) | Размещает в форме рисунок
Command Group (Группа кнопок) | Размещает в форме группу кнопок
Timer (Таймер) | Создает в форме объект типа таймера
Page Frame (Вкладка) | Размещает в форме страницы с вкладками
ActivX Bound Control(OleBoundControl) (ActivX-объект) | Отображает содержимое OLE-объекта, хранящегося в поле типа General
ActivX Control(OleControl) (OLE-объект) | Создает OLE-объект
HyperLink (Гиперссылка) | Создает объект для работы с Интернетом
Separator (Разделитель) | Размещает на панели инструментов разделитель кнопок
Builder Lock (Закрепитель построителя) | Закрепляет выбор построителя
Button Lock (Закрепитель кнопки) | Закрепляет выбранную кнопку на панели инструментов

Панель инструментов Form Designer (Конструктор форм) содержит кнопки вызова панелей инструментов Form Controls (Элементы управления формы),Color Palette (Цветовая палитра), Layout (Расположение). С помощью этой панели можно выполнять и некоторые дополнительные действия по управлению формой. Краткое назначение кнопок данной панели инструментов приведено в табл. 6.2.

Таблица 6.2. Кнопки панели инструментов Form Designer

Наименование | Назначение
Set Tab Order (Порядок объектов) | Переключает конструктор форм в режим установления порядка обхода объектов формы
Data Environment (Окружение данных) | Открывает окно определения среды окружения формы
Code Window (Окно кода) | Открывает окно просмотра исходного кода формы
Color Palette Toolbar (Панель инструментов Цветовая палитра) | Отображает на экране панель инструментов Color Palette (Цветовая палитра)
Form Builder (Построитель формы) | Вызывает построитель формы
Properties Window (Окно свойств) | Открывает на экране окно свойств объектов формы
Form Controls Toolbar (Панель инструментов Элементы управления формы) | Вызывает на экран панель инструментов FormControls (Элементы управления формы)
Layout (Расположение) | Вызывает на экран панель инструментов Layout(Расположение)
Auto Format (Авто формат) | Вызывает построитель авто формата для выбранных объектов формы

Для выравнивания объектов, размещенных в форме, удобно использовать панель инструментов Layout (Расположение). Краткое назначение кнопок данной панели приведено в табл. 6.3.

Таблица 6.3. Кнопки панели инструментов Layout

Наименование | Назначение
Align Left Sides (По левому краю) | Выравнивает выбранные объекты по левому краю самого левого объекта
Align Top Edges (По верхнему краю) | Выравнивает выбранные объекты по верхнему краю самого верхнего объекта
Align Right Sides (По правому краю) | Выравнивает выбранные объекты по правому краю самого правого объекта
Align Bottom Edges (По нижнему краю) | Выравнивает выбранные объекты по нижнему краю самого нижнего объекта
Align Vertical Centers (По вертикали) | Выравнивает выбранные объекты по вертикали
Align Horizontal Centers (По горизонтали) | Выравнивает выбранные объекты по горизонтали
Center Vertically (По вертикальному центру) | Центрирует выбранные объекты относительно вертикальной средней линии формы
Center Horizontally (По горизонтальному центру) | Центрирует выбранные объекты относительно горизонтальной средней линии
Same Width (Одинаковая ширина) | Устанавливает одинаковую ширину для выбранных объектов формы
Same Size (Одинаковый размер) | Устанавливает одинаковую ширину и высоту для выбранных объектов формы
Same Height (Одинаковая высота) | Устанавливает одинаковую высоту для выбранных объектов формы
Send to Back (Позади) | Направляет выбранный объект на самый нижний слой формы
Bring to From (Поверх) | Направляет выбранный объект на самый верхний слой формы


  • Окно конструктора форм
  • Создание формы
  • Настройка параметров формы
  • Расположение формы
  • Заголовок формы
  • Стиль обрамления формы
  • Среда окружения формы
  • Последовательность действий при настройке параметров формы
  • Размещение объектов в форме
  • Размещение полей таблиц и надписей к ним с использованием построителя формы
  • Текстовая информация
  • Поле ввода
  • Использование построителя для создания поля ввода
  • Поле редактирования
  • Кнопки управления
  • Размещение изображений в форме
  • Размещение в форме объекта типа General
  • Использование в форме флажков
  • Что такое переключатель
  • Списки
  • Раскрывающиеся списки
  • Использование построителя для создания раскрывающегося списка
  • Счетчики
  • Линии и контуры


Печать отчета

Вы подготовили отчет, просмотрели его в окне предварительного просмотра и убедились, что он выглядит так, как вы хотите. Теперь можно распечатать отчет на принтере, воспользовавшись одним из предложенных ниже способов.

  • Выберите команду Print (Печать) из меню File (Файл).
  • Выберите команду Run Report (Запустить отчет) из меню Report (Отчет).
  • Выберите команду Print (Печать) контекстного меню.
  • Нажмите кнопку Print One Copy (Печать одной копии) или Run(Запустить) на стандартной панели инструментов Visual FoxPro.
  • Нажмите комбинацию клавиш <Ctrl>+<P>.

Открывается диалоговое окно Print (Печать) (рис. 7.14), позволяющее указать имя используемого для печати принтера, изменить, в случае необходимости, его настройки и установить параметры печати.

Рис. 7.14. Диалоговое окно Print

В верхней части диалогового окна Print (Печать) расположен раскрывающийся список Name (Наименование), позволяющий выбрать тип подключаемого принтера. Эта возможность особенно важна при работе в сети, когда у вас имеется несколько сетевых принтеров.

Переключатели области Print range (Печатать) позволяют указать печатаемые страницы и имеют следующее назначение:

  • All (Все) —печатаются все страницы отчета;
  • Pages (Страницы)— печатаются страниц, номера которых заданы в полях ввода from: (от) и to: (до).

Счетчик области Copies (Копии) позволяет указать количество печатаемых копий отчета.

В случае, если требуется дополнительная настройка параметров принтера, нажмите кнопку Options (Опции). В результате откроется диалоговое окно Print Options (Параметры печати) (рис. 7.15).

Рис. 7.15. Диалоговое окно Print Options

Поле Туре (Тип) области Print what (Что печатать) позволяет указать тип выводимой на печать информации. Поле File (Файл) содержит наименование и расположение печатаемого файла.

В области Options (Опции) расположены флажки, имеющие назначения, описанные в табл. 7.7.

Таблица 7.7. Назначение флажков окна Print Options

Флажок | Назначение
Line numbers (Линии нумерации) | Печатает в левой части отчета номера строк. Данный флажок используется только при печати содержимого окна команд и временного буфера Windows
Page eject before (Новая страница перед отчетом) | Выдает принтеру команду перехода на новую страницу перед печатью отчета
Page eject after (Новая страница после отчета) | Выдает принтеру команду перехода на новую страницу после печати отчета
Restore environment (Восстановить окружение) | Используется для совместимости с отчетами FoxPro версий 2.x

При нажатии кнопки Options (Параметры) диалогового окна Print Options(Параметры печати) открывается диалоговое окно Report and Label Print Options (Параметры печати отчета и этикетки) (рис. 7.16).

Рис. 7.16. Диалоговое окно Report and Label Print Options позволяет указать критерий для выбора записей

В диалоговом окне Report and Label Print Options (Параметры печати отчета и этикетки) вы можете указать критерии для выбора записей, печатаемых в отчете (табл. 7.8).

Таблица 7.8. Критерии выбора записей

Критерий | Назначение
Scope (Печатаемые записи) | Содержит раскрывающийся список Scope (Печатаемые записи), в котором указывается область печатаемых записей
For (Пока) | Вызывает построитель выражений, в котором вы создаете логическое выражение, равное True (Истина) для всех печатаемых записей отчета
While (При условии) | Вызывает построитель выражений, в котором вы создаете логическое выражение для выбора записей отчета. В отличие от критерия For, печать отчета прекращается при первом же значении выражения, равном False (Ложь)

Для настройки дополнительных параметров печати отчета можно использовать диалоговое окно Свойства (рис. 7.17), открываемое при нажатии кнопки Properties (Свойства) в окне Print (Печать) (см. рис. 7.14).

На вкладке Бумага/Качество данного диалогового окна можно задать тип подачи бумаги в принтер. Вкладка Расположение позволяет указать расположение бумаги (книжная или альбомная), порядок печати страниц. Для того чтобы изменить размер используемой при печати бумаги, качество печати, используйте диалоговое окно Дополнительные возможности, открываемое при нажатии кнопки Дополнительно.

Рис. 7.17. Диалоговое окно Свойства


Панель инструментов, используемая для просмотра отчета

При открытии отчета в окне предварительного просмотра на экране появляется панель инструментов Print Preview (Предварительный просмотр) (рис. 7.13), позволяющая перемещаться между страницами отчета и распечатать его. Назначение кнопок этой панели инструментов приведено в табл. 7.6.

Рис. 7.13. Панель инструментов, используемая в окне предварительного просмотра отчета


Просмотр подготовленного отчета

Если вы хотите посмотреть, как ваш отчет выглядит, совсем не обязательно его распечатывать. Достаточно открыть его в окне предварительного просмотра, воспользовавшись любым из следующих средств, предоставляемых в ваше распоряжение программой Visual FoxPro:

  • команда Print Preview (Просмотр печати) из меню File (Файл);
  • команда Preview (Просмотр) из меню View (Вид);
  • команда Preview (Просмотр) контекстного меню;
  • кнопка Print Preview (Предварительный просмотр) на стандартной панели инструментов Visual FoxPro;
  • кнопка Preview (Просмотр) окна проекта.


Использование мастера для создания однотабличного отчета

Для создания отчета с помощью мастера вам необходимо его запустить, а затем в открывающихся диалоговых окнах выбрать таблицы, входящие в отчет, определить список полей отчета и порядок их размещения, указать тип упорядочения данных.

Для запуска мастера отчетов выполните одно из следующих действий:

  • Выберите в меню Tools (Сервис) команду Wizards (Мастера), а затем в открывшемся меню значение Report (Отчет).
  • Нажмите кнопку Report Wizard (Мастер отчета) в диалоговом окне NewReport (Новый отчет), открываемом при создании нового отчета из окна проекта.
  • Нажмите кнопку Wizard (Мастер) диалогового окна New (Новый), открываемого при нажатии кнопки New (Новый) на стандартной панели инструментов или выборе команды New (Новый) из меню File (Файл) и установке опции Report (Отчет).

Рассмотрим создание однотабличного отчета с помощью мастера.

  1. Откройте создаваемый вами проект, например Sales.
  2. Откройте базу данных проекта. Для этого на вкладке Data (Данные) установите курсор на ее названии и нажмите кнопку Open (Открыть) окна проекта. При этом на стандартной панели инструментов в списке Databases (Базы данных) появится название открытой базы данных.
  3. Перейдите на вкладку Documents (Документы) и выберите группу Reports(Отчеты).
  4. Нажмите кнопку New (Новый) окна проекта (рис. 7.1).
  5. В открывшемся диалоговом окне New Report (Новый отчет) (рис. 7.2) выберите опцию Report Wizard (Мастер отчета).
  6. После запуска мастера для построения отчета на экране открывается диалоговое окно (рис. 7.3), в котором вы должны указать тип создаваемого отчета (табл. 7.1).

Рис. 7.1. Группа Reports в окне создания проекта

Рис. 7.2. Диалоговое окно New Report

Таблица 7.1. Типы отчетов

Тип отчета | Описание
One-to-Many Report Wizard (Мастер отчетов с отношением "один-ко-многим") | Создает отчет для таблиц с отношением "один-ко-многим"
Report Wizard {Мастер отчетов) | Создает простой однотабличный отчет

Для создания простого однотабличного отчета выберите значение ReportWizard и нажмите кнопку ОК.

Рис. 7.3. Диалоговое окно для выбора типа создаваемого отчета

  7. Открывается первое диалоговое окно мастера (рис, 7.4), в котором необходимо указать таблицу, для которой вы создаете отчет, и выбрать размещаемые в отчете поля. В области Databases and tables (Базы данных и таблицы) расположены два списка. Верхний список содержит открытые базы данных, а нижний — таблицы выбранной из верхнего списка базы. Выберите из верхнего списка необходимую базу данных, а из нижнего —таблицу, для которой создаете отчет.

Рис. 7.4. Окно создания однотабличного отчета с помощью мастера

Замечание

Может оказаться, что в диалоговом окне мастера списки области Databasesand tables (Базы данных и таблицы) пусты или содержат не те данные, которые вы предполагаете использовать для построения отчета. Такая ситуация возникает в том случае, если предварительно вы не открыли необходимую базу данных. Ничего страшного. Для выбора базы данных и входящих в нее таблиц нажмите кнопку, расположенную рядом со списком баз данных. На экране откроется диалоговое окно Open (Открыть), позволяющее найти таблицу, которая будет использоваться в отчете.

  8. После выбора таблицы, для которой создается отчет, список Availablefields (Имеющиеся поля) будет содержать перечень всех полей таблицы. Вам необходимо из данного перечня перенести в список Selected fields (Выбранные поля) поля, которые вы хотите разместить в создаваемом отчете. Для переноса полей используйте располагающиеся между списками кнопки. После формирования списка отображаемых в отчете полей нажмите кнопку Next (Далее) для перехода к следующему шагу в создании отчета.
  9. В следующем диалоговом окне мастера создания отчета необходимо указать поля, по которым будет осуществляться группировка данных в отчете (рис. 7.5).

Рис. 7.5. Определение полей для группировки данных в отчете

В центре диалогового окна расположены три раскрывающихся списка, позволяющих задать до трех группировок данных в отчете. Эти списки содержат все поля таблицы. Для осуществления группировки данных в отчете выберите нужное поле из раскрывающегося списка 1. При создании второй и третьей группировки используются, соответственно, списки 2 и 3.

  10. Для задания интервала группировки нажмите кнопку Grouping options(Опции группировки). Открывается диалоговое окно Grouping Intervals(Интервалы группировки) (рис. 7.6). Раскрывающийся список Groupingintervals (Интервалы группировки) этого окна содержит значения, описанные в табл. 7.2.

Таблица 7,2. Описание интервалов группировки раскрывающегося списка Grouping intervals

Интервал группировки | Описание
Entire Field (Полное поле) | Интервал группировки задается исходя из полного значения поля таблицы
1st Letter (1 буква) | Группировка осуществляется по первой букве значения поля таблицы
2, 3, 4, 5 Initial Letters (2, 3, 4, 5 начальных букв) | Группировка осуществляется по 2, 3, 4 или 5первым буквам значения поля таблицы соответственно

Установите необходимое значение и нажмите кнопку ОК.

Рис. 7.6. Диалоговое окно Grouping Intervals

  11. Для формирования в отчете итоговых значений воспользуйтесь диалоговым окном Summary Options ( Итоговые опции ) . В нем содержится таблица, строками которой являются поля таблицы, а столбцами - возможные итоговые значения отчета (табл. 7.3.)

Таблица 7.3. Итоговые значения отчета

Столбец | Назначение
Field | Наименование поля таблицы, по которому будет вычисляться итоговое значение в отчете
Sum | При установке флажка в отчет будет помещена итоговая сумма поданному полю
Avg | При установке флажка в отчет будет помещено итоговое среднее значение по данному полю
Count | При установке флажка в отчет будет помещено итоговое количество строк
Min | При установке флажка в отчет будет помещено минимальное значение поля таблицы
Max | При установке флажка в отчет будет помещено максимальное значение поля таблицы

Установите флажки для тех итоговых значений, которые хотите разместить в отчете.

Рис. 7.7. Диалоговое окно Grouuping Intervals

В диалоговом окне Summary Options (Итоговые опции) под таблицей расположен переключатель, управляющий отображением в отчете областей данных (табл. 7.4).

Таблица 7.4. Назначение опций переключателя окна Summary Options

Опция | Назначение
Detail and Summary (Область данных и итоги) | При установке этой опции в отчете отображается область данных, промежуточные итоговые значения по группировкам и конечные итоговые значения по отчету
Summary only (Только итоги) | При установке данной опции в отчете отображается область данных и конечные итоговые значения по отчету
No totals (Нет итогов) | Если выбрана эта опция, то в отчете будет отображаться только область данных

В нижнем правом углу диалогового окна Summary Options (Итоговые опции) расположен флажок Calculate percent of total for sums (Вычислить процент итоговых сумм), позволяющий в качестве итогового значения печатать процент промежуточного итогового суммарного значения от конечного итогового суммарного значения по отчету.

Завершив в диалоговом окне Summary Options (Итоговые опции) все необходимые установки, нажмите кнопку ОК.

  12. В следующем диалоговом окне мастера задается стиль отображения объектов в отчете (рис. 7.8).

Рис. 7.8. Выбор стиля отображения объектов отчета

Список Style (Стиль) содержит несколько вариантов отображения объектов (полей, линий, заголовков и т. д.) в отчете. При выборе стиля мастер позволяет просмотреть, как будут выглядеть элементы отчета. Для этого используется область просмотра в верхнем левом углу диалогового окна. Выбрав стиль, нажмите кнопку Next (Далее), чтобы перейти к следующему шагу.

  13. На четвертом шаге создания отчета необходимо указать порядок размещения объектов в отчете (рис. 7.9) и ориентацию страницы отчета. После того как вы установили требуемые опции, нажмите кнопку Next (Далее).

Рис. 7.9. Установка порядка размещения объектов в отчете

  14. На пятом шаге создания отчета с помощью мастера задаются поля, по которым требуется упорядочение данных в отчете (рис. 7.10). Для формирования списка полей, по которым будет осуществляться сортировка, из списка Available fields or index tag (Выбранные поля и индексы), содержащего перечень всех полей отчета и индексов таблицы, перенесите в список Selected fields (Выбранные поля) требуемые поля в том порядке, в каком будут упорядочиваться данные. Для переноса полей используйте кнопку Add(Добавить) или двойной щелчок мыши на наименовании поля.

Рис. 7.10. Установка критерия упорядочения данных

Используя опции Ascending (По возрастанию) и Descending (По убыванию), укажите тип сортировки выбранного поля: по возрастанию или по убыванию соответственно.

Сформировав список полей и указав тип сортировки, нажмите кнопку Next (Далее) для перехода к следующему шагу.

  15. На шестом шаге вы можете задать заголовок отчета, используя для этого поле ввода Type a title for your report (Тип заголовка отчета). В этом же диалоговом окне вы можете указать один из трех вариантов дальнейшей работы с отчетом (рис. 7.11) (табл. 7.5).

Таблица 7.5. Переключатели окна Report Wizard (Step 6)

Переключатель | Действие
Save report for later use (Сохранить отчет) | Созданный отчет сохраняется на диске
Save report and modify it in the Report Designer (Сохранить и открыть в конструкторе для модификации) | Созданный отчет сохраняется на диске и открывается в конструкторе отчетов для модификации
Save and print report (Сохранить и распечатать отчет) | Созданный отчет сохраняется на диске и печатается

Рис. 7.11. Заключительный этап создания отчета

В правом нижнем углу диалогового окна находится кнопка Preview(Просмотр), позволяющая просмотреть созданный отчет. Если созданный отчет не удовлетворяет вашим требованиям, с помощью кнопки Back (Назад) вы можете вернуться к предыдущим шагам построения отчета и изменить установленные там параметры.

Введя заголовок и установив требуемую опцию, для завершения создания отчета с помощью мастера нажмите кнопку Finish (Готово). Открывается диалоговое окно Save as (Сохранить как), в котором введите имя созданного файла.

На рис. 7.12 представлен отчет, созданный с помощью мастера. Если он вас полностью устраивает, вы можете его распечатать. Но скорее всего, вам захочется в нем что-то изменить. В этом случае откройте созданный отчет в конструкторе отчетов и модифицируйте его.

Рис. 7.12. Отчет, созданный с помощью мастера

Замечание

При создании отчета с помощью мастера надписи к полям отчета создаются на основе информации, введенной в поле Caption (Надпись) конструктора таблиц Table Designer (Конструктор таблиц). Если это поле пусто, надписи совпадают с именами полей таблицы.


Средства создания отчетов

В Visual FoxPro для создания отчетов можно использовать следующие средства.

  • Report Wizard (Мастер отчета). Позволяет достаточно быстро создать отчет, применяя сортировку, группировку данных и заданный вами стиль оформления. Для создания готового отчета с помощью мастера достаточно ответить на ряд вопросов Report Wizard (Мастер отчета) Visual FoxPro.
  • Report Designer (Конструктор отчета). В конструкторе отчетов вы можете разрабатывать или модифицировать отчеты, созданные с помощью мастера.
  • Quick Report (Быстрый отчет). Данное средство предназначено для размещения в конструкторе отчета полей и задания среды окружения. Разработчику на выбор предлагается два варианта размещения полей.

При создании отчета можно использовать любые средства, предлагаемые Visual FoxPro, какие вам кажутся более удобными. Конечно, больше возможностей предоставляет конструктор отчетов, позволяющий создавать отчеты как в табличном виде, так и в свободной форме. Разработке отчетов средствами конструктора будет посвящена следующая глава.


Рекомендации по созданию отчета

Если вам требуется создать простой табличный отчет, в котором используются поля из одной таблицы, то трудностей, скорее всего, у вас не возникнет. При разработке более сложного отчета прежде чем приступить к его созданию, вы должны четко представлять, что же хотите получить в результате. Поэтому продумайте следующие вопросы.

  • С какой целью создается настоящий отчет?
  • Отчет какого вида вы создаете (табличный, в свободной форме или наклейки)?
  • Информация из каких таблиц должна быть представлена в отчете?
  • Из используемых в отчете таблиц какая таблица будет главной, а какая —подчиненной?
  • По каким параметрам будет упорядочиваться информация в отчете?
  • Будет ли при создании отчета использоваться группировка данных и по каким параметрам?

Получив четкие ответы на поставленные вопросы, вы облегчите свою работу при создании отчета.

Создавая первые отчеты, прежде чем приступить к работе с конструктором отчетов, прорисуйте формат отчета на бумаге. Это избавит вас от ошибок и сократит время, затрачиваемое на разработку отчета.

При создании сложных отчетов, использующих данные из нескольких таблиц с отношением "один-ко-многим", желательно идти последовательными шагами от простого к сложному. Сначала добавить в среду окружения главную таблицу и расположить в отчете ее поля. После этого просмотреть отчет в окне предварительного просмотра и убедиться, что он формируется верно. Затем добавить в окружение вторую таблицу, связать ее с главной, задать тип используемого между таблицами отношения и расположить в отчете ее поля. И опять убедиться, что отчет печатает те данные, какие вы хотите получить. При таком подходе к созданию отчета вам будет значительно легче разобраться в появляющихся ошибках или вообще их избежать.


ГЛАВА 7
Создание и печать отчетов

В предыдущих двух главах вы познакомились с инструментами VisualFoxPro, предназначенными для создания форм. Не менее мощные средства предоставляются в распоряжение разработчика для создания отчетов. Прочитав эту главу, вы узнаете, что такое отчет и познакомитесь со средствами создания и печати отчетов в Visual FoxPro.

Что такое отчет

Отчет представляет собой форматированное представление данных, выводимое на экран, принтер или в файл. Отчет, создаваемый в Visual FoxPro, может быть представлен в табличном виде или в свободной форме. Табличный отчет — это напечатанная таблица, в которой строка представляет собой запись, а каждый из элементов строки содержит поле исходной таблицы или вычисляемое поле. Данные в таблице упорядочены. Табличные отчеты используются для печати данных, представленных в виде списка. При подготовке писем, почтовых этикеток поля используемых в отчете таблиц должны располагаться в специально выделенных для них местах. В этом случае табличный отчет не подходит и используются отчеты в свободной форме. При создании такого отчета вы можете воспользоваться стандартным форматом, автоматически создаваемым Visual FoxPro для каждой таблицы, при котором поля исходной таблицы располагаются вертикально. Используя конструктор отчетов, вы можете разрабатывать собственные форматы отчета, где поля исходной таблицы будут расположены там, где вам нужно.


  • Что такое отчет
  • Рекомендации по созданию отчета
  • Средства создания отчетов
  • Использование мастера для создания однотабличного отчета
  • Просмотр подготовленного отчета
  • Панель инструментов, используемая для просмотра отчета
  • Печать отчета


ГЛАВА 7
Создание и печать отчетов

  • Что такое отчет
  • Рекомендации по созданию отчета
  • Средства создания отчетов
  • Использование мастера для создания однотабличного отчета
  • Просмотр подготовленного отчета
  • Панель инструментов, используемая для просмотра отчета
  • Печать отчета

В предыдущих двух главах вы познакомились с инструментами VisualFoxPro, предназначенными для создания форм. Не менее мощные средства предоставляются в распоряжение разработчика для создания отчетов. Прочитав эту главу, вы узнаете, что такое отчет и познакомитесь со средствами создания и печати отчетов в Visual FoxPro.

Что такое отчет

Отчет представляет собой форматированное представление данных, выводимое на экран, принтер или в файл. Отчет, создаваемый в Visual FoxPro, может быть представлен в табличном виде или в свободной форме. Табличный отчет — это напечатанная таблица, в которой строка представляет собой запись, а каждый из элементов строки содержит поле исходной таблицы или вычисляемое поле. Данные в таблице упорядочены. Табличные отчеты используются для печати данных, представленных в виде списка. При подготовке писем, почтовых этикеток поля используемых в отчете таблиц должны располагаться в специально выделенных для них местах. В этом случае табличный отчет не подходит и используются отчеты в свободной форме. При создании такого отчета вы можете воспользоваться стандартным форматом, автоматически создаваемым Visual FoxPro для каждой таблицы, при котором поля исходной таблицы располагаются вертикально. Используя конструктор отчетов, вы можете разрабатывать собственные форматы отчета, где поля исходной таблицы будут расположены там, где вам нужно.

Рекомендации по созданию отчета

Если вам требуется создать простой табличный отчет, в котором используются поля из одной таблицы, то трудностей, скорее всего, у вас не возникнет. При разработке более сложного отчета прежде чем приступить к его созданию, вы должны четко представлять, что же хотите получить в результате. Поэтому продумайте следующие вопросы.

  • С какой целью создается настоящий отчет?
  • Отчет какого вида вы создаете (табличный, в свободной форме или наклейки)?
  • Информация из каких таблиц должна быть представлена в отчете?
  • Из используемых в отчете таблиц какая таблица будет главной, а какая —подчиненной?
  • По каким параметрам будет упорядочиваться информация в отчете?
  • Будет ли при создании отчета использоваться группировка данных и по каким параметрам?

Получив четкие ответы на поставленные вопросы, вы облегчите свою работу при создании отчета.

Создавая первые отчеты, прежде чем приступить к работе с конструктором отчетов, прорисуйте формат отчета на бумаге. Это избавит вас от ошибок и сократит время, затрачиваемое на разработку отчета.

При создании сложных отчетов, использующих данные из нескольких таблиц с отношением "один-ко-многим", желательно идти последовательными шагами от простого к сложному. Сначала добавить в среду окружения главную таблицу и расположить в отчете ее поля. После этого просмотреть отчет в окне предварительного просмотра и убедиться, что он формируется верно. Затем добавить в окружение вторую таблицу, связать ее с главной, задать тип используемого между таблицами отношения и расположить в отчете ее поля. И опять убедиться, что отчет печатает те данные, какие вы хотите получить. При таком подходе к созданию отчета вам будет значительно легче разобраться в появляющихся ошибках или вообще их избежать.

Средства создания отчетов

В Visual FoxPro для создания отчетов можно использовать следующие средства.

  • Report Wizard (Мастер отчета). Позволяет достаточно быстро создать отчет, применяя сортировку, группировку данных и заданный вами стиль оформления. Для создания готового отчета с помощью мастера достаточно ответить на ряд вопросов Report Wizard (Мастер отчета) Visual FoxPro.
  • Report Designer (Конструктор отчета). В конструкторе отчетов вы можете разрабатывать или модифицировать отчеты, созданные с помощью мастера.
  • Quick Report (Быстрый отчет). Данное средство предназначено для размещения в конструкторе отчета полей и задания среды окружения. Разработчику на выбор предлагается два варианта размещения полей.

При создании отчета можно использовать любые средства, предлагаемые Visual FoxPro, какие вам кажутся более удобными. Конечно, больше возможностей предоставляет конструктор отчетов, позволяющий создавать отчеты как в табличном виде, так и в свободной форме. Разработке отчетов средствами конструктора будет посвящена следующая глава.

Использование мастера для создания однотабличного отчета

Для создания отчета с помощью мастера вам необходимо его запустить, а затем в открывающихся диалоговых окнах выбрать таблицы, входящие в отчет, определить список полей отчета и порядок их размещения, указать тип упорядочения данных.

Для запуска мастера отчетов выполните одно из следующих действий:

  • Выберите в меню Tools (Сервис) команду Wizards (Мастера), а затем в открывшемся меню значение Report (Отчет).
  • Нажмите кнопку Report Wizard (Мастер отчета) в диалоговом окне NewReport (Новый отчет), открываемом при создании нового отчета из окна проекта.
  • Нажмите кнопку Wizard (Мастер) диалогового окна New (Новый), открываемого при нажатии кнопки New (Новый) на стандартной панели инструментов или выборе команды New (Новый) из меню File (Файл) и установке опции Report (Отчет).

Рассмотрим создание однотабличного отчета с помощью мастера.

  1. Откройте создаваемый вами проект, например Sales.
  2. Откройте базу данных проекта. Для этого на вкладке Data (Данные) установите курсор на ее названии и нажмите кнопку Open (Открыть) окна проекта. При этом на стандартной панели инструментов в списке Databases (Базы данных) появится название открытой базы данных.
  3. Перейдите на вкладку Documents (Документы) и выберите группу Reports(Отчеты).
  4. Нажмите кнопку New (Новый) окна проекта (рис. 7.1).
  5. В открывшемся диалоговом окне New Report (Новый отчет) (рис. 7.2) выберите опцию Report Wizard (Мастер отчета).
  6. После запуска мастера для построения отчета на экране открывается диалоговое окно (рис. 7.3), в котором вы должны указать тип создаваемого отчета (табл. 7.1).

Рис. 7.1. Группа Reports в окне создания проекта

Рис. 7.2. Диалоговое окно New Report

Таблица 7.1. Типы отчетов

Тип отчета | Описание
One-to-Many Report Wizard (Мастер отчетов с отношением "один-ко-многим") | Создает отчет для таблиц с отношением "один-ко-многим"
Report Wizard {Мастер отчетов) | Создает простой однотабличный отчет

Для создания простого однотабличного отчета выберите значение ReportWizard и нажмите кнопку ОК.

Рис. 7.3. Диалоговое окно для выбора типа создаваемого отчета

  7. Открывается первое диалоговое окно мастера (рис, 7.4), в котором необходимо указать таблицу, для которой вы создаете отчет, и выбрать размещаемые в отчете поля. В области Databases and tables (Базы данных и таблицы) расположены два списка. Верхний список содержит открытые базы данных, а нижний — таблицы выбранной из верхнего списка базы. Выберите из верхнего списка необходимую базу данных, а из нижнего —таблицу, для которой создаете отчет.

Рис. 7.4. Окно создания однотабличного отчета с помощью мастера

Замечание

Может оказаться, что в диалоговом окне мастера списки области Databasesand tables (Базы данных и таблицы) пусты или содержат не те данные, которые вы предполагаете использовать для построения отчета. Такая ситуация возникает в том случае, если предварительно вы не открыли необходимую базу данных. Ничего страшного. Для выбора базы данных и входящих в нее таблиц нажмите кнопку, расположенную рядом со списком баз данных. На экране откроется диалоговое окно Open (Открыть), позволяющее найти таблицу, которая будет использоваться в отчете.

  8. После выбора таблицы, для которой создается отчет, список Availablefields (Имеющиеся поля) будет содержать перечень всех полей таблицы. Вам необходимо из данного перечня перенести в список Selected fields (Выбранные поля) поля, которые вы хотите разместить в создаваемом отчете. Для переноса полей используйте располагающиеся между списками кнопки. После формирования списка отображаемых в отчете полей нажмите кнопку Next (Далее) для перехода к следующему шагу в создании отчета.
  9. В следующем диалоговом окне мастера создания отчета необходимо указать поля, по которым будет осуществляться группировка данных в отчете (рис. 7.5).

Рис. 7.5. Определение полей для группировки данных в отчете

В центре диалогового окна расположены три раскрывающихся списка, позволяющих задать до трех группировок данных в отчете. Эти списки содержат все поля таблицы. Для осуществления группировки данных в отчете выберите нужное поле из раскрывающегося списка 1. При создании второй и третьей группировки используются, соответственно, списки 2 и 3.

  10. Для задания интервала группировки нажмите кнопку Grouping options(Опции группировки). Открывается диалоговое окно Grouping Intervals(Интервалы группировки) (рис. 7.6). Раскрывающийся список Groupingintervals (Интервалы группировки) этого окна содержит значения, описанные в табл. 7.2.

Таблица 7,2. Описание интервалов группировки раскрывающегося списка Grouping intervals

Интервал группировки | Описание
Entire Field (Полное поле) | Интервал группировки задается исходя из полного значения поля таблицы
1st Letter (1 буква) | Группировка осуществляется по первой букве значения поля таблицы
2, 3, 4, 5 Initial Letters (2, 3, 4, 5 начальных букв) | Группировка осуществляется по 2, 3, 4 или 5первым буквам значения поля таблицы соответственно

Установите необходимое значение и нажмите кнопку ОК.

Рис. 7.6. Диалоговое окно Grouping Intervals

  11. Для формирования в отчете итоговых значений воспользуйтесь диалоговым окном Summary Options ( Итоговые опции ) . В нем содержится таблица, строками которой являются поля таблицы, а столбцами - возможные итоговые значения отчета (табл. 7.3.)

Таблица 7.3. Итоговые значения отчета

Столбец | Назначение
Field | Наименование поля таблицы, по которому будет вычисляться итоговое значение в отчете
Sum | При установке флажка в отчет будет помещена итоговая сумма поданному полю
Avg | При установке флажка в отчет будет помещено итоговое среднее значение по данному полю
Count | При установке флажка в отчет будет помещено итоговое количество строк
Min | При установке флажка в отчет будет помещено минимальное значение поля таблицы
Max | При установке флажка в отчет будет помещено максимальное значение поля таблицы

Установите флажки для тех итоговых значений, которые хотите разместить в отчете.

Рис. 7.7. Диалоговое окно Summary Options

В диалоговом окне Summary Options (Итоговые опции) под таблицей расположен переключатель, управляющий отображением в отчете областей данных (табл. 7.4).

Таблица 7.4. Назначение опций переключателя окна Summary Options

Опция | Назначение
Detail and Summary (Область данных и итоги) | При установке этой опции в отчете отображается область данных, промежуточные итоговые значения по группировкам и конечные итоговые значения по отчету
Summary only (Только итоги) | При установке данной опции в отчете отображается область данных и конечные итоговые значения по отчету
No totals (Нет итогов) | Если выбрана эта опция, то в отчете будет отображаться только область данных

В нижнем правом углу диалогового окна Summary Options (Итоговые опции) расположен флажок Calculate percent of total for sums (Вычислить процент итоговых сумм), позволяющий в качестве итогового значения печатать процент промежуточного итогового суммарного значения от конечного итогового суммарного значения по отчету.

Завершив в диалоговом окне Summary Options (Итоговые опции) все необходимые установки, нажмите кнопку ОК.

  12. В следующем диалоговом окне мастера задается стиль отображения объектов в отчете (рис. 7.8).

Рис. 7.8. Выбор стиля отображения объектов отчета

Список Style (Стиль) содержит несколько вариантов отображения объектов (полей, линий, заголовков и т. д.) в отчете. При выборе стиля мастер позволяет просмотреть, как будут выглядеть элементы отчета. Для этого используется область просмотра в верхнем левом углу диалогового окна. Выбрав стиль, нажмите кнопку Next (Далее), чтобы перейти к следующему шагу.

  13. На четвертом шаге создания отчета необходимо указать порядок размещения объектов в отчете (рис. 7.9) и ориентацию страницы отчета. После того как вы установили требуемые опции, нажмите кнопку Next (Далее).

Рис. 7.9. Установка порядка размещения объектов в отчете

  14. На пятом шаге создания отчета с помощью мастера задаются поля, по которым требуется упорядочение данных в отчете (рис. 7.10). Для формирования списка полей, по которым будет осуществляться сортировка, из списка Available fields or index tag (Выбранные поля и индексы), содержащего перечень всех полей отчета и индексов таблицы, перенесите в список Selected fields (Выбранные поля) требуемые поля в том порядке, в каком будут упорядочиваться данные. Для переноса полей используйте кнопку Add(Добавить) или двойной щелчок мыши на наименовании поля.

Рис. 7.10. Установка критерия упорядочения данных

Используя опции Ascending (По возрастанию) и Descending (По убыванию), укажите тип сортировки выбранного поля: по возрастанию или по убыванию соответственно.

Сформировав список полей и указав тип сортировки, нажмите кнопку Next (Далее) для перехода к следующему шагу.

  15. На шестом шаге вы можете задать заголовок отчета, используя для этого поле ввода Type a title for your report (Тип заголовка отчета). В этом же диалоговом окне вы можете указать один из трех вариантов дальнейшей работы с отчетом (рис. 7.11) (табл. 7.5).

Таблица 7.5. Переключатели окна Report Wizard (Step 6)

Переключатель | Действие
Save report for later use (Сохранить отчет) | Созданный отчет сохраняется на диске
Save report and modify it in the Report Designer (Сохранить и открыть в конструкторе для модификации) | Созданный отчет сохраняется на диске и открывается в конструкторе отчетов для модификации
Save and print report (Сохранить и распечатать отчет) | Созданный отчет сохраняется на диске и печатается

Рис. 7.11. Заключительный этап создания отчета

В правом нижнем углу диалогового окна находится кнопка Preview(Просмотр), позволяющая просмотреть созданный отчет. Если созданный отчет не удовлетворяет вашим требованиям, с помощью кнопки Back (Назад) вы можете вернуться к предыдущим шагам построения отчета и изменить установленные там параметры.

Введя заголовок и установив требуемую опцию, для завершения создания отчета с помощью мастера нажмите кнопку Finish (Готово). Открывается диалоговое окно Save as (Сохранить как), в котором введите имя созданного файла.

На рис. 7.12 представлен отчет, созданный с помощью мастера. Если он вас полностью устраивает, вы можете его распечатать. Но скорее всего, вам захочется в нем что-то изменить. В этом случае откройте созданный отчет в конструкторе отчетов и модифицируйте его.

Рис. 7.12. Отчет, созданный с помощью мастера

Замечание

При создании отчета с помощью мастера надписи к полям отчета создаются на основе информации, введенной в поле Caption (Надпись) конструктора таблиц Table Designer (Конструктор таблиц). Если это поле пусто, надписи совпадают с именами полей таблицы.

Просмотр подготовленного отчета

Если вы хотите посмотреть, как ваш отчет выглядит, совсем не обязательно его распечатывать. Достаточно открыть его в окне предварительного просмотра, воспользовавшись любым из следующих средств, предоставляемых в ваше распоряжение программой Visual FoxPro:

  • команда Print Preview (Просмотр печати) из меню File (Файл);
  • команда Preview (Просмотр) из меню View (Вид);
  • команда Preview (Просмотр) контекстного меню;
  • кнопка Print Preview (Предварительный просмотр) на стандартной панели инструментов Visual FoxPro;
  • кнопка Preview (Просмотр) окна проекта.

Панель инструментов, используемая для просмотра отчета

При открытии отчета в окне предварительного просмотра на экране появляется панель инструментов Print Preview (Предварительный просмотр) (рис. 7.13), позволяющая перемещаться между страницами отчета и распечатать его. Назначение кнопок этой панели инструментов приведено в табл. 7.6.

Рис. 7.13. Панель инструментов, используемая в окне предварительного просмотра отчета

Таблица 7.6. Кнопки панели инструментов Print Preview

Кнопка | Назначение
 | Открывает первую страницу отчета
 | Открывает предыдущую страницу отчета
 | Открывает диалоговое окно Go to Page (Переход на страницу) для перехода к заданной странице отчета
 | Открывает следующую страницу отчета
 | Открывает последнюю страницу отчета
 | Изменяет масштаб отображения отчета
 | Закрывает окно просмотра отчета
 | Печатает отчет

Печать отчета

Вы подготовили отчет, просмотрели его в окне предварительного просмотра и убедились, что он выглядит так, как вы хотите. Теперь можно распечатать отчет на принтере, воспользовавшись одним из предложенных ниже способов.

  • Выберите команду Print (Печать) из меню File (Файл).
  • Выберите команду Run Report (Запустить отчет) из меню Report (Отчет).
  • Выберите команду Print (Печать) контекстного меню.
  • Нажмите кнопку Print One Copy (Печать одной копии) или Run(Запустить) на стандартной панели инструментов Visual FoxPro.
  • Нажмите комбинацию клавиш <Ctrl>+<P>.

Открывается диалоговое окно Print (Печать) (рис. 7.14), позволяющее указать имя используемого для печати принтера, изменить, в случае необходимости, его настройки и установить параметры печати.

Рис. 7.14. Диалоговое окно Print

В верхней части диалогового окна Print (Печать) расположен раскрывающийся список Name (Наименование), позволяющий выбрать тип подключаемого принтера. Эта возможность особенно важна при работе в сети, когда у вас имеется несколько сетевых принтеров.

Переключатели области Print range (Печатать) позволяют указать печатаемые страницы и имеют следующее назначение:

  • All (Все) —печатаются все страницы отчета;
  • Pages (Страницы)— печатаются страниц, номера которых заданы в полях ввода from: (от) и to: (до).

Счетчик области Copies (Копии) позволяет указать количество печатаемых копий отчета.

В случае, если требуется дополнительная настройка параметров принтера, нажмите кнопку Options (Опции). В результате откроется диалоговое окно Print Options (Параметры печати) (рис. 7.15).

Рис. 7.15. Диалоговое окно Print Options

Поле Туре (Тип) области Print what (Что печатать) позволяет указать тип выводимой на печать информации. Поле File (Файл) содержит наименование и расположение печатаемого файла.

В области Options (Опции) расположены флажки, имеющие назначения, описанные в табл. 7.7.

Таблица 7.7. Назначение флажков окна Print Options

Флажок | Назначение
Line numbers (Линии нумерации) | Печатает в левой части отчета номера строк. Данный флажок используется только при печати содержимого окна команд и временного буфера Windows
Page eject before (Новая страница перед отчетом) | Выдает принтеру команду перехода на новую страницу перед печатью отчета
Page eject after (Новая страница после отчета) | Выдает принтеру команду перехода на новую страницу после печати отчета
Restore environment (Восстановить окружение) | Используется для совместимости с отчетами FoxPro версий 2.x

При нажатии кнопки Options (Параметры) диалогового окна Print Options(Параметры печати) открывается диалоговое окно Report and Label Print Options (Параметры печати отчета и этикетки) (рис. 7.16).

Рис. 7.16. Диалоговое окно Report and Label Print Options позволяет указать критерий для выбора записей

В диалоговом окне Report and Label Print Options (Параметры печати отчета и этикетки) вы можете указать критерии для выбора записей, печатаемых в отчете (табл. 7.8).

Таблица 7.8. Критерии выбора записей

Критерий | Назначение
Scope (Печатаемые записи) | Содержит раскрывающийся список Scope (Печатаемые записи), в котором указывается область печатаемых записей
For (Пока) | Вызывает построитель выражений, в котором вы создаете логическое выражение, равное True (Истина) для всех печатаемых записей отчета
While (При условии) | Вызывает построитель выражений, в котором вы создаете логическое выражение для выбора записей отчета. В отличие от критерия For, печать отчета прекращается при первом же значении выражения, равном False (Ложь)

Для настройки дополнительных параметров печати отчета можно использовать диалоговое окно Свойства (рис. 7.17), открываемое при нажатии кнопки Properties (Свойства) в окне Print (Печать) (см. рис. 7.14).

На вкладке Бумага/Качество данного диалогового окна можно задать тип подачи бумаги в принтер. Вкладка Расположение позволяет указать расположение бумаги (книжная или альбомная), порядок печати страниц. Для того чтобы изменить размер используемой при печати бумаги, качество печати, используйте диалоговое окно Дополнительные возможности, открываемое при нажатии кнопки Дополнительно.

Рис. 7.17. Диалоговое окно Свойства


Размещение полей

Для размещения в отчете поля, которое может быть полем таблицы или вычисляемым полем, выполните следующие действия:

  1. Нажмите кнопку Field (Поле) на панели инструментов Report Controls (Элементы управления отчета).
  2. Щелкните мышью в месте предполагаемого размещения поля в окне конструктора отчета.
  3. В открывшемся диалоговом окне Report Expression (Выражение отчета) (рис. 8.12) укажите для поля источник данных, формат, условие, при котором поле будет выводиться на печать.
  4. Завершив установку параметров, нажмите кнопку ОК.

Рис. 8.12. Диалоговое окно Report Expression

Диалоговое окно Report Expression (Выражение отчета) позволяет: G определить выражение, результат вычисления которого будет выводиться в данное поле;

  • задать формат отображения данных в поле;
  • указать условие печати;
  • установить положение поля в отчете.

В поле ввода Expression (Выражение) можно задать поле таблицы или выражение, размещаемое в отчете, а в поле Format (Формат) — формат данных, выводимых на печать.

Используя опции диалогового окна Calculate Field (Вычисляемое поле), открываемого при нажатии кнопки Calculations (Вычисления), можно поместить в отчет статистические значения размещенных в полях данных. Поля данного типа размещаются в отчете, как правило, в колонтитулах, полосах группы и в итоговой части отчета.

Диалоговое окно, открываемое при нажатии кнопки Print When (Условия печати), позволяет задать условия, при которых информация данного поля будет выводиться на печать.

Формирование выражения поля

Чтобы сформировать выражение для поля, размещаемого в отчете, выполните следующие действия:

  1. Дважды щелкните мышью на размещенном в отчете поле. Открывается диалоговое окно Report Expression (Выражение отчета) (см. рис. 8.12).
  2. Введите необходимое выражение в поле Expression (Выражение). Для задания выражения поля вы можете воспользоваться построителем, нажав расположенную справа от поля кнопку. При этом на экране открывается диалоговое окно Expression Builder (Построитель выражения), в поле Expression for Field on Report (Выражение для поля отчета) которого необходимо задать требуемое выражение.

Список Fields (Поля) диалогового окна Expression Builder (Построитель выражения) содержит поля помещенных в окружение отчета таблиц, список Variables (Переменные) — системные переменные Visual FoxPro. В области Functions (Функции) размещены строковые, логические, математические функции, а также функции даты и времени. Используя значения из этих списков, сформируйте необходимое выражение для создаваемого поля.

Совет

Для формирования выражения нет необходимости вводить информацию в поле Expression for Field on Report (Выражение для поля отчета) вручную, Достаточно выбирать требуемое значение из любого списка и щелчком мыши переносить его в это поле.

Рис. 8.13. Определение вычисляемого поля

При создании вычисляемых полей сформируйте выражение и проверьте его правильность с помощью кнопки Verify (Проверить). Например, вы можете отобразить в отчете вместо двух полей, содержащих город и адрес клиента, одно вычисляемое поле, которое содержит полный адрес. Выражение для этого поля имеет следующий вид (рис. 8.13):

ALLTRIM{Customer.cCity)+", "+ ALLTRIM(Customer.cAddress)

  3. Завершив формирование выражения, нажмите кнопку OK для закрытия диалогового окна Expression Builder (Построитель выражения).
  4. Закройте диалоговое окно Report Expression (Выражение отчета), также нажав кнопку ОК.

Задание формата данных

Диалоговое окно Report Expression (Выражение отчета) позволяет задать формат отображения поля при печати, допуская использование тех же функций форматирования, которые используются при форматировании полей формы. С помощью форматирования вы можете:

  • преобразовать весь символьный вывод в прописные буквы;
  • выравнивать информацию;
  • показывать в числах пробелы и десятичные запятые;
  • переводить дату из американского формата в европейский и многое другое.

Рис. 8.14. Диалоговое окно Format

Для задания формата поля нажмите кнопку вызова построителя поля Format (Формат). Откроется диалоговое окно Format (Формат) (рис. 8.14), содержащее опции и флажки, позволяющие задать тип данных поля.

Замечание

Кнопки вызова построителя всегда располагаются справа от поля ввода.

Перечень параметров настройки поля определяется выбором соответствующей опции для форматирования полей символьного, числового типов, а также полей дат. Список этих параметров представлен в табл. 8.5—8.7.

Таблица 8.5. Параметры настройки символьных полей

Параметр | Назначение
То upper case (Верхний регистр) | Символы преобразуются в прописные буквы
SET DATE format (В виде даты) | Данные отображаются в виде даты в формате, установленном командой SET DATE
Ignore input mask (Игнорировать маску ввода) | Отображает данные на экране в соответствии с маской ввода
British date (Европейская дата) | Данные отображаются в виде даты в европейском формате
Left justify (Сдвинуть влево) | Данные выравниваются по левому краю поля
Right justify (Сдвинуть вправо) | Данные выравниваются по правому краю поля
Center justify (По центру) | Данные в поле центрируются

Таблица 8.6. Параметры настройки числовых полей

Параметр | Назначение
Left justify (Сдвинуть влево) | Число выравнивается по левому краю поля
Blank if zero (Пусто, если ноль) | Ноль не печатается
(Negative) (Отрицательное) | Отрицательные числа заключаются в круглые скобки
SET DATE format (В виде даты) | Данные отображаются в виде даты в формате, установленном командой SET DATE
British date (Европейская дата) | Данные отображаются в виде даты в европейском формате
CR if positive (CR, если положительно) | Если число положительное, после него ставится CR (кредит)
DB if negative (DB, если отрицательно) | Если число отрицательное, после него ставится DB (дебет)
Leading zeros (Незначащие нули) | Печатаются все ведущие нули
Currency (Денежная единица) | Данные отображаются в формате денежной единицы, который задается командой SET CURRENCY
Scientific (Экспоненциально) | Отображает число в экспоненциальном формате

Таблица 8.7. Параметры настройки полей типа "дата"

Параметр | Назначение
SET DATE format (В виде даты) | Дата отображается в формате, установленном командой SET DATE
British date (Европейская дата) | Дата отображается в европейском формате

Задание условий печати

Для задания условий печати данных отчета используется диалоговое окно Print When (Условие печати) (рис. 8.15), открываемое из диалогового окна Report Expression (Выражение отчета) нажатием кнопки Print When (Условие печати). С помощью параметров этого окна вы можете удалить из отчета пустые строки, определить условия печати значений полей, при переходе на следующую страницу или при изменении выражения группы и т. п.

Рис. 8.15. Диалоговое окно Print When

Для подавления печати повторяющихся значений полей используется значение No (Нет) переключателя Print repeated values (Печатать один раз на полосу). При установленном значении Yes (Да) печатаются все значения поля.

Область Also print (Печатать) содержит флажки (табл. 8.8).

Таблица 8.8. Флажки области Also print

Флажок | Назначение
In first whole band of new page/column (На первой целой полосе новой страницы/ колонки) | Поле печатается в первой полосе новой страницы или колонки
When this group changes (При изменении группы) | Поле печатается при изменении группы, выбранной в списке групп
When detail overflows to new page/column (При переходе на новую страницу/колонку) | Поле печатается при переходе полосы Detail (Детали) на новую страницу

При установке флажка Remove line if blank (Удалять пустые строки) пустые строки удаляются из отчета.

В поле Print only when expression is true (Печатать, если истинно), используя построитель выражения, можно задать выражение, вычисляемое перед печатью данного поля. Если значение выражения ложно, то значение поля печататься не будет.

Расположение поля в полосе

Диалоговое окно Report Expression (Выражение отчета) (см. рис. 8.12) содержит переключатель Field position (Положение поля), позволяющий управлять расположением поля в полосе (табл. 8.9).

Таблица 8.9. Опции диалогового окна Report Expression

Опция | Характеристика
Float (Плавающее) | Позиция поля в отчете может изменяться при изменении размеров окружающих его полей
Fix relative to top of band (Постоянное относительно верхней полосы) | Поле сохраняет постоянную позицию относительно верхней границы полосы
Fix relative to bottom of band (Постоянное относительно нижней полосы) | Поле сохраняет постоянную позицию относительно нижней границы полосы

Размещение итогового поля

В колонтитулах, полосах группы, в итоговой части отчета, а также в полосе Detail (Детали) можно размещать поля, содержащие статистические значения полей отчета.

Замечание

Итоговые поля, размещаемые в полосе Detail (Детали), предназначены для вывода значений нарастающих итогов.

Для определения поля в качестве итогового выполните следующие действия:

  1. Откройте диалоговое окно Report Expression (Выражение отчета), дважды щелкнув мышью на поле.
  2. Определите выражение для поля, введя необходимую информацию в поле Expression (Выражение).
  3. Нажмите кнопку Calculations (Вычисления). При этом на экране открывается диалоговое окно Calculate Field (Вычисление поля) (рис. 8.16), в котором может быть выбрана математическая операция над значением выражения, определенного для данного поля.

Рис. 8.16. Диалоговое окно Calculate Field

Диалоговое окно Calculate Field (Вычисляемое поле) содержит группу переключателей Calculate, описанную в табл. 8.10.

Таблица 8.10. Опции диалогового окна Calculate Field

Переключатель | Назначение
Nothing (Ничего) | Над полем не производится вычислений
Count (Сосчитать) | Вычисляется количество значений поля (сами значения поля не используются)
Sum (Сумма) | Вычисляется итоговая сумма значений поля
Average (Среднее арифметическое) | Вычисляется среднее арифметическое значений поля
Lowest (Наименьшее) | Отображается наименьшее значение поля
Highest (Наибольшее) | Отображается наибольшее значение поля
Standard deviation (Квадратный корень из дисперсии) | Возвращается квадратный корень из дисперсии
Variance (Отклонение от среднего) | Возвращается статистическая величина отклонения отдельных значений поля от среднего в группе
  4. Установите требуемый переключатель и нажмите кнопку ОК.

Замечание

В верхней части диалогового окна находится раскрывающийся список Reset (Сброс), используя который, вы можете определить момент обнуления итогового поля.

  5. Нажмите кнопку ОК для закрытия диалогового окна Report Expression (Выражение отчета).


Создание простого отчета

Мы рассмотрели основные действия, необходимые для создания простого отчета с помощью конструктора отчетов. Теперь, подводя итоги, рассмотрим последовательность действий по созданию отчета для таблицы customer, содержащей список клиентов.

  1. Откройте проект Sales.
  2. Откройте базу данных проекта. Для этого на вкладке Data (Данные) установите курсор на названии базы данных и нажмите кнопку Open (Открыть) окна проекта. При этом на стандартной панели инструментов в списке Databases (Базы данных) появляется название открытой базы данных.
  3. Перейдите на вкладку Documents (Документы), выберите группу Reports (Отчеты) и нажмите кнопку New (Новый).
  4. В открывшемся диалоговом окне New Report (Новый отчет) выберите опцию New Report (Новый отчет). Открывается окно конструктора, предназначенное для создания нового отчета.
  5. Для задания среды окружения отчета откройте диалоговое окно Data Environment (Среда окружения), выбрав команду Environment (Окружение) в меню View (Вид) или Data Environment (Среда окружения) контекстного меню.
  6. Для добавления таблицы в окружение отчета в меню Data Environment (Среда окружения) выберите команду Add (Добавить).
  7. В открывшемся диалоговом окне Add Table or View (Добавить таблицу или представление) выберите таблицу customer и нажмите кнопку ОК. В окне Data Environment (Среда окружения) будет отображена выбранная таблица.
  8. Откройте окно свойств таблицы. Для этого установите курсор на ее названии, нажмите правую кнопку мыши и выберите из контекстного меню команду Properties (Свойства).
  9. Выделите свойство order (Порядок). Для упорядочения данных в отчете по кодам клиентов в поле коррекции свойства нажмите кнопку раскрытия списка и из списка индексов таблицы выберите icdcustomer.
  10. Закройте окно Data Environment (Среда окружения).
  11. Для размещения полей таблицы в отчете воспользуйтесь командой Quick Report (Быстрый отчет) в меню Report (Отчет). Открывается диалоговое окно Quick Report (Быстрый отчет).
  12. Выберите вариант размещения полей по столбцам и нажмите кнопку Fields (Поля).
  13. В диалоговом окне Field Picker (Выбор поля) выберите поля, помещаемые в отчет, и перенесите их в список Selected fields (Выбранные поля), используя кнопку Move (Перенести). Нажмите кнопку ОК.
  14. Возвратившись в диалоговое окно Quick Report (Быстрый отчет), нажмите кнопку ОК для завершения процедуры размещения полей в отчете.
  15. Используя кнопку Label (Метка) панели инструментов Report Controls (Элементы управления отчета), скорректируйте заголовки полей.
  16. Для того чтобы придать отчету законченный вид, добавьте область заголовка отчета, выбрав в меню Report (Отчет) команду Title/Summary (Титул/Итоги).
  17. В открывшемся диалоговом окне Title/Summary (Титул/Итоги) установите флажок Title Band (Полоса титула) и нажмите ОК. В отчете появляется полоса Title (Титул). Разместите в ней текст заголовка отчета с помощью кнопки Label (Метка) панели инструментов Report Controls (Элементы управления отчета).

Рис. 8.11. Список клиентов

  18. Просмотрите внешний вид отчета (рис. 8.11), воспользовавшись командой контекстного меню Preview (Просмотр).
  19. Сохраните отчет.


Добавление в отчет областей заголовка и итогов

Как правило, все отчеты содержат заголовок и итоговую часть отчета. Для их формирования необходимо добавить в отчет полосы Summary (Итоги) и Title (Титул), используя команду Title/Summary (Титул/Итоги) из меню Report (Отчет). В результате выполнения этой команды открывается диалоговое окно Title/Summary (Титул/Итоги), содержащее флажки, приведенные в табл. 8.10.

Таблица 8.4. Кнопки панели инструментов Report Controls

Флажок | Назначение
Title band (Полоса титула) | Добавляет в отчет полосу Title (Титул) для размещения заголовка в отчете
New page (Новая страница) области Report title (Титул отчета) | Размещает заголовок отчета на отдельной странице
Summary band (Полоса итогов) | Добавляет в отчет полосу Summary (Итоги) для размещения в отчете итоговой части
New page (Новая страница) области Report summary (Итоги отчета) | Размещает итоговую часть отчета на отдельной странице

Установите необходимые флажки и нажмите ОК. В отчете появятся указанные вами полосы. В полосе Title (Титул) разместите объекты заголовка отчета, в качестве которых может выступать текст, поля и рисунки.

Рис. 8.10. Диалоговое окно Title/Summary

В полосе Summary (Итоги) могут размещаться итоговые значения полей отчета, а также объекты оформления отчета, такие как текст и рисунки.


Размещение в отчете текстовой информации

Размещаемый в отчете текст является объектом, который можно выделять, перемещать, изменять его размеры, используя для этого маркеры выделения, сохранять во временном буфере Windows, копировать из буфера или удалять.

Для ввода или редактирования текста в отчете выполните следующие действия:

  1. Нажмите кнопку Label (Метка) на панели инструментов Report Controls (Элементы управления отчета).
  2. Щелкните мышью в том месте окна конструктора отчета, где необходимо разместить или исправить текст.
  3. Внесите необходимые добавления или изменения.
  4. Нажмите кнопку Select Objects (Выбор объектов) на панели инструментов Report Controls (Элементы управления отчета).

Совет

Текст может состоять из нескольких строк. Для переноса части текста на новую строку используйте клавишу <Enter>.

Для размещенного в отчете текста можно изменять параметры используемого шрифта и цвет, выполнив следующие действия:

  1. Используя мышь, выделите текстовый объект.
  2. В меню Format (Формат) выберите команду Font (Шрифт).
  3. В открывшемся диалоговом окне Шрифт установите начертание, стиль, цвет и размер символов выделенного текста. Вид выбранного шрифта просмотрите в области Образец этого же диалогового окна.
  4. Завершив установку параметров, нажмите кнопку ОК. Если дважды щелкнуть на текстовом объекте, откроется диалоговое окно Text (Текст) (рис. 8.9), в котором можно определить условия печати текста, его расположение в полосе, а также разместить комментарии.

Рис. 8.9. Диалоговое окно Text


Размещение объектов в отчете

Любой отчет состоит из объектов: пояснительного текста, полей отчета, разделительных линий и рамок.


Установка среды окружения отчета

Для отчета, созданного мастером или с помощью команды Quick Report (Быстрый отчет), среда окружения отчета уже определена. Разработчику, создающему отчет с помощью конструктора отчетов, среду окружения необходимо сформировать, выполнив для этого следующие действия:

  1. Разместить в окружении используемые в отчете таблицы.
  2. Установить для таблиц необходимые индексы.
  3. Установить отношения между таблицами.

Вся относящаяся к среде окружения информация хранится в файле описания отчета.

Рис. 8.7. Диалоговое окно Data Environment Report Designer

Для формирования среды окружения отчета используется окно Data Environment Report Designer (Среда окружения Конструктор отчета) (рис. 8.7), для открытия которого можно воспользоваться одним из следующих способов.

  • В меню View (Вид) выбрать команду Data Environment (Среда окружения).
  • Выбрать пункт Data Environment (Среда окружения) контекстного меню.
  • В среде окружения необходимо разместить все таблицы, используемые в отчете. Для добавления таблицы в окружение используется команда Add (Добавить) контекстного меню или команда Add (Добавить) из меню Data Environment (Среда окружения). Связанные таблицы базы данных переносятся в Environment Report Designer (Среда окружения Конструктор отчета) с сохранением связей, установленных между ними.

После размещения таблиц в среде окружения отчета вам необходимо упорядочить данные, находящиеся в таблицах. Для этого выполните следующие действия:

  1. Выделите таблицу, в которой хотите упорядочить данные.
  2. Откройте окно свойств таблицы. Для этого установите на нее курсор, нажмите правую кнопку мыши и выберите в появившемся контекстном меню команду Properties (Свойства).
  3. Выделите свойство order (Порядок) (рис. 8.8).

Рис. 8.8. Свойство Order используется для упорядочения записей в таблице

  4. В поле коррекции свойства нажмите кнопку раскрытия списка. Из списка индексов таблицы выберите тот, по которому хотите упорядочить данные в отчете.

Если в отчете используется несколько связанных таблиц, то вам необходимо убедиться, что связи установлены так, как требуется для создания правильного отчета. Для этого выполните следующие действия:

  1. Выделите линию, соединяющую таблицы. При этом в окне свойств Properties (Свойства) будут отображаться свойства, характеризующие установленную между таблицами связь.
  2. Проверьте, какая из таблиц является родительской, а какая дочерней по отношению к ней. Для этого просмотрите свойства chiidAlias (Дочерняя таблица) и ParentAiias (Родительская таблица).
  3. Посмотрите выражение, по которому связаны таблицы. Для этого воспользуйтесь свойством ReiationalExpr (Выражение отношения).

После размещения в окне Data Environment (Среда окружения) всех используемых в отчете таблиц, закройте его, после чего Visual FoxPro сохранит созданную вами среду окружения.


Использование команды Quick Report для размещения полей

В процессе создания отчета выполняются все или часть из приведенных ниже процедур:

  • определение среды окружения;
  • размещение объектов в отчете: текста, полей, линий, прямоугольников и рисунков;
  • группирование данных в отчете;
  • сохранение отчета;
  • просмотр созданного отчета в окне предварительного просмотра;
  • печать отчета.

Ускорить размещение данных в отчете можно с помощью команды Quick Report (Быстрый отчет) из меню Report (Отчет). Отчет, получаемый в результате выполнения этой команды г называется быстрым или стандартным отчетом. Иными словами, Quick Report (Быстрый отчет) — это средство конструктора отчетов, которое автоматически помещает выбранные поля и надписи к ним в окно конструктора отчета. После этого вы можете модифицировать полученный отчет, изменив текст надписей, порядок расположения полей, добавить в отчет группирование данных, заголовок и т. д.

Для создания отчета с использованием команды Quick Report (Быстрый отчет) необходимо выполнить следующие действия:

  1. Откройте базу данных проекта. Для этого на вкладке Data (Данные) установите курсор на ее название и нажмите кнопку Open (Открыть) окна проекта. При этом на стандартной панели инструментов в списке Databases (Базы данных) появится название открытой базы данных.
  2. Откройте любым удобным для вас способом окно конструктора отчетов.
  3. Находясь в окне конструктора отчета, выберите в меню Report (Отчет) команду Quick Report (Быстрый отчет).
  4. В открывшемся диалоговом окне Open (Открыть) содержится список всех таблиц открытой в проекте базы данных (рис. 8.2). Выберите таблицу, для которой создается стандартный отчет, и нажмите кнопку ОК.

Замечание

Если перед созданием отчета вы не откроете базу данных, то на экране появится диалоговое окно Open (Открыть), отличающееся от представленного на рис. 8.2. Оно будет содержать не список таблиц базы данных, а окно, открывающееся в программе FoxPro для поиска на диске необходимого файла.

Рис. 8.2. Диалоговое окно Open

  5. После выбора таблицы открывается диалоговое окно Quick Report (Быстрый отчет) (рис. 8.3), в котором предлагаются варианты расположения полей в отчете — в столбец или в строку (две кнопки). Выберите один из предложенных вариантов:
  • при нажатии левой кнопки поля будут размещены в полосе Detail (Детали) слева направо по всей странице;
  • если вы нажмете правую кнопку, поля будут размещены в полосе Detail (Детали) друг под другом.

Диалоговое окно Quick Report (Быстрый отчет) содержит флажки, описанные в табл. 8.3.

Таблица 8.3. Флажки диалогового окна Quick Report

Флажок | Назначение
Titles (Заголовки) | При установке флажка в отчет помещаются поля и надписи к ним
Add Alias (Добавить псевдоним) | Флажок определяет, указывать ли псевдоним таблицы в именах полей в окне конструктора отчета
Add Table to Data Environment (Добавить таблицу в среду окружения) | При установке флажка используемая в отчете таблица помещается в среду окружения

Рис. 8.3. Диалоговое окно Quick Report

  6. Если вы хотите разместить в отчете все поля исходной таблицы, то этот шаг пропустите и сразу нажмите кнопку ОК, чтобы закрыть диалоговое окно Quick Report (Быстрый отчет). Для выбора полей, размещаемых в отчете, нажмите кнопку Fields (Поля). Откроется диалоговое окно Field Picker (Выбор поля) (рис. 8.4). Выберите поля, которые вы собираетесь поместить в отчет, используя для этого кнопку Move (Переместить). Если в отчет нужно поместить все поля, воспользуйтесь кнопкой All (Все).

Рис. 8.4. Диалоговое окно Field Picker

Совет

Если вам нужно разместить в отчете все поля за исключением нескольких, сначала выберите все поля, а затем удалите лишние, воспользовавшись кнопкой Remove (Удалить).

  7. Завершив выбор полей, нажмите кнопку ОК для закрытия диалогового окна Field Picker (Выбор поля). Нажмите также кнопку ОК в окне Quick Report (Быстрый отчет). Теперь отчет содержит все необходимые поля. Кроме того, в полосе Page Footer (Нижний колонтитул) расположено поле с функцией DATE () и поле с системной переменной _PAGENO, указывающие дату и текущий номер страницы отчета соответственно.

Фрагмент отчета, сформированного с помощью команды Quick Report (Быстрый отчет), представлен на рис. 8.5.

Если текст и наименования полей в отчете представлены некорректно, необходимо изменить шрифт этих объектов. Для этого выполните следующие действия:

  1. 1. Выделите все объекты отчета, воспользовавшись командой Select All (Выбрать все) из меню Edit (Правка).
  2. 2. Откройте диалоговое окно Шрифт (рис. 8.6). Для этого в меню Format (Формат) выберите команду Font (Шрифт).

Рис. 8.5. Фрагмент отчета, созданного с помощью команды Quick Report

Рис. 8.6. Диалоговое окно Шрифт

  3. Используя список Шрифт диалогового окна Выбор шрифта, установите необходимый шрифт.
  4. Задайте начертание, стиль, цвет и размер символов выделенных объектов.
  5. Завершив установку параметров, нажмите кнопку ОК для закрытия диалогового окна.
  6. Щелкните мышью в любом месте отчета вне выделенной области.


Типы полос окна конструктора отчета

Вся рабочая область конструктора отчетов по умолчанию разделена на три полосы, ограничиваемые разделительными строками (см. рис. 8.1). Наименование полосы отображается на разделительной строке, находящейся непосредственно под этой полосой. При использовании в отчете группирования данных, добавлении в него титульной страницы и итоговых данных появляются дополнительные полосы. Каждая полоса может содержать элементы управления отчета, такие как текст, табличные и вычисляемые поля, линии, прямоугольники, рисунки.

Типы возможных в отчете полос приведены в табл. 8.2. Основное назначение полосы — определять, когда и где будут печататься размещенные в полосе объекты.

Таблица 8.2. Типы полос отчета

Полоса | Назначение
Title (Титул) | В этой полосе размещается информация, появляющаяся перед основным отчетом и называемая титульной. Это может быть имя отчета, сопроводительное письмо или любые данные, которые необходимо поместить на первой странице отчета
Page Header (Верхний колонтитул) | Эта полоса в отчете называется верхним колонтитулом. Данные, помещенные в полосу, печатаются в начале каждой страницы. Примерами элементов управления могут быть название отчета, текущая дата, номер страницы и т. д.
Group Header (Группа сверху) | В этой полосе печатается информация, используемая при группировке. При группировке данных группа может иметь верхние полосы, печатаемые до нее. Они помогают идентифицировать информацию, содержащуюся на каждом уровне группировки
Detail (Детали) | Эта полоса содержит данные полей из таблицы или результат вычислений над ними
Group Footer (Группа снизу) | В полосе размещается итоговая информация по группе
Page Footer (Нижний колонтитул) | В нижнем колонтитуле печатается название отчета, дата, номер страницы и итоговые значения по данным текущей страницы
Summary (Итоги) | В итоговой части отчета содержится информация, появляющаяся один раз после основного отчета и содержащая итоговые значения или заключительный текст


Создание многоколоночного отчета

Мы рассмотрели создание отчета для рассылки информации потенциальным клиентам. Используя многоколоночный отчет, подготовим данные для печати адресов, наклеиваемых на конверты для отправки клиентам.

  1. Откройте конструктор отчета.
  2. Добавьте в среду окружения отчета таблицу customer, содержащую адреса клиентов.
  3. Расположите в отчете требуемые для формирования адреса поля и обратный адрес. Отчет будет иметь вид, показанный на рис. 8.31.

Рис. 8.31. Многоколоночный отчет

Рис. 8.32. Многоколоночный отчет в окне предварительного просмотра

  4. В меню File (Файл) выберите команду Page Setup (Разметка страницы).
  5. В поле Number (Число) открывшегося диалогового окна Page Setup (Разметка страницы) введите число 2, определяющее количество колонок в отчете, и нажмите кнопку ОК.
  6. Просмотрите внешний вид отчета в окне предварительного просмотра с помощью команды контекстного меню Preview (Предварительный просмотр) (рис. 8.32).
  7. Сохраните отчет.


Разметка страницы отчета

Для разметки страницы отчета используется диалоговое окно Page Setup (Разметка страницы) (рис. 8.30), открываемое при выборе в меню File (Файл) команды Page Setup (Разметка страницы). Оно позволяет определить количество колонок в отчете, порядок вывода записей, ширину левого поля отчета, ширину колонок и расстояние между ними, единицу измерения координат отчета и выбор режима печати.

В области Columns (Колонки) этого диалогового окна определяются размеры колонок и их количество на странице (табл. 8.18).

Таблица 8.18. Назначение полей области Columns диалогового окна Page Setup

Поле | Назначение
Number (Число) | Определяет число колонок на странице
Width (Ширина) | Определяет ширину колонок в сантиметрах или дюймах
Spacing (Расстояние) | Определяет расстояние между колонками

Рис. 8.30. Диалоговое окно Page Setup

Опции переключателя Print area (Область печати) описаны в табл. 8.19.

Таблица 8.19. Назначение опций переключателя Print area

Опция | Назначение
Printable page (Печатаемая страница) | Устанавливает режим печати с полями страницы, определяемыми в соответствии с требованиями текущего драйвера печати
Whole page (Страница в целом) | Устанавливает режим печати с минимальными полями

Для задания порядка вывода записей в многоколоночных отчетах используются две кнопки области Print order (Порядок печати). Расположенный ниже счетчик Left margin (Левая граница) задает ширину левого поля отчета.


Использование в отчете переменных

В отчете вы можете использовать переменные из программы, доступные в момент вызова отчета, а также переменные, определенные в конструкторе отчетов и используемые для хранения результатов вычислений, выполняемых во время печати отчета.

Переменные отчета определяются в диалоговом окне Report Variables (Переменные отчета) (рис. 8.29), для открытия которого используется команда Variables (Переменные) из меню Report (Отчет). Кнопки Insert (Вставить) и Delete (Удалить) позволяют добавлять в отчет новые переменные и удалять существующие.

Рис. 8.29. Диалоговое окно Report Variables

Диалоговое окно Report Variables (Переменные отчета) содержит три поля, описанных в табл. 8.16.

Таблица 8.16. Поля диалогового окна Report Variables

Наименование поля | Назначение
Variables (Переменные) | Содержит наименование переменной, которое может включать в себя только буквы, цифры и символ подчеркивания и не может начинаться с цифры
Value to store (Хранимое значение) | Значение переменной
Initial value (Начальное значение) | Начальное значение переменной

Замечание

Для формирования значений переменных, задаваемых в полях Value to store (Хранимое значение) и Initial value (Начальное значение), можно использовать диалоговое окно Expression Builder (Построитель выражения), открываемое при нажатии расположенных с правой стороны поля кнопок.

При установке флажка Release after report (Освободить после отчета) после завершения печати отчета переменная очищается из памяти.

Список Reset at (Сброс) содержит три значения, указывающие момент сброса переменной в начальное значение: в конце отчета, в конце страницы или в конце группы.

Группа переключалей Calculate, расположенные в диалоговом окне Report Variables (Переменные отчета), позволяет задать выражения, выполняемые над переменной вычисления (табл. 9.17).

Таблица 8.17. Назначение группы переключалей Calculate диалогового окна Report Variables

Переключатель | Назначение
Nothing (Ничего) | Над переменной вычисления не производятся
Count (Количество) | Вычисляется количество появлений переменной в группе, на странице, в колонке или отчете (значение переменной не используется)
Sum (Сумма) | Вычисляется итоговая сумма значений переменной
Average (Среднее) | Вычисляется среднее арифметическое значений переменной в группе, на странице, в колонке или отчете
Lowest (Минимальное) | Отображается наименьшее значение переменной в группе, на странице, в колонке или отчете
Highest (Максимальное) | Отображается наибольшее значение переменной в группе, на странице, в колонке или отчете
Std, deviation (Станд. отклонение) | Возвращается квадратный корень из дисперсии значений переменной в группе, на странице, в колонке или отчете
Variance (Дисперсия) | Возвращается статистическая величина отклонения отдельных значений переменной от среднего в группе, на странице, в колонке или отчете

При использовании переменных в отчете необходимо иметь в виду следующее.

  • Переменные в отчете могут использоваться в качестве полей или в выражениях, определяющих поля. Все созданные в диалоговом окне Report Variables (Переменные отчета) переменные отображаются в списке переменных в окне построителя выражения.
  • При запуске отчета переменной присваивается начальное значение, а затем в процессе формирования отчета ее значение изменяется в соответствии с выбранным выражением. При заданных для переменной условиях она принимает свое начальное значение.
  • Для определения начального или вычисляемого значения переменной могут использоваться другие переменные, но значения этих переменных должны вычисляться до момента их использования переменной.


Использование группировки в отчете

Модифицируем отчет, созданный в предыдущем примере. Добавим в него группировку по клиентам и разместим в полосах группы наименование клиента и итоговую сумму приобретенных им товаров.

  1. Откройте отчет, созданный в предыдущем примере.
  2. Для группировки данных в отчете по полю icdCustomer в меню Report (Отчет) выберите команду Data Grouping (Группировка данных).
  3. В поле Group expressions (Выражение группировки) открывшегося диалогового окна Data Grouping (Группировка данных) нажмите кнопку вызова построителя выражения.
  4. В окне построителя сформируйте выражение группировки. Для этого в списке Fields (Поля) дважды щелкните мышью на поле icdCustomer таблицы Ordsalem.
  5. Закройте окно построителя выражения. В поле Group expressions (Выражение группировки) диалогового окна Data Grouping (Группировка данных) появилось выбранное нами поле icdCustomer.
  6. Закройте диалоговое окно, нажав кнопку ОК.
  7. В отчет добавились полосы группировки. Расширьте полосу Group Header (Группа сверху). Для этого установите курсор в нижнюю часть полосы и, когда он примет вид двунаправленной стрелки, переместите вниз.
  8. Перенесите в образовавшуюся область поле с наименованием клиента, а также его заголовок.

Рис. 8.27. Группировка данных в отчете по коду клиента

Рис. 8.28. Просмотр отчета с группировкой данных

  9. Расширьте полосу Group Footer (Группа снизу) и создайте в ней итоговое поле, которое будет показывать сумму продаж по каждому клиенту. При формировании поля укажите суммирование по следующему выражению: OrdSaled.nQuant * OrdSaled.nUnitPrice Отчет в окне конструктора отчетов будет иметь вид, представленный на рис. 8.27.
  10. Просмотрите внешний вид отчета в окне предварительного просмотра (рис. 8.28).
  11. Сохраните созданный отчет.


Группировка данных в отчете

Посмотрите на отчет, представленный на рис. 8.25. Видно, что клиент может приобрести разные товары. Сам собой возникает вопрос: а нельзя ли объединить данные в отчете таким образом, чтобы иметь краткую информацию о том, какие товары приобрел тот или иной клиент?

Для группировки данных в отчете используется команда Data Grouping Группировка данных) меню Report (Отчет) и команда Data Grouping

Группировка данных) контекстного меню, которые позволяют создавать до 20 уровней вложенности групп и выполнять над ними следующие операции:

  • печатать текст, идентифицирующий конкретные группы;
  • печатать каждую группу отчета с новой страницы;
  • при печати каждой группы начинать новую нумерацию страниц.

Рис. 8.26. Диалоговое окно Data Grouping

При выполнении данных команд открывается диалоговое окно Data Grouping (Группировка данных) (рис. 8.26), содержащее список созданных в отчете групп. Используя расположенные в окне кнопки, можно редактировать или удалять имеющиеся в отчете группы, добавлять новые.

Для формирования выражения, по которому будут группироваться данные в отчете, можно использовать построитель выражения или ввести требуемое выражение непосредственно в поле Group expressions (Выражение группировки).

В диалоговом окне Data Grouping (Группировка данных) вы можете установить следующие параметры группировки данных (табл. 8.15).

Таблица 8.15. Параметры группировки данных окна Data Grouping

Флажок | Назначение
Start group on new column (Каждая группа в новой колонке) | Если флажок установлен, то при каждом изменении группы происходит формирование новой колонки
Start each group on a new page (Каждая группа на новой странице) | При установке флажка каждая группа отчета размещается на новой странице
Reset page number to 1 for each group (Сброс нумерации страниц для каждой группы) | При установке флажка каждая группа отчета размещается на новой странице. Нумерация страниц группы начинается с 1
Reprint group header on each page (Верхняя полоса группы для каждой страницы) | Если группа занимает несколько страниц, то при установке флажка верхняя полоса группы размещается после верхнего колонтитула страницы
Start group on new page when less than (Печатать группу с новой страницы, если) | Если под заголовком группы остается расстояние меньше указанного в данном поле, то информация группы будет перенесена на новую страницу

С помощью кнопки Insert (Вставить) диалогового окна Data Grouping (Группировка данных) можно добавить в отчет новую группу. Для удаления полосы группы используется кнопка Delete (Удалить).


Создание табличного отчета

Создадим в конструкторе отчетов табличный отчет, содержащий список заказов. При создании отчета будем использовать три таблицы. Таблица Ordsaiem содержит сведения о заказе на товары — это главная таблица, на основании которой строится отчет. Остальные две таблицы являются вспомогательными. Таблица ordsaied содержит сведения о товарах, входящих в заданный заказ (количество купленных товаров и цена товара), а таблица Customer — информацию о клиентах. Приступим к созданию отчета.

  1. Откройте новое окно в конструкторе отчетов.
  2. В среду окружения отчета Data Environment (Среда окружения) добавьте поочередно таблицы Ordsaiem, customer и ordsaied. При создании связей между таблицами для данного отчета необходимо учитывать следующее:
  • таблица Ordsaiem является родительской по отношению к таблицам Ordsaied и Customer;
  • связь между таблицами Ordsaiem и customer осуществляется по коду клиента;
  • связь между таблицами Ordsaiem и ordsaied осуществляется по коду заказа;
  • данные в таблице Ordsaiem должны быть упорядочены по коду заказа, в таблице customer — по коду клиента, в таблице ordsaied — no коду заказа.

Установив связи между таблицами и упорядочив данные (рис. 8.23), закройте окно Data Environment (Среда окружения).

  3. Используя команду Quick Report (Быстрый отчет) из меню Report (Отчет), разместите в отчете следующие поля:
  • ccompany с наименованием компании из таблицы Customer;
  • dDoc, содержащее дату продажи из таблицы Ordsaiem;
  • nQuant с количеством проданного товара из таблицы Ordsaied;
  • nUnitprice с ценой товара из таблицы Ordsaied.
  4. Создайте вычисляемое поле, которое содержит выражение для подсчета стоимости проданного товара: OrdSaled.nQuant * OrdSaled.nUnitPrice
  5. Добавьте в полосу Page Header (Верхний колонтитул) заголовки для размещенных полей.
  6. Добавьте в отчет заголовок и итоговую часть отчета, выполнив команду Title/Summary (Титул/Итоги) из меню Report (Отчет).
  7. В заголовке отчета введите Список заказов.

Рис. 8.23. Диалоговое окно Data Environment

Рис. 8.24. Созданный отчет в окне конструктора отчетов

  8. В итоговой части отчета создайте поле, которое вычислит стоимость всех заказов, просуммировав стоимость проданного товара.
  9. Отчет в окне конструктора отчетов будет иметь вид, представленный на рис. 8.24. Просмотрите внешний вид отчета в окне предварительного просмотра (рис. 8.25).
  10. Сохраните отчет.

Рис. 8.25. Просмотр табличного отчета


Создание отчета в свободной форме

Мы рассмотрели основные этапы работ для создания отчета в конструкторе отчетов. Приступим к созданию отчета в свободной форме для рассылки прайс-листов потенциальным клиентам.

  1. Откройте проект sales.
  2. Откройте базу данных проекта. Для этого на вкладке Data (Данные) установите курсор на ее название и нажмите кнопку Open (Открыть) окна проекта. При этом на стандартной панели инструментов в списке Databases (Базы данных) появляется название открытой базы данных.
  3. Перейдите на вкладку Documents (Документы), выберите группу Reports (Отчеты) и нажмите кнопку New (Новый). В открывшемся диалоговом окне New Report (Новый отчет) выберите опцию New Report (Новый отчет). Открывается окно конструктора отчетов.
  4. Откройте среду окружения отчета Data Environment (Среда окружения), выполнив команду Environment (Окружение) из меню View (Вид) или выбрав команду Data Environment (Среда окружения) контекстного меню.
  5. Для размещения таблицы в среде окружения в меню Data Environment (Среда окружения) выберите команду Add (Добавить). Затем в открывшемся диалоговом окне Add Table or View (Добавить таблицу или представление данных) выберите таблицу customer и нажмите кнопку ОК. Закройте среду окружения.
  6. Расположите в отчете поля, воспользовавшись командой Quick Report (Быстрый отчет) из меню Report (Отчет). При создании быстрого отчета выберите размещение полей по строкам и поля с наименованием предприятия, индекса и страны. Остальную информацию вы сформируете с помощью вычисляемых полей.
  7. Добавьте в полосу Detail (Детали) отчета вычисляемое поле для отображения имени представителя клиента, содержащее следующее выражение:

    ALLTRIM(Customer.cFirstName) + " "+ ALLTRIM(Customer.cSecondName)

  8. Добавьте в отчет вычисляемое поле для вывода адреса, которое содержит следующее выражение:

    ALLTRIM{Customer.cCity)+ " " +ALLTRIM(Customer.cAddress)

  9. Разместите в отчете текст и поля, как показано на рис. 8.21.
  10. Просмотрите внешний вид отчета с помощью команды контекстного меню Preview (Просмотр). Экран будет иметь вид, представленный на рис. 8.22.
  11. Сохраните отчет.

Рис. 8.21. Отчет в свободной форме Edit

Рис. 8.22. Отчет в свободной форме Preview


Размещение в отчете рисунков

В отчеты, создаваемые в программе Visual FoxPro, можно включать растровые рисунки, которые улучшат внешний вид отчета. В письмах, рассылаемых клиентам, можно, например, поместить фирменный знак или эмблему фирмы. Для подготовки изображения можно использовать графические редакторы или сканер для считывания изображения.

Для размещения в отчете рисунка используется кнопка Picture/ActiveX Bound Control (Изображение/ActivX объект) панели инструментов Report Controls (Элементы управления отчета) конструктора отчетов. Нажмите данную кнопку, а затем установите курсор в один из углов области, в которой должен находиться рисунок, и переместите курсор в противоположный угол до образования рамки необходимого размера. При этом открывается диалоговое окно Report Picture (Изображение отчета) (рис. 8.20), в котором вы определяете источник данных рисунка и его параметры. Источником данных может быть файл, содержащий рисунок, или поле таблицы типа General. Для указания источника данных используются опции области Picture from (Изображение из) диалогового окна.

Рис. 8.20. Диалоговое окно Report Picture

При размещении в отчете графического изображения в диалоговом окне Report Picture (Изображение отчета) установите опцию File (Файл). Затем нажмите кнопку выбора файла, расположенную с правой стороны поля. В открывшемся диалоговом окне Open (Открыть) выберите требуемый графический файл. Если вы знаете полное имя файла, то можете ввести его непосредственно в поле ввода File (Файл) без использования диалогового окна Open (Открыть).

В том случае, если вы хотите печатать в отчете изображения, размещенные в поле таблицы (в Visual FoxPro для хранения графических изображений используются поля типа General), в диалоговом окне Report Picture (Изображение отчета) установите опцию Field (Поле). Затем нажмите расположенную с правой стороны поля кнопку и в открывшемся диалоговом окне Choose Field/Variable (Выбор поля/переменной) выберите необходимое поле таблицы.

Если размер выделенной для размещения изображения области и размер самого изображения не совпадают, воспользуйтесь группой переключателей If picture and frame different sizes (Если разный размер) (табл. 8.13).

Таблица 8.13. Группа переключателей If picture and frame different sizes

Переключатель | Режим отображения
Clip picture (Обрезать изображение) | Рисунок фиксируется в левой верхней части рамки, сохраняя первоначальный размер
Scale picture, retain shape (Масштабировать, сохраняя форму) | Рисунок полностью заполняет отведенное ему поле, сохраняя относительные пропорции растрового изображения
Scale picture, fill the frame (Масштабировать, заполняя рамку) | Рисунок полностью заполняет отведенное ему поле, в случае необходимости подвергаясь вертикальному или горизонтальному искажению

Переключатель Object Position (Положение объекта) диалогового окна Report Picture (Изображение отчета) позволяет задать положение графического изображения в полосе при изменении размеров окружающих его полей (табл. 8.14).

Таблица 8.14. Группа переключателей Object Position

Переключатель | Характеристика
Float (Плавающее) | Расположение изображения в отчете может изменяться при изменении размеров окружающих его полей
Fix relative to top of band (Постоянное относительно верхней полосы) | Изображение сохраняет свое положение относительно верхней границы полосы
Fix relative to bottom of band (Постоянное относительно нижней полосы) | Изображение сохраняет свое положение относительно нижней границы полосы


Панель инструментов Color Palette

Visual FoxPro предоставляет в распоряжение разработчика средства для изменения цвета размещенных в отчете объектов. Для печати такого отчета вам потребуется цветной принтер.

Для изменения в отчете цвета объекта выполните следующие действия:

  1. Разместите на экране панель инструментов Color Palette (Цветовая палитра) выполнив одно из следующих действий:
  • нажав кнопку Color Palette Toolbar (Панель инструментов Цветовая палитра) на панели инструментов Report Designer (Конструктор отчетов);
  • выбрав в меню View (Вид) команду Color Palette Tollbar (Панель инструментов Цветовая палитра).

Панель инструментов Color Palette (Цветовая палитра) (рис. 8.17) содержит шестнадцать кнопок с заданными цветами и три дополнительные кнопки (табл. 8.12).

Рис. 8.17. Панель инструментов Color Palette

  2. Выберите в отчете объект, цвет которого вы хотите изменить.
  3. Щелкните мышью на панели инструментов Color Palette (Цветовая палитра) по кнопке Foreground Color (Цвет объекта) или Background Color (Цвет фона) в зависимости от того, что вы хотите поменять, — цвет объекта или его фон.
  4. Щелкните мышью на панели инструментов по любому понравившемуся цвету.

Рис. 8.18. Диалоговое окно Цвет

При создании отчетов можно использовать более широкую цветовую гамму. Для этого необходимо щелкнуть мышью на кнопке Other Colors (Другие цвета) панели инструментов Color Palette (Цветовая палитра) и в открывшемся диалоговом окне Цвет (рис. 8.18) выбрать один из 48 цветов, предлагаемых программой Visual FoxPro или использовать пользовательские цвета, расположенные в области Дополнительные цвета.

Для создания пользовательского цвета, размещаемого в области Дополнительные цвета, выполните следующие действия:

  1. В диалоговом окне Цвет нажмите кнопку Определить цвет. Открывается расширенное диалоговое окно Цвет (рис. 8.19).

Рис. 8.19. Диалоговое окно Цвет для создания собственного цвета

  2. Выберите в правой части окна нужный цвет. Используя поля ввода, расположенные в правом нижнем углу, вы можете также задать параметры цвета с помощью чисел.
  3. Если вы подобрали необходимый цвет, нажмите кнопку Добавить в набор. Выбранный цвет будет размещен в области Дополнительные цвета.
  4. Нажмите кнопку ОК.


Размещение в отчете линий и прямоугольников

Для улучшения внешнего вида отчета и повышения читабельности можно использовать линии и прямоугольники.

Для проведения вертикальной или горизонтальной линии в отчете выполните следующие действия:

  1. Нажмите кнопку Line (Линия) на панели Report Controls (Элементы управления отчета) конструктора отчетов.
  2. Установите указатель в начальную точку линии.
  3. Нажмите кнопку мыши и, удерживая ее, проведите линию необходимой длины.
  4. Используя опции команды Реп (Перо) из меню Format (Формат), установите атрибуты линии (толщину и тип).
  5. Для задания цвета размещенной в отчете линии щелкните мышью на понравившемся цвете цветовой палитры панели Color Palette (Цветовая палитра).

Для размещения в отчете прямоугольника и прямоугольника со скругленными углами используются кнопки Rectangle (Прямоугольник) и Rounded Rectangle (Прямоугольник со скругленными углами) на панели инструментов Report Controls (Элементы управления отчета) конструктора отчетов. Нажмите необходимую кнопку на панели инструментов, установите указатель в какой-либо угол прямоугольника и перемещайте курсор в противоположный угол до получения прямоугольника нужного размера. Затем установите необходимые атрибуты прямоугольника, используя для этого следующие опции команды Реп (Перо) из меню Format (Формат) (табл. 8.11).

Таблица 8.11. Опции команды Реп из меню Format

Опция | Атрибут объекта
Hairline (Тонкая линия) | Контур шириной в один пиксел
1 Point {1 пункт) | Контур шириной в один пункт
2 Point (2 пункта) | Контур шириной в два пункта
4 Point (4 пункта) | Контур шириной в четыре пункта
6 Point (6 пунктов) | Контур шириной в шесть пунктов
None (Нет) | Выделенный объект не имеет контура
Dotted (Пунктир) | Пунктирный контур
Dashed (Штрих) | Контур в виде коротких штрихов
Dash-dot (Штрих-точка) | Контур в виде чередующихся штрихов и точек
Dash-dot-dot {Штрих-точкаточка) | Контур в виде чередующихся штрихов и пар точек


ГЛАВА 8
Создание отчета с помощью конструктора отчетов

В предыдущей главе мы рассмотрели создание отчета с помощью мастера. В процессе использования отчета практически всегда возникает необходимость его модификации. Создавать сложные отчеты с помощью мастера не удается. И в этих случаях вам не обойтись без конструктора отчетов.

Окно конструктора отчетов

Существует несколько различных вариантов открытия окна конструктора отчетов. Если вы хотите модифицировать ранее созданный отчет, то в окне проекта установите курсор на его названии и нажмите кнопку Modify (Модификация).

Для открытия окна конструктора отчетов при создании нового отчета выполните одно из следующих действий.

  • В меню File (Файл) выберите команду New (Новый). В открывшемся диалоговом окне New (Новый) выберите опцию Report (Отчет) и нажмите кнопку New file (Новый файл).
  • Нажмите кнопку New (Новый) в окне проекта, предварительно выбрав группу Reports (Отчеты).
  • Нажмите кнопку New (Новый) на стандартной панели инструментов; в открывшемся диалоговом окне New (Новый) установите опцию Report (Отчет) и нажмите кнопку New file (Новый файл).

Для работы в конструкторе отчетов используются панели инструментов Report Designer (Конструктор отчета) и Report Controls (Элементы управления отчета), а также команды пункта Report (Отчет) (рис. 8.1), появившегося в строке основного меню при открытии конструктора.

В табл. 8.1 приведено краткое описание кнопок панели инструментов Report Controls (Элементы управления отчета). Более подробно назначение кнопок этой панели будет рассмотрено в разделах, посвященных размещению в отчетах различных элементов управления.

Рис. 8.1. Окно конструктора отчета

Таблица 8.1. Кнопки панели инструментов Report Controls

Наименование | Назначение
Select Objects (Выбор объектов) | Является указателем выбора объектов отчета
Label (Метка) | Размещает текст
Field (Поле) | Размещает поля
Line (Линия) | Рисует линии
Rectangle (Прямоугольник) | Рисует прямоугольники
Rounded Rectangle (Скругленный прямоугольник) | Рисует прямоугольник со скругленными краями
Picture/Act! vX Bound Control (Изображение/Ас1!уХ-объект) | Помещает в отчет рисунок
Button Lock (Закрепитель кнопки) | Закрепляет выбор кнопки


  • Окно конструктора отчетов
  • Типы полос окна конструктора отчета
  • Использование команды Quick Report для размещения полей
  • Установка среды окружения отчета
  • Размещение объектов в отчете
  • Размещение в отчете текстовой информации
  • Добавление в отчет областей заголовка и итогов
  • Создание простого отчета
  • Размещение полей
  • Размещение в отчете линий и прямоугольников
  • Панель инструментов Color Palette
  • Размещение в отчете рисунков
  • Создание отчета в свободной форме
  • Создание табличного отчета
  • Группировка данных в отчете
  • Использование группировки в отчете
  • Использование в отчете переменных
  • Разметка страницы отчета
  • Создание многоколоночного отчета


Задание условий для выбора записей

Во всех рассмотренных ранее примерах в запрос включались все или часть полей исходной таблицы, упорядоченных соответствующим образом. В большинстве случаев требуется получить отдельные записи исходной таблицы, удовлетворяющие определенным условиям.

Для формирования условий выбора определенных записей предназначена вкладка Filter (Фильтр) конструктора запросов.


Упорядочение по нескольким полям

Теперь рассмотрим ситуацию, когда необходимо упорядочить данные по нескольким полям. В этом примере отобразим данные в результирующей таблице по городам клиентов в алфавитном порядке и по убыванию значений кредита. При формировании запроса воспользуемся запросом, созданным в предыдущем примере.

  1. На вкладке Fields (Поля) добавьте в список Selected fields (Выбранные поля ) Поле YcreditLimit.
  2. В окне конструктора запросов перейдите на вкладку Order By (Упорядочение). В списке Ordering criteria (Критерии упорядочения) находится поле ccity, по значению которого были упорядочены данные в предыдущем запросе.
  3. Выделите поле YcreditLimit и дважды щелкните по нему мышью. Поле будет перенесено в список Ordering criteria (Критерии упорядочения).
  4. Установите для данного поля опцию Descending (По убыванию). Обратите внимание, как выглядит теперь окно конструктора запросов (рис. 9.8).

Рис. 9.8. Использование для упорядочения двух полей

В списке Ordering criteria (Критерии упорядочения) рядом с полем ccity расположена стрелка, направленная вверх, а рядом с полем YcreditLimit — стрелка, направленная вниз. Направленная вверх стрелка означает, что данные отображаются в порядке возрастания, а направленная вниз — что данные расположены в порядке убывания.


Вкладка Order By конструктора запросов

Вкладка Order By (Упорядочение) конструктора запросов (рис. 9.6) позволяет указать критерий упорядочения данных в результирующей таблице, используя одно или несколько полей исходной таблицы, перенесенных из списка Selected fields (Выбранные поля) в список Ordering criteria (Критерии упорядочения). Для каждого поля в списке Ordering criteria (Критерии упорядочения) вы можете указать критерий упорядочения, используя следующие опции переключателя Order options (Опции упорядочения):

  • Ascending — по возрастанию;
  • Descending — по убыванию.

В списке Ordering criteria (Критерии упорядочения) с левой стороны поля, для которого установлена опция Ascending (По возрастанию), расположена направленная вверх стрелка. Для обозначения упорядочения по убыванию используется стрелка, направленная вниз.

Рис. 9.6. Вкладка Order By конструктора позволяет сформировать условия упорядочения данных в запросе

Порядок сортировки записей результирующей таблицы определяется порядком следования полей в списке Ordering criteria (Критерии упорядочения) и критерием упорядочения отдельных полей. Для изменения порядка следования полей в списке Ordering criteria (Критерии упорядочения) предназначен маркер перемещения, расположенный слева от поля.

Рассмотрим создание запроса для таблицы customer, в котором упорядочим отображаемые в результирующей таблице данные по городам клиентов.

  1. Откройте окно конструктора запросов.
  2. В открывшемся диалоговом окне Add Table or View (Добавить таблицу или представление) выберите таблицу customer.
  3. На вкладке Fields (Поля) перенесите в список Selected fields (Выбранные поля ) поля Ccompany и Ccity.
  4. Откройте вкладку Order By (Упорядочение).
  5. Дважды щелкнув на поле Ccity, перенесите его в список Ordering criteria (Критерии упорядочения). По умолчанию для него установлена опция Ascending, т. е. данные будут упорядочены в алфавитном порядке по возрастанию.
  6. Нажмите кнопку Run (Выполнить) на стандартной панели инструментов и просмотрите результаты выполненного запроса (рис. 9.7).

Рис. 9.7. Результаты выборки запроса


Вычисляемые поля запроса

Visual FoxPro позволяет включать в результирующую таблицу запроса не только информацию из исходных таблиц, но и производить вычисления над ними, позволяя, таким образом, получить данные, отсутствующие в исходной таблице. Например, из базы данных, предназначенной для учета междугородних разговоров, вы можете выбрать поля таблиц с продолжительностью разговора и стоимостью одной минуты. На основании этой информации вы можете получить в запросе сведения о стоимости разговоров.

Кроме того, вы можете использовать вычисляемые поля для объединения нескольких полей исходной таблицы в одно результирующее поле. Например, таблица customer содержит фамилию, имя и отчество клиента. В результирующий запрос вы можете поместить одно поле, в котором будет размещена фамилия и инициалы клиента.

Для формирования выражения предназначено поле Functions and expressions (Функции и выражения) вкладки Fields (Поля). Нажмите расположенную справа от поля кнопку вызова построителя выражения и в диалоговом окне Expression Builder (Построитель выражения) создайте выражение для вычисляемого поля. После того как выражение в поле Functions and expressions (Функции и выражения) сформировано, нажатием кнопки Add (Добавить) перенесите его в список Selected fields (Выбранные поля).

Замечание

В окне Expression Builder (Построитель выражения) при создании выражения вы можете использовать поля исходных таблиц, константы, функции. Используя круглые скобки, вы можете изменить порядок вычисления или сгруппировать данные.

Используя данные из таблицы Customer, создадим запрос, результирующая таблица которого будет содержать название предприятия и полный адрес клиента с учетом города.

  1. Откройте окно запроса для таблицы customer.
  2. На вкладке Fields (Поля) перенесите в список Selected fields (Выбранные поля) поле ccompany, содержащее наименование предприятия.
  3. Для объединения города и адреса клиента нажмите кнопку вызова построителя выражения поля Functions and expressions (Функции и выражения) и в диалоговом окне Expression Builder (Построитель выражений) создайте следующее выражение:

    ALL/TRIM (Ccity) + ", " +ALLTRIM(Caddress)

  4. Закройте окно построителя выражения, нажав кнопку ОК.
  5. Для размещения созданного выражения в списке Selected fields (Выбранные поля) нажмите кнопку Add (Добавить).
  6. На этом формирование запроса завершено (рис. 9.4). Нажмите кнопку Run (Выполнить) на стандартной панели инструментов, и на экране появится результирующая таблица (рис. 9.5).

Рис. 9.4. Определение вычисляемого поля

Рис. 9.5. Результат выборки


Формирование списка полей результирующей таблицы запроса

В результирующей таблице запроса поля формируются на основе полей исходных таблиц и вычисляемых полей. Для задания списка полей результирующей таблицы запроса предназначена вкладка Fields (Поля) конструктора запросов (рис. 9.3).

Рис. 9.3. Вкладка Fields предназначена для выбора полей запроса

Вкладка Fields (Поля) содержит два списка: Available fields (Имеющиеся поля) и Selected fields (Выбранные поля). Список Available fields (Имеющиеся поля) содержит все поля размещенных в окне конструктора таблиц. Selected fields (Выбранные поля) отображает поля формируемого запроса.

Перенести поля из списка Available fields (Имеющиеся поля) в Selected fields (Выбранные поля) вы можете одним из следующих способов.

  • Использовать для переноса кнопки Add (Добавить) и Add All (Добавить все), позволяющие перенести в список Selected fields (Выбранные поля) выделенные или все поля, соответственно. Используя кнопку Remove (Удалить), вы можете вернуть в список Available fields (Имеющиеся поля) ошибочно перенесенные поля.
  • Использовать механизм "перенести-и-оставить". Для этого на панели, содержащей образы используемых в запросе таблиц, выделите поля, которые вы собираетесь отобразить в запросе, нажмите кнопку мыши и, не отпуская ее, перенесите их в список Selected fields (Выбранные поля). Для выбора всех полей используется строка таблицы, содержащая звездочку. Этот же механизм можно использовать для удаления полей из списка Selected fields (Выбранные поля).
  • Для переноса поля из списка Available fields (Имеющиеся поля) в Selected fields (Выбранные поля) вы можете дважды щелкнуть мышью на поле в образе таблицы или в списке Available fields (Имеющиеся поля).

Совет

Как и при работе с объектами в Windows, для выделения группы полей вы можете использовать мышь совместно с клавишами <Shift> и <Ctrl>. Сначала выделите первое из выбираемых полей и нажмите клавишу <Shift> или <Ctrl> в зависимости от того, расположены выбираемые поля рядом или вразброс. Затем, не отпуская клавишу, щелкните мышью по крайнему полю из группы подряд выбираемых полей или по каждому из отдельно расположенных полей.

Поля в результирующей таблице запроса будут следовать в том порядке, в котором они расположены в списке Selected fields (Выбранные поля). Для изменения расположения полей в этом списке можно использовать находящийся слева от поля маркер перемещения. Установите курсор на маркер и переместите поле в требуемую строку.


Запуск запроса на выполнение

После задания условий для выбора записей и указания результирующих полей в окне конструктора вы можете просмотреть результаты выполнения запроса. Для этого выполните одно из следующих действий:

  • нажмите кнопку Run (Выполнить) на стандартной панели инструментов;
  • выберите команду контекстного меню Run Query (Выполнить запрос);
  • выберите в меню Query (Запрос) команду Run Query (Выполнить запрос);
  • нажмите комбинацию клавиш <Ctrl>+<Q>.

На экране появятся результаты запроса, представленные в табличном виде.

Для просмотра результатов запроса, не открытого в окне конструктора запросов, необходимо в окне проекта установить курсор на имя запроса и нажать кнопку Run (Выполнить).


Сохранение запроса

Сформировав в окне конструктора запросов условия выборки, вы можете их сохранить в файле с расширением QPR, что позволит сэкономить время при последующих запусках запроса.

Для сохранения условий выборки в меню File (Файл) выберите команду Save as (Сохранить как). В открывшемся диалоговом окне Save As (Сохранить как) откройте папку, в которой хотите сохранить файл, введите в поле ввода имя файла и нажмите кнопку Сохранить.

В окне проекта запросы размещаются в разделе Queries (Запросы) вкладки Data (Данные). Для открытия запроса необходимо установить на него курсор и нажать кнопку Modify (Модифицировать) окна проекта.


Изменение наименований полей в запросе

Visual FoxPro по умолчанию присваивает полям результирующей таблицы запроса наименования, которые имеют поля исходной таблицы. Вычисляемым и итоговым полям присваиваются наименования в соответствии с соглашением, принятым в Visual FoxPro.

Используя ключевое слово AS, вы можете по своему усмотрению изменить наименования полей результирующей таблицы. При этом наименования полей изменятся только в результирующей таблице, а имена полей в исходной таблице останутся без изменения.

Для изменения наименования поля необходимо за именем поля или выражением, заданным для определения поля результирующей таблицы, поместить ключевое слово AS, а за ним указать новое имя поля.

В предыдущем примере наименование итогового поля было определено Visual FoxPro по умолчанию. Результат запроса будет более читабельным, если вы измените наименования полей. Для этого выполните следующие действия:

  1. Откройте окно запроса, созданного в предыдущем примере.
  2. Добавьте в поле, содержащее номер заказа, ключевое слово AS и наименование поля заказ. OrdSalem.cnDoc AS заказ
  3. 3. Аналогичным образом добавьте в итоговое поле вычисления итоговой стоимости заказа ключевое слово AS и наименование поля стоимость.

    SUM(OrdSaled.nQuant * OrdSaled.nUnitPrice) AS Стоимость

  4. Сохраните запрос. Для выполнения запроса нажмите кнопку Run (Выполнить), в результате на экране появится результирующая таблица, содержащая новые наименования полей (рис. 9.22).

Рис. 9.22. Изменение наименования полей


Команды, используемые при формировании запросов

Для работы в окне конструктора запроса можно использовать команды меню Query и панель инструментов Query Designer (Конструктор запроса). Назначение команд и кнопок на панели инструментов описано в табл. 9.2.

Таблица 9.2. Назначение команд меню Query и кнопок панели инструментов Query Designer

Команда меню | Назначение
Add Table (Добавить таблицу) | Добавляет в запрос новую таблицу
Remove Table (Удалить таблицу) | Удаляет выбранную таблицу из запроса
Remove Join Condition (Удалить условие объединения) | Удаляет условие объединения таблиц
Output Fields (Результирующие поля) | Открывает вкладку Fields для выбора полей результирующей таблицы
Join (Объединение) | Открывает вкладку Join для задания условия объединения таблиц
Filter (Фильтр) | Открывает вкладку Filter для задания фильтра
Order By (Упорядочение) | Открывает вкладку Order By для определения критерия упорядочения
Group By (Группировка) | Открывает вкладку Group By для определения условия группировки данных
Miscellaneous (Разное) | Открывает вкладку Miscellaneous для задания дополнительных параметров запроса
Query Destination (Результат запроса) | Открывает диалоговое окно Query Destination, в котором указывается, куда выводить результат запроса
View SQL (Показать SQL) | Открывает диалоговое окно, в котором отображается SQL-оператор, соответствующий созданному запросу
Maximize the table view (Максимизировать панель отображения) | Раскрывает панель отображения используемых в запросе таблиц на весь экран. Повторное нажатие на эту кнопку возвращает панели первоначальный размер
Add Join (Добавить условие объединения) | Открывает диалоговое окно Join Condition для задания условия объединения таблиц
Comments (Комментарии) | Открывает диалоговое окно, в котором вы можете ввести краткое описание создаваемого запроса
Run Query (Выполнить запрос) | Запускает запрос на выполнение

Совет

Для просмотра конструкции SELECT, соответствующей выборке, предназначены команда View SQL и кнопка Show the SQL window панели инструментов. Сформировав запрос, вы можете скопировать конструкцию SELECT во временный буфер Windows и использовать ее при написании программ.


Включение в запрос итоговых значений

В данном примере создадим запрос для таблиц Ordsalem и Ordsaled об итоговой сумме по каждому заказу.

  1. Откройте окно запроса для таблиц Ordsalem и Ordsaled.
  2. На вкладке Fields (Поля) перенесите в список Selected fields (Выбранные поля) поле cndoc, содержащее номер документа.
  3. Чтобы вычислить стоимость проданного товара по текущему заказу, воспользуйтесь функцией зим. Для этого нажмите кнопку открытия диалогового окна Expression Builder (Построитель выражения) поля Functions and expressions (Функции и выражения).
  4. В поле ввода Expression (Выражение) открывшегося диалогового окна введите выражение, по которому будет просуммирована стоимость каждого проданного товара и помещена в соответствующее поле результирующей таблицы:

    SUM (Ordsaled. nQuant * Ordsaled.nUnitPri.ee)

  5. Нажмите кнопку OK для закрытия диалогового окна Expression Builder (Построитель выражения).
  6. Для перемещения сформированного выражения в список Selected fields (Выбранные поля) нажмите кнопку Add (Добавить).
  7. Для группировки записей результирующей таблицы по полю icdorder откройте вкладку Group By (Группировка) и перенесите поле icdorder в список Grouped fields (Поля группировки).
  8. Сохраните запрос. Для выполнения запроса нажмите кнопку Run (Выполнить). На экране появится результирующая таблица, содержащая информацию об итоговой стоимости товаров по каждому заказу (рис. 9.21).

Рис. 9.21. Результат выборки


Использование в запросе выражений и функций полей

В запрос можно включать статистические значения, вычисляемые по одному или нескольким полям исходной таблицы. Например, используя функцию COUNT (), вы можете подсчитать количество клиентов, проживающих в том или ином городе.

Кроме того, Visual FoxPro позволяет выполнять итоговые операции над вычисляемыми в запросе полями. Например, в запросе, выбирающем данные из таблиц ordsaiem и Ordsaied, вы можете вычислить итоговую стоимость продажи каждого товара за интересующий вас интервал времени.

Для вычисления итоговых значений в запросе вы можете использовать функции, описанные в табл. 9.4.

Таблица 9.4. Функции для вычисления итоговых значений в запросе

Функция | Результат вычисления
COUNT ( ) | Количество строк в итоговой таблице
МАХ() | Наибольшее значение в столбце
MIN() | Наименьшее значение в столбце
AVG() | Среднее значение столбца численных данных
SUM() | Сумма численных данных столбца

Для формирования в запросе выражения предназначено поле Functions and expressions (Функции и выражения) вкладки Fields (Поля) и расположенная справа от него кнопка открытия построителя выражения. Нажмите данную кнопку. Откроется диалоговое окно Expression Builder (Построитель выражения) (рис. 9.19). В поле ввода Expression (Выражение) сформируйте итоговое значение, используя поля таблиц запроса, расположенные в списке Fields (Поля), и функции области Functions (Функции), сгруппированные по типам данных и представленные в виде четырех списков.

Рис. 9.19. Диалоговое окно Expression Builder позволяет включить в запрос функцию или выражение

При нажатии кнопки Options (Опции) открывается диалоговое окно Expression Builder Options (Опции построителя выражения) (рис. 9.20). Используя параметры этого окна, можно настроить список наиболее часто используемых в запросе функций, отображаемых в области Functions (Функции) диалогового окна Expression Builder (Построитель выражения).

Рис. 9.20. Диалоговое окно Expression Builder Options

Чтобы настроить список функций, выполните следующие действия:

  1. В диалоговом окне Expression Builder Options (Опции построителя выражений) установите опцию типа настраиваемой функции.
  2. Нажмите кнопку Clear (Очистить) для очистки списка функций.
  3. Используя клавишу <Shift>, если выбираемые функции расположены подряд в списке, или клавишу <Ctrl>, выберите необходимые функции.
  4. Нажмите кнопку ОК.

В нижней части диалогового окна Expression Builder Options (Опции построителя выражений) находится группа переключателей Field aliases (Псевдонимы поля), содержащая опции, описанные в табл. 9.5.

Таблица 9.5. Назначение группы переключателей Field aliases диалогового окна Expression Builder Options

Переключатель | Назначение
Always add alias (Всегда добавлять псевдоним) | Указывает, что имя таблицы или представления данных всегда включается в имя поля
Add non-selected alias only (Добавлять только невыбранные псевдонимы) | Если открыто более одной таблицы или представления данных, Visual FoxPro включает имя таблицы или представления данных только в том случае, если они не содержатся в списке псевдонимов в окне Data Session (Сеанс данных)
Never add alias (He добавлять псевдоним) | Указывает, что имя таблицы или представления данных никогда не включается в имя поля

Флажок Show system memory variables (Показывать системные переменные) указывает, будут ли отображаться в окне построителя выражения системные переменные.

При формировании выражения вы можете использовать поля, константы и функции, связанные арифметическими операторами, список которых приведен в табл. 9.6.

Таблица 9.6. Арифметические операторы, используемые при формировании выражений

Оператор | Функция
+ | Сложение
_ | Вычитание
* | Умножение
/ | Деление

Для изменения порядка вычислений в формируемом выражении, а также для группировки данных можно использовать круглые скобки.


Группировка полей запроса

Группировка полей запроса позволяет получить информацию о подгруппах таблицы. Например, сгруппировав по коду заказа данные в таблице, содержащей сведения о заказах, можно получить сведения об итоговой сумме по каждому заказу.

Для группировки записей в запросе предназначена вкладка Group By (Группировка) (рис. 9.18), содержащая список Grouped fields (Поля группировки) с полями, по которым осуществляется группировка данных.

Рис. 9.18. Вкладка Group By окна конструктора запросов


Выборка из четырех таблиц

Рассмотрим пример выборки товаров, приобретенных клиентами. Для решения ЭТОЙ задачи нам потребуются таблицы Customer, Ordsalem, Ordsaled и Goods. Таблица customer содержит информацию о клиентах, таблица Ordsalem — сведения о заказе на товары, таблица Ordsaled — сведения о товарах, входящих в заказ (количество купленных товаров и цена товара), а таблица Goods — наименования всех товаров. При создании базы данных между этими таблицами уже были определены постоянные отношения.

  1. Откройте новое окно конструктора запросов.
  2. Добавьте в конструктор запросов таблицы Customer, Ordsalem, Ordsaled и Goods. Между этими таблицами в базе данных установлены постоянные отношения. После их перенесения в запрос в окне конструктора запросов отобразятся установленные между таблицами связи, а на вкладку Join (Объединение) добавятся три строки с условиями объединения таблиц (рис. 9.16).
  3. В список Selected fields (Выбранные поля) вкладки Fields (Поля) перенесите фамилию клиента, номер заказа, наименование товара и количество заказанного им товара.
  4. Нажмите кнопку Run (Выполнить), и на экране появится результирующая таблица (рис. 9.17), содержащая информацию о заказах всех клиентов.

Рис. 9.16. Вкладка Join окна запроса для выборки из четырех таблиц

Рис. 9.17. Результаты запроса для выборки из четырех таблиц


Многотабличные запросы

Во всех рассмотренных ранее в этой главе примерах данные при формировании запроса выбирались из одной таблицы. На практике при формировании запросов часто используются выборки из нескольких таблиц, т. к. в реляционных базах данных информация содержится не в одной отдельной таблице, а в совокупности связанных таблиц.

При создании многотабличного запроса в окно конструктора запросов добавляются все участвующие в выборке таблицы и определяются условия их объединения. Если между участвующими в запросе таблицами в базе данных установлены постоянные отношения, то в окне конструктора запросов эта связь будет отображаться в виде линии, соединяющей таблицы, а на вкладке Join (Объединение) появится запись, содержащая условие объединения таблиц (рис. 9.14).

Рис. 9.14. Вкладка Join содержит условия объединения таблиц

Если таблица, добавляемая в конструктор запросов, не имеет установленных в базе данных связей с уже размещенными в конструкторе таблицами, на экране открывается диалоговое окно Join Condition (Условие объединения) (рис. 9.15), в котором необходимо задать условие объединения двух таблиц.

В верхней части диалогового окна Join Condition (Условие объединения) размещены два раскрывающихся списка, содержащие поля, которые можно использовать для объединения таблиц. Ниже расположен переключатель Type of join (Тип объединения), содержащий опции, определяющие тип создаваемой между таблицами связи. Назначение опций описано в табл. 9.3.

Рис. 9.15. Определение условия объединения таблиц в диалоговом окне Join Condition

Таблица 9.3. Назначение опций диалогового окна Join Condition

Опция | Тип создаваемой связи
Inner join (Внутреннее объединение) | Создает объединение, в котором выбираются только те записи, которые содержат совпадающие значения в полях связи
Left join (Объединение слева) | Создает объединение, в котором выбираются все записи из левой таблицы, а также записи из правой таблицы, значения поля связи которого совпадают со значениями поля связи левой таблицы
Right join (Объединение справа) | Создает объединение, в котором выбираются все записи из правой таблицы, а также записи из левой таблицы, значения поля связи которого совпадают со значениями поля связи правой таблицы
Full join (Полное объединение) | Создает объединение, в котором выбираются все записи из правой и левой таблиц

Замечание

По умолчанию Visual FoxPro при объединении таблиц использует опцию Inner join (Внутреннее объединение), при которой из таблиц выбираются только те записи, которые содержат совпадающие значения в полях связи.

Замечание

В отличие от постоянных отношений, определяемых между таблицами в базе данных, при объединении таблиц в конструкторе запросов вы можете использовать любые поля таблиц.

Установленные между таблицами условия объединения можно изменять. Для этого выполните следующие действия:

  1. Дважды щелкните мышью на линии, связывающей таблицы, или на вкладке Join (Объединение) нажмите кнопку с двунаправленной стрелкой с левой стороны поля Туре (Тип).
  2. В открывшемся диалоговом окне Join Condition (Условие объединения), отображающем текущее условие объединения таблиц, измените требуемые параметры.
  3. Нажмите кнопку ОК.

Совет

Для установления связи между таблицами в конструкторе запросов, как и в базе данных, можно использовать механизм "перенести-и-оставить". Выберите поле одной из таблиц, нажмите кнопку мыши и удерживая ее нажатой, перенесите поле на связываемое поле в другой таблице. После этого откройте диалоговое окно Join Condition (Условие объединения) и отредактируйте установленное условие объединения таблиц.


Формирование списка условий

Visual FoxPro позволяет при создании запросов формировать несколько условий. В том случае, если все задаваемые условия накладываются на одно поле, их можно разместить в одной строке. В противном случае условия размещаются в разных строках вкладки Filter (Фильтр). Рассмотрим следующий пример. Выберем всех покупателей из Москвы, Новгорода и Киева.

  1. Откройте окно конструктора запросов.
  2. Поместите в него таблицу customer.
  3. На вкладке Fields (Поля) разместите в списке Selected fields (Выбранные поля) требуемые поля.
  4. Откройте вкладку Filter (Фильтр).
  5. Из списка Field Name (Имя поля), содержащего все поля таблицы Customer, выберите поле Ccity.
  6. В списке Criteria (Критерии) выберите значение In (В).
  7. В поле столбца Example (Пример) через запятую задайте названия городов, покупатели которых вас интересуют (рис. 9.13).
  8. Для просмотра результатов выборки нажмите кнопку Run (Выполнить) на стандартной панели инструментов.

Рис. 9.13. Окно запроса со списком условий отбора


Выбор записей, находящихся в заданном диапазоне значений

Для выбора записей, лежащих в заданном диапазоне значений, используются операторы > (Больше), < (Меньше) и Between (Между) из списка Criteria (Критерий) вкладки Filter (Фильтр). Операторы > (Больше) и < (Меньше) используются в том случае, если задана только нижняя или верхняя граница диапазона, a Between (Между) — когда известны обе границы. Предположим, что вам потребовался список заказов, итоговая сумма которых превышает 10 000 рублей. В другом случае вам нужно получить сведения о клиентах, воспользовавшихся услугами вашей фирмы в определенный интервал времени. В обоих случаях необходимо выбрать из таблицы записи, попадающие в диапазон значений.

Создадим запрос, формирующий список заказов, итоговая сумма которых превышает 10 000 рублей.

  1. Откройте новое окно конструктора запросов.
  2. Добавьте в него таблицу ordsaiem.
  3. В списке Selected fields (Выбранные поля) вкладки Fields (Поля) разместите поля с номером заказа, датой и итоговой суммой по заказу.
  4. Для задания условия отбора на вкладке Filter (Фильтр) выберите поле nsumdoc.
  5. В списке Criteria (Критерий) выберите оператор >.
  6. В текстовом поле столбца Example (Пример) введите 10 000.
  7. Нажмите кнопку Run (Выполнить) на стандартной панели инструментов.

На экране появляется результирующая таблица, содержащая заказы, итоговая сумма по которым превышает 10 000.

В этом примере мы задавали только нижнюю границу диапазона. Очевидно, что для получения списка продаж за определенный интервал времени необходимо задать начальную и конечную даты. Воспользуемся запросом, созданным в предыдущем примере, и изменим в нем заданные на вкладке Filter (Фильтр) условия выбора записей.

  1. Откройте запрос, созданный в предыдущем примере.
  2. На вкладке Filter (Фильтр) из списка Field Name (Имя поля) выберите поле ddoc, содержащее дату заказа.
  3. В списке Criteria (Критерий) выберите значение Between (Между).
  4. В поле Example (Образец) введите начальную и конечную даты интервала (рис. 9.12) в следующем виде:

    CTOD("01.11.2001") , CTOD("15.11.2001")

Рис. 9.12. Выбор записей по диапазону значений поля дат

  5. Нажмите кнопку Run (Выполнить) на стандартной панели инструментов.

Просмотрите данные в появившейся на экране результирующей таблице. Она содержит информацию о всех продажах за указанный в запросе интервал времени.

Замечание

При задании условий для выбора записей по диапазону значений можно использовать не только числовые поля, но и текстовые. В этом случае при выполнении запроса Visual FoxPro сравнивает коды символьных величин. Например, условие выбора "Л, М", помещенное в поле Example (Образец) для поля Ccompany, позволит выбрать из таблицы Customer список предприятий, названия которых начинаются на буквы Л и М.


Выбор похожих значений

Список вариантов сравнения Criteria (Критерий) вкладки Filter (Фильтр) содержит значения, позволяющие задавать различные критерии выбираемых в результирующую таблицу записей. При работе с большими таблицами время от времени возникает необходимость найти записи, точное написание которых вы не знаете. Например, вы не знаете, верхний или нижний регистр был использован при вводе записей. В этом случае вы можете осуществить выбор записей по условию неточного совпадения значений.

Предположим, что в таблице customer требуется найти запись о фирме, представитель которой имеет фамилию, начинающуюся на "Ник". Для поиска необходимых записей выполните следующие действия:

  1. Откройте окно конструктора запросов.
  2. Поместите в него таблицу Customer.
  3. На вкладке Fields (Поля) выделите курсором поля, которые хотите отобразить в запросе, и с помощью кнопки Add (Добавить) перенесите их в список Selected fields (Выбранные поля).
  4. Для задания условия на вкладке Filter (Фильтр) выберите поле с last name.
  5. В списке вариантов сравнения выберите значение =.
  6. В поле столбца Example (Образец) введите Ник (рис. 9.11). В результате выполнения запроса Visual FoxPro отобразит в результирующей таблице записи о фирмах, имеющих представителей с фамилиями Никифоров и Николаев.

Рис. 9.11. Задание условия неточного совпадения


Выбор полей, не удовлетворяющих заданному условию

Флажок Not (He), расположенный на вкладке Filter (Фильтр) окна конструктора запросов, позволяет выбрать из таблицы записи, не удовлетворяющие заданному условию. Например, в предыдущем примере мы осуществляли выбор клиентов, проживающих в Москве. Если бы в дополнение к заданному условию выборки мы установили флажок Not (He), то в результирующей таблице мы получили бы список клиентов, не проживающих в Москве.

В данном примере выберем из таблицы customer все записи, за исключением записей со значением Казахстан в поле ccountry.

  1. Откройте запрос, созданный в предыдущем примере.
  2. Перейдите на вкладку Filter (Фильтр).
  3. В столбце Field Name (Имя поля) выберите из раскрывающегося списка поле Ccountry.
  4. Щелкните мышью в поле Not (He), установив тем самым флажок.
  5. В списке вариантов сравнения Criteria (Критерий) выберите значение ==,
  6. В текстовом поле столбца Example (Образец) введите Казахстан (рис. 9.10).
  7. Для выполнения запроса нажмите кнопку Run (Выполнить). На экране появится результирующая таблица, которая содержит записи о клиентах, проживающих вне Казахстана.

Рис. 9.10. Задание условия для выбора полей, не удовлетворяющих определенному критерию


Задание условия точного совпадения значений одного поля

На практике часто требуется выбрать из таблицы запись или группу записей, одно из полей которых содержит заданную величину. Например, вам требуется список всех клиентов, живущих в Москве. В этом случае вам необходимо на вкладке Filter (Фильтр) ввести требуемые значения в соответствующих полях, создав тем самым шаблон, с которым, прежде чем помещать записи в результирующую таблицу, Visual FoxPro будет сравнивать все записи исходной таблицы.

В этом примере выберем данные о клиентах из Москвы.

  1. Откройте окно конструктора запросов.
  2. Поместите в него таблицу customer.
  3. На вкладке Fields (Поля) перенесите в список Selected fields (Выбранные поля) наименование предприятия.
  4. Перейдите на вкладку Filter (Фильтр) конструктора запросов.
  5. В столбце Field Name (Имя поля) нажмите кнопку раскрытия списка и из всех полей исходной таблицы выберите ccity.
  6. В списке Criteria (Критерии) выберите значение ==.
  7. В поле Example (Образец) введите Москва (рис. 9.9).
  8. Для выполнения запроса нажмите кнопку Run (Выполнить). На экране появится результирующая таблица, которая содержит записи о клиентах, чьи фирмы расположены в Москве.

Рис. 9.9. Задание условия точного совпадения значения одного поля

Замечание

Если условие выбора, вводимое в поле Example, содержит специальные символы или ключевые слова языка запросов, поместите задаваемое условие в кавычки.


ГЛАВА 9
Запросы к базе данных

Одним из основных назначений разработанного приложения является быстрый поиск информации в базе данных и получение ответов на разнообразные вопросы. Для этих целей в Visual FoxPro используются средства, называемые запросами.

Например, вам необходимо выбрать из таблиц информацию о клиентах, проживающих в Москве и Московской области, или сформировать список клиентов, купивших в последний месяц товаров на сумму свыше 5000 рублей, и упорядочить их в алфавитном порядке по полю, содержащему фамилии клиентов. Для решения таких задач предназначен конструктор запросов и команда SELECT языка Visual FoxPro.

С помощью конструктора запросов Visual FoxPro вы можете формировать различной сложности критерии для выбора записей из одной или нескольких таблиц, указывая при этом, какие поля должны быть отображены в запросе. Над полями, выбираемыми из таблиц с помощью запросов, можно выполнять различные вычисления.

Рис. 9.1. Ввод условия выборки в мастере запросов

Результатом запроса является таблица, которую вы можете сохранить в массиве, в создаваемой новой таблице, отобразить на экране в режиме Browse (Просмотр) или вывести в виде отчета.

Для создания запросов вы можете использовать мастер запросов, который последовательно запрашивает наименования таблиц, используемых в запросе, перечень полей таблиц, критерий упорядочения и условия фильтрации данных. На рис. 9.1 приведено диалоговое окно мастера, позволяющее сформировать условия фильтрации выбираемых из таблицы данных. Мы не будем рассматривать создание запросов с помощью мастера, т. к. конструктор запросов достаточно прост и работа в нем у вас не вызовет затруднений.

Конструктор запросов

Для создания запроса в окне конструктора запросов выполните следующие действия:

  1. На вкладке Data (Данные) конструктора проекта выберите группу Queries (Запросы).
  2. Нажмите кнопку New (Новый).
  3. В открывшемся диалоговом окне New Query (Новый запрос) нажмите кнопку New Query (Новый запрос). Открывается диалоговое окно выбора таблиц Add Table or View (Добавить таблицу или представление данных).
  4. В этом диалоговом окне выберите таблицы, данные из которых хотите использовать в запросе, и с помощью кнопки Add (Добавить) перенесите их в окно конструктора запросов.
  5. Завершив выбор таблиц, нажмите кнопку Close (Закрыть).

На экране появляется окно конструктора запросов (рис. 9.2), которое содержит названия выбранных таблиц, а в основном меню появляется пункт Query (Запрос). Можно приступать к формированию условий запроса.

Совет

Для открытия ранее созданного запроса в окне конструктора запросов на вкладке Data (Данные) окна проекта в группе Queries (Запросы) найдите модифицируемый запрос, установите на него курсор и нажмите кнопку Modify (Модифицировать).

Далее, открывая в конструкторе запросов необходимые вкладки, вы выполняете следующие действия:

  • выбираете поля результирующей таблицы запроса;
  • формируете вычисляемые поля;
  • указываете критерии для выборки, группировки и упорядочения данных;
  • задаете, куда выводить результат выборки.

В верхней части окна конструктора запросов расположена панель, на которой отображаются используемые в запросе таблицы. Ниже находятся вкладки, предназначенные для выбора полей запроса и формирования условий выборки. Назначение этих вкладок приведено в табл. 9.1.

Рис. 9.2. Окно конструктора запросов с выбранной таблицей клиентов

Таблица 9.1. Назначение вкладок окна конструктора запросов

Вкладка | Назначение
Fields (Поля) | Позволяет указать поля исходных таблиц, выбираемые в результирующий запрос
Join (Объединение) | Позволяет задать условия объединения таблиц
Filter (Фильтр) | Позволяет определить фильтры, накладываемые для выбора записей
Order By (Упорядочение) | Позволяет задать критерии упорядочения данных
Group By (Группировка) | Позволяет задать условия группировки данных
Miscellaneous (Разное) | Позволяет задать дополнительные условия, такие как признак выборки повторяющихся значений, количество или процент выбора данных


  • Конструктор запросов
  • Команды, используемые при формировании запросов
  • Сохранение запроса
  • Запуск запроса на выполнение
  • Формирование списка полей результирующей таблицы запроса
  • Вычисляемые поля запроса
  • Вкладка Order By конструктора запросов
  • Упорядочение по нескольким полям
  • Задание условий для выбора записей
  • Задание условия точного совпадения значений одного поля
  • Выбор полей, не удовлетворяющих заданному условию
  • Выбор похожих значений
  • Выбор записей, находящихся в заданном диапазоне значений
  • Формирование списка условий
  • Многотабличные запросы
  • Выборка из четырех таблиц
  • Группировка полей запроса
  • Использование в запросе выражений и функций полей
  • Включение в запрос итоговых значений
  • Изменение наименований полей в запросе


Файлы инициализации

В Visual FoxPro для автоматической установки рабочей среды используются файлы инициализации FOXPRO.INI и CONFIG.FPW.

Файл FOXPRO.INI

Файл FOXPRO.INI содержит информацию об используемом по умолчанию шрифте, размере и внешнем виде окна Visual FoxPro. Эти установки можно изменить, отредактировав файл FOXPRO.INI.

Данный файл не обязателен для работы Visual FoxPro. Его можно удалить, но при очередном завершении работы Visual FoxPro создаст его вновь.

Файл CONFIG.FPW

Файл CONFIG.FPW предназначен для определения места хранения файлов Visual FoxPro и установок по умолчанию для команды SET. При запуске Visual FoxPro можно установить ключ для указания имени конфигурационного файла или ввести команду SET в файл AUTOEXEC.BAT:

SET FOXPROWCFG =путь\имяФайла

Определение цветовой палитры

В файле CONFIG.FPW можно установить цветовую палитру по умолчанию, загружаемую при старте Visual FoxPro, или индивидуальную цветовую схему. Для выбора нужного варианта необходимо включить строку определения в файл CONFIG.FPW.

  • По умолчанию:

COLOR SET = цветовойнабор VisualF охРго

  • Индивидуальная цветовая схема:

COLOR OF SCHEME числовоеВыражение = списокЦветовыхПар

SET-команды

Рабочую среду Visual FoxPro можно настраивать автоматически при запуске Visual FoxPro или во время работы Visual FoxPro с помощью SET-команд. Файл CONFIG.FPW может содержать установки по умолчанию почти для всех SET-команд. Для получения информации по текущим командам во время работы используйте оперативную справку.


Стартовые ключи

В командной строке можно установить несколько ключей, влияющих на работу Visual FoxPro после запуска.

Ключ командной строки состоит из знака минуса с прописной или строчной буквой, иногда сопровождаемой дополнительной информацией (имя файла или путь к папке).

Для запуска Visual FoxPro с использованием ключей командной строки необходимо:

  1. Выделить значок запуска Microsoft Visual FoxPro 7.0.
  2. Нажать правую кнопку мыши и выбрать из контекстного меню команду Свойства.
  3. В открывшемся диалоговом окне Свойства: Microsoft Visual FoxPro 7.0 (рис. П.3) перейти на вкладку Ярлык.
  4. В поле ввода Рабочая папка добавить соответствующий код ключа к имени файла.
  5. Нажать ОК для подтверждения ваших намерений.

Рис. П.З. Диалоговое окно Свойства: Visual FoxPro 7.0

Для каждого ключа командной строки можно создать отдельную пиктограмму, используя опцию Ярлык команды Создать из системного меню папки. После выполнения этой команды с помощью мастера Создание ярлыка определите необходимую информацию.

Определение файла конфигурации

Ключ -с переопределяет имя и местоположение файла CONFIG. FPW:

-с<путь >\имяфайла

Если имяфайла не указано, необходимо добавить символ "\" после аргумента

путь, чтобы система производила поиск существующего файла

CONFIG.FPW.

Например, если файл CONFIG.FPW находится в папке COMMON диска С, командная строка будет выглядеть так:

D:\VFP\VFP.ЕХЕ -сС:\COMMON\CONFIG.FPW

Ключи командной строки имеют высший приоритет по отношению к установкам команды SET.

Отмена вывода заставки Visual FoxPro

Для отключения вывода заставки установите ключ -t.

D:\VFP\VFP.EXE -t


Настройка Visual FoxPro

В данном разделе описываются средства, которые могут быть использованы при настройке Visual FoxPro на конкретную конфигурацию аппаратуры.


Установка Visual FoxPro

Установка программы Visual FoxPro 7.0 возможна в следующих вариантах:

  • с компакт-диска, содержащего установочные файлы;
  • из сети, если установочные файлы хранятся на одном из сетевых компьютеров, и вы имеете к ним доступ.

Для того чтобы установить программу Visual FoxPro 7.0 с компакт-диска, выполните следующие действия:

  1. Вставьте первый установочный компакт-диск Visual FoxPro 7.0 в устройство CD-ROM.
  2. Если устройство CD-ROM вашего компьютера является загрузочным, автоматически запустится находящаяся на нем программа Setup. Если устройство CD-ROM не является загрузочным, откройте папку Панель управления и дважды щелкните мышью на значке Установка и удаление программ.
  3. В открывшемся диалоговом окне нажмите кнопку Установка новой программы. В предложенном варианте установки выберите значение CD или дискеты. Запустится программа поиска файлов установки, которая найдет на вставленном вами компакт-диске программу установки и предложит ее запустить. Нажмите кнопку Готово.
  4. Запустится мастер установки Visual FoxPro 7.0, который проверяет наличие необходимых компонентов Windows и при необходимости предложит их установить (рис. Ш).

Рис. П1. Диалоговое окно Visual FoxPro Setup

  5. После установки компонентов Windows становится доступной опция с цифрой 2, при нажатии на которую открывается следующее окно мастера, в котором запрашивается номер программного продукта, а также идентификатор пользователя. После ввода этих данных перейдите к следующему шагу.
  6. Появляется диалоговое окно, в котором задаются устанавливаемые компоненты Visual FoxPro 7.0 (рис. Ш).
  7. Далее следуйте появляющимся на экране инструкциям.

Рис. П2. Диалоговое окно Microsoft Visual FoxPro 7.0 с выбором файлов установки


ПРИЛОЖЕНИЕ
Установка Visual FoxPro

В данном приложении описываются условия, необходимые для установки Visual FoxPro, и объясняется его установка. В приложении также приведены некоторые параметры настройки Visual FoxPro.

Требования к системе

Для работы системы необходимы следующие ресурсы.

  • Процессор Pentium 133 или выше.
  • Минимальный объем оперативной памяти — 64 Мбайт, рекомендуемый — 128 Мбайт или выше.
  • Жесткий диск с объемом свободного пространства не менее 115 Мбайт при минимальной конфигурации и до 200 Мбайт при полной установке.
  • Операционная система MS Windows 98, Windows ME, Windows NT 4.0, Windows 2000 (или выше).
  • При работе в сети — сетевое обеспечение.
  • Рекомендуется монитор типа VGA или с лучшей разрешающей способностью.
  • Устройство для чтения компакт-дисков. П Мышь.

Кроме того, для инсталляции Visual FoxPro 7.0 на компьютер с операционной системой Windows 2000, необходимо, чтобы на компьютере были установлены Windows 2000 Service Pack 1 и Microsoft Internet Explorer 5.5.


  • Требования к системе
  • Установка Visual FoxPro
  • Настройка Visual FoxPro
  • Стартовые ключи
  • Файлы инициализации


Иллюстрированный самоучитель по Visual Foxpro 7

Знакомство с Visual FoxPro

Начало работы с Visual FoxPro

Проект как средство объединения элементов приложения

Создание базы данных проекта

Форма как средство ввода и редактирования данных

Конструктор форм

Создание и печать отчетов

Создание отчета с помощью конструктора отчетов

Запросы к базе данных

Перекрестные таблицы и диаграммы

Меню приложения

Создание справочной системы приложения

Управление проектом и создание приложения

Условия достоверности, хранимые процедуры, триггеры, представления данных

Расширенные средства ввода данных

Библиотеки классов и ActiveX-компоненты

Расширенные средства создания отчетов

Расширенные средства выборки данных

Визуальное объектно-ориентированное программирование

Многопользовательская работа в локальной сети

Связывание и внедрение объектов, экспорт и импорт данных

Удаленные представления данных

Перенос данных из Visual FoxPro на платформу клиент-сервер

Публикация данных на Web-сервере

Настройка параметров Visual FoxPro

Установка Visual FoxPro